Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Was ist beim PHP installieren unter Server 2008 zu beachten ? Gibt es auch eine aktuelle Version mit Windows Installiert oder nur bis 5.3.28

Mitglied: 91863

91863 (Level 2)

30.05.2014, aktualisiert 23:03 Uhr, 1322 Aufrufe, 10 Kommentare, 1 Danke

Hallo,

Kollege hat auf Server 2008

Mysql installiert
PHP lauft wie es aussieht (Evenutell nicht komplett)
hallo.php Testfile "Da steht nur "Hello World" lässt sich öffnen.
Also Hello World:

01.
  
02.
<html> 
03.
 <head> 
04.
  <title>PHP-Test</title> 
05.
 </head> 
06.
 <body> 
07.
 <?php echo '<p>Hallo Welt</p>'; ?> 
08.
 </body> 
09.
</html>


Dann PHPinfo.php
hat den Inhalt:
01.
?php 
02.
/* vim: set expandtab sw=4 ts=4 sts=4: */ 
03.
/** 
04.
 * phpinfo() wrapper to allow displaying only when configured to do so. 
05.
06.
 * @package PhpMyAdmin 
07.
 */ 
08.
 
09.
/** 
10.
 * Gets core libraries and defines some variables 
11.
 */ 
12.
require_once 'libraries/common.inc.php'; 
13.
PMA_Response::getInstance()->disable(); 
14.
 
15.
/** 
16.
 * Displays PHP information 
17.
 */ 
18.
if ($GLOBALS['cfg']['ShowPhpInfo']) { 
19.
    phpinfo(); 
20.
21.
?>
Problem ist er hat so installiert: Er hat aber den Install Teil nicht gemacht . Da er PHP 5.5 oder so runtergeladen hatte. Mit Installier ist nur bis 5.3.28

http://blog.pluralsight.com/iis-7-install-fastcgi-php

Es gibt aber nur bis Version 5.3.28 einen Installierer. Ich glaube der Kollege hat das ja nur Extrahiert , da er eine spätere Version genommen und somit den Installpart ausgelassen !

Er hat das zwar verknüpft:
3. Fill out the following information and click OK:

Request Path: *.php
Module: FastCgiModule
Executable: {path to your PHP install}\php-cgi.exe
Name: Whatever you want

Und Module Mapping hat er gemacht. Mirist nun aufgefallen.
Vermutlich sind die späteren Versionen nur Updates zum drüberlegen ? Oder nicht ?

Werde am Montag PHP neu installieren mit 5.3.28 Das Programm "Moodle" velangt aber einen höher Version. Gibt es PHP mit Installier. Oder muss man 5.3.28 installieren und dann updaten ?


Gruss
Ralf

Mitglied: certifiedit.net
30.05.2014 um 22:13 Uhr
wow, nett einfach alles zu löschen. Aber immerhin, du bekommst nun Code Tags gebacken.

Wenn PHP nicht installiert ist ist PHP nicht installiert, ist PHP nicht installiert. such dir ein anderes PHP Modul. Abgesehen macht hier nach fragen, wenn man nicht am Objekt ist kaum Sinn.
Bitte warten ..
Mitglied: Dani
30.05.2014 um 22:17 Uhr
Guten Abend Ralf,
ich glaube es nicht! Warum hast du die Frage, die 1:54 Stunden alt ist, gelöscht? Das ist nicht Sinn der Löschfunktion.


Grüße,
Dani (Mod)
Bitte warten ..
Mitglied: wiesi200
30.05.2014 um 22:22 Uhr
Hallo,

Php an sich muss nicht installiert werden und es gibt neue Versionen hier
http://windows.php.net/

Das Fast-Cgi Modul bzw. CGI ist da das interessantere, es "schiebt" die PHP Dateien vom Webserver zu PHP rüber die dann da verarbeitet werden empfängt sie dann wieder und der Webserver schickt sie dann an den Client.
Bitte warten ..
Mitglied: certifiedit.net
30.05.2014 um 22:29 Uhr
Darüber lässt sich trefflich streiten, Installiert bedeutet für mich, dass eine Interaktion möglich ist (wie geplant). Das ist hier wohl nicht der Fall.
Bitte warten ..
Mitglied: 91863
30.05.2014, aktualisiert um 22:37 Uhr
Hallo,

ich komme am Montag auf den Thread zurück. Ist einfach neu formuliert. Ich installieren mal 5.3.28 . Ich brauche das für Windows !
Da ist mit Installer. Vermute das es dann geht. Muss man halt dann schauen, wie man es updatet.
Benutze mal die Anleitung hier

http://blog.pluralsight.com/iis-7-install-fastcgi-php



Gruss
Ralf
Bitte warten ..
Mitglied: Xaero1982
30.05.2014 um 22:37 Uhr
Tschuldige, aber wegen Leuten wie dir sollte man das Löschen hier verbieten.

Des Weiteren sehe ich hier noch immer absolut gar keinen Sinn in diesem Beitrag - es gibt keine Frage, außer nach einem PHP Installer - Hallo Suchmaschine?

PHP funktioniert oder eben nicht. Halbes PHP gibts nicht - Module mal außen vorgelassen.

Was ist das bitte für ein Deutsch?

"Problem ist er hat so installiert: Er hat aber den Install Teil nicht gemacht . Da er PHP 5.5 oder so runtergeladen hatte. Mit Installier ist nur bis 5.3.28"
??

Und: Glauben kannst du in der Kirche. Frage deinen "Kollegen" was er gemacht hat.

"Und Module Mapping hat er gemacht. Mirist nun aufgefallen." ???
Was ist dir aufgefallen?

"Das Programm "Moodle" velangt aber einen höher Version. Gibt es PHP mit Installier."???

Nimms mir nicht übel, aber du löscht einen Beitrag weil du nicht in der Lage bist, auch nach x maligen Aufforderungen Code-Tags zu benutzen und nun, tschuldige, "rotzt" du uns einen Beitrag hin der vor Deutschfehlern nur so strotzt. Ist doch nicht dein ernst oder?
Wie ich schon in dem gelöschten Beitrag schrieb hat das was mit Respekt zu tun den Leuten gegenüber die du hier um Hilfe bittest.

Kannst du nun auch gerne alles wieder löschen.
Bitte warten ..
Mitglied: Xaero1982
30.05.2014, aktualisiert um 22:42 Uhr
Zitat von 91863:

Hallo,

ich komme am Montag auf den Thread zurück. Ist einfach neu formuliert. Ich installieren mal 5.3.28 . Ich brauche das für
Windows !
Da ist mit Installer. Vermute das es dann geht. Muss man halt dann schauen, wie man es updatet.

Gruss
Ralf

Wo zur Hölle ist eigentlich dein Problem??? Was geht denn nicht? Du sagst uns ja nicht was nicht geht!!!!!!!

"Ich installieren mal 5.3.28 " Hallo DEUTSCH?

Edit: Noch was: Benutze zum Download doch bitte die offizielle Seite:
http://windows.php.net/download/
Da wirst du dann gleich sehen: Es gibt keinen Installer! Dein Kollege hat das vollkommen richtig gemacht mit der aktuellen Version und muss dann die Module noch konfigurieren.
Bitte warten ..
Mitglied: 91863
30.05.2014, aktualisiert um 22:46 Uhr
Willst Du mich nun dumm anmachen ?
Ich habe die Frage neu formuliert.
Mir ist nicht klar, warum die neuen Versionen von PHP keinen Installier haben. Gehe ich auf Youtube etc.. Dann wird PHP immer per Installer installiert. Und die Wege sind innerhalb 5 Minuten jeweils gelöst.

Wenn Du glauben willst, dann geh in die Kirche . Das hier ist neu formuliert um die Frage einfach zu gestalten. Wenn Dir das zu hoch ist, dann kümmer Dich nicht um die Frage.
Das ist ein Forum, und Foren leben von Fragen ! Wer kein Respekt hat bist Du.
Wir können das gerne ausdiskutieren im Forum, bis das Niveau hier anfängt zu sinken. Du hast ja bereits damit begonnen.
Vor allem denke ich nicht, das der Kollege das richtigt gemacht hat, sonst würde PHP ja laufen !
Da waren wir ja
http://windows.php.net/download/
Habe ihm noch zugeschaut, nun ist er im Urlaub und er hat einen verkorksten Server übergeben !
Ich denke das wenn man laut Anleitung das PHP in einen Ornder wie D:PHP macht und dann das per Module Handler anbindet etc.. doch nicht so sauber funktioniert.
Weil wie erwähnt, warum soll so ein Einzeiler gehen. Und nachher gehen andere Aufrufe nicht.
Daher ist ja auch die Frage, was man beachten muss. Gibt es Prerequisites über die man nichts liest . Z.bsp Netframework etc..


Gruss
Ralf
Bitte warten ..
Der Kommentar von 91863 wurde vom Moderator Dani am 30.05.14 ausgeblendet!
Mitglied: Xaero1982
30.05.2014, aktualisiert um 22:51 Uhr
Ich mache dich an, weil du uns gegenüber - den Leuten die anderen helfen wollen - keinen Respekt hast. Du löscht den kompletten Beitrag. Bist nicht in der Lage zu editieren und die Codetags einzufügen, obwohl ich es dir schon ziemlich klar und verständlich geschrieben habe.

Die Frage neu formuliert? Welche? Ob es keinen Installer gibt? Schau auf der offiziellen Seite nach. Wenn du nur in der Lage bist PHP mit einem Installer zu installieren solltest du die Finger davon lassen.
Youtube? Alles klar - damit ist ja alles gesagt - Kategorie: Ich weiß wie man einen PC anmacht!

Der Satz macht keinen Sinn, weißte selbst oder?
So dumm bin ich nicht, denn ich bekomme PHP auch ohne Installer installiert - hab ich bereits, da war an Installer für PHP unter Windows noch nicht zu denken.

"Vor allem denke ich nicht, das der Kollege das richtigt gemacht hat, sonst würde PHP ja laufen !"
Natürlich der Kollege ist schuld - vermutlich derjenige von euch beiden der Ahnung hat - auch wenn er irgendwelche Module nicht konfiguriert hat. Wozu du FastCGI brauchst, weißt du sicherlich selbst nicht.

Und wie ich schon sagte: PHP funktioniert!!!! Sonst würde es kein "Hello World" ausgeben.
Bitte warten ..
Mitglied: Dani
30.05.2014, aktualisiert um 22:50 Uhr
Guten Abend Ralf,
ich glaube es pfeift von den Dächern...
Deine Antwort auf meine erste Frage und für den letzten Kommentar kannst du mir per PN zukommen lassen. Solange ist hier Feierabend!


Grüße,
Dani
Bitte warten ..
Ähnliche Inhalte
Windows 10

Systemwechsel von Windows 7 auf Win 10 - Was gibt es zu beachten?

Frage von Boje1288Windows 1011 Kommentare

Hallo zusammen! Ich bin am Überlegen, ob ich jetzt schon mein Windows 7 auf Windows 10 update. Die Frage ...

DSL, VDSL

Einrichtung VDSL Router: Was gibt es zu beachten?

gelöst Frage von QQR700DSL, VDSL7 Kommentare

Hallo und guten Tag, ich habe demnächst vermutlich das Vergnügen, meinen ersten VDSL-Router einzurichten. Gibt es dabei irgendwas besonderes ...

Netzwerkmanagement

Aktuelle WSUS Version

Frage von sammy65Netzwerkmanagement3 Kommentare

Hallo miteinander, welches ist die aktuelle WSUS Version. Auf meinem 2008R2 Server läuft derzeit 3.2.7600.274 Gibt es irgendwo ne ...

Windows Update

WSUS welche Version ist aktuell

gelöst Frage von ganymedWindows Update6 Kommentare

Hallo, alle Artikel die ich zu diesem Thema bisher im Web gefunden habe verweisen letztendlich auf die FAQs von ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Debian
Wie finde ich den betroffenen user
Frage von ProtectedDebian8 Kommentare

Hallo, Wie kann ich den User finden der dies verursacht hat? Betriebsystem ist Debian 7 your Server/Customer with the ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall8 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...