Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ping zu Rechner funktioniert nicht immer!

Mitglied: 69757

69757 (Level 1)

16.09.2008, aktualisiert 17.09.2008, 5183 Aufrufe, 10 Kommentare

Guten Morgen zusammen,

mein Problem beschäftigt mich nun mehr als 2 Monate.
Ich betreibe ein kleines Netzwerk mit 2 Rechnern. (Beides Win XP Pro)

Auf Rechner 1 läuft über MSDE eine Datenbank auf die Rechner 2 zugreift.

Beide Rechner sind mit einem Router verbunden.

Soweit so gut, das Problem ist aber, dass ganz sporadisch (alle 2-4 Tage ca.) Rechner 1 für sehr kurze Zeit nicht erreichbar ist
und meine Datenbankanwendung auf Rechner 2 eine Fehlermeldung ausspuckt. (SQL Fehlermeldung das kein Zugriff auf bestimmtes Recordset besteht).

Nachdem ich dann mal von Rechner 2 einen Dauerping auf Rechner 1 gemacht habe, stellte sich heraus, dass bei ca. 1500 gesendeten Paketen 3 Dabei waren die den Zielhost nicht erreichen konnten.

Also Netzwerkkabel habe ich ausgetauscht
MSDE neu installiert
Datenbankanwendung neu installiert
Netzwerkkonfiguration unter Windows neu eingerichtet

In den Fehlerprotokollen von Windows lässt sich nichts finden (oder ich suche an falscher Stelle)

Auf Rechner 2 erscheint beim Abbruch der Verbindung auch keine Meldung das das Netzwerkkabel nicht eingesteckt ist.

Im Internet surfen ist Problemlos und es treten keine (sichtbaren) Verbindungsunterbrechungen auf.

Schwere Frage, aber wo soll ich den Fehler suchen??


Über Hilfe wäre ich sehr dankbar

mit freundlichen Grüßen

Sebastian
Mitglied: aqui
16.09.2008 um 11:16 Uhr
Das ist schwer zu sagen, denn die Ausfallrate ist sehr gering.
Wenn du die Kabel getauscht hast fällt das schon mal weg.
Möglich wären dann noch folgende Dinge:
  • defekter Switch im Router
  • defekte Netzwerkkarte
  • nicht optimaler Kartentreiber

Letzteres kannst du ganz einfach beheben indem du su deinen verwendeten Netzwerkkkarten den jeweils aktuellsten Treiber von der Herstellerseite einspielst.

Die beiden anderen HW basierenden Möglichkeiten sind nicht ganz so einfach zu erkennen. Was du machen kannst ist dir einen kleinen 12 Euro 5 Port Switch im PC Handel um die Ecke zu kaufen und damit einmal beide Rechner zusammenstecken und checken ob du weiter Pingverluste hast.
Ist das der Fall bleiben fast nur noch die Netzwerkkarten selber sofern der fehler denn wirklich HW bedingt ist.
Hast du diese Ausfälle auch bei größeren Paketen (ping -l 1024 -t) ??
Bitte warten ..
Mitglied: v3rtico
16.09.2008 um 11:19 Uhr
Ist der Router auch auf Internetrouting eingestellt?

Router, die ins Internet routen, müssen die Internetverbindung einmal am Tag auomatisch beenden, sonst wird die Verbindung vom Provider zwangs-getrennt. Je nach Modell wird dabei nicht nur die Internetverbindung sondern auch die Netzwerkverbindung kurzzeitig getrennt.

Meine Empfehlung deshalb: Schau mal in den Routereinstellungen, wann diese zwangstrennung stattfindet. Normalerweise sollte man die dann machen, wenn keine Netzwerkverbindung benötigt wird, so 3.00 Nachts oder so.
Bitte warten ..
Mitglied: 69757
16.09.2008 um 11:50 Uhr
Erst einmal Danke für die Tipps.

klingt ja alles danach als wäre wirklich die Hardware defekt.

Ich werde mich melden, wenn ich eure Vorschläge ausprobiert habe.

Danke
Bitte warten ..
Mitglied: aqui
16.09.2008 um 13:58 Uhr
@v3rtico
Was hat das denn mit seinem Problem zu tun ??? Rein gar nichts !
Wenn du seinen Thread mal richtig durchliest geht es um eine lokale Ethernetverbindung über den im Router integrierten 4 Port Switch.

Mit dem Internet und irgendwelchen Providereinstellungen oder PPPoE Zwangstrennungen hat sein Problem nun wahrlich nicht im Geringsten was zu tun, denn seine Rechner 1 und 2 reden nur mit sich selber OHNE Internet !!!
Bitte warten ..
Mitglied: v3rtico
16.09.2008 um 15:47 Uhr
@aqul
Das hat genau mit dem Problem zu tun. Denn einige Router beenden nicht nur die Internetverbindung sondern stellen für kurze Zeit auch alle Lan-Verbindungen ab. Wenn das der Fall ist, gehen Pingpakete in der kurzen Zeit verloren. Von daher ist nicht nur das Internet, sondern auch das LAN betroffen. Die ausführliche Erklärung war nur Hintergrundwissen.
Bitte warten ..
Mitglied: 69757
16.09.2008 um 16:08 Uhr
Hallo und vielen Dank für die schnellen und guten Antworten.

ich habe jetzt mal den Router getauscht um einen defekt auszuschließen. Leider ohne Erfolg.

Die Möglichkeit das der Router für kurze Zeit das LAN deaktiviert kann ich aber wahrscheinlich ausschließen, da das Problem teilweise mehrmals am Tag und teilweise in recht kurzen Abständen auftritt und dann an anderen Tagen gar nicht.

Außerdem schließe ich den Router aus da die Fehlermeldung auftritt wenn der Benutzer eine Aktion im Programm macht und in dem Moment die Datenbank angesprochen wird. Wäre doch wirklich extremer Zufall wenn die Datenbank in der kurzen Zeit, in der die LAN Verbindung deaktiviert ist, angesprochen wird und das auf die ganze Zeit gesehen. (bestimmt 3 Monate)

Wäre es der Router oder die NIC Treiber hätte es doch nicht die letzten 3 Jahre funktioniert
Oder täusche ich mich?

Außerdem kann ich Antiviren Software und Backup ausschließen da der Fehler auch zu Zeiten auftritt, zu denen die Software nicht arbeitet.
Bitte warten ..
Mitglied: aqui
16.09.2008 um 16:32 Uhr
@v3rtigo
Es ist sehr ungewöhnlich das Router sowas tun, denn der integrierte 4 Port Switch ist in seiner Funktion völlig unabhängig von der Router CPU und damit der Internetverbindung.
Wenn du solch ein Verhalten gesehen hast bei einem Router ist das sehr ungewöhnlich aber bei exotischer Taiwan Billighardware ggf. nicht ganz auszuschliessen.
Ein externer stand alone Switch hätte dann letze Gewissheit gegeben.

Dann bleibt als Ursache eigentlich nur noch eine defekte NIC in einem der PCs übrig...
Bitte warten ..
Mitglied: v3rtico
16.09.2008 um 18:53 Uhr
Nö, das war zum Beispiel vor dem letzten Firmwareupdate der Speedport V-Serie der Fall, die von der Telekom vertrieben wurden und auch unser Zyxel hatte den Fehler gehabt (Die Marke, die bei AOL Verträgen verkauft wird)... ;)
Bitte warten ..
Mitglied: 69757
17.09.2008 um 08:38 Uhr
gibt es denn möglicherweise Software die solch "kleine" Netzwerkausfälle verursacht?
Bitte warten ..
Mitglied: aqui
17.09.2008 um 10:00 Uhr
Wenn diese "Software" deine Rechner CPU zu 90% und mehr auslastet und du eine nicht so performante NIC hast (wie z.B. solche mit Realtek Chipsätzen..) kann so etwas durchaus schon mal passieren !!
Bitte warten ..
Ähnliche Inhalte
Internet
Kein Internet, Ping funktioniert
gelöst Frage von crinaXInternet20 Kommentare

Guten Morgen liebe Community, ich habe ein kleines Problem was mich grade ein wenig zum verzweifeln bringt Ich bin ...

Netzwerkprotokolle
Router Ping funktioniert nicht
Frage von Barti20Netzwerkprotokolle4 Kommentare

Hallo Leute, ich habe ein Problem worauf ich mir kein Reim machen kann. Folgendes Problem: Ich komme von einem ...

Router & Routing

WOL über zwei Router - Ping funktioniert nicht

gelöst Frage von erdmeloneRouter & Routing3 Kommentare

Hallo zusammen, Ich habe vor meinen Rechner im Heimnetzwerk mit WOL so einzurichten, dass ich on überll her ihr ...

Firewall

Ping oder nicht Ping?

Erfahrungsbericht von LordGurkeFirewall10 Kommentare

Immer wieder erzählt mir jemand, dass man eine Firewall so konfigurieren soll, dass sie nicht auf ICMP-Echo-Requests ("Ping") antworten ...

Neue Wissensbeiträge
Server-Hardware
HP iLO ist gefährdet (iLO 4))
Tipp von AlFalcone vor 12 StundenServer-Hardware3 Kommentare

Gemäss Twitter und Heise gibt es eine Angriffsmöglichkeit auf iLO Quelle: iLO ist gefährdet

CMS
Erneut kritische Zero-Day-Lücke in Drupal
Tipp von Reini82 vor 21 StundenCMS

Laut einem Bericht auf t3n gibt es eine Schwere Sicherheitslücke in Drupal die auch schon ausgenutzt wird. Betroffen sind ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 1 TagSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 2 TagenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

Heiß diskutierte Inhalte
Ausbildung
Wie gelingt ein guter Einstieg in die FiSi-Ausbildung? (Umschulung)
Frage von SiAnKoAusbildung30 Kommentare

Schönen guten Tag, ich bin SiAnKo und habe seit dem 1.04.2018 eine Umschulung als FiSi angefangen. Ich möchte natürlich ...

Windows Server
Alten DC entfernen
gelöst Frage von smartinoWindows Server27 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...

Batch & Shell
OU an eine Variable übergeben
gelöst Frage von oesi1989Batch & Shell22 Kommentare

Hallo, ich würde gerne alle OUs an eine Variable übergeben und danach einen Teil per .remove entfernen. Das Anzeigen ...

Batch & Shell
Mit Powershell den Inhalt einer Excel mit einer Text Datei abgleichen
gelöst Frage von Bommi1961Batch & Shell21 Kommentare

Hallo zusammen, ich muss den Inhalt einer Excel Datei (Mappe1) mit dem Daten einer Text Datei abgleichen. Die Daten ...