Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Port Weiterleitung oder ein anderes Problem?

Mitglied: wsurfer78

wsurfer78 (Level 1) - Jetzt verbinden

11.03.2007, aktualisiert 18.10.2012, 3811 Aufrufe, 4 Kommentare

Hallo,

habe folgendes Problem. Mein Windows 2003 Server besitzt 2 Netzwerkkarten. Die eine ist für die Internetverbindung zuständig, die andere fürs interne Netzwerk. Nun habe ich auf dem Server XAMPP installiert. Die erforderlichen Ports habe ich an meinem Router auf die IP meiner internet Netzwerkkarte weitergeleitet. Das Problem ist nun, dass der Webserver auf der IP des internen Netzes läuft und die Ports hier nicht erreichbar sind. Kann ich die Ports von der IP des Internetzugangs auf die IP des Servers weiterleiten oder gibt es hier noch ne andere Lösung?

danke und Grüße Matze
Mitglied: aqui
11.03.2007, aktualisiert 18.10.2012
Das kommt auf deinen Router drauf an ob er das kann ?! Gute Systeme machen das, aber viele Consumer Systeme koennen es nicht oder nicht richtig !
Wichtig ist das du auf dem Router eine statische Route zum internen Netz ueber deinen Server als Router eingetragen hast. Dann kann man IP technisch gesehen problemlos eine Port Forwarding Adresse aus dem internen Netz nehmen, denn der Router wuerde sie ja anhand der statischen Route sauber zuordnen koennen !!!
Wie gesagt, nicht alle Consumer DSL Router koennen das sauber umsetzen ! Wie so ein Szeanrio aussieht siehst du z.B. hier:

https://www.administrator.de/forum/internetrouter-nicht-erreichbar%2c-ab ...

Ein Port Forwarding auf den Server selber klappt natuerlich nicht, da er denkt das Packet ist fuer ihn als Endstation gedacht. IP adresstechnisch ist es ja direkt an ihn addressiert durch den Forwarding Tabelleneintrag. Dieser Workaround greift also nicht !
Bitte warten ..
Mitglied: wsurfer78
11.03.2007 um 17:21 Uhr
Vielen Dank. Habe jetzt auf meinem Router folgende Einstellungen vorgenommen:

Statistische Route
Netzwerk 192.168.10.254
Subentz: 255.255.255.0
Gateway: 192.168.178.1

Hier mein IPconfig:

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Dokumente und Einstellungen\Administrator>ipconfig /all

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : server
Primäres DNS-Suffix . . . . . . . : khmediatec.local
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Ja
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : khmediatec.local

Ethernet-Adapter Intranet:

Verbindungsspezifisches DNS-Suffix:
Beschreibung . . . . . . . . . . : Realtek RTL8139-Familie-PCI-Fast Ethernet
-NIC
Physikalische Adresse . . . . . . : 00-C1-26-07-B6-AB
DHCP aktiviert . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.10.254
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . :
DNS-Server . . . . . . . . . . . : 192.168.10.254
Primärer WINS-Server . . . . . . : 192.168.10.254

Ethernet-Adapter Internet:

Verbindungsspezifisches DNS-Suffix:
Beschreibung . . . . . . . . . . : National Semiconductor Corp. DP83820-Giga
bit-Netzwerkcontroller
Physikalische Adresse . . . . . . : 00-40-F4-21-CB-5B
DHCP aktiviert . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.178.2
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.178.1
DNS-Server . . . . . . . . . . . : 192.168.178.1

C:\Dokumente und Einstellungen\Administrator>


Irgendwie wills aber immer noch nicht funktionieren. Hab ich vielleicht was verwechselt?

Danke und Grüße
Bitte warten ..
Mitglied: wsurfer78
11.03.2007 um 17:58 Uhr
Also der Router ist jetzt von den Clients erreichbar. Das hat vorhin nicht funktioniert. Beim XAMPP kann ich auch einstellen, auf welcher IP der Apache lauschen soll... Welche muß ich mit der Statistischen Route denn jetzt dort eingeben? Die des Gateways oder die IP des Servers?
Bitte warten ..
Mitglied: aqui
13.03.2007 um 10:51 Uhr
Deine statische Route ist falsch !

Statistische Route
Netzwerk 192.168.10.254
Subentz: 255.255.255.0
Gateway: 192.168.178.1


Warum willst du denn Packete für das .10er Netz zurück auf den Router routen (Gateway IP !?) ??? Woher soll der denn wissen wo die Packete hinsollen, wenn du ihm das nicht richtig sagst ! Außerdem hast du ihm zu allem Unglück auch noch eine einzelne Host also Endgeräte Adresse mitgegeben, so das er ausnahmslos nur Packete für den Host .10.254 routen könnte !!! Da gehört natürlich ein Netzwerk rein und nicht nur eine einzelne Host Adresse. Bei einer Netzwerk Adresse sind alle Host Bits auf 0 !!!
Der Einzige der weiss wie deine Packete ins .10er Netz kommen ist doch der Server !!! Also muss deine statische Route so:

Statistische Route
Netzwerk 192.168.10.0
Subenetz: 255.255.255.0
Gateway: 192.168.178.2


aussehen !!! die .178.2. sollte eine statische Adresse außerhalb der DHCP Range des Routers sein !!!
Nochwas: Auf die 2te NIC gehört keine DNS Server und WinS Adresse !!! Also
DNS-Server . . . . . . . . . . . : 192.168.10.254
Primärer WINS-Server . . . . . . : 192.168.10.254
unbedingt entfernen !
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Mikrotik DynDNS und Port Weiterleitung
gelöst Frage von Rolf14Router & Routing6 Kommentare

Hallo Leute, ich habe hier einen MikroTik Router vor mir ( zum ersten mal ) und bin dabei diesen ...

Firewall

PfSense Port Weiterleitung über die FritzBox

gelöst Frage von matze2090Firewall4 Kommentare

Hallo, ich würde gerne auf meinem Server für Plex ein Port Weiterleiten. Meine frage ist, wenn ich in pfSesne ...

Router & Routing

Port Weiterleitung unter Server 2012 R2

gelöst Frage von davidoff1100101Router & Routing6 Kommentare

Hallo, ich habe in meinem Netzwerk das Problem das ich (meines Erachtens) eine Portweiterleitung unter Server 2012 benötige. Wenn ...

Router & Routing

Fritzbox 7490 und selfhost Port-Weiterleitung

Frage von petersberlinRouter & Routing31 Kommentare

Ich möchten über das Internet auf eine IP-Kamera zugreifen. Das hat alles per Port-Weiterleitung mit einem Speedport 504V der ...

Neue Wissensbeiträge
Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 6 StundenHardware

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Sicherheit

Oracle gibt kritische Updates für diverse Produkte frei (16. Oktober 2018)

Information von kgborn vor 17 StundenSicherheit

Oracle hat zum 16. Oktober 2018 eine ganze Reihe an kritischen Updates für seine Produkte freigegeben. Eine Kurzübersicht mit ...

Windows 10
FYI: Fristen beim Windows 10 Downgrade-Recht
Information von kgborn vor 17 StundenWindows 10

Möglicherweise ist das bei euch bekannt - ich habe es gerade aus einem Newsletter eines OEMs herausgefischt. Beim Downgrade-Recht ...

CMS
Freie Wähler Bayern MySQL PW online
Information von sabines vor 20 StundenCMS6 Kommentare

Die Typo3 Installation der Freien Wähler Bayern scheint wohl längere Zeit nicht mehr angefasst und/oder fehlkonfiguriert zu sein. Nach ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1021 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Internet
Ist diese URL denkbar (Syntax)?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Der Sohn eines Arbeitskollegen hat im Gymnasium EDV-Unterricht. Leider hat er in der letzten Klassenarbeit einen Fünfer geschrieben. ...

Exchange Server
Outlook Anywhere - Anmeldefenster muss mit Domain gefüllt werden
Frage von leon123Exchange Server15 Kommentare

Hallo zusammen, ich habe relativ erfolgreich einen Exchange 2016 aufgesetzt, sowie ein SAN-Zertifikat eingespielt und Outlook Anywhere aktiviert. Beim ...

Debian
Linux debian 9 Installation
Frage von Green14Debian15 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...