Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Portfreigabe funktioniert nicht richtig

Mitglied: Xandros

Xandros (Level 1) - Jetzt verbinden

02.08.2008, aktualisiert 05.08.2008, 7363 Aufrufe, 12 Kommentare

Hallo zusammen,

ich habe mir das FTP Server Programm ServU heruntergeladen. Das ganze habe ich auf meinem Win2008 server installiert. ServU braucht folgende Ports: 21, 990, 22, 80, 443. Allerdings hat das mit Port 80 Probleme bereitet, wodurch der Server immer einen fehler angezeigt hat. Ich habe den HTTP Port für ServU dann auf Port 90 gelegt.

Im Router habe ich die dementsprechenden Weiterleitungen eingerichtet. (siehe Bild)

82e4405367157b9c3ab060063135f492-aufzeichnen1 - Klicke auf das Bild, um es zu vergrößern

Der Server hat eine feste IP. Der Router ist ein Linksys WRT54GL

Wenn ich nun aber einen Portscan mache, bekomm ich folgende Ports.

3007cfb04dd93252c1aac0b59cc4372d-aufzeichnen - Klicke auf das Bild, um es zu vergrößern

(die oberen gehören zum Server, die unteren zum router)

Intern komm ich über https://xxx.dyndns.org drauf, über http nicht.

Von extern gar nicht.

Hoffentlich könnt ihr mir weiterhelfen, ich dreh hier noch durch

Danke
Mitglied: aqui
02.08.2008 um 17:19 Uhr
Wo hast du den DynDNS Client installiert ??? Hoffentlich auf dem Router, denn da gehört er hin !

Ansonsten ist die Port Weiterleitung richtig mit Ausnahme das du nicht "Beide" einstellen musst sondern TCP denn wie du selber weisst benutzt HTTP(S) und FTP(S) nur TCP Ports und keine UDP Ports ?

Du solltest dir auf deinem Server einen Packet Sniffer wie den
http://www.wireshark.org/
oder
http://www.microsoft.com/downloads/details.aspx?FamilyID=18b1d59d-f4d8- ...
installieren, damit du sehen kannst ob der Router oder Server der Buhmann ist.
Wenn du eingehende IP Packete von draussen via Router siehst ist es der Server.

Vermutlich ist das wie immer wieder hier die Firewall des Servers, denn von aussen kommst du ja nun mit einer Quell IP Adresse rein die nicht aus dem lokalen Netz kommt !!
Das blockt die Firewall dann sofort und schmeisst die Packete weg.

Du musst also die lokale Firewall entsprechend für diese Ports customizen, das sie dort auch externe IP Adressen zulässt !!!
Bitte warten ..
Mitglied: Arch-Stanton
02.08.2008 um 17:25 Uhr
witzig, daß Du die internen Adressen mühselig ausgeixxt hast. Nimm doch einfach Filezilla, das Programm ist viel einfacher einzurichten.

Gruß,
Arch Stanton
Bitte warten ..
Mitglied: Xandros
02.08.2008 um 17:32 Uhr
HI,

das ging ja fix.

Also der Router verfügt über die Funktion die IP immer selbst zu updaten. Das funktioniert auch. Ich habe beim router unter Anonyme Internet-Anfragen blockieren , den Hacken rausgemacht und es auch schon mit deaktivierter Routerfirewall und Win Firewall versucht , funktioniert aber auch nicht.

Wenn ich es nur mit HTTP mache bekomme ich folgendes Bild

[url=http://www.picbutler.de/bild/12910/aufzeichnen21GJK3.jpg][img]http://www.picbutler.de/thumb/12910/aufzeichnen21GJK3.jpg[/img][/url]

daraufhin, habe ich natürlich unter den ServerRollen nachgeschaut, konnte aber nichts finden. Zur sicherheit habe, ich alle Rollen die unter dem ISS angeboten wurden aktiviert.

@Arch Stanton: ServU hat aber ein Webinterfaces und ist gut zu bedienen (wenn es den mal läuft )


Danke


edit: hab jetzt mal wireshark installiert, wie werte ich das jetzt am besten aus?
Bitte warten ..
Mitglied: aqui
03.08.2008 um 18:37 Uhr
Einen Hacken hat man am Fuss oder benutzt ihn im Garten.....

So wie es aussieht funktioniert deine Port Forwarding doch fehlerfrei, denn das was du siehst ist das Default Bild vom IIS Webserver unter Winblows.
Vermutlich musst du den stoppen, damit dann das vom ServU gezeigt wird oder den ServU auf einem anderen Port wie z.B. 8080 laufen lassen !!

P.S.: Warum postest du die Bilder nicht direkt hier im Forum ?? Wie hier:

9c3ae3ce338c5f3545709ab026b8990d-aufzeichnen21gjk3 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Xandros
03.08.2008 um 18:41 Uhr
Hi, weil ich hier im antwortfeld keine Möglichkeit gefunden habe, Bilder anzuhängen (außer im ersten Post).

Weißt du welcher Port davon genau betroffen ist, da ich den ISS schlecht stoppen kann, da hier noch ein WSUS dranhängt -.-

Danke
Bitte warten ..
Mitglied: aqui
03.08.2008 um 18:46 Uhr
So geht das auch...!! Du importierst das Bild im ersten Post, kopierst den URL per cut and paste und pastest den in die Antwort....einfacher gehts nicht...

Was passiert denn wenn du lokal auf den Server zugreifst mit dem Browser ?? Dort muesste ja auch das IIS Bild erscheinen ?!

Im Handbuch von ServU sollte drinstehen wie man den Webserver auf einem anderen Port startet. Das machst du mit z.B. dem Port 8080.
Wenn du nun im Browser http://<ip_servu>:8080 eingibst dann sollte der ServU antworten parallel zum IIs...
Bitte warten ..
Mitglied: Xandros
03.08.2008 um 19:10 Uhr
ahja, danke werd ich mal testen. ja lokal bekomme ich das bild vom IIS. wenn ich von außen zugreife kommt ein The page cannot be displayed.
Bitte warten ..
Mitglied: aqui
04.08.2008 um 12:19 Uhr
Das solltest du erstmal fixen, das dein ServU auch lokal richtig angezeigt wird (ggf. mit der Port Redirection des Servers), denn sonst kann es ja logischerweise remote auch nicht funktionieren... !!

Eigentlich müsstest du remote auch das IIs Bild genau wie lokal bekommen.
Hast du als Workaround statt der DynDNS Adresse mal die richtige IP des Routers von remote angesprochen ??
Welche das ist kannst du sehen wenn du auf www.wieistmeineip.de gehst.

Bedenke das du von intern NICHT die remote Adresse ansprechen kannst, das funktioniert nur extern.
Du musst also einen Kollegen anrufen und ihn mal fragen einen Connect versuch zu machen.
Alternativ kannst du dich z.B. mit einem analogen Modem bei einem by Call ISP wie z.B. Arcor einwählen
Benutzername: "arcor", Passwort "internet"
Rufnummer: 01920787
einwählen und das testen....
Bitte warten ..
Mitglied: Xandros
04.08.2008 um 14:14 Uhr
Hallo zusammen

@aqui. Ich habe mal testweise alle Ports geändert und geforwarded, aber ging auch nicht

Für den Workaround muss ich einfach die IP adresse eintragen, ohne irgendwelchen Zusatz oder? Den da kommt dann ein "Not found" Wenn ich http:// davorschreibe ein The Page cannot be displayed. (habs von extern versucht)

So langsam verzweifele ich -.-
Bitte warten ..
Mitglied: aqui
04.08.2008 um 18:35 Uhr
Schalt doch in den Security Settings einmal das Pingen auf dem DSL/WAN Interface aktiv, damit du den Router von extern pingen kannst.

Nun sollte wenigstens von remote ein ping auf die DSL IP Adresse oder auf den DynDNS namen sauber funktionieren.

Wenn das der Fall ist dann fängst du erstmal nur mit dem Port TCP 80 an und sonst nix.
Ggf. falls der Router immer sleber antworten will mit seinem Web Setup (das rennt ja auch auf TCP 80 !!) dann nimm einfach TCP 8080 und leite das intern auf TCP 80 deinen Server um, damit umgehst du das Problem !

Falls alle Stricke reissen definieren die IP als DMZ Host, dann forwardet der Linksys alle Ports auf diese IP. Das ist zwar gefährlich, klappt aber immer.
Solltest du aber nur zum Testen machen.

Das du den Linksys auf das neueste Firmware Image geflasht hast und die Firewall am Server ausgestellt hast setzen wir hier mal voraus !!!
Bitte warten ..
Mitglied: Xandros
05.08.2008 um 08:02 Uhr
Ich habs jetzt hinbekommen.

Die Einstellungen waren soweit schon richtig, nur kommt man auf das Webinterface nur mit Https:\\ vorne weg. Das dürfte an der Anmeldeliste liegen oder? Da muss ich vorher ein Zertifikat bestätigen, dann lässt er mich drauf . Danke, endlich steht dieses Teil ^^

Gruß
Bitte warten ..
Mitglied: aqui
05.08.2008 um 13:35 Uhr
Alles wird gut !
Bitte dann
https://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Gast-WLAN funktioniert nicht richtig
Frage von Dukenukem263LAN, WAN, Wireless4 Kommentare

Hallo, ich habe privat daheim einen Kabel BW Anschluß ohne WLAN Funktion. Habe mir über ein Devolo 500 Wifi ...

Windows Server

Faxserver funktioniert vom Client aus nicht richtig

Frage von CharlyXLWindows Server9 Kommentare

Hallo zusammen, ich habe einen Windows Server 2012 R2, ohne Domäne und ein paar Clients. Auf dem Server hab ...

Exchange Server

Funktionspostfach funktioniert nicht richtig

gelöst Frage von JudgelgExchange Server25 Kommentare

Hallo, ich habe das Problem, das diverse Funktionspostfächer beim senden "von" nicht richtig funktionieren. Folgende Fehlermeldung bekomme ich, oder ...

Windows Server

GPO Fonts - funktioniert nicht richtig

gelöst Frage von Adnan88Windows Server10 Kommentare

Hallo, kann mir hier jemand eventuell helfen ? Ich will gewissen Fonts auf gewisse Rechner kopieren im Unternehmen, den ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...