Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix (Lokale Mails werden ohne Authentifizierung gesendet)

Mitglied: hanspeter

hanspeter (Level 1) - Jetzt verbinden

13.02.2007, aktualisiert 21.02.2007, 5610 Aufrufe, 1 Kommentar

Hallo,
ich habe ein kleines Problem. Ich verwende auf einem Server Postfix und den Cyrus.
Bei einer ausgehenden Mail über den Server wird nach einer Authorisierung gefragt. Klappt alles wunderbar. Ein problem tritt nur auf, wenn ich eine email an <user>@<meinhost> sende. Postfix verlangt nun nicht nach einer Authentifizierung, er sendet die E-Mail ohne irgendwelche Beanstandigungen. Er fragt lediglich bei <user>@<anderer host z.b. web.de> nach einer Authentifizierung. Wo liegt der Einstellungsfehler? Weiß jemand darüber etwas?


Hier die main.cf von Postfix

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
myhostname = <mein host>
inet_interfaces = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
mail_spool_directory = /var/spool/imap/user
mailbox_transport = cyrus
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = maildrop
html_directory = /usr/share/doc/packages/postfix/html
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples
readme_directory = /usr/share/doc/packages/postfix/README_FILES
biff = no
message_size_limit = 31457280
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_authenticated_header = yes
Mitglied: flo84
21.02.2007 um 16:47 Uhr
Serwus,
auch ich hab' Postfix und Cyrus unter Debian am Werkeln. Zudem wurden die notwendigen Pakete installiert, damit Cyrus auch als POP3-Server arbeiten kann.
Zu deinem Problem: zunächst hab' ich das mal bei mir getestet und festgestellt, dass ich in keinem Fall nach eine Passwort beim Versand gefragt werde
Da ich mich ja gerne mit solchen Sachen rumspiele bin ich auf folgendes Ergebnis gekommen: ergänze bzw. ändere mal deine main.cf um diese Einträge:

01.
smtpd_sasl_auth_enable = yes 
02.
smtpd_sender_restrictions = permit_sasl_authenticated, reject_non_fqdn_sender,reject_unknown_sender_domain,permit 
03.
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_auth_destination, reject_unauth_destination,permit 
Diese Zeilen haben bei mir geholfen, damit ich beim Versenden der Mail auch nach dem Passwort gefragt werde - hoffe, dass dir das weiterhilft.


Flo
Bitte warten ..
Ähnliche Inhalte
RedHat, CentOS, Fedora

Postfix lokale Kopie der Mail und Relay an Exchange Server

Frage von addamainRedHat, CentOS, Fedora7 Kommentare

Hallo zusammen, ich würde gerne ein Archiv bei einem Exchange Server selber zusammenbasteln. Ich möchte, dass das Archiv auf ...

Exchange Server

Gesendete Mails sind gesendet landen aber im Postausgang

Frage von xchr1sExchange Server3 Kommentare

Hallo Community, ich habe gerade eingerichtet (erstmal zu Test-Zwecken), dass ich über ein anderes Konto Mails "im Auftrag von" ...

Sicherheits-Tools

GPG4Win - gesendete Mails können nicht geöffnet werden

gelöst Frage von Oneil-1989Sicherheits-Tools2 Kommentare

Hallo zusammen, etwas seltsam bekomme ich eine verschlüsselte Mail, alles Super! Antworte ich, alles Super (der Empfänger kann sie ...

Outlook & Mail

Gesendete Mails vorübergehend in Posteingang

Frage von ITSpycherOutlook & Mail6 Kommentare

Liebe Forumsmitglieder In Outlook 2013 in Zusammenhang mit verschiedenen Exchangeversionen werden gesendete Mails in Posteingang angezeigt. Wird der Ordner ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 1 TagHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement13 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android12 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...