Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix (Lokale Mails werden ohne Authentifizierung gesendet)

Mitglied: hanspeter

hanspeter (Level 1) - Jetzt verbinden

13.02.2007, aktualisiert 21.02.2007, 5627 Aufrufe, 1 Kommentar

Hallo,
ich habe ein kleines Problem. Ich verwende auf einem Server Postfix und den Cyrus.
Bei einer ausgehenden Mail über den Server wird nach einer Authorisierung gefragt. Klappt alles wunderbar. Ein problem tritt nur auf, wenn ich eine email an <user>@<meinhost> sende. Postfix verlangt nun nicht nach einer Authentifizierung, er sendet die E-Mail ohne irgendwelche Beanstandigungen. Er fragt lediglich bei <user>@<anderer host z.b. web.de> nach einer Authentifizierung. Wo liegt der Einstellungsfehler? Weiß jemand darüber etwas?


Hier die main.cf von Postfix

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
myhostname = <mein host>
inet_interfaces = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
mail_spool_directory = /var/spool/imap/user
mailbox_transport = cyrus
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = maildrop
html_directory = /usr/share/doc/packages/postfix/html
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples
readme_directory = /usr/share/doc/packages/postfix/README_FILES
biff = no
message_size_limit = 31457280
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_authenticated_header = yes
Mitglied: flo84
21.02.2007 um 16:47 Uhr
Serwus,
auch ich hab' Postfix und Cyrus unter Debian am Werkeln. Zudem wurden die notwendigen Pakete installiert, damit Cyrus auch als POP3-Server arbeiten kann.
Zu deinem Problem: zunächst hab' ich das mal bei mir getestet und festgestellt, dass ich in keinem Fall nach eine Passwort beim Versand gefragt werde
Da ich mich ja gerne mit solchen Sachen rumspiele bin ich auf folgendes Ergebnis gekommen: ergänze bzw. ändere mal deine main.cf um diese Einträge:

01.
smtpd_sasl_auth_enable = yes 
02.
smtpd_sender_restrictions = permit_sasl_authenticated, reject_non_fqdn_sender,reject_unknown_sender_domain,permit 
03.
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_auth_destination, reject_unauth_destination,permit 
Diese Zeilen haben bei mir geholfen, damit ich beim Versenden der Mail auch nach dem Passwort gefragt werde - hoffe, dass dir das weiterhilft.


Flo
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Gesendete Mails sind gesendet landen aber im Postausgang

Frage von xchr1sExchange Server3 Kommentare

Hallo Community, ich habe gerade eingerichtet (erstmal zu Test-Zwecken), dass ich über ein anderes Konto Mails "im Auftrag von" ...

RedHat, CentOS, Fedora

Postfix lokale Kopie der Mail und Relay an Exchange Server

Frage von addamainRedHat, CentOS, Fedora7 Kommentare

Hallo zusammen, ich würde gerne ein Archiv bei einem Exchange Server selber zusammenbasteln. Ich möchte, dass das Archiv auf ...

Sicherheits-Tools

GPG4Win - gesendete Mails können nicht geöffnet werden

gelöst Frage von Oneil-1989Sicherheits-Tools2 Kommentare

Hallo zusammen, etwas seltsam bekomme ich eine verschlüsselte Mail, alles Super! Antworte ich, alles Super (der Empfänger kann sie ...

Outlook & Mail

Gesendete Mails vorübergehend in Posteingang

Frage von ITSpycherOutlook & Mail6 Kommentare

Liebe Forumsmitglieder In Outlook 2013 in Zusammenhang mit verschiedenen Exchangeversionen werden gesendete Mails in Posteingang angezeigt. Wird der Ordner ...

Neue Wissensbeiträge
Windows 10

Blackscreen nach dem Update von 1908 auf 1809 wenn der Rechner aus dem Standby gestartet wird

Tipp von FSX2010 vor 15 StundenWindows 103 Kommentare

Habt ihr den Samsung Treiber "Samsung_NVM_Express_Driver_3.0" installiert sollte dieser für 1809 deinstalliert werden da dieser nicht kompatibel ist. Der ...

Utilities
Teamviewer 14 Verbindungsprobleme mit Proxy
Tipp von PeterleB vor 1 TagUtilities

Nach dem Umstieg von Version 13 auf 14 wollte sich TV nicht mehr mit dem Netz verbinden, ignorierte offenbar ...

Administrator.de Feedback
Unsere Datenbank wurde umgestellt
Information von Frank vor 2 TagenAdministrator.de Feedback5 Kommentare

Hallo User, ich habe in der Nacht unsere Datenbank umgestellt. D.h. neue Version (MySQL 8) und andere Örtlichkeit. Sollte ...

Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 4 TagenSonstige Systeme8 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Heiß diskutierte Inhalte
Vmware
Gebrauchten ESXi- Server verkaufen: Festplatten DSGVO-konform löschen?
Frage von l.scheperVmware20 Kommentare

Hallo, wir möchten einen gebrauchten FUJITSU Server verkaufen. Auf dieser Maschine ist noch ein installiertes ESXi 5.1 und ne ...

Router & Routing
Dediziertes ISP -Routing
gelöst Frage von niLuxxRouter & Routing13 Kommentare

Liebe Community, Ich hätte eine kurze Frage an euch. Durch verschiedene Umstände kann es nun sein, dass sich zwei ...

Samba
Linux Server und Windows Linux Client
gelöst Frage von 137898Samba12 Kommentare

Hallo, ich bräuchte dringend bei der Aufgabe etwas Hilfe. Die Firma XYZ besteht auf zwei Abteilungen Logistik und Technik ...

Windows Server
Windows Server 2012 R2 Komponentenspeicher wurde beschädigt. Inplace Upgrade?
Frage von DeRo93Windows Server11 Kommentare

Hallo liebes Forum, Wir besitzen einen Domänencontroller der auf einem Windows Server 2012 R2 läuft. Dadurch, dass alle Windows ...