Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix Routet keine Mails mehr nach Änderung in amavisd.conf

Mitglied: Burschi

Burschi (Level 1) - Jetzt verbinden

20.04.2006, aktualisiert 24.04.2006, 5131 Aufrufe, 4 Kommentare

Nach Änderung der amavisd.conf nimmt...

... Postfix die Mail aus dem Internet zwar noch an, beim Weiterleiten an 127.0.0.1 (Virenscanner) wird die Mail dann aber rejected. Die von mir vorgenommende Änderung sollte bewirken, dass Empfänger von Virenverseuchten Mails darüber informiert werden, dass Sie die Mail nicht bekommen haben.

  1. SOME OTHER VARIABLES WORTH CONSIDERING (see amavisd.conf-default for all)

  1. $warnbadhsender,
  2. $warnvirusrecip, <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<---------- den Eintrag hier hatte ich aktiviert.
  3. $warnbannedrecip, $warnbadhrecip, (or @warn*recip_maps)
  1. @bypass_virus_checks_maps, @bypass_spam_checks_maps,
  2. @bypass_banned_checks_maps, @bypass_header_checks_maps,
  1. @VIRUS_lovers_maps, @spam_lovers_maps,


Das Problem sieht dann im LOG so aus:

Apr 20 15:24:13 mail1 postfix/smtp[16579]: 29A8E81E044: to=<LXXXXX@gmx.de>, relay=none, delay=588, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)


So. Ich hoffe, dass jemand eine Idee hat, ich bin grad mit meinem Latein am Ende und gehe erst aml eine Runde Radeln.

Vielen Dank für sinnige Beiträge
Mitglied: justinp
20.04.2006 um 16:21 Uhr
Hallo,

jetzt mal ungeachtet deiner Änderungen an der .conf...Hast du überprüft ob der Amavisd läuft
(ps -ef|grep amavis)
und die Ports entsprechend der master.cf offen sind (default 10024 + 10025)
(netstat -anp|grep 10024)?

Gruß
justin
Bitte warten ..
Mitglied: Burschi
20.04.2006 um 16:39 Uhr
Hallo,

also das mit dem Port könnte sein:


Apr 20 16:34:03 mail1 postfix/smtpd[22722]: connect from pdxxxxxx4.dip0.t-ipconnect.de[2xx.91.x.xxx]
Apr 20 16:34:03 mail1 postfix/smtpd[22722]: DE33481E044: client=pdxxxxxxx.dip0.t-ipconnect.de[217.91.8.228], sasl_method=LOGIN, sasl_username=lixxxxxxx
Apr 20 16:34:04 mail1 postfix/cleanup[23523]: DE33481E044: message-id=<20060420143403.DE33481E044@mail1.xxxxxxx.de>
Apr 20 16:34:04 mail1 postfix/qmgr[9060]: DE33481E044: from=<lixxxx.xxxxx@xxxxx.de>, size=474, nrcpt=1 (queue active)
Apr 20 16:34:04 mail1 postfix/smtp[23651]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Apr 20 16:34:04 mail1 postfix/smtpd[22722]: disconnect from pxxxxxxe4.dip0.t-ipconnect.de[x17.xx.8.xx8]
Apr 20 16:34:04 mail1 postfix/smtp[23651]: DE33481E044: to=<lixxxx.xxxxx@xxxxx.de>, relay=none, delay=1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)

Nur wieso ist der Port aufgrund des geänderten parameters nicht mehr aktiv? Das hat doch damit garnichts zu tun!????
Bitte warten ..
Mitglied: justinp
24.04.2006 um 12:08 Uhr
Das hat doch damit garnichts zu tun!????


So ist es.
Du solltest daher erstmal sicherstellen, dass Amavis läuft und die Ports 10024 _und_ 10025 offen sind. Falls es nicht läuft starte Amavis:
/etc/init.d/amavis start
Falls es sich nicht starten lässt prüfe in den logs warum.


Weiterhin hast du jetzt vermutlich jede Menge alte E-Mails in der Warteschlange. Check das mit postqueue -p

Mit einem postqueue -f werden die E-Mails zugestellt.

Gruß
Justin
Bitte warten ..
Mitglied: Burschi
24.04.2006 um 13:07 Uhr
Okay... ich seh schon, so kommen wir nicht weiter. Also eine mailq gabs zum glück nicht, denn wenn ich den Parameter wieder entferne (was ich auch getan habe) dann funktioniert alles in alter Güte. Nach einem restart.

Aber ums auf den Punkt zu bringen, meine Absicht war ja, dass Amavis nicht nur erfolgreich verseuchte Nachrichten blockt, löscht und mir als Admin einen Nachricht zukommen lässt, sondern dem Empfänger auch noch mitteilt, dass er was aus dem o.a. Grund nicht bekommen hat.

Alles funtkioniert, nur nicht die Nachricht an den ursprünglichen Empfänger.

Kannst Du mir damit helfen? Danke jedenfalls schon jetzt für Deine Bemühungen!
Bitte warten ..
Ähnliche Inhalte
Linux
Postfix: Annahme von Mails
Frage von schneerunzelLinux

Hallo zusammen, ich habe seit über eine Jahr ein Zarafa Server mit einem Postfix dadrunter. Bisher hatten wir nur ...

Exchange Server

Exchange 2016 routet E-Mails in falsches Postfach

Frage von MasterPhilExchange Server13 Kommentare

Hallo Zusammen, ein etwas komischer Fehler, der seit einiger Zeit auftaucht und ich mich zum Verzweifeln bringt: Installiert ist ...

RedHat, CentOS, Fedora

Postfix lokale Kopie der Mail und Relay an Exchange Server

Frage von addamainRedHat, CentOS, Fedora7 Kommentare

Hallo zusammen, ich würde gerne ein Archiv bei einem Exchange Server selber zusammenbasteln. Ich möchte, dass das Archiv auf ...

Debian

Postfix courier imap - Probleme mails von einem Client zu versenden

gelöst Frage von JoshuaTreeDebian4 Kommentare

Hallo, habe einen Debian 7 Server Darauf läuft Postfix und Courier-imap Das hat mir jemand eingerichtet da mir das ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 8 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 8 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Viren und Trojaner
Neue Avira Management Console Egosecure
Information von OSelbeck vor 1 TagViren und Trojaner1 Kommentar

Hallöchen zusammen, ich weiß nicht, wer von euch noch Avira einsetzt Wir haben ein paar Kunden Avira hatte ja ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
Frage von YellowcakeExchange Server16 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server12 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...