Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem mit Abschlussprojekt VLAN

Mitglied: christian87

christian87 (Level 1) - Jetzt verbinden

03.04.2009, aktualisiert 20:03 Uhr, 6845 Aufrufe, 7 Kommentare

Hallo liebe IT Community, ich bin Christian und bin in den letzten Zügen meiner Ausbildung als FISI tätig. Meine Ausbildungsfirma möchte das stark gewachsene LAN neu strukurieren, wobei die logische Unterteilung mit VLAN ein entscheidende Rolle spielt. Ich soll als Abschlussarbeit eine VLAN Testumgebung aufbauen, in der verschiedene Szenarien durchgespielt werden und so wichtige Erkenntnisse gesammelt werden können.

Ich bin schon voll im Projekt vertieft und habe als geeignete Variante des VLANs die portbasierte Variante genommen, da in der Firma die Rechner ihren festen Platz haben und so die portabilität und Flexibilität eher eine Untergeordenete Rolle im Gegensatz zu Sicherheit und Kosten/ Nutzen Faktor spielt.

Meine Testumgebung besteht aus einem 3Com 4226T Switch und 2 weiteren, nicht VLAN fähigen Switches, an denen jeweils 2 Clients hängen. Desweiteren gibt es noch einen Windows Vista PC, der exemplarisch als "Server" dienen soll.

Mit der Durchspielung verschiedene Szenarien bin ich soweit durch, nur eins bereitet mir ein wenig Probleme und damit zu meiner Frage:

Ich möchte, dass beide Clients auf den Server zugreifen, sich aber gegenseitig nicht sehen können. D.h. der Server muss im Prinzip eine Netwerkkarte z.B. in VLAN 2 und eine in VLAN 3 besitzen und es darf kein Routing verwendet werden, dann sollte es klappen... Richtig?

Nun hab ich aber die Möglichkeit auf administrator.de gefunden, dieses Szenario über eine Intel NIC mit Pro Suite zu realisieren, wo in der Treibersofteare pro eingerichtetem VLAN ein virtueller Netzwerkadapter hinzugefügt wird, der mit der VLAN ID und dem Namen versehen wird. Die Einstellungen in der Treibersuite hab ich vorgenommen und IP- Adressen an die virtuellen Adapter vergeben und auf dem Switch wurde der entsprechende Port des Servers ( z.B. Port 2 auf dem Switch) als tagged in beiden VLANs ( 2 und 3) hinzugefügt wird.

Das ganze sieht wiefolgt aus:
Die beiden "normalen" Switches hängen an den Ports 5 und 10. Einer an Port 5 in VLAN 2 und einer an Port 10 in VLAN 3, der "Server" hängt an Port 2 und ist in VLAN 2 und 3 jeweils als "tagged" eingetragen.


Das hab ich soweit erlidigt und dann kommt das Problem: Die beiden virtuellen Netzweradapter werden als "Deaktiviert" gekennzeichnet, sie sind im Geräte Manager aber aktiv und beim tatsächlichen Netzweradapter sind nach dem Hinzufügen der VLANs in den Einstellungen sämtliche Häkchen z.B. bei IPv4 und IPv6 entfernt. Wenn man auf einen der Einträge klickt und auf "Eigenschaften" geht kommt eine Fehlermeldung, dass erst ein Netzwerkadapter installiert sein muss und es ist keinerlei Kommunokation mehr möglich.... häh? und da liegt nun der Hase im Pfeffer begraben,
Wie bekomme ich nun die VLAN Karten aktiv?

Was hat es mit den fehlenden Häkchen im tatsächlichen Netzwerkadapter auf sich?

... hoffe Ihr könnt mir weitrehelfen.
Mitglied: dog
04.04.2009 um 01:58 Uhr
Was hat es mit den fehlenden Häkchen im tatsächlichen Netzwerkadapter auf sich?

Die sind vollkommen normal und gehören so.
Sobald du VLANs benutzt wird die physikalische Netzwerkkarte nicht mehr für Datenverkehr (im Sinne von: Windows überträgt direkt Daten über die Karte) benutzt, darum sind die Haken entfernt. Die Intel PRO Software kann sie aber auch nicht einfach wegzaubern, da sie ja immer noch für den (physikalischen) Datenverkehr benutzt wird.

Die beiden virtuellen Netzweradapter werden als "Deaktiviert" gekennzeichnet

Rechtsklick auf die Netzwerkverbindung (ich meine nicht den Geräte-Manager) und Aktivieren funktioniert nicht?
Ich hatte mit Intel PRO Karten und VLANs noch nie Probleme...

Grüße

Max
Bitte warten ..
Mitglied: aqui
04.04.2009 um 16:51 Uhr
Du meinst vermutlich dieses Tutorial:

https://www.administrator.de/VLAN_Routing_%C3%BCber_802.1q_Trunk_auf_MS_ ...

richtig ??

Das ist für ein VLAN Projekt wie dem deinigen eigentlich nur ein Notnagel, denn es beschreibt ein Routing (sofern man es aktiviert) über einen 802.1q Trunk angebundenen Server.
Kein Gutes Design bei einer VLAN Connectivity, denn das erledigt man immer mit einem Layer 3 Switch der zwischen den VLANs routet. Den Server nmmt man nur wenn man keinen L3 Switch im Netz hat.
Normalerweise sollte alle Netzconnectivity auch von den Netzkomponenten ausgehen niemals aber von Servern oder Clients....soviel zur Theorie !

Bei dir ist es aber ein Sonderfall, da beide VLANs zugreifen sollen auf den Server aber keine Connectivity untereinander haben sollen !
In der Beziehung ist das o.a. Tutorial richtig wenn du kein Routing auf dem Server aktivierst.
Die VLANs können dann separat auf den Server zugreifen aber nicht untereinander kommunizieren. Genau das was du willst also !

Normalerweise sollte es mit dem Intel Treiber keinerlei Probleme geben was dog ja auch mehr oder minder bestätigt !

Für dich ist nur wichtig das du auf deinem 3Com Switch den Server Port tagged in die beiden VLANs 2 und 3 legst.
Ferna natürlich das einer der nicht VLAN fähigen Swicthes in VLAN 2 ist und der andere in VLAN 3.

Damit sollte das Szenario absolut problemlos laufen !!
Bitte warten ..
Mitglied: christian87
05.04.2009 um 20:53 Uhr
Ich hab alles, auch wie Ihr sagt eingerichtet, die VLANs, tagged Ports und nach diesem Tutorial ( genau das aqui) den Intel NIC.

@dog:

die virtuellen Adapter sind aktiviert, wenn ich mit der rechten Maustaste darauf klicke kann ich nur "deaktivieren" auswählen. In dem Menü "Netzwerkverbindungen" ist bei den Adaptern das gleiche Symbol, wie wenn ein Netzwerkkabel nicht angeschlossen ist. ( IP Adressen sind ordnugsgemäß vergeben)

@aqui
Natürlich ist es ein Notnagel, auch wie ein Server/ PC mit 2 NICs und jeder in einem VLAN, in dem Projekt sollen aber lediglich Erkenntnisse über die Verhaltensweisen der Netzwerkkommunikation bei verschiedenen VLAN Konfigurationen in einer vom Firmennetz abgetrennten Testumgebung gesammelt werden. Dazu hab ich aber nur den VLAN fähigen Layer 2 Switch. Später bei dem EIgentlichen Umbau des Netzwerks werden dann auch Layer 3 Switches eingesetzt.
Bitte warten ..
Mitglied: aqui
06.04.2009 um 11:50 Uhr
OK, das macht natürlich Sinn !
Dennoch funktioniert die im o.a. Tutorial vorgestellte VLAN Lösung (getestet) völlig problemlos mit den Treibern der Intel Karte !

Irgendwo ist also noch der Wurm in deiner Karten Konfiguration !!! Vermutlich...
Bitte warten ..
Mitglied: christian87
06.04.2009 um 16:26 Uhr
Also, dank für eure Hilfe!

Ich bin nun drauf gekommen.
Also:
Der Übeltäter war Windows Vista, warum auch immer. Ich hab heute einer Rechner mit selber Ausstattung, aber mit XP ausprobiert. Die Konfigurationsdaten sind die gleichen geblieben, ich hab auch die Netzwerkkarte auf dem PC mit exakt den gleichen VLAN Konfigurationsdaten eingerichtet und.... siehe da, es funktionierte auf Anhieb, die VLANs wurden sofort als aktiv gekennzeichnet und ich musste nur noch die IP- Adressen vergeben.
Bitte warten ..
Mitglied: dog
06.04.2009 um 18:02 Uhr
Dann bitte noch den Beitrag als gelöst markieren
Bitte warten ..
Mitglied: aqui
07.04.2009 um 16:32 Uhr
Wie das geht kannst du hier:
https://www.administrator.de/index.php?faq=32
nachlesen !!
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing Problem VLANS Internet
Frage von CyberurmelRouter & Routing74 Kommentare

Hi all , nachdem die Kiste Thread (danke Aqui! ) jetzt einigermaßen läuft für TV und Internet habe ich ...

Netzwerkmanagement
Problem DHCP und VLAN
Frage von idontknowNetzwerkmanagement6 Kommentare

Hi, Ich würde mich sehr freuen, wenn mir jemand bei meinem kleinen aber feinen Problem helfen könnte ;-) Problem: ...

Netzwerke
VLAN Problem zwischen Switch und Router
gelöst Frage von Diddi93Netzwerke3 Kommentare

Hallo liebe Community, Ich bin im Moment dabei ein Netzwerk einzurichten und verschiedene Geräte via VLAN's von einander zu ...

LAN, WAN, Wireless
Problem mit der VLAN-Kompatibilität
gelöst Frage von Diddi93LAN, WAN, Wireless

Hallo Leute, Ich bin momentan dabei zu Testzwecken ein kleines Netzwerk aufzubauen. Ich möchte damit die Trennung von Telefon- ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...