Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit ALIX-Board und Monowall

Mitglied: Fatboy

Fatboy (Level 1) - Jetzt verbinden

14.02.2010 um 22:15 Uhr, 7176 Aufrufe, 7 Kommentare

Ich habe mir ein neues Alix 2D13 Board gekauft, um einen Monowall-Router daraus zu bauen. Als ich dieses Wochenende das System mit Monowall (1.3 embedded) eingerichtet habe, welches noch problemlos ging, habe ich beim Testen Probleme festgestellt.

Nach Abziehen des Netzwerkkabels und erneutem Connecten war keine Netzwerkverbindung mehr zum System möglich, gleiches zeigt sich auch nach Neustart des Rechners. Weder der DHCP-Server arbeitet, noch kann eine Verbindung über manuelle Konfiguration der IP hergestellt werden, immer wieder nur eingeschränkte Connectivität. Dieses Verhalten zeigt sich auf allen Interfaces und kann nur durch einen Reboot der Monowall gelöst werden, danach läuft es wieder solange man die Netzwerkverbindung aufrechterhält.
Hört sich das nach einem Hardware-Problem an oder liegt es am Gesamtsystem. Die Konfiguration der Monowall mit DHCP usw. ist korrekt, da ich eine Monowall erfolgreich am Laufen habe und nach einem Monowall Reboot ja auch alles einwandfrei funktioniert.
Weiß jemand Rat?
Mitglied: StefanKittel
15.02.2010 um 08:45 Uhr
Hallo,
klingt eher nach einem bug/feature der monowall oder einem Bug des Treibers für die Netzwerkkarte an.

Gib doch mal 2 PCs eine feste IP-Adresse und versucht ob die sich gegenseitig oder die monowall anpingen können und ob Dein Alix von der Console die beiden anpingen kann.
Leuchtet die Link LED?

Stefan
Bitte warten ..
Mitglied: aqui
16.02.2010 um 16:17 Uhr
Was das Thema DHCP angeht: Benutzt du da etwa Vista ??
Dann gilt ggf. das hier für dich:
http://support.microsoft.com/kb/928233/de
Ansonsten funktioniert die 1.3 vollkommen fehlerfrei mit DHCP an allen Windows Derivaten, Apple Macs und Linux/Unix sowieso wie du ja an deiner Zweitfirewall auch selber siehst.

Ist vermutlich eher ein Problem der Kabellage oder angeschlossenem Switch (Autonegotiation). Bekommst du ggf. Fehlermeldungen auf der Alix Konsole ?? oder in den Mono Logs ??
Bitte warten ..
Mitglied: Fatboy
16.02.2010 um 17:59 Uhr
Nein, es funktioniert sowohl mit meinem Win XP Pro Notebook als auch dem Vista-Notebook nicht. Bzw. das gleiche Fehlverhalten.
Kabellänge glaube ich nicht (3m Patchkabel) und ein Switch benutze ich auch nicht.

@Stefan: feste IP hatte ich auch vergeben, trotzdem bleibt die Konnektivität auf eingeschränkt und pingen ist dann auch erfolglos.

Auf meiner Googlerecherche hatte ich noch irgendwo gelesen, das FreeBSD6 nicht alle Treiber der Netzwerkkarten unterstützt und es mit "Link up and down" Probleme gibt.

Mein Problem ist ähnlich wie das was esc444 beschrieben hat:
"Hi,

Habe mich mittlerweile schon ziemlich exzessiv mit der monowall beschäftigt und diesen Fred schon rauf und runtergelesen. Im Prinzip läuft auch alles wie es soll (auf einem Alix 2d1 board) nur hab ich das banale Problem dass der DHCP Server nach mehrfachen Anfragen aufhängt. Ich stecke das Kabel abwechselnd in 2 verschiedene PCs und lasse ihnen eine IP zuweisen. Das funktioniert dann etwa 3-6 mal und dann kommt plötzlich eingeschränkte Konnektivität und er bekommt keine IP mehr. "ipconfig /renew" nutzt dann auch nichts, selbst wenn ich die IP manuell vergebe bekomme ich keine Verbindung zur monowall hin. Nach einem reboot klappt dann wieder alles. Wenn er verbunden ist funktioniert auch alles über stunden hinweg perfekt, nur wenn ich ein paar mal IPs vom DHCP server anfordere hängt es sich nach einigen versuchen auf und dann geht bis zum reboot nichts mehr. Hab die monowall auch schon auf factory defaults gesetzt und alles auf standartkonfiguration gelassen aber trotzdem dasselbe Problem. Das Alixboard ist nagelneu, kann sich das jemand erklären oder hat ähnliche erfahrungen gemacht?
gruß
Esc444"
Habe ihm auch schon eine PN geschickt, aber noch keine Antwort.
Bitte warten ..
Mitglied: aqui
18.02.2010 um 00:13 Uhr
Jetzt schreibst du aber kompletten Unsinn !! Sorry...
Wenn du auf "eingeschränkter Konnektivität" hängenbleibst dann findet dein Rechner keinen DHCP Server. Diese Meldung unterbleibt vollkommen wenn du eine statische IP auf dem Client vergbst...das ist ja logisch, weil der Client dann nicht mehr nach einem DHCP Server sucht und diese Fehlermeldung dann niemals mehr auftaucht !! Das ist also Unsinn was du da sagst..
Wenn es dennoch bei dir auftaucht hast du ein gravierendes Windows Problem mit deinem IP Stack !!!

Ein Ethernet Kabel darf 100 Meter lang sein...3 Meter sind also nicht die Welt es sei denn das Kabel ist defekt oder schadhaft ! Sicherheitshalber solltest du ein anderes testen. Was noch sein kann ist das deine Netzwerkkarte am PC Probleme mit der Autonegotiation hat (Speed/Duplex) Hier solltest du auch testweise im Treiber mal auf 100 Mbit und Fulldup fest gehen und das prüfen.
Im Zweifelsfalle bootest du mal eine Linux Live CD wie z.B. Knoppix schnell mal auf dem Rechner und checkst ob das damit auch passiert.
Ein schneller Labortest hier kann das problem nicht nachvollziehen. Mehrfaches schnelles Ziehen und Stecken des Kabels bringt den DHCP Server nicht in Bedrängnis oder zum Absturz !

Was du noch machen kannst: Flashe doch einfach schnell mal Pfsense auf die CF Karte und checke ob das damit auch passiert !!
Bitte warten ..
Mitglied: Fatboy
18.02.2010 um 09:26 Uhr
Mit der eingeschränkten Konnektivität ist es so, wie ich es beschrieben habe und das mit beiden Rechnern (XP Pro/Vista). Sage ich automatisch beziehen, kriege ich irgendeine Phanatsie-IP-Adresse. Vergebe ich dann eine feste IP aus dem Subnetbereich, bleibt es bei der eingeschränkten Konnektivität, trotz Neustart des Rechners oder kurzzeitiges Deaktivieren der Netzwerkkarte. Nach Neustart der Monowall läuft, wieder alles. Auf meiner im Betrieb befindlichen Monowall (auch V1.3 alter PC mit CF-Card) habe ich keinerlei Probleme.
Macht ein BIOS-Update auf dem Alix-Board Sinn, falls was neueres zur Verfügung steht oder kann man dort irgendwelche Einstellungen zum Testen ändern?
Mit Pfsense kann ich mal ausprobieren. Ergebnis folgt demnächst!
Bitte warten ..
Mitglied: aqui
19.02.2010 um 21:03 Uhr
Ooops da hast du dann aber wohl eher ein Riesenproblem mit deinen Endgeräten als mit Monowall/Pfsense.
Das Verhalten ist absolut abartig und entspricht nicht dem Standard von Windows...
Ist ja auch logisch. Bei fehlendem DHCP Server und der damit folgenden "Eingeschränkten Konnektivität" vergibt der Rechner sich eine APIPA Adresse:
http://de.wikipedia.org/wiki/Zeroconf
Also keineswegs eine "Phanatsie-IP-Adresse" wie du behauptest. APIPA Adressen fangen immer mit 169.254...an ! Mit Phantasie hat das rein gar nichts zu tun...
Sollten es dennoch völlig andere IPs sein bleibt es dabei...dann hast du ein Windows Problem !!
Boote einfach mal eine Linux Live CD wie Knoppix und check mal ob die Monowall/Pfsense dort auch so verhält...??
Vermutlich wird das nicht der Fall sein...!!
Bitte warten ..
Mitglied: Fatboy
19.03.2010 um 15:16 Uhr
Das es an den Endgeräten liegt, schließe ich nach wie vor aus. Ich denke, es liegt eher an dem hier Geschriebenden aus dem Monowall-Forum:
Der vr(4)-Treiber in FreeBSD 6.3 (der für die NICs auf den ALIX-Boards verwendet wird) scheint manchmal Probleme zu haben, Link-Up-Ereignisse zu erkennen (das muss er z.B. wenn du einen direkt am ALIX-Board angeschlossenen PC neustartest, weil dann der Link mindestens einmal kurz flappt). Leider gibt's dafür noch keine Lösung; das Problem scheint nur in FreeBSD 7.0 behoben zu sein; die Änderungen sind aber zu tiefgreifend, als dass sie einfach auf 6.3 zurückportiert werden könnten. 6.4 scheint auch nichts zu nützen.

Siehe dazu auch http://m0n0.ch/wall/list/showmsg.php?id=344/90

Wenn man das ganze damit umgehen kann, dass ein Switch zw. PC und Mono zwischengeschaltet ist, bin ich glücklich. Meine Netzwerkarchitektur sieht es ehe vor. Werde es mal testen und das Ergebnis hier posten.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Kein Erfolg mit monowall auf ALIX Board
gelöst Frage von estebuLAN, WAN, Wireless24 Kommentare

Hallo Gemeinde, ich bin bei der Suche nach einer Captive Portal-Lösung auf die monowall gestossen und habe mir ein ...

Firewall

PfSense auf ALIX-Board installieren - Problem

gelöst Frage von R3nD0mFirewall8 Kommentare

Moinsens Ich habe heute versucht pfSense auf meinem ALIX Board (pc-engines) zu installieren. Das Image habe ich mit WinDiskImager32 ...

LAN, WAN, Wireless

Alix Board keine USB-Tastatur

gelöst Frage von RalphTLAN, WAN, Wireless4 Kommentare

Hallo, eigentlich gehört das Thema ja nicht in Netzwerke, aber ich denke, dass es hier am meisten gelesen wird. ...

LAN, WAN, Wireless

Openvpn Alix Board

Frage von nullpeilerLAN, WAN, Wireless10 Kommentare

Hallo Admins, ich habe hier ein Alixboard und möchte das als Openvpn Server betreiben ohne Firewall. Welche Linux Distri ...

Neue Wissensbeiträge
Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 29 MinutenWindows 10

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 3 StundeniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 1 TagSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++28 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...

Hyper-V
HyperV DC + DNS + AC
gelöst Frage von HardstylesHyper-V16 Kommentare

Hallo kann mir jemand sagen wieso meine Domänen Computer kein Internetzugang erhalten? Ich hab hier ein Server wo die ...