Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem beim kopieren von Daten von einer Festplatte auf eine externe Festplatte per Batchdatei

Mitglied: imebro

imebro (Level 2) - Jetzt verbinden

21.07.2011, aktualisiert 18:02 Uhr, 4772 Aufrufe, 5 Kommentare

Hallo!

Heute mal eine Frage für ein privates Problem

Ich habe eine Batchdatei geschrieben, mit der ich meine wichtigen Daten aus einem Verzeichnis auf der Laptop-Festplatte kopieren möchte in ein Verzeichnis auf meiner externen Festplatte.
Die externe Festplatte ist per USB am Laptop angeschlossen.
Betriebssystem ist Windows 7, 64-bit

Zwar meldet mir die Batch, dass die Daten erfolgreich kopiert wurden, aber wenn ich dann in dem Verzeichnis auf der externen FP nachsehe, fehlen dort die neuen Dateien.
Ich habe testweise mal 2 Dateien in ein bestimmtes Verzeichnis kopiert... diese tauchen aber dann später auf der externen FP nicht auf.
Auch als ich den Parameter "/D" weggelassen habe, funktionierte es nicht und die beiden neuen Dateien wurden nicht kopiert.

Die LOG-Datei zeigt später auch nur das Verzeichnis an, aus dem kopiert wurde --> also "G:\Personal-Backup" und nicht das Verzeichnis, wohin kopiert werden sollte --> also "I:\Personal-Backup".

Hier meine Batchdatei:

01.
@ echo off 
02.
 
03.
CHOICE /C JN /M ".     wollen Sie beginnen?" 
04.
if errorlevel 2 goto ENDE 
05.
if errorlevel 1 goto WEITER 
06.
 
07.
:WEITER 
08.
 
09.
xcopy G:\Personal-Backup I:\Personal-Backup /D /L /R /S /Y 1>c:\LOG_BATCH.LOG 2>&1 
10.
 
11.
 
12.
if errorlevel 1 goto FEHLER 
13.
if errorlevel 0 goto ERFOLG 
14.
 
15.
 
16.
:FEHLER 
17.
echo.            Leider gab es einen FEHLER! - Programm mit Tastendruck beenden! 
18.
 
19.
pause > nul 
20.
goto ENDE 
21.
 
22.
 
23.
:ERFOLG 
24.
echo.             Das Backup auf der ext. Festplatte wurde aktualisiert! 
25.
 
26.
 
27.
echo.      Programm mit Tastendruck beenden - Zielverzeichnis wird geoeffnet 
28.
 
29.
pause > nul 
30.
 
31.
:ENDE 
32.
 
33.
start I:\Personal-Backup 
34.
start C:\LOG_BATCH.LOG
Vielleicht könnte es sein, dass ein solcher Kopiervorgang zu einer externen FP per Batch gar nicht funktioniert?
Ich habe das ganze auch schon ohne den "Choice"-Befehl getestet und einfach nach der Kopierzeile noch ein "/W" eingegeben, damit eine Aufforderung zum Beginn des Kopiervorganges erscheint. Aber auch das funktioniert nicht... bringt also kein anderes Ergebnis.

Hoffe Euch fällt etwas ein

Danke und schöne Grüße,
imebro
Mitglied: Hubert.N
21.07.2011 um 18:45 Uhr
Moin

Wenn du mal das /L in deiner Befehlszeile entfernst, dann klappt das auch mit dem Kopieren

Gruß

Hubert

btw: für ein Backup würde ich eher robocopy verwenden
Bitte warten ..
Mitglied: Friemler
21.07.2011 um 18:54 Uhr
Hallo imebro,

um sowohl Quell- als auch Zieldateien im Log zu sehen verwende den Parameter /F.

Ansonsten gilt, was schon HubertN schrieb...

Gruß
Friemler
Bitte warten ..
Mitglied: imebro
21.07.2011 um 20:14 Uhr
Hallo Ihr Beiden und danke für die schnellen Antworten.

Ich hatte die Beschreibung von "/L" irgendwie ganz falsch verstanden und auch beim "/F" war mir nicht klar, dass es sich auch auf die LOG-Ausgabe auswirkt.

Werde gleich mal testen

Schöne Grüße,
imebro
Bitte warten ..
Mitglied: imebro
21.07.2011 um 20:24 Uhr
VIELEN DANK!

Hat wunderbar geklappt mit "/F" und ohne "/L"

Schöne Grüße,
imebro
Bitte warten ..
Mitglied: ForgottenRealm
22.07.2011 um 10:30 Uhr
Hi

Ich würde dir zum Sichern auch robocopy empfehlen, da xcopy bei einer gewissen Anzahl an Daten abbricht.
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid

Daten kopieren von teildefekter Festplatte

gelöst Frage von FreankhFestplatten, SSD, Raid17 Kommentare

Hi. Ich habe ein defektes Laufwerk,auf das noch zugegriffen werden kann. Ich habe 60 GB Daten zu verschieben/retten. Problem ...

Festplatten, SSD, Raid

Problem mit meiner externen Festplatte

Frage von CrystalexFestplatten, SSD, Raid7 Kommentare

Hallo liebe Nutzer. Ich hatte letztens beim anschließen ein Problem mit meiner externen Festplatte.Auf meinem Lapotop unter Windows 7 ...

Batch & Shell

Laufwerk auf externe Festplatte kopieren mit Rückgabe eines Errorlevels

gelöst Frage von ExzelBatch & Shell5 Kommentare

Hallo zusammen, ich habe eine Batch geschrieben, in der mit Hilfe von Fastcopy eine Festplatte auf eine von drei ...

Verschlüsselung & Zertifikate

Daten von verschlüsselter NAS Festplatte auf PC kopieren

Frage von WurstschoernchenVerschlüsselung & Zertifikate5 Kommentare

Hallo, ich habe folgendes Problem: Ich besitze ein NAS von Zyxel (NSA325) und habe zwei Festplatten mit je 2TB ...

Neue Wissensbeiträge
Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 12 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 18 StundenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Microsoft Office

MS Office 2019 ohne OneNote - OneNote App speichert nur in Cloud

Information von Deepsys vor 1 TagMicrosoft Office5 Kommentare

Microsoft zeigt deutlich wohin alles bei Ihnen geht, OneNote 2019 wird es nicht mehr geben, und die Windows 10 ...

Humor (lol)

Warum man sein Gast-WLAN nicht beliebig nennen sollte

Erfahrungsbericht von Henere vor 2 TagenHumor (lol)5 Kommentare

Servus, mal was aus dem Alltag. Zu Hause. Eigentlich wollte ich nur einen weiteren WLAN-AP ins Netz bringen, damit ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Windows 10
Windows 10 Startmenü-Einstellungen Systemweit festlegen
Frage von flotautWindows 1013 Kommentare

Guten Morgen liebe Admins, wir möchten bei uns am Lehrstuhl demnächst auf Windows 10 umsteigen. Wir installieren unsere PC's ...

LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless12 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...