Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit MIME-Lite

Mitglied: daddyo2

daddyo2 (Level 1) - Jetzt verbinden

17.02.2006, aktualisiert 20.02.2006, 7854 Aufrufe, 11 Kommentare

Hallo!

Ich habe folgendes Problem:

Ich habe ein Perl-Script geschrieben, mit dem E-Mails samt Anhang verschickt werden sollen (mit MIME-Lite). Dies soll letztendlich automatisiert geschehen.
Das Script funktioniert so hervorragend, wenn das Script allerdings kompiliert wurde (perl2exe) bekomme ich folgende Fehlermeldung:

"Failed to connect to mail server: Unknown error"

Was mich daran halt sehr irritiert, dass das Script unkompiliert einwandfrei funktioniert.

Hat jemand eine Idee woran es liegen könnte?
Mitglied: 6890
20.02.2006 um 10:33 Uhr
ja hallo erstmal,

du nutzt ja sicherlich Perl2Exe oda???

hast du auch eingestellt das die Module mit hineinkompiliert werden und wenn ja wird der mail-server direct im script eingetragen oder eher per config datei???

und wenn ich ein kleinen tipp geben darf: mußte das auch vor kurzen machen (mails mit anhängen automatisiert usw.) und da kann ich dir das modul (http://search.cpan.org/~gmpassos/Mail-SendEasy-1.2/lib/Mail/SendEasy.pm) Mail::SendEasy nur wärmstens empfehlen!!!
das is am einfachsten wegen anhängen und so!!

mfg godlike P
Bitte warten ..
Mitglied: daddyo2
20.02.2006 um 11:41 Uhr
Vielen Dank erstemal für den Tip!

Also zunächst zu den Fragen:

Ich benutze Perl2Exe und auch die Module wurden mit hineinkompiliert.

Ein Problem gibt es allerding noch:
Mit MIME::Lite benötigt man kein User oder PWD, was ich bei Mail::SendEasy benötige. Das ist hier in der Firma eine größere Sache, daher war die Methode über MIME::Lite die erste Wahl...
Bitte warten ..
Mitglied: 6890
20.02.2006 um 11:46 Uhr
nee brauchste ni, bei mir im script steht auch nur der mailhost drinne, das andere (alos user &pass) is optional.

das hängt davon ab wie ihr euren server eingestellt habt!!!

mfg
godlike P
Bitte warten ..
Mitglied: daddyo2
20.02.2006 um 11:48 Uhr
Vielen Dank ich hoffe damit klappt der ganze Spass.

Vielen Dank für die Hilfe
Bitte warten ..
Mitglied: 6890
20.02.2006 um 11:52 Uhr
Vielen Dank ich hoffe damit klappt der ganze
Spass.

was mir natürlich gerade noch eingefallen ist:

wie gibst du denn mailhost an??
bzw über was schickt MIME::lite die nachricht??
Bitte warten ..
Mitglied: daddyo2
20.02.2006 um 11:55 Uhr
use MIME::Lite;
use Net::SMTP;
[...]
MIME::Lite->send('smtp', 'mailhost', Timeout=>60);
$msg->send;
Bitte warten ..
Mitglied: 6890
20.02.2006 um 11:57 Uhr
MIME::Lite->send('smtp', 'mailhost',
Timeout=>60);

also tust du den mailhost normal reinschreiben und nich über ne variable?!!

dann probier das bitte mal so:
MIME::Lite->send("smtp", "mailhost",Timeout=>60);

also anstatt hochkommas, gänsefüßchen!!!

mfg godlike P
Bitte warten ..
Mitglied: daddyo2
20.02.2006 um 12:03 Uhr
Nee, sorry das habe ich schon alles probiert, da ich mir wegen diesem Fehler schon einige Tage die Haare ausraufe
Bitte warten ..
Mitglied: 6890
20.02.2006 um 12:26 Uhr
Nee, sorry das habe ich schon alles probiert,
da ich mir wegen diesem Fehler schon einige
Tage die Haare ausraufe

hmm na gut dann kann ich nur sagen probiers halt mal mit nem anderen modul!!!

wird schon klappen =)
und wenns doch ni geht kannste wenn du willst mir das script eventuell mal schicken?!
4 augen sehen immer besser als 2...

mfg godlike P
Bitte warten ..
Mitglied: daddyo2
20.02.2006 um 13:27 Uhr
können wir machen, aber wie gesagt, ich glaube fast, das bringt nichts, das das Script unkompiliert einwandfrei geht....
Bitte warten ..
Mitglied: 6890
20.02.2006 um 13:30 Uhr
also wenn du willst kannst du das script mal an god@amnasty-metal.de schicken...
dann schau ich mir das mal an!!

mfg godlike P
Bitte warten ..
Ähnliche Inhalte
DSL, VDSL
Dual Stack Lite Problem
gelöst Frage von NePheusDSL, VDSL3 Kommentare

Hallo zusammen, ich habe auf meinem Synology NAS die FTP Funktion aktiviert, einen neuen Benutzer mit entsprechenden Rechten angelegt ...

Netzwerke

DS Lite Problem mit Openvpn und Raspberry lösen

gelöst Frage von winlinNetzwerke14 Kommentare

Hi Leute Leider habe ich auch einen blöden ds lite Anschluss von unitymedia und erreiche mein Netzwerk von außen ...

Outlook & Mail

S Mime Verschlüsselung mit VPS

Frage von m.zeiseOutlook & Mail

Hallo zusammen, folgende Situation habe ich. Bei uns steht ein Exchange 2010 Standard mit Outlook 2010 Clients. Eine Handvoll ...

Windows Tools

Nachfolger für Wininstall Lite gesucht

Frage von Winfried-HHWindows Tools2 Kommentare

Hallo Experten! Erstmal wünsche ich allen ein gutes neues Jahr! Weiß jemand, ob man das gute alte WinInstall Lite ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 1 TagHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Router & Routing
Mikrotik: Routing zwischen Interfaces mit Geräten ohne Gateway
Frage von TonLichtVideoRouter & Routing17 Kommentare

Hallo zusammen, ich komme aus dem Veranstaltungstechnik Bereich und habe zwei Netze um verschiedene Hardware zu Remoten. CONTROL1 192.168.1.0/24 ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...