Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit monowall-captive portal. keine weiterleitung nach login, teilweiße kein einloggen möglich.

Mitglied: tokn136

tokn136 (Level 1) - Jetzt verbinden

01.09.2011, aktualisiert 15:35 Uhr, 5979 Aufrufe, 3 Kommentare

Hallo,
erstmal kurz meine Konfiguration:

DSL Modem -- WAN Interface (10.0.0.136/8) -- LAN Interface (192.168.10.1/24)
-- GUEST(WLAN mit AP) Interface (192.168.2.1/24)

mein Problem ist folgendes.
Zunächst erhalte ich manchmal keinen Zugriff auf das Captive Portal, besonders häufig falls sich ein neuer Client verbinden will. sprich nachdem sich der Client mit dem WLAN verbunden hat, bleibt nach der Eingabe im Browser eine weiße Seite zurück oder es kommt eine Meldung dass der Name nicht aufgelöst werden konnte (was auf ein DNS Problem hindeuten würde), dem Client wird als DNS Server die 192.168.2.1 zugeordnet.

Falls, wie es manchmal dann doch der Fall ist, das Captive Portal erscheint, erhält der Client nach der Eingabe des Voucher Codes entweder wiederum eine leere Seite (in der Adressleiste bleibt 192.168.2.1:8000) oder es kommt die Statusseite des Captive Portals. Allerdings wird der Client nie auf die vorher eingegeben Seite weitergeleitet.


DHCP Einstellungen für das GUEST Interface:
c87ce79f0ceea5055ea003347a8edb68 - Klicke auf das Bild, um es zu vergrößern

Die Firewall Rules für das GUEST Interface:
f2e7497c47728285a05c9e8421f63e31 - Klicke auf das Bild, um es zu vergrößern

Und noch die Captive Portal Einstellungen:
f2a8b88382f5ddf9b9859f4f5df21c27 - Klicke auf das Bild, um es zu vergrößern

Ich bin leider mit meinem Latein am Ende. Ich hoffe es kam mir jemand weiterhelfen.
Viele Dank,
tokn
Mitglied: aqui
01.09.2011 um 16:28 Uhr
Das ist schonmal gelogen oder technsich falsch: "DSL Modem -- WAN Interface (10.0.0.136/8)"
Wenn du ein DSL Modem hättest würdest du dort eine öffentliche IP bekommen und keine private RFC 1918 IP (10er Netz !) Dein "Modem" ist folglich also ein NAT Router den du vor der FW betreibst !
Fürs weitere Troubleshooting stellt sich dann jetzt die Frage ob du an der Verbindung WAN Port FW zu LAN Port Internet Router DHCP machst oder ob du dort die IP Adressen statisch vergeben hast ??
Wenn letzteres der Fall ist hast du den DNS Server (IP Adresse des Internet Routers) dann statisch in den Globalen Einstellungen der FW angegeben ??
Leider keinerlei Info dazu von dir... Das ist aber wichtig um die DNS Funktion sicherzustellen denn vermutlich ist dein Fehler ein DNS Fehler !
Da du als Gast Interface ein neues IP Netzwerk definiert hast auf dem Port musst du auch zwingend neue Firewall Regeln auf diesem Port definieren denn also default blockt die FW erstmal alles wie es sich für eine FW auch gehört.
Zum Testen könntest du erstmal eine "any to any" Regel nehmen um nicht in die Blocking Falle zu geraten. Wenn du das nicht willst musst du hier zwingend DNS (UDP und TCP 53), die Portalseite mit TCP 8000 und erstmal TCP 80 (Webtraffic) erlauben und zwar gleich am Anfang damit das sauber funktioniert !!! Hast du ja mehr oder weniger auch schon gemacht.
Einen Fehler hast du mit der CP Regel für die Portal Seite auf TCP 8000 gemacht indem du als Ziel die 192.168.2.1 dort eingesetzt hast. Das ist etwas unglücklich. Belasse das Ziel lieber auf * !
So sollte es dann richtig aussehen und damit funktioniert es sauber !:
4bb3760f0c5e04c21f05f9a0642e3106 - Klicke auf das Bild, um es zu vergrößern
Nochwas zu deinen FW Regeln:
Deine "Guest HHTPS --> any" Regel ist so wie si im Screenshot ist kompletter Blödsinn, denn damit erlaubst du generell jegliche TCP Session weil du die Angabe von Port TCP 443 in der Destination vergessen hast ! Das solltest du also besser schnell korrigieren !
Für POP3, SSH, SMTP und IMAP stimmen sie dann wieder !
Zusätzlich solltest du noch die verschlüsselten Email Ports freigeben falls jemand gesicherte Email Kommunikation aktiviert hat
Secure SMTP (SSMTP) - port TCP 465
Secure IMAP (IMAP4-SSL) - port TCP 585
IMAP4 over SSL (IMAPS) - port TCP 993
Secure POP3 (SSL-POP) - port TCP 995
Ansonsten würden solche Email Verbindungen geblockt !
Damit müsste die CP Seite einwandfrei laufen sofern die DNS Parameter wie oben genannt entsprechend konfiguriert sind !
Bitte warten ..
Mitglied: tokn136
02.09.2011 um 01:10 Uhr
Estmal vielen vielen Dank für die Antwort.
Das war vl etwas unglücklich formuliert, damit wollte ich lediglich andeuten, dass ich als Verbindundstyp für die WAN Seite PPTP ausgewählt habe und dort dann eben diese IP Adresse zugeteilt habe. Diese wird dann aber natürlich, wie du richtig gesagt hast, nach dem sich die Firewall mit dem Modem verbindunden und beim Provider angemeldet hat, durch eine öffentliche IP ersetzt.
Des Weiteren werden keine Adressen statisch vergeben, weder die im GUEST Netz noch die im normalen LAN Netz.
Ich habe die Regeln enstprechend angepasst und die BLOCKING Regeln erstmal alle rausgenommen. Es scheint nun 'häufiger' zu klappen.
Trotzdem, gerade als ich dann gestern den Beitrag abschicken wollte, wurde meine Verbindung unterbrochen und es ging wieder gar nichts mehr.
Das gleiche Spiele heute, erstmal wird gar keine Seite geladen, später dann die Portal Seite, nach dem dann wieder keine Seite und irgendwann nach ein paar Versuchen klappt es dann
Ein nslookup vom Client aus klappt ohne Probleme.

Die Sache mit der Weiterleitung nach erflogreicher Anmeldung klappt leider auch noch nicht. Muss ich dies händisch in dem von mir erstellen Formular zur Anmeldung einbauen?
Soweit ich das in den verschiedenen Beiträgen gelesen habe, muss ich doch einfach nur das entsprechende URL-Feld im Menüpunkt Captive Portal freilassen. Dies habe ich auch gemacht, nur komme ich immer nach der Eingabe des Vouchers wieder auf die Portal Seite zurück. (Bei erfolgreichem Anmelden halt auf die Status Seite des Portals).
Ich hatte in diesem URL-Feld mal für Testzwecke eine URL eingetragen, diese Weiterleitung hat auch funktioniert. Kann es sein, dass ich deshalb nun nicht mehr zur eingetlich gewünschten Seite weitergeleitet werde und deshalb auf der Portal Seite bleibe? Muss ich vl. irgendwas zurücksetzen?

Vielen Dank für die schnelle Antwort und die Hilfe!!
Bitte warten ..
Mitglied: aqui
02.09.2011 um 09:51 Uhr
Leerer Kommentar ??? :-o
Wenns das denn war wie immer
https://www.administrator.de/index.php?faq=32
Bitte warten ..
Ähnliche Inhalte
Netzwerke

Weiterleitung nach Anmeldung im Captive Portal

gelöst Frage von MLangHSENetzwerke1 Kommentar

Hallo, ich habe eine Frage bzgl. des Tutorials zum Theme Captive Portal wie hier beschrieben: Es geht darum ob ...

HTML

Captive Portal login Seite

gelöst Frage von gansa28HTML2 Kommentare

Hallo zusammen, ich betreibe ein offenes Gäste WLAN über eine PFSense (2.3.2-RELEASE-p1) mit Captive Portal. Leider bin ich zu ...

Utilities

Monowall Captive Portal - Ein Benutzername und Kennwort für alle möglich?

gelöst Frage von eisbeinUtilities4 Kommentare

Hallo! Es geht hier nur um die Grundsatzfrage, ob es genügt beim Captive Portal der monowall einen Benutzernamen mit ...

LAN, WAN, Wireless

PfSense Captive Portal Login via Apple nicht möglich

gelöst Frage von AkroshLAN, WAN, Wireless10 Kommentare

Hallo zusammen, ich hoffe es gibt ein paar pfSense-Gurus unter euch. Ich habe folgendes Problem. Wir haben einen WLAN-Controller ...

Neue Wissensbeiträge
Windows 10
Windows 10 Oktober 2018 Update: Es ist wieder da
Tipp von Bowsette vor 8 StundenWindows 10

Ein neuer Versuch von Microsoft das Windows 10 Oktober 2018 Update, auch bekannt als 1809, an den Mann zu ...

Windows Server

Windows Server 2016: Achtung - ab heute gibt es wieder Express Updates

Information von kgborn vor 18 StundenWindows Server1 Kommentar

Kurze Info für Administratoren, die Windows Server 2016 per WSUS/SCCM mit Updates betanken. Ab heute gibt es für Windows ...

Windows Netzwerk
Windows Admin Center - Sagt was ihr braucht!
Tipp von Juanito vor 2 TagenWindows Netzwerk18 Kommentare

Hallo zusammen, der ein- oder andere hat sicherlich schon vom Windows Admin Center gehört. - Microsoft's neue Adminkonsole welche ...

Verschlüsselung & Zertifikate

Bitlocker-Verschlüsselung und -Monitoring ohne MBAM

Tipp von DerWoWusste vor 2 TagenVerschlüsselung & Zertifikate

Der Folgende Tipp beschreibt, wie man ohne MBAM die Verschlüsselung erzwingt und monitort. MBAM ist ein Enterprise-Benefit und somit ...

Heiß diskutierte Inhalte
Entwicklung
Meine Nachbarn sehen meinen Internet Trafic
gelöst Frage von beatnguEntwicklung51 Kommentare

Hallo Also ich wohne in einem Mehrparteien Haus mit 24 wohnungen. Meine nachbaren im letzten stock fummeln immer an ...

Microsoft Office
Lizenzierung
Frage von opc123Microsoft Office29 Kommentare

Hallo, eventuell ein oft bekanntes Thema. Office 365 ist mir zu teuer, da wir als Bildungsträger andere Konditionen beim ...

Windows 10
Windows 10 mit CRITICAL PROCESS DIED
Frage von liquidbaseWindows 1028 Kommentare

Das aktuelle Problem was ich habe steht bereits im Threadtitel. Etwas mehr zum Hintergrund soll nun folgen. Problemkind ist ...

Voice over IP
Andere Rufnummer bei abgehenden Gesprächen vom All-IP-Anschluß der Telekom anzeigen
Frage von vafk18Voice over IP19 Kommentare

Ich möchte bei abgehenden Gesprächen vom All-IP-Anschluß der Telekom meine Handynummer hinterlegen, damit ich Rückrufe jederzeit empfangen kann. Derzeit ...