Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Robocopy.exe aus dem Recource Kit von Windows

Mitglied: horschte

horschte (Level 1) - Jetzt verbinden

05.08.2006, aktualisiert 07.08.2006, 13218 Aufrufe, 3 Kommentare

Ordnernamen mit Leerzeichen darin werden von Robocopy nicht akzeptiert

Ich nutze robocopy.exe mit viel Erfolg zum schnellen Sichern ganzer Partitionen und von Ordnern. Ich habe jedoch ein Problem, wenn Leerzeichen in einem Namen enthalten sind.

Obwohl ich entsprechend der Vorschrift in der Dokumentation Robocopy.doc die fraglichen Pfade in Anführungszeichen (quotation marks) setze, kommt eine Fehlermeldung und die Sicherung findet nicht statt.

Beispiel für die Kommandozeile:
C:\>robocopy "C:\Dokumente und Einstellungen" "V:\backup\Dokumente und Einstellungen" /MIR /W:1 /R:1

Würde der Befehl lauten
C:\>robocopy C:\Programme V:\backup\Programme/MIR /W:1 /R:1
gäbe es kein Problem. Die Sicherung läuft ab.

Für das o.g. Beispiel kommt als Fehlermeldung:
Source: C:\"C\Dokumente\

Dest: C:\und\

Files: Einstellungen"
Options: /COPY DAT /R:1000000 /W:30
ERROR: Invalid Parameter #4: "

Kann mir bitte jemand weiter helfen?
Mitglied: Biber
05.08.2006 um 19:39 Uhr
Moin horschte,

für dieses Verhalten gibt es nur eine einzige logische Erklärung.
Bei deinem Beispiel wird nicht dir M$-Robocopy.exe aufgerufen, sondern eine robocopy.bat oder *.cmd, die irgendeine Pappnase im Such-Pfad %path% abgelegt hat.
Und von dieser wird das eigentliche RoboCopy-Tool aufgerufen.

Überprüf das bitte mal mit WHICH, falls das installiert ist, oder einfacher, rufe einmal die Robocopy.exe mit voll qualifiziertem Pfad auf statt nur mit "robocopy".

Kann nichts anderes sein....

Gruß
Biber
Bitte warten ..
Mitglied: horschte
07.08.2006 um 17:55 Uhr
Hallo Biber, vielen Dabk für Deine schnelle Reaktion. Tatsächlich ruft man robocopy so auf, wie ich es seit langem praktiziere, indem man in die Eingabeaufforderung einfügt:

C:\>robocopy Quellpfad Zielpfad /Mir

Sofern ein Pfad Leerzeichen enthält, muss man ihn in Anführungszeichen setzen. Alles das habe ich getan, habe aber leider den Befehl in WORD editiert. Das war mein Fehler. Ich habe dann den Editor benutzt: Jetzt läft alles.
Nochmals besten Dank und Grüße
horschte
Bitte warten ..
Mitglied: Biber
07.08.2006 um 18:05 Uhr
Moin horschte,

danke für die Rückmeldung.
Irgend so eine Verkettung unglücklicher Umstände bzw. Arbeitsschritte musste es auch gewesen sein...

Schönen Abend
Biber
Bitte warten ..
Ähnliche Inhalte
Vmware
Essentials kit für 3 hosts
Frage von obi-wan-kenobiVmware13 Kommentare

hallo zusammen, ich habe zwei exakt identische server die ich gerne so betrieben hätte, dass sich auf beiden systemen ...

LAN, WAN, Wireless

Erfahrungsbericht Mikrotik RBWAPG-60AD-KIT !?

gelöst Frage von IP-PUPPILAN, WAN, Wireless9 Kommentare

wünsche allen Admin´s für das Jahr 2018 wenig Spam, saubere Routen und immer erreichbare Interface ! Egal ob Local ...

Verschlüsselung & Zertifikate

Passware Password Recovery Kit und Nvdia Grafikkarten Einstellungen

gelöst Frage von SimonTemplerVerschlüsselung & Zertifikate5 Kommentare

Hallo zusammen, seit längerem (2 Monate) versuche ich an eine alte .RAR Datei zukommen, diese ist aber leider mit ...

Windows 10

Moechte WIM Datei für Windows 10 erstellen Gibt es Windows Automated Installation Kit AIK für Windows 10

gelöst Frage von 116480Windows 1011 Kommentare

Hallo, ich möchte eine WIM Datei für Windows 10 erstellen. Jedoch finde ich kein AIK Kit für Windows 10 ...

Neue Wissensbeiträge
Erkennung und -Abwehr
Trendmicro WFBS 10 ist in deutsch verfügbar!
Tipp von VGem-e vor 38 MinutenErkennung und -Abwehr

Servus Kollegen, downloadbar unter Gruß

Windows Update

MS Patchday Juni 2018 - BSOD, obwohl noch kein Patch freigegeben

Erfahrungsbericht von diemilz vor 1 StundeWindows Update

Hallo zusammen, wir hatten hier letzte Woche ein massives Problem. Alles begann damit, dass ein Mitarbeiter kurz vor Feierabend ...

Microsoft
Shadow Defender
Tipp von Hyrule vor 12 StundenMicrosoft

Ich denke viele kennen es: Ein Update oder ein neues Programm und vieles funktioniert nicht mehr wie gewünscht. Die ...

Microsoft
Microsoft verarztet 50 Sicherheitslücken
Tipp von Hyrule vor 4 TagenMicrosoft

Microsoft verarztet mal wieder ein "paar" Sicherheitslücken in ihren Produkten: Und mal wieder Remote Code Execution und der abartige ...

Heiß diskutierte Inhalte
Hyper-V
Hyper V startet nicht wenn eine Offline geschaltene HD integriert wird
Frage von DieAzubinneHyper-V11 Kommentare

Hallö, bei einem PC der mit Windows 10 Pro installiert ist habe ich das Problem, dass der Virtuelle PC ...

CPU, RAM, Mainboards
ASUS P5W DELUXE startet nur manchmal und nur mit 2 GraKas
Frage von Windows10GegnerCPU, RAM, Mainboards11 Kommentare

Hallo, ich habe das o.g. Motherboard erhalten. Egal ob C2D 8400, Pentium D 945 oder P4 670, das teil ...

Virtualisierung
Virtuelle Maschinen langsam unabhängig vom Hypervisor
gelöst Frage von HyruleVirtualisierung9 Kommentare

Hallo, ich möchte gerne zwei bis drei virtuelle Maschinen virtualisieren, darauf sollen jeweils Windows 10 und diverse etwas größere ...

Rechtliche Fragen
Vorlage "private Nutzung dienstlicher Mobiltelefone"
Frage von linos2Rechtliche Fragen8 Kommentare

Hallo zusammen, ich bin auf der Suche nach einer Vorlage für die private Nutzung von dienstlichen Mobiltelefonen. Unsere Firma ...