Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Robocopy.exe aus dem Recource Kit von Windows

Mitglied: horschte

horschte (Level 1) - Jetzt verbinden

05.08.2006, aktualisiert 07.08.2006, 13227 Aufrufe, 3 Kommentare

Ordnernamen mit Leerzeichen darin werden von Robocopy nicht akzeptiert

Ich nutze robocopy.exe mit viel Erfolg zum schnellen Sichern ganzer Partitionen und von Ordnern. Ich habe jedoch ein Problem, wenn Leerzeichen in einem Namen enthalten sind.

Obwohl ich entsprechend der Vorschrift in der Dokumentation Robocopy.doc die fraglichen Pfade in Anführungszeichen (quotation marks) setze, kommt eine Fehlermeldung und die Sicherung findet nicht statt.

Beispiel für die Kommandozeile:
C:\>robocopy "C:\Dokumente und Einstellungen" "V:\backup\Dokumente und Einstellungen" /MIR /W:1 /R:1

Würde der Befehl lauten
C:\>robocopy C:\Programme V:\backup\Programme/MIR /W:1 /R:1
gäbe es kein Problem. Die Sicherung läuft ab.

Für das o.g. Beispiel kommt als Fehlermeldung:
Source: C:\"C\Dokumente\

Dest: C:\und\

Files: Einstellungen"
Options: /COPY DAT /R:1000000 /W:30
ERROR: Invalid Parameter #4: "

Kann mir bitte jemand weiter helfen?
Mitglied: Biber
05.08.2006 um 19:39 Uhr
Moin horschte,

für dieses Verhalten gibt es nur eine einzige logische Erklärung.
Bei deinem Beispiel wird nicht dir M$-Robocopy.exe aufgerufen, sondern eine robocopy.bat oder *.cmd, die irgendeine Pappnase im Such-Pfad %path% abgelegt hat.
Und von dieser wird das eigentliche RoboCopy-Tool aufgerufen.

Überprüf das bitte mal mit WHICH, falls das installiert ist, oder einfacher, rufe einmal die Robocopy.exe mit voll qualifiziertem Pfad auf statt nur mit "robocopy".

Kann nichts anderes sein....

Gruß
Biber
Bitte warten ..
Mitglied: horschte
07.08.2006 um 17:55 Uhr
Hallo Biber, vielen Dabk für Deine schnelle Reaktion. Tatsächlich ruft man robocopy so auf, wie ich es seit langem praktiziere, indem man in die Eingabeaufforderung einfügt:

C:\>robocopy Quellpfad Zielpfad /Mir

Sofern ein Pfad Leerzeichen enthält, muss man ihn in Anführungszeichen setzen. Alles das habe ich getan, habe aber leider den Befehl in WORD editiert. Das war mein Fehler. Ich habe dann den Editor benutzt: Jetzt läft alles.
Nochmals besten Dank und Grüße
horschte
Bitte warten ..
Mitglied: Biber
07.08.2006 um 18:05 Uhr
Moin horschte,

danke für die Rückmeldung.
Irgend so eine Verkettung unglücklicher Umstände bzw. Arbeitsschritte musste es auch gewesen sein...

Schönen Abend
Biber
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Erfahrungsbericht Mikrotik RBWAPG-60AD-KIT !?

gelöst Frage von IP-PUPPILAN, WAN, Wireless9 Kommentare

wünsche allen Admin´s für das Jahr 2018 wenig Spam, saubere Routen und immer erreichbare Interface ! Egal ob Local ...

Drucker und Scanner

USB-Problem - NUC-Kit N3050 mit Windows 7 Pro 64 Bit und ADMITTO-A-1200-D V1.00 Chipkartenlesegerät

Frage von 133808Drucker und Scanner2 Kommentare

Liebe Forumsleser, ich habe das Problem, dass sich das ADMITTO-A-1200-D V1.00 Chipkartenlesegerät (über USB angeschlossen), nach einer gewissen Zeit ...

Off Topic

Suche: ML350p Gen8 Rack Conversion Kit

Frage von chgorgesOff Topic2 Kommentare

Hallo zusammen, ich suche für einen Kollegen und dessen "älteren" Server ein Tower-to-Rack Conversion Kit, die P/N müsste 659488-B21 ...

Verschlüsselung & Zertifikate

Passware Password Recovery Kit und Nvdia Grafikkarten Einstellungen

gelöst Frage von SimonTemplerVerschlüsselung & Zertifikate5 Kommentare

Hallo zusammen, seit längerem (2 Monate) versuche ich an eine alte .RAR Datei zukommen, diese ist aber leider mit ...

Neue Wissensbeiträge
Router & Routing

Endlich: Reines Kabel-TV Modem in D erhältlich !

Information von aqui vor 1 TagRouter & Routing9 Kommentare

Mit dem Technicolor TC4400-EU Modem sind nun auch Breitband Router ohne integriertes Modem oder Firewalls wie z.B. die pfSense ...

Netzwerkgrundlagen
The Illustrated TLS Connection
Information von Lochkartenstanzer vor 2 TagenNetzwerkgrundlagen

Moin, Unter findet man eine gelungene Erläuterung von TLS. Fördert sehr das verständnis darüber, was da passiert. lks

Windows 10

Zuverlässiger Remove-AppxProvisionedPackage Ausführen in W10-1803

Tipp von NetzwerkDude vor 4 TagenWindows 104 Kommentare

Moin, Remove-AppxProvisionedPackage hat in 1709 recht zuverlässig funktioniert, in 1803 ist es leider so das es gerne mail failed ...

LAN, WAN, Wireless
Erfahrung mit dem tplink eap115-wall
Erfahrungsbericht von fisi-pjm vor 4 TagenLAN, WAN, Wireless

Die Hintergründe Als ausgebildeter Fisi und ambitionierter "Hobby ITler" bin ich Netzwerktechnisch immer auf der Suche nach "schönen" Lösungen ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerklaufwerk verbinden nicht möglich
gelöst Frage von SteiniMNetzwerkmanagement13 Kommentare

Hallo Leute, ich bin neu hier und brauche eure Hilfe. Danke schon mal im Voraus. Ich habe folgendes Problem: ...

Apache Server
Webserver überlastet - wie entlasten?
Frage von coltseaversApache Server13 Kommentare

Hi ho, ich hoste aktuell für nen Kunden eine Webseite basierend auf Wordpress. Die Seite liegt auf einem Debian ...

Windows Server
AD User wird immer wieder gesperrt
Frage von YellowcakeWindows Server12 Kommentare

Hey ich habe einen User (ein GL User - Natürlich was denn sonst) der immer wieder gesperrt wird. Ich ...

Netzwerkprotokolle
OpenVPN auf dem Client Verständnisfrage
gelöst Frage von bk900042Netzwerkprotokolle11 Kommentare

Hallo Community, möchte OpenVPN benutzen, um mich über VPN per RDP zu einem Server zu verbinden und auch GIT ...