Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem mit Softwareverteilung via GPO

Mitglied: dario.schlegel

dario.schlegel (Level 1) - Jetzt verbinden

27.09.2011 um 15:25 Uhr, 5335 Aufrufe, 13 Kommentare

Ich habe die Softwareverteilung für den Flash-Player bereits erfolgreich im Einsatz.
Beim Acrobat Reader stolpere ich jetzt dedoch über etwas und ich weiss nicht ber was.

Umgebung: Server W2K3 / Client:W7

MSI-Paket für AcrobatReader gemäss folgender Anleitung erfolgreich erstellt:
http://j-sys.de/2011/09/16/adobe-64bitmapibroker-problemlosung/

Was habe ich gemacht:
- Neues Gruppenrichtlinienobjekt erstellt und SW-Verteilung für AcrobatReader eingerichtet
- Testclient in dessen OU das Objekt verknüpft ist gestartet > keine Auswirkung
- mmc auf Client gestartet, Richtlinienergebnissatz generiert, unter SW-Install kein Eintrag
- gpresult /scope computer result.html ausgefürt
> die Richtlinie wird bei den angewandten RiLi aufgelistet, bei der Installation jedoch nicht aufgeführt
> die funktionierende RiLi für den Flashplayer wird jedoch sowohl bie den Rilis wie auch bei den Installationen aufgeführt (so wie es sein soll)
- In der Ereignisanzeige finde ich keinen Eintrag der mir einen Hinweis gibt, das etwas nicht klappte
- Wenn ich den Pfad im Netlogon vom Client aus direkt aufrufe (msi-datei) startet die installation

Jetzt bin ich mit meinem Latein am Ende. Hat hier eventuell jemand noch einen Tipp für mich?

Gruss
Dario
Mitglied: 101238
27.09.2011 um 16:36 Uhr
Hallo,

ich hatte ähnliche Probleme, bei mir hat es erst funktioniert als ich in den GPO eingestellt habe, das die Netzwerverbindungen gestartet werden bevor die Benutzeranmeldung erfolgt.

Hintergrund ist das unter Win 2000 die Netzverbindungen vor der Benutzeranmeldung aufgebaut werden, aber ab XP bzw. Win7 nicht mehr. Der Start der Clients dauert zwar etwas länger aber nach dem starten wird Software sauber installiert.
Bitte warten ..
Mitglied: dario.schlegel
27.09.2011 um 17:01 Uhr
Zitat von 101238:

ich hatte ähnliche Probleme, bei mir hat es erst funktioniert als ich in den GPO eingestellt habe, das die
Netzwerverbindungen gestartet werden bevor die Benutzeranmeldung erfolgt.
Hintergrund ist das unter Win 2000 die Netzverbindungen vor der Benutzeranmeldung aufgebaut werden, aber ab XP bzw. Win7 nicht
mehr. Der Start der Clients dauert zwar etwas länger aber nach dem starten wird Software sauber installiert.

Danke, damit hatte ich auch schon experimentiert.
Habe dein Eintrag jetzt sicherheitshalber nochmals hinzugefügt. Im RSOP der mmc sehe ich die Einstellung. Der Eintrag vom AcrobatReader bei der Softwareinstallation bleibt jedoch leer.
Bitte warten ..
Mitglied: 101238
27.09.2011 um 17:12 Uhr
Hallo nochmal,

ist auf den Clients vielleicht eine alte Version, manchmal klappt das "Drüberinstallieren" nicht, dann muss erst das alte deinstalliert werden um dann das neue zu installieren.

In der GPO das Paket mit der rechten Maustaste anklicken -> Alle Aufgaben -> entfernen -> Sofort entfernen

MfG


PS: Vielleicht ist noch eine alte Richtlinie mit gleichem Inhalt aktiv, die vielleicht die Softwareverteilung verhindert, denn beim FlashPlayer hat es ja funktioniert.
Bitte warten ..
Mitglied: DerWoWusste
27.09.2011 um 21:13 Uhr
Hi.

Mach mal am DC einen Richtlinienergenissatz, nicht am Client.
Bitte warten ..
Mitglied: jsysde
27.09.2011 um 21:56 Uhr
Moin,

[...]ist auf den Clients vielleicht eine alte Version, manchmal klappt das "Drüberinstallieren" nicht, dann muss erst
das alte deinstalliert werden um dann das neue zu installieren.[...]
In diesem Fall _muss!_ die alte Version zuerst deinstalliert werden - so habe ich es ja im verlinkten Artikel auch beschrieben.
Der Direkt-Aufruf des MSI-Files klappt zwar, will man die Installation aber durchführen, erhält man eine Fehlermeldung - was ich merkwürdig finde, denn diese Fehlermeldung taucht normalerweise auch im Eventlog des Clients auf.


Was mir noch auffällt:
Neues Gruppenrichtlinienobjekt erstellt und SW-Verteilung für AcrobatReader eingerichtet
Erstellt, schön und gut. Aber auch auf die OU verknüpft?

Cheers,
jsysde
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 07:23 Uhr
Zitat von 101238:
ist auf den Clients vielleicht eine alte Version, manchmal klappt das "Drüberinstallieren" nicht, dann muss erst
das alte deinstalliert werden um dann das neue zu installieren.
Auf der virtuellen Testmaschine ist gar kein AcrobatReader installiert, sollte also nichts im Wege stehen.


PS: Vielleicht ist noch eine alte Richtlinie mit gleichem Inhalt aktiv, die vielleicht die Softwareverteilung verhindert, denn
beim FlashPlayer hat es ja funktioniert.
Wie meinst du das genau? Also in die OU mit dem Testclient ist nur diese eine Richtlinie mit dem AR verknüpft.
Im Bereich der unverknüpften Gruppenrichtlinienobjekte hat es auch noch andere "Testkandidaten" der AR-Install.

Gruss Dario
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 07:34 Uhr
Ja sorry, habe ich nicht sauber geschrieben. Ja es wurde auch auf die OU verknüpft.

Gruss Dario
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 08:29 Uhr
Hi
Nach etwas gewerkel um den Ergebnissatz erstellen zu können hat es geklappt mit dem Satz.

Ergebnis:
- Angewendete Gruppenrichtlinienobjekte steht mein AcrobatReader_test drin
- Einstellungen>Installierte Anwendungen: steht der AcrobatReaer nicht drin

Gruss Dario
Bitte warten ..
Mitglied: DerWoWusste
28.09.2011 um 09:04 Uhr
Dumme Fehler ausgeschlossen, wie z.B. nicht im Computerbereich, sondern im Userbereich zugewiesen?
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 15:20 Uhr
Danke

Habe es nochmals durchgecheckt und noch eine andere Einstellung in der gleichen Richtlinie gesettz (beim Start auf Netzwerk warten). Diese RiLi erscheint im Ergebnissatz, aber bezüglich Softwareinstallation bleibt alles beim alten.

Nun habe ich in der "Testrichtlinie" zusätzlich noch ein weiteres MSI-Paket einer anderen Software (Teamviewer) hinzugefügt. Dieses wird sofort installiert
Das heisst, dass das Problem definitiv beim AcrobatPaket liegen muss, obwohl der Pfad stimmt und die Zugriffsrechte auf beide Paketordner identisch sind...

Gruss Dario
Bitte warten ..
Mitglied: DerWoWusste
28.09.2011 um 22:43 Uhr
Ok. Kann es sein, dass es funktioniert, wenn Du in den Eigenschaften des Pakets "Sprache ignorieren" anhakst? Das muss es eigentlich sein.
Bitte warten ..
Mitglied: dario.schlegel
29.09.2011 um 07:23 Uhr
Zitat von DerWoWusste:
Ok. Kann es sein, dass es funktioniert, wenn Du in den Eigenschaften des Pakets "Sprache ignorieren" anhakst? Das muss
es eigentlich sein.

YEEEEESSSSSSS you made my day!
Nach über 50 Stunden experimentieren (bin Neuling in diesem Gebiet) war es dieser eine Haken. Jetzt klappt auch die VLC-Verteilung, dort war es das Selbe.

Vielen Dank, du hast Anteil daran, dass die Schweiz in ihrem technischen Vortschritt nicht stehen bleibt.
Sollte ich je eine Steuer-CD verkaufen, werde ich deinen Namen vorgängig löschen

1000 Dank und Gruss aus der Ostschweiz
Dario
Bitte warten ..
Mitglied: DerWoWusste
29.09.2011 um 11:11 Uhr
Schön!

Irgendwann hatte ich das auch mal, eine dunkle Erinnerung regte sich da zum Glück noch...
Bitte warten ..
Ähnliche Inhalte
Netzwerke

Softwareverteilung über GPO - Zielpfad ändern?

Frage von MilanoMNetzwerke2 Kommentare

Hallo zusammen, ich möchte über Gruppenrichtlinien das neueste Java-Update (Version 8.66) an die User verteilen. Ich habe dazu bereits ...

Windows Netzwerk

GPO-Softwareverteilung Error 1612

Frage von freenodeWindows Netzwerk3 Kommentare

Hallo Kollegen, wir haben ein merkwürdiges Problem in einer unserer Domänen (Stand 2008 R2): Es existiert ein DFS-Share, welcher ...

Windows Tools

WMI-Filter für GPO - Softwareverteilung

gelöst Frage von banane31Windows Tools7 Kommentare

Guten Morgen zusammen, ich habe folgendes Problem: Wir setzten im Unternehmen Miranda ein und dieses wird via GPO auf ...

Microsoft

Softwareverteilung via GPO

gelöst Frage von tomolpiMicrosoft8 Kommentare

Hallo, habe ein Problem mit der Softwareverteilung per GPO Also. Ich habe eine OU "Laptops" die alle 7zip bekommen ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

Grafikkarten & Monitore
4k EIZO Monitor, Fernseher und Splitter
Frage von LerxxeyGrafikkarten & Monitore9 Kommentare

Hallo Zusammen, vielleicht könnt ihr mir bei einem Problem helfen wo ich einfach nicht mehr weiterkomme Und zwar haben ...

TK-Netze & Geräte
Fax im Betrieb
Frage von gansa28TK-Netze & Geräte6 Kommentare

Hallo zusammen, Endlich wurden meine Gebete Erhört und der Rechner meines Bekannten dem ich etwas unter die Arme greife, ...

Humor (lol)
Nerd Zeitschrift gesucht
Frage von 2SeitenHumor (lol)6 Kommentare

Hey Zusammen, Ich suche eine Zeitschrift bei der es ums technische Basteln geht. Pc zusammenschrauben, Arduino Projekte, Server Tipps ...