Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem mit Softwareverteilung via GPO

Mitglied: dario.schlegel

dario.schlegel (Level 1) - Jetzt verbinden

27.09.2011 um 15:25 Uhr, 5369 Aufrufe, 13 Kommentare

Ich habe die Softwareverteilung für den Flash-Player bereits erfolgreich im Einsatz.
Beim Acrobat Reader stolpere ich jetzt dedoch über etwas und ich weiss nicht ber was.

Umgebung: Server W2K3 / Client:W7

MSI-Paket für AcrobatReader gemäss folgender Anleitung erfolgreich erstellt:
http://j-sys.de/2011/09/16/adobe-64bitmapibroker-problemlosung/

Was habe ich gemacht:
- Neues Gruppenrichtlinienobjekt erstellt und SW-Verteilung für AcrobatReader eingerichtet
- Testclient in dessen OU das Objekt verknüpft ist gestartet > keine Auswirkung
- mmc auf Client gestartet, Richtlinienergebnissatz generiert, unter SW-Install kein Eintrag
- gpresult /scope computer result.html ausgefürt
> die Richtlinie wird bei den angewandten RiLi aufgelistet, bei der Installation jedoch nicht aufgeführt
> die funktionierende RiLi für den Flashplayer wird jedoch sowohl bie den Rilis wie auch bei den Installationen aufgeführt (so wie es sein soll)
- In der Ereignisanzeige finde ich keinen Eintrag der mir einen Hinweis gibt, das etwas nicht klappte
- Wenn ich den Pfad im Netlogon vom Client aus direkt aufrufe (msi-datei) startet die installation

Jetzt bin ich mit meinem Latein am Ende. Hat hier eventuell jemand noch einen Tipp für mich?

Gruss
Dario
Mitglied: 101238
27.09.2011 um 16:36 Uhr
Hallo,

ich hatte ähnliche Probleme, bei mir hat es erst funktioniert als ich in den GPO eingestellt habe, das die Netzwerverbindungen gestartet werden bevor die Benutzeranmeldung erfolgt.

Hintergrund ist das unter Win 2000 die Netzverbindungen vor der Benutzeranmeldung aufgebaut werden, aber ab XP bzw. Win7 nicht mehr. Der Start der Clients dauert zwar etwas länger aber nach dem starten wird Software sauber installiert.
Bitte warten ..
Mitglied: dario.schlegel
27.09.2011 um 17:01 Uhr
Zitat von 101238:

ich hatte ähnliche Probleme, bei mir hat es erst funktioniert als ich in den GPO eingestellt habe, das die
Netzwerverbindungen gestartet werden bevor die Benutzeranmeldung erfolgt.
Hintergrund ist das unter Win 2000 die Netzverbindungen vor der Benutzeranmeldung aufgebaut werden, aber ab XP bzw. Win7 nicht
mehr. Der Start der Clients dauert zwar etwas länger aber nach dem starten wird Software sauber installiert.

Danke, damit hatte ich auch schon experimentiert.
Habe dein Eintrag jetzt sicherheitshalber nochmals hinzugefügt. Im RSOP der mmc sehe ich die Einstellung. Der Eintrag vom AcrobatReader bei der Softwareinstallation bleibt jedoch leer.
Bitte warten ..
Mitglied: 101238
27.09.2011 um 17:12 Uhr
Hallo nochmal,

ist auf den Clients vielleicht eine alte Version, manchmal klappt das "Drüberinstallieren" nicht, dann muss erst das alte deinstalliert werden um dann das neue zu installieren.

In der GPO das Paket mit der rechten Maustaste anklicken -> Alle Aufgaben -> entfernen -> Sofort entfernen

MfG


PS: Vielleicht ist noch eine alte Richtlinie mit gleichem Inhalt aktiv, die vielleicht die Softwareverteilung verhindert, denn beim FlashPlayer hat es ja funktioniert.
Bitte warten ..
Mitglied: DerWoWusste
27.09.2011 um 21:13 Uhr
Hi.

Mach mal am DC einen Richtlinienergenissatz, nicht am Client.
Bitte warten ..
Mitglied: jsysde
27.09.2011 um 21:56 Uhr
Moin,

[...]ist auf den Clients vielleicht eine alte Version, manchmal klappt das "Drüberinstallieren" nicht, dann muss erst
das alte deinstalliert werden um dann das neue zu installieren.[...]
In diesem Fall _muss!_ die alte Version zuerst deinstalliert werden - so habe ich es ja im verlinkten Artikel auch beschrieben.
Der Direkt-Aufruf des MSI-Files klappt zwar, will man die Installation aber durchführen, erhält man eine Fehlermeldung - was ich merkwürdig finde, denn diese Fehlermeldung taucht normalerweise auch im Eventlog des Clients auf.


Was mir noch auffällt:
Neues Gruppenrichtlinienobjekt erstellt und SW-Verteilung für AcrobatReader eingerichtet
Erstellt, schön und gut. Aber auch auf die OU verknüpft?

Cheers,
jsysde
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 07:23 Uhr
Zitat von 101238:
ist auf den Clients vielleicht eine alte Version, manchmal klappt das "Drüberinstallieren" nicht, dann muss erst
das alte deinstalliert werden um dann das neue zu installieren.
Auf der virtuellen Testmaschine ist gar kein AcrobatReader installiert, sollte also nichts im Wege stehen.


PS: Vielleicht ist noch eine alte Richtlinie mit gleichem Inhalt aktiv, die vielleicht die Softwareverteilung verhindert, denn
beim FlashPlayer hat es ja funktioniert.
Wie meinst du das genau? Also in die OU mit dem Testclient ist nur diese eine Richtlinie mit dem AR verknüpft.
Im Bereich der unverknüpften Gruppenrichtlinienobjekte hat es auch noch andere "Testkandidaten" der AR-Install.

Gruss Dario
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 07:34 Uhr
Ja sorry, habe ich nicht sauber geschrieben. Ja es wurde auch auf die OU verknüpft.

Gruss Dario
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 08:29 Uhr
Hi
Nach etwas gewerkel um den Ergebnissatz erstellen zu können hat es geklappt mit dem Satz.

Ergebnis:
- Angewendete Gruppenrichtlinienobjekte steht mein AcrobatReader_test drin
- Einstellungen>Installierte Anwendungen: steht der AcrobatReaer nicht drin

Gruss Dario
Bitte warten ..
Mitglied: DerWoWusste
28.09.2011 um 09:04 Uhr
Dumme Fehler ausgeschlossen, wie z.B. nicht im Computerbereich, sondern im Userbereich zugewiesen?
Bitte warten ..
Mitglied: dario.schlegel
28.09.2011 um 15:20 Uhr
Danke

Habe es nochmals durchgecheckt und noch eine andere Einstellung in der gleichen Richtlinie gesettz (beim Start auf Netzwerk warten). Diese RiLi erscheint im Ergebnissatz, aber bezüglich Softwareinstallation bleibt alles beim alten.

Nun habe ich in der "Testrichtlinie" zusätzlich noch ein weiteres MSI-Paket einer anderen Software (Teamviewer) hinzugefügt. Dieses wird sofort installiert
Das heisst, dass das Problem definitiv beim AcrobatPaket liegen muss, obwohl der Pfad stimmt und die Zugriffsrechte auf beide Paketordner identisch sind...

Gruss Dario
Bitte warten ..
Mitglied: DerWoWusste
28.09.2011 um 22:43 Uhr
Ok. Kann es sein, dass es funktioniert, wenn Du in den Eigenschaften des Pakets "Sprache ignorieren" anhakst? Das muss es eigentlich sein.
Bitte warten ..
Mitglied: dario.schlegel
29.09.2011 um 07:23 Uhr
Zitat von DerWoWusste:
Ok. Kann es sein, dass es funktioniert, wenn Du in den Eigenschaften des Pakets "Sprache ignorieren" anhakst? Das muss
es eigentlich sein.

YEEEEESSSSSSS you made my day!
Nach über 50 Stunden experimentieren (bin Neuling in diesem Gebiet) war es dieser eine Haken. Jetzt klappt auch die VLC-Verteilung, dort war es das Selbe.

Vielen Dank, du hast Anteil daran, dass die Schweiz in ihrem technischen Vortschritt nicht stehen bleibt.
Sollte ich je eine Steuer-CD verkaufen, werde ich deinen Namen vorgängig löschen

1000 Dank und Gruss aus der Ostschweiz
Dario
Bitte warten ..
Mitglied: DerWoWusste
29.09.2011 um 11:11 Uhr
Schön!

Irgendwann hatte ich das auch mal, eine dunkle Erinnerung regte sich da zum Glück noch...
Bitte warten ..
Ähnliche Inhalte
Netzwerke

Softwareverteilung über GPO - Zielpfad ändern?

Frage von MilanoMNetzwerke2 Kommentare

Hallo zusammen, ich möchte über Gruppenrichtlinien das neueste Java-Update (Version 8.66) an die User verteilen. Ich habe dazu bereits ...

Windows Netzwerk

GPO-Softwareverteilung Error 1612

Frage von freenodeWindows Netzwerk3 Kommentare

Hallo Kollegen, wir haben ein merkwürdiges Problem in einer unserer Domänen (Stand 2008 R2): Es existiert ein DFS-Share, welcher ...

Microsoft

Softwareverteilung via GPO

gelöst Frage von tomolpiMicrosoft8 Kommentare

Hallo, habe ein Problem mit der Softwareverteilung per GPO Also. Ich habe eine OU "Laptops" die alle 7zip bekommen ...

Windows Tools

WMI-Filter für GPO - Softwareverteilung

gelöst Frage von banane31Windows Tools7 Kommentare

Guten Morgen zusammen, ich habe folgendes Problem: Wir setzten im Unternehmen Miranda ein und dieses wird via GPO auf ...

Neue Wissensbeiträge
E-Mail
Email-Apps und Verhalten bei Pop3
Erfahrungsbericht von kfranzk vor 13 StundenE-Mail3 Kommentare

Hallo Freunde, da mir mein diesbezüglicher Faden als gelöst markiert wurde, muss ich hier neu aufsetzen. Ich arbeite bewusst ...

Hyper-V

Optimiertes Ubuntu per Microsoft Hyper-V-Schnellerstellung verfügbar

Anleitung von Frank vor 14 StundenHyper-V

Für Microsofts Virtualisierungssoftware Hyper-V ist ab sofort auch ein optimiertes Ubuntu 18.04.1 LTS verfügbar. In der "Hyper-V-Schnellerstellung" App, die ...

Sicherheits-Tools

Trend Micro WorryFree Business Security (WFBS) 10 - neuer Patch 1470 verfügbar

Tipp von VGem-e vor 18 StundenSicherheits-Tools1 Kommentar

Servus, mal sehen, ob mit Patch 1470, zu finden unter dann die angeblich fehlerhafte Funktion, die unter W10 im ...

Server-Hardware

Lösung für Ersatz eines defekter Raid-Controllers

Anleitung von wellknown vor 1 TagServer-Hardware3 Kommentare

Hallo, da ich nichts gefunden habe und selbst eine Lösung brauchte, hier eine kleine Anleitung für alle die vor ...

Heiß diskutierte Inhalte
Windows Server
Mit der alten Domäneprofil anmelden ohne Server
gelöst Frage von SyosseWindows Server37 Kommentare

Hallo Jungs Folgendes Szenario: Ich habe bei einem sehr kleinen Unternehmen (2Personen) den Server migriert, soweit hat alles geklappt. ...

Sicherheits-Tools
Virenprogramm lässt Programme nicht starten
Frage von SurferGirlSicherheits-Tools23 Kommentare

Hallo, ich bin neu hier, ich hoffe ich habe die richtige Rubrik gewählt. Falls nicht, tut es mir leid. ...

Windows Server
Kann DNS-Einträge nicht finden
gelöst Frage von BPeterWindows Server19 Kommentare

Hallo, wenn ich folgenden Befehl absetze, bekomme ich eine Liste zurück mit allen Einträgen der DNS-Zone. Wenn ich aber ...

Windows Server
SQL Server Instanz (Eplan) auf WIN 2008 RC2 Server frisst RAM ohne Limit
Frage von derinderinderinWindows Server17 Kommentare

Hallo Zusammen, Wir haben hier einen Windows 2008 RC2 Server. Darauf läuft ein SQL Server Express 2014 Version 12.0.4232.0. ...