Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem beim Starten eines DOs-Progs. unter Windows XP Prof

Mitglied: Trantor

Trantor (Level 1) - Jetzt verbinden

11.01.2006, aktualisiert 17.01.2006, 3950 Aufrufe, 2 Kommentare

Hallo,

ich habe ein kleines DOS-Prog. mit dem die Daten unserer Betriebstankstelle verwaltet werden. Ich kann das Programm im DOS-Prompt starten. Leider sperrt sich die Tastatur gegen Eingaben.
Das Seltsame ist, daß das nicht immer so ist. Das Passwort (nur Buchstaben) daß eingegeben werden muß, um in die Auswahlmenüs zu kommen, kann ich immer per Tastatur eingeben. Die Zahlen für die Menüs hin und wieder, aber spätestens nach der 2. eingabe hängt sich das Ganze auf. Bei einem Kollegen läuft das Prog. einwandfrei.
Es wird auch nicht installiert, sondern mit einer Batch-Datei gestartet

Inhalt der Batch :

@echo off
echo Bitte Datendiskette einlegen und Enter drcken
Pause
Copy A:\sd.xd2 C:\ta1000\sd.xd1
Copy C:\ta1000\sd.xd1 C:\ta1000\sd.xd2
set sddata1=C:\ta1000\sd.xd1
set sddata2=C:\ta1000\sd.xd2
C:
cd \ta1000
ta1000.exe

Habe schon probiert, das Prog in allen möglichen Komp-Modi laufen zu lassen. Bringt aber rein gar nichts.

Was mir aufgefallen ist, ist daß die mit set gesetzten Werte nicht angezeigt werden, wenn ich set allen eingebe.

Wäre schön wenn jemand wüßte, woran es liegt.

Gruß

Trantor
Mitglied: tom-k
14.01.2006 um 23:01 Uhr
Der set-Befehl aus Deiner Batch ist DOS-Fenster bezogen.

Zum Test:
- Öffne ein DOS-Fenster und starte die Batch von Hand in dem DOS-Fenster,
- beende dann das Prog "ta1000.exe" aber schließe nicht das DOS-Fenster,
- prüfe mit "set s" die Variablen.

Wenn der Test OK war:
- kopiere alle Daten die zu dem Prog gehören in einen Ordner (z.B. nach: "C:\ta1000\")
- lege Verknüpfung auf die Datei "ta1000.exe" an
- lege in dem Ordner eine Datei "autoexec.ta" an
- öffne diese Datei im Editor und kopiere die Befehle hinein:
        @echo off
        echo Bitte Datendiskette einlegen und Enter drücken
        Pause
        Copy A:\sd.xd2 C:\ta1000\sd.xd1
        Copy C:\ta1000\sd.xd1 C:\ta1000\sd.xd2
        set sddata1=C:\ta1000\sd.xd1
        set sddata2=C:\ta1000\sd.xd2
- speichere die Datei ("autoexec.ta")
- Eigenschaften der "Verknüpfung auf ta1000.exe" Befehlszeile: "C:\ta1000\ta1000.exe"
- Eigenschaften der "Verknüpfung auf ta1000.exe" Arbeitsverzeichnis: "C:\ta1000"
- Eigenschaften > Erweitert > Autoexec-Dateiname: "C:\ta1000\autoexec.ta"
- Eigenschaften > Erweitert > Config-Dateiname nicht ändern,
- Eigenschaften > [Tab] Speicher
        Insgesamt: 640
        Anf.Umgb.Sp.: 4096
        EMS Insgesamt: 4096
        XMS Insgesamt: 4096
        DPMI Insgesamt: 4096
- Übernehmen > OK

nun sollte es funktionieren, hoffe ich bisher habe ich alle möglichen Exoten wie Programmiertools so zum Laufen bekommen

Arbeitet ihr immer mit Diskette? Die Daten könnte man auch Lokal oder auf einem Netzlaufwerk ablegen, dann würde der Befehlt mit "Datendiskette" entfallen und der erste Copy-Befehl müßte entsprechend angepaßt werden.
Bitte warten ..
Mitglied: Trantor
17.01.2006 um 10:59 Uhr
Hallo tom-k,

erstmal danke für die Antwort. Leider ist immernoch der selbe Fehler da. Bekomme das Teil nicht zum Laufen. Habe nochmal den Rechner auf dem es unter XP läuft auf den Kopf gestellt. Konnte aber nichts finden.

Gruß Trantor
Bitte warten ..
Ähnliche Inhalte
Windows XP
Windows XP: Probleme beim Starten
gelöst Frage von nobody8806Windows XP2 Kommentare

Hallo, ich habe in der Firma noch einen PC mit Windows XP. Wenn ich den PC starte, kommt er ...

Windows XP
Problem beim hochfaren meines Windows XP
Frage von GerdoranWindows XP4 Kommentare

Guten Tag :) mein Problem ist: Immer wenn ich meinen XP hochfahre wird nur der hintergrund angezeigt,keine desktopsymbole oder ...

Grafikkarten & Monitore

Wie kann ich das alte Word5 unter XP starten?

Frage von axalonGrafikkarten & Monitore16 Kommentare

Hallo liebe Gemeinde, ich trau mich einfach mal zu fragen: mein Vater arbeitet mit seinen 92 Jahren noch gerne ...

Windows 7

Openvpn und windows 7 prof

gelöst Frage von jensgebkenWindows 75 Kommentare

hallo gemeinschaft, möchte mich über mein w7 notebook und openvpn in einer domäne anmelden - wenn ich als administrator ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 6 StundenPeripheriegeräte1 Kommentar

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 1 TagWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 1 TagWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 3 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Humor (lol)
Freitagsfrage: Was tun, wenn der Admin der DAU ist?
Frage von VoiperHumor (lol)29 Kommentare

Moin Zusammen, Eine nicht ganz ernst gemeinte Frage an die Außendienstler unter uns. Zusammenfassung: Ein Inhouse Admin ruft bei ...

Windows Server
W2K16 Essentials: keine Namensauflösung nach der Einrichtung DNS + AD DS
Frage von Ben-WittWindows Server21 Kommentare

Ich versuche bereits seit ca. 4 Wochen einen Server 2016 "Essentials" richtig zu installieren. An diesem Server möchte ich ...

Exchange Server
Exchange Backup 10 Jahre Aufbewahrung
Frage von arccosExchange Server20 Kommentare

Hallo zusammen. Aktuell beschäftigen mich ein paar Fragen zum Thema Office365/ Exchange. 1.10 Jahre Aufbewahrungspflicht sicherstellen 2.Kann man als ...

Windows Netzwerk
LTE Modul - Kein Internet trotz Verbindung
Frage von killtecWindows Netzwerk18 Kommentare

Hallo, ich habe hier ein Dell 7390 2-in-1 mit W10 Pro wo ich nachträglich eine LTE-Karte (Original Dell DW5811e ...