Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit einer VMware bzw. auch Virtualbox VM (Windows XP Pro) in Kombination mit einem Samba-share

Mitglied: Mario.Steinberg

Mario.Steinberg (Level 1) - Jetzt verbinden

02.03.2010 um 13:26 Uhr, 6689 Aufrufe, 6 Kommentare

Der Zugriff auf einem, von einem extern Server gemounteten, Samba-share in einer virtuellen Windows XP SP3 Maschine ist sehr, sehr langsam.
Der Zugriff auf den gleichen Share von einem Windows Rechner gleicher Konfiguration aber nicht VM aus ist um Längen schneller. Warum?

Hallo,

bereits seit Tagen arbeite ich erfolglos an dem folgenden Problem.
Ich habe einen Linux Fileserver auf dem ein Sambashare eingerichtet ist. Auf diesem liegen Daten, die ich auf einem Windowsrecher verarbeite und die entsprechendne Ergebnisse dann wieder dort hinschreibe. (Konkret: Dort liegen ein haufen Quellen, die ich unter Windows kompiliere. Das Objektworkspace also der Teil, wo die fertig kompilierten Sachen landen ist ebenfalls auf dem Share)

Das Windows XP Pro SP3 in welchem ich die Arbeiten erledigen möchte, ist eine virtuelle Maschine, die ich im Rahmen der Tests wahlweise auf einem Windows bzw. einem Linux Host und dort jeweils mit VMware bzw. Virtualbox gestartet habe.

Im Grunde funktioniert erstmal alles wie geplant. Ich kann das Laufwerk einbinden und alles kompilieren. Dieser Vorgang dauert allerdings 5 Stunden. Normalerweise ist er in nicht einmal 30 Min erledigt.

Um zu schauen wo die Probleme liegen könnten, habe ich auf einer ziemlich ähnlich konfigurierten Windows Maschine, die allerdings NICHT als VM läuft, die selben Quellen auf dem Share kompiliert und benötigte dafür keine 30 Min.

Folglich liegt das Problem also an dem Share in kombination mit der VMware, wobei ich aufgrund der Tatsache, dass unter einer nicht VM alles rund läuft das Problem eher bei der VM sehe und nicht am Share.

Das System sowie die eingesetzte VMware/Virtualbox sind aktuelle Versionen. Ich habe bereits die Option ethernet0.virtualDev = "e1000" in die vmx-Datei geschrieben und in der VM die anschließend gefundene Gigabit-Netzwerkkarte mit einem aktuellen Inteltereiber installiert. Es ergaben sich keine Änderungen. Siehe hierzu auch: http://www.linuxforen.de/forums/showthread.php?threadid=47553. Die Netzwerkkarte der VM läuft in Vollduplex.

Nun bin ich mit meinem Latin mehr als am Ende. Ich hoffe hier Hilfe zu finden. Dafür schon mal danke und schöne Grüße,

Mario
Mitglied: gijoe
02.03.2010 um 15:08 Uhr
Hi, ich habe eine lange Zeit mit Virtualbox gearbeitet, und die Netzwerkperformance blieb eigentlich immer unbefriedigend (Linux Host/Windows XP Client). Beim messen des Netzwerkdurchsatzes wurde ich das Gefühl nicht los, dass das ganze nur im Halbduplexmodus lief, du kannst ja mal nachprüfen, ob die Bandbreite zusammenfällt, wenn du gleichzeitig sendest und empfängst. Allerdings ist das jetzt schon über ein halbes Jahr her, es kann also sein, das Virtualbox Vortschritte gemacht hat.

Was du evtl. als Workaround versuchen kannst: Mounte dein Laufwerk im Host, und das neue lokale Verzeichnis mountest du wiederum im Client.

Wie sind deine Netzwerkkarten eingebunden? Gebridged? Oder NAT? Kannst dort noch ein wenig rumspielen.
Bitte warten ..
Mitglied: Mario.Steinberg
02.03.2010 um 16:13 Uhr
Hallo gijoe,

habe es mal probiert. Der Vollduplexbetrieb haut schon hin. Aber du hast recht, der Eindruck kann tatsächlich entstehen.

Ich benutze neben Virtualbox auch VMware und dort habe ich das selbe Problem.

Was ich ebenfalls schon versucht habe, den Share auf dem Host zu mounten und das Laufwerk dann in der VM als Shared Folder zu benutzen.

Was ich noch nicht versucht habe, das Laufwerk auf dem Host zu mounten, diesen dann zu sharen und anschl. in der VM zu mounten.

Die Netzwerkarte ist via NAT eingebunden. Habe es aber auch schon mit Bridged versucht. Ich habe der VM auch mal eine eigene Netzwerkarte überlassen. Immer wieder trat das selbe Problem auf.

Gruß,
Mario
Bitte warten ..
Mitglied: perseues
03.03.2010 um 09:27 Uhr
beim Kompilieren kommts ja auch auf den IO Durchsatz und den Prozessor an. Beides ist langsamer, als bei einer "echten" Installation. Hast Du versuchsweise die Quellen mal in die VM kopiert und dort auch als Ziellaufwerk kompiliert? Da könnte man dann sehen, was der virtuelle Rechner wirklich leistet. Meine Erfahrung ist, dass die virtuellen Maschinen vor allem bei rechenintensiven Dingen sehr in die Knie gehen. (Habe selber eine virtuelle Maschine zeitweise zum Programmieren verwendet mit VS2008).

Grüße p
Bitte warten ..
Mitglied: Mario.Steinberg
03.03.2010 um 10:00 Uhr
Ich habe die Sachen einmal auf der virtuellen Maschine local gebaut. Dort hat es auch nur ca. 30 Min gedauert. Wie oben schon erwähnt habe ich auch dann mal versucht die Sachen unter Einbeziehung des Share auf einer nicht VM änhnlicher Konfiguration zu bauen. Auch hier, war ich bei ca. 30 Min.

Es muss einen Zusammenhang zwischen der VM und dem Samba-share geben. Das alles etwas langsamer läuft, wenn es mittels VM passiert ist okay aber 5h wo ich sonst 30 Min brauche da muss es ein ganz klares Problem geben.

Gruß,
Mario
Bitte warten ..
Mitglied: Schwedenbitter
12.07.2010 um 14:25 Uhr
Hallo Mario,

hast Du schon eine Lösung finden können? Ich habe hier nämlich das selbe Problem. Ein Win XP Client auf einem reellen PC macht es; ein Client in einer VM nicht.
Es liegt meines Erachtens an Samba. Schaue mal bitte Deine logs an. Mich würde ehrlich mal interessieren, ob bei Dir zumindest die selben (Fehler)Meldungen auftauchen. Meine logs der betreffenden VM sehen immer so aus:

[2010/07/12 14:15:51, 1] smbd/service.c:make_connection_snum(1042)
advoplex-server (192.168.1.113) connect to service E initially as user advoplex (uid=1034, gid=1002) (pid 11161)
[2010/07/12 14:16:02, 1] smbd/service.c:close_cnum(1239)
advoplex-server (192.168.1.113) closed connection to service E
[2010/07/12 14:16:02, 1] smbd/service.c:make_connection_snum(1042)
advoplex-server (192.168.1.113) connect to service E initially as user advoplex (uid=1034, gid=1002) (pid 11172)
[2010/07/12 14:16:13, 1] smbd/service.c:close_cnum(1239)
advoplex-server (192.168.1.113) closed connection to service E
[2010/07/12 14:16:14, 1] smbd/service.c:make_connection_snum(1042)
advoplex-server (192.168.1.113) connect to service E initially as user advoplex (uid=1034, gid=1002) (pid 11181)
[2010/07/12 14:16:25, 1] smbd/service.c:close_cnum(1239)
advoplex-server (192.168.1.113) closed connection to service E
[2010/07/12 14:16:25, 1] smbd/service.c:make_connection_snum(1042)
advoplex-server (192.168.1.113) connect to service E initially as user advoplex (uid=1034, gid=1002) (pid 11186)
[2010/07/12 14:16:36, 1] smbd/service.c:close_cnum(1239)
advoplex-server (192.168.1.113) closed connection to service E
u.s.w. ...

Bei kleineren Datein stellt das kein Problem dar. Große lassen sich aber NICHT kopieren. Spätestens bei 148 MB ist Schluss. Wobei sich dieser Wert aus der max. Verbindungsdauer (keine Ahnung warum) von ca. 10 Sek. und dem entsprechenden Datendurchsatz ergibt. Am Durchsatz liegt es insoweit auch nicht. Denn knapp 15 MB/Sek. finde ich ziemlich schnell. Das Sytem hängt sich dann so auf, dass nur noch ein Kaltstart der VM hilft.

Ich habe noch nicht probiert, auf der VM eine Freigabe zu machen und dann vom Host (bei mir Linux) aus darauf zuzugreifen. Falls Du eine Lösung gefunden hast, dann poste sie bitte mal hier. Ich denke, es dürfte evtl. mehrere Leute interessieren.

Gruß, Alex
Bitte warten ..
Mitglied: Mario.Steinberg
13.07.2010 um 09:25 Uhr
Hallo Alex,

habe leider auch noch keine Lösung gefunden allerdings etwas weiter geforscht.
Ich habe die VM mal außen vor gelassen und einen "echten" WinXP Rechner genommen.
Auch hier habe ich die gleichen Probleme festgestellt.

Ich habe mal versucht ein rekursives "dir" über das Netz auf die Verzeichnisstruktur zu machen also eigentlich nur die Inhalte aller Verzeichnisse anzuzeigen.
Auch hier konnte ich zwischen Linux und Windows extreme Zeitunterschiede feststellen. Ich kann mir das nicht erklären.

Ich hatte auch mal mit NFS für Windows rumgespielt, also den Sambashare mal außen vor gelassen, aber das lief garnicht rund!

Leider sind die Ressourcen aufgebraucht und ich kann an diesem Problem erstmal nicht weiter forschen.
Eigentlich müsste man jetzt mal mit einem Profi in Bezug auf Windowsnetztwerke sprechen.

Ich kann mir fast nicht vorstellen, dass große Firmen, die Software für Windows entwickeln nicht auch irgendwelche Netzwerklösungen nurtzen. Aber wie haben die das umgestezt? Vielleicht kennt von euch ja jemand, der einen kennt......

Würde mich über Lösungsvorschlage sehr freuen.

So long,
Mario
Bitte warten ..
Ähnliche Inhalte
Vmware

VM von VMware VSphere 5 nach VirtualBox migrieren - aber wie?

Frage von mhard666Vmware2 Kommentare

Hallo allerseits, ich habe folgendes Problem: Ich will/muss von unserem Domänencontroller und einem weiteren Server eine Kopie als Testumgebung ...

Virtualisierung

Virtualbox: Windows 10 VM Performance

Frage von Fenris14Virtualisierung3 Kommentare

Hallo, Ich habe auf einem Linux Mint 18.3 die Virtualbox Version 5.2.6 r120293 installiert. Dort widerum eine VM mit ...

Virtualisierung

Installation eines Spiels auf einer VirtualBox-VM

gelöst Frage von honeybeeVirtualisierung6 Kommentare

Hallo, ich versuche gerade, Europa Universalis auf eine VM unter VirtualBox zu installieren. Beim Starten kam diese u. g. ...

Virtualisierung

Virtualbox Vm Datei auf NAS

Frage von Jocki278Virtualisierung5 Kommentare

Gras eich! Folgendes Schema! Um auf die Vm immer zugreifen zu können, liegt sie auf dem Nas. Da in ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)5 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...