Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem mit VNC-RDP über VPN

Mitglied: chrisale

chrisale (Level 1) - Jetzt verbinden

06.12.2006, aktualisiert 07.01.2009, 6900 Aufrufe, 6 Kommentare

Hi Leute,

ich hab hier was, wo ich nicht wirklich zuordnen kann wo es hingehört.

Ich hab ein (mittlerweile schon lustiges) Problem!

Folgende Konfiguration:

Linksys RV082 der einen PPTP Server für VPN Verbindungen integriert hat. Ich verbinde mich nun mit einem Windows XP Rechner mit einer PPTP VPN Verbindung auf die Firewall und bekomme eine interne IP Adresse vom Firmennetzwerk zugewiesen. Ich kann auch auf jeden Rechner im Netzwerk ein Ping ausführen und bekomm auch was zurück. Somit ist für mich klar, die Verbindung steht einwandfrei. ABER jetzt kommt das lustige: Ich verbinde mich jetzt mit VNC auf einen Client, soweit alles ganz normal, er verbindet sich, fragt mich nach dem Passwort, dann gebe ich das Passwort ein und dann, wo eigentlich das Bild vom anderen Rechner kommen sollte, bleibt das Bild schwarz!?! Was das ganze noch viel "komischer" macht, wenn ich die Maus in diesem schwarzen Fenster bewege, bewegt sich auch die Maus auf dem Client zu dem ich mich verbunden habe!!???

Mit Remotedesktop komm ich auf die Server nicht drauf, er versuchts zwar, aber irgendwas läuft da schief.

Ich dachte mir zuerst, vielleicht ist es das Windows, was Probleme macht, ABER dann versuchte ich ein Portforwarding mit RDP von der Firewall direkt zu einem Client bzw. Server ohne eine PPTP verbindung aufzubauen, hier funktioniert allerdings Remotedesktop ganz normal.

Da denkt man sich natürlich, haha, da passt was mit der PPTP Verbindung nicht, aber falsch... von einem anderen PC oder von einem anderen Laptop mit XP SP2 funktionierts einwandfrei.

Ich hab die Windows Firewall deaktiviert und auch alle Virenprogramme die auf dem Rechner laufen.

Wisst ihr was??

Bitte um Mithilfe!

Danke!

LG
Mitglied: aqui
06.12.2006 um 19:41 Uhr
Durch den Overhead von PPTP im VPN kann es sein das deine MTU zu groß ist und größere Packete (z.B. mit dem Schirminhalt) vom Router verworfen werden, da dieser nicht fragmentieren kann. Dadurch hat man dann so einen "halbgaren" Zustand, da kleine Packete zum Sessionaufbau meist passieren. Eigentlich sollte der VPN Router bei der MTU Path Discovery vorm Verbindungsaufbau die max. MTU ermitteln aber Consumer Router machen das oft nicht richtig bzw. beachten den zusätzlichen VPN Overhead nicht richtig.
Ggf. hilft es das Problem zu fixen wenn du die max. MTU deines Router noch weiter nach unten setzt ?!
Bitte warten ..
Mitglied: chrisale
07.12.2006 um 08:21 Uhr
Hi aqui,

erstmal danke für deine Antwort!

Ein Versuch ist auf alle Fälle wert die MTU runterzuschrauben. Wenn es wirklich die MTU ist, dann dürfte es ja eigentlich von keinem Computer aus über VPN funktionieren oder?

LG
Bitte warten ..
Mitglied: aqui
07.12.2006 um 11:29 Uhr
Doch, denn es hängt lediglich von der Größe der Packete ab. Packete sind ja unterschiedlich und nicht ausschliesslich mit einer fixen Größe auf dem Netz unterwegs. Solange die Nettogröße plus Overhead unter der MTU bleibt geht alles durch. Dadrüber wirds u.U. verworfen
Bitte warten ..
Mitglied: chrisale
08.12.2006 um 10:00 Uhr
HI!

Vielen Dank Aqui, es hat funktioniert!

Hab MTU jetzt auf 1300 gestellt und nochmal versucht! Nun funktionierts!!!! ;)

Danke nochmal!
Bitte warten ..
Mitglied: sushidelic
13.04.2007 um 13:24 Uhr
Hallo!

Ich hatte das selbe Problem mit einer VPN-Verbindung zwischen zwei Linksys RV042 Routern.
Die Änderung der MTU führte allerdings nicht zur Lösung des Problems, sondern die Änderung des "Local Security Group Types", bzw. des "Remote Security Group Types" von einer einzelnen IP in ein IP-Subnetz der VPN-Verbindung brachte das gewünschte Ergebnis, sprich Bildschirmdarstellung.
Abgesehen davon, dass das Problem ja nun gelöst ist: Hat evtl. jemand eine Erklärung für die Ursache, oder einen Denkansatz der zu einer Erklärung führen könnte?

Für jede Anregung dankbar!
Bitte warten ..
Mitglied: sushidelic
13.04.2007 um 13:26 Uhr
Hallo!

Ich hatte das selbe Problem mit einer VPN-Verbindung zwischen zwei Linksys RV042 Routern.
Die Änderung der MTU führte allerdings nicht zur Lösung des Problems, sondern die Änderung des "Local Security Group Types", bzw. des "Remote Security Group Types" von einer einzelnen IP in ein IP-Subnetz der VPN-Verbindung brachte das gewünschte Ergebnis, sprich Bildschirmdarstellung.
Abgesehen davon, dass das Problem ja nun gelöst ist: Hat evtl. jemand eine Erklärung für die Ursache, oder einen Denkansatz der zu einer Erklärung führen könnte?

Für jede Anregung dankbar!
Bitte warten ..
Ähnliche Inhalte
Windows 10
RDP über VPN, alles andere nicht
gelöst Frage von ClaudKWindows 1010 Kommentare

Ich habe heute meinen Computer auf Windows 10 aktualisiert. Wenn ich nun eine VPN Verbindung zu meiner Firma aufbaue, ...

Netzwerkgrundlagen
VPN und RDP
gelöst Frage von Stefan19Netzwerkgrundlagen3 Kommentare

Hallo zusammen! Habe nur eine Verständnisfrage zu VPN und RDP. LAN A ist mit LAN B über VPN verbunden. ...

Netzwerkmanagement
RDP nur über VPN
Frage von FiolitoNetzwerkmanagement11 Kommentare

Hallo zusammen, wir wollen mehrer Mitarbeiter über OpenVPN per RDP auf einen PC innerhalb eines "Firmennetzwerks" zugreifen lassen. Das ...

Windows Server
RDP Problem
Frage von agowa338Windows Server5 Kommentare

Hallo, ich habe jetzt immer öfter bei verschiedenen PCs das Problem, dass sich RDP irgendwie seltsam verhält. Was passiert: ...

Neue Wissensbeiträge
Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 1 TagAusbildung9 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 3 TagenSpeicherkarten3 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 3 TagenSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 4 TagenHardware3 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Vmware
Offene LDAP-Server in AS
gelöst Frage von obi-wan-kenobiVmware19 Kommentare

Hallo alle Miteinander, ich habe ein Problem, unsere VM-Ware Appliance (Version. 6.5.0.10000) ist scheinbar angreifbar. Wir haben eben die ...

Windows Server
Zertifikat RemoteDesktop hinterlegen
gelöst Frage von Green14Windows Server12 Kommentare

Hallo zusammen. ich habe mehrere Server (WinSrv 2016). Die Server sind in keiner Domäne und keine Terminalserver. Ich verbinde ...

Windows Server
DNS - Bedingte Weiterleitung
gelöst Frage von m8ichaelWindows Server11 Kommentare

Guten Tag zusammen, ich stehe gerade bzgl. einer bedingten DNS-Weiterleitung etwas auf dem Schlauch: Ich möchte, dass für bestimmte ...

Suche Projektpartner
Debian 9.5 32 Bit und PHP 7 Fehlerbeseitigungen
Frage von zeroblue2005Suche Projektpartner11 Kommentare

Hallo Zusammen, ich habe eine VM auf Basis von ESXI am laufen. Dieser wurde unter Debian 7 installiert mt ...