Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem mit xcopy und log-Datei

Mitglied: admin-lif

admin-lif (Level 1) - Jetzt verbinden

30.10.2007, aktualisiert 31.10.2007, 13448 Aufrufe, 8 Kommentare

Hallo,

in meinem Backup-Skript steht folgender Befehl:

xcopy "C:\" "N:\backup\system" /c /v /f /e /y /k /h >>N:\backup\backup.log

wenn dieser Befehl abgearbeitet werden soll, kommt die Fehlermeldung "Unzulässiger Share-Vorgang" und die zu kopierenden Dateien werden nicht im Bachtfenster angezeigt... Die Fehlermeldung bedeutet ja soweit ich weiß, das Dateien, die unter Verwendung stehen nicht kopiert werden können.... Allerdings funktioniert alles Prima wenn ich ">>N:\backup\backup.log" weglasse... Wo liegt mein Fehler?

Danke im voraus
Mitglied: 56153
30.10.2007 um 15:31 Uhr
mal ganz vage vermutung, aber sollte da nicht nur eine klammer stehen zum umleiten der ausgabe ?!

also quasi: xcopy "C:\" "N:\backup\system" /c /v /f /e /y /k /h >N:\backup\backup.log
Bitte warten ..
Mitglied: admin-lif
30.10.2007 um 15:40 Uhr
Hab:

xcopy "C:\" "N:\backup\system" /c /v /f /e /y /k /h >N:\backup\backup.log

mit nur einer Klammer mal ausprobiert, leider ist das Problem immer noch vorhanden.
Bitte warten ..
Mitglied: 51705
30.10.2007 um 20:14 Uhr
Kleiner Hinweis:

einfache Klammer -> bestehende Datei wird überschrieben
doppelte Klammer -> Log wird an bestehender Datei angehängt

Gruß, Steffen

PS: Ich würde robocopy nehmen.

[EDIT]

Probier mal:

xcopy "C:" "N:\backup\system" /c /v /f /e /y /k /h >>N:\backup\backup.log
Bitte warten ..
Mitglied: admin-lif
30.10.2007 um 21:29 Uhr
Ok, danke das kopieren funktioniert jetzt perfekt... allerdings werden die Dateien die im Moment kopiert werden nicht im Batchfenster angezeigt...
Bitte warten ..
Mitglied: 51705
31.10.2007 um 09:49 Uhr
du leitest ja auch die Ausgabe in deine Logdatei um...
Bitte warten ..
Mitglied: admin-lif
31.10.2007 um 11:21 Uhr
Und es gibt keine Möglichkeit das es im Batchfenster angezeigt und in eine Logdatei umgeleitet wird?
Bitte warten ..
Mitglied: 51705
31.10.2007 um 13:03 Uhr
Mit robocopy geht das mit xcopy nicht (soweit mir bekannt).
Bitte warten ..
Mitglied: admin-lif
31.10.2007 um 13:08 Uhr
Alles klar. Danke für die Info.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Xcopy jedoch nur die Dateien die nicht älter

gelöst Frage von zeroblue2005Batch & Shell13 Kommentare

Hallo Zusammen, Wie kann ich diese Script anpassen, so dass aus der Quelle nur die Dateien kopiert werden, die ...

Batch & Shell

Xcopy Batch-Datei

gelöst Frage von LauchheimerBatch & Shell3 Kommentare

Tag Leute, Ich habe in einer Batchdatei einen xcopy-Befehl. Dieser soll eine bestimmte Datei kopieren. Diesen führe ich mit ...

Batch & Shell

Von xcopy nicht gefundene Dateien werden nicht protokolliert

gelöst Frage von phsprengerBatch & Shell4 Kommentare

Hallo, mit einem kleinen Batch-Programm versuche ich, eine Liste von Dateien, die in einer TXT-Datei stehen, von A nach ...

Batch & Shell

Nach xcopy feststellen, ob Datei kopiert wurde oder nicht

gelöst Frage von Scar61Batch & Shell9 Kommentare

Hallo zusammen, in einem Skript wird eine Datei nur dann kopiert, wenn sie in der Quelle neuer ist als ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...