Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

If Probleme

Mitglied: A0D0S0

A0D0S0 (Level 1) - Jetzt verbinden

28.07.2011 um 16:58 Uhr, 2365 Aufrufe, 7 Kommentare

Hallo,

ich habe eine config Datei geschrieben , die sich autom. den Pfad sucht (mit %~dp0)

Alles funktioniert soweit, auf meinem Latop, denn auf meinem Latop ist der Pfad z.B. C:\Programme\....
Auf meinem Stand-Rechner lautet der Pfad dann C:\Program Files\...

batch erkennet (wegen dem Leerzeichen) jedoch nur C:\Program -.-

irgendwelche Tipps ?

Greez A0D0S0
Mitglied: Luckyguy
28.07.2011 um 17:01 Uhr
also bei shellscripten schreibt man auseinander geschriebene Pfad namen in Anführungszeichen
Bitte warten ..
Mitglied: A0D0S0
28.07.2011 um 17:05 Uhr
Habe ich schon probiert, bricht dan einfach ab

Habe schon daran gedacht den pfad manuell zu ändern sprich :

if %pfad%=="C:\Program Files\" (
set pfad="C:\Programme\"
)

leider wird auch immer abgebrochen
Bitte warten ..
Mitglied: Luckyguy
28.07.2011 um 17:12 Uhr
ja ist bei deinem desktop rechner was hast da für ein system drauf ?? und was auf deinem latop also windows klar aber welches
Bitte warten ..
Mitglied: Luckyguy
28.07.2011 um 17:14 Uhr
und was soll der batch denn genau machen ?
Bitte warten ..
Mitglied: bastla
28.07.2011 um 17:18 Uhr
Hallo A0D0S0!

Grundsätzlich ist es immer sinnvoll, den entsprechenden Code zu posten (und dabei die entsprechende Formatierung zu verwenden) ...

Zu Deinem kurzen Schnippsel fehlt natürlich die Zuweisung an die Variable %pfad% - soferne der darin enthaltene Pfad nicht unter Anführungszeichen steht oder ev eine andere Schreibweise (Stichwort Groß-/Kleinschreibung) enthält, kann das so nicht funktionieren, wobei ich es sowieso nicht für sinnvoll hielte, den Pfad zu "verbiegen".

Es gibt übrigens die Variable %ProgramFiles%, die den entsprechenden Pfad zum "Programme"-Ordner (also je nachdem "C:\Programme" oder "C:\Program Files") enthält.

Grüße
bastla
Bitte warten ..
Mitglied: A0D0S0
28.07.2011 um 17:38 Uhr
01.
set var1=%~dp0 
02.
for /f "delims=V" %%a in ("%var1%") do set pfad=%%a 
03.
 
04.
if %pfad%=="C:\Program Files\" ( 
05.
set pfad="C:\Programme\" 
06.
07.
 
Ich weiß , das ist nicht ganz sauber, zur Info: Mein Programm heißt VideoTool und deshalb trenn ich bei V sprich wenn der Pfad heißt C:\Programme\VideoTools\... bleibt
nach der Schleife noch C:\Programme\ ;)

%programFiles% wäre gut, aber ich will das ganze unabhängig machen ( z.B. auch mal nicht im Ordner Programme )


Am Laptop hab ich : XP
Am Stand-Rechner : Win7 Home premium

greez A0D0S0
Bitte warten ..
Mitglied: bastla
28.07.2011 um 19:31 Uhr
Hallo A0D0S0!

Um den "Elternordner" zu finden, sollte
for %%i in ("%~f0\..") do set "pfad=%%~dpi"
genügen ...
Wozu das Umwandeln von "C:\Program Files\" nach "C:\Programme\" gut sein sollte, habe ich übrigens noch immer nicht verstanden ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Windows Server
Spooler Probleme
Frage von joergWindows Server4 Kommentare

Hallo zusammen wir auf unseren Terminalserver das Problem, dass der Spooler sind in unregelmäßigen Abständen aufhängt. Die Vermutung liegt ...

Hardware
Probleme mit der Tastatur
gelöst Frage von hometownHardware2 Kommentare

Moin Moin habe ein ganz komisches Problem Ich soll mehre PC neu mit Win 7 und Windows 10 bespielen ...

Windows Server
Probleme mit Serververbindung
Frage von EnriqeWindows Server5 Kommentare

Hallo zusammen, seit einiger Zeit habe ich im Betrieb das Problem, dass sich Netzlaufwerke auf einem Server nicht verbinden ...

Batch & Shell
Probleme mit PSWindowsUpdate
Frage von supertuxBatch & Shell3 Kommentare

Hallo zusammen, ich wollte eben PSWindowsUpdate einrichten, so wie es aussieht hat das mein Vorgänger es auch schon verwendet. ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 20 StundenSonstige Systeme4 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 23 StundenDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 1 TagHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Werksreset HP 1920S-24G
gelöst Frage von HenereNetzwerkgrundlagen14 Kommentare

Servus zusammen, ich habe mir 2 neue Switche zugelegt, doch ich komme damit nicht ganz klar. Waren Vorführgeräte zum ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL14 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Firewall
Sophos UTM 9.5 Firewall Log-File durchsuchen
gelöst Frage von Leo-leFirewall13 Kommentare

Hallo zusammen, weiß jemand von Euch, ob man bei der Sophos die Firewall logs noch etwas besser filtern kann? ...

LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless12 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...