Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Probleme mit falschem Wert in ALLUSERSPROFILE

Mitglied: Scar61

Scar61 (Level 1) - Jetzt verbinden

12.05.2009, aktualisiert 10:10 Uhr, 5500 Aufrufe, 4 Kommentare

Hallo zusammen,

Da auf einem XP Rechner die Systempartition sehr klein ist und lokale Benutzer angelegt werden sollten, deren Profil groß werden kann, dachte ich mir, sorge dafür, dass das Profil für neue Benutzer auf der großen Partition D: angelegt wird.
Nach einigen Tipps von 'Dr. Google' hatte ich dann einige Änderungen in der Registry gemacht, die dazu führten, das bestehende Benutzer ihr 'ALLUSERSPROFILE' nicht mehr finden konnten.
Als Ursache hab ich ausgemacht, das in der Variablen 'ALLUSERSPROFILE' der Wert 'D:\Dokumente und Einstellungen\All UsersC:\Dokumente und Einstellungen\All Users' hat, was natürlich falsch ist.
Kann mir jemand sagen an welcher Stelle ich das wieder ändern kann? Ich hab in der Registry nichts auffälliges gefunden. Es gibt kein Login Skript das für irgendwelche Benutzer ausgeführt wird, es sollte also der Standardweg sein, wie Windows diese Variable zusammensetzt.

LG
Arno
Mitglied: Logan000
12.05.2009 um 11:44 Uhr
Moin Moin

Nach einigen Tipps von 'Dr. Google' hatte ich dann einige Änderungen in der Registry gemacht,....
Kann mir jemand sagen an welcher Stelle ich das wieder ändern kann?

Du machst diese Registry Änderungen wieder rückgängig, dann sollte sich auch dein Problem behoben haben.

Gruß L.
Bitte warten ..
Mitglied: Scar61
12.05.2009 um 11:55 Uhr
Jau,

genau das ist mein Problem...
Immer, wenn man schnell mal was macht und denkt: 'bisher ist ja noch nie was passiert.' passiert's genau dann. (Murphy oder auch Blödheit genannt).
D.h.: ich kann kein Backup einspielen und wohl auch nicht alle Änderungen nachvollziehen, sonst hätte ich es hier nicht gepostet.

Ich hatte jetzt halt die Hoffnung, das mir jemand sagen kann, wie und wo diese Variable nach der Anmeldung zusammengebaut wird, damit ich's wieder reparieren kann.

Gruß
Arno

P.S.: Nachdem ich ALLUSERSPROFILE im Machinenenvironment auf den alten Pfad gesetzt habe, war alles wieder in Ordnung auf der Kiste.

Es würde mich trotzdem interessieren, nach welchen Regeln ALLUSERSPROFILE gesetzt wird, wenn die Variable nicht explizit in irgendeinem
Environment (machine, user, volatile,default) gesetzt wird.
Bitte warten ..
Mitglied: Logan000
13.05.2009 um 08:23 Uhr
Moin Moin

Schau Dir mal unter folgendem Registry Schlüssel an:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\ProfilesDirectory
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\DefaultUserProfile
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\AllUsersProfile

Die Standartwerte solten sein:
ProfilesDirectory = %SystemDrive%\Dokumente und Einstellungen
DefaultUserProfile=Default User
AllUsersProfile=All Users

Gruß L.
Bitte warten ..
Mitglied: Scar61
13.05.2009 um 08:30 Uhr
Moin Moin,

das war jetzt zeitgleich, aber ein guter Hinweis, da die Standardwerte bei mir sowohl bei DefaultUserProfile, als auch bei AllUsersProfile den kompletten Pfad enthalten, aber wie es ausieht, werden die wohl aus diesen Werten zusammengesetzt.
Wie sieht den dann die richtige Lösung aus, wenn es wie in meinem Fall die Standardprofilpfade zwar auf C: liegen, die Pfade für neu angelegte Benutzer aber auf D: liegen soll?
Gibt es dafür den eigentlich eine saubere Lösung?

LG
Arno
Bitte warten ..
Ähnliche Inhalte
Windows Server
Völlig falsche Werte nach gpupdate
Frage von ofodagWindows Server4 Kommentare

Hallo zusammen, ich habe folgendes Problem bei einem einzigen Server. Ich habe eine Policy bzgl. WSUS die auch bei ...

Batch & Shell

Powershell Probleme mit initialer Start-Wert-Befüllung einer DropDownList

gelöst Frage von dschauerteBatch & Shell5 Kommentare

Hallo liebe Community, ich schreibe hier das erste Mal und hoffe auf eure guten Tipps. Aktuell schreibe ich ein ...

Windows Netzwerk

Probleme beim Netzwerkrouting oder suche ich an der falschen Stelle

gelöst Frage von G3W077Windows Netzwerk6 Kommentare

Folgende Konfiguration PC Windows 7 Professional 64bit ist mit 2 Netzwerkkarten ausgestattet. LAN1 besitzt eine statische IP 10.191.2.10 255.255.255.0 ...

Microsoft Office

Suchen mit 2 Werten (x,y) in einer Tabell - Bereich.vergleich gibt nur Wahr oder Falsch aus

gelöst Frage von ArafatMicrosoft Office2 Kommentare

Hallo Zusammen, ich suche in einem 2. Tabellenbatt nach über 2 Werte x und y nach einem 3. Wert. ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...