Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Probleme mit NAS Buffalo Linkstation LS-W2.0TGL

Mitglied: AsciWhite

AsciWhite (Level 1) - Jetzt verbinden

30.08.2011, aktualisiert 18.10.2012, 8375 Aufrufe, 6 Kommentare

extrem lange Ladezeiten beim Zugriff auf Dateien auf NAS-Freigabe

Hallo,
ich habe ein Problem mit einer Buffalo Linkstation LS-W2.0TGL
Diese ist mit mehreren Freigaben konfiguriert und die User haben Daten darauf abgelegt.
Seit kurzem bekomme ich von einigen Usern Berichte über extrem lange Ladezeiten bei Öffnen von (Excel, Word, Bilder) Dateien die auf dem gemappten NAS-Laufwerk liegen. Dateigröße ca. 250 kb, also nichts extremes. Verzeichnisswechsel machen keine Probleme.

Ich habe daher mal die Zugriffe auf die NAS mit einem Netzwerkmonitor überwacht und musste feststellen, dass bei einer solch kleine Datei (250kb) unglaubliche 8MB in ca. 70.000 TCP Paketen (!!) übertragen werden. Das dauert dann natürlich unangenehm lange, ca. 45 sec.
An einem anderen PC, der nicht diese "Ladeprobleme" hat, werden für die gleiche Datei nur ca. 900 TCP Pakete und ca. 325kb Daten übertragen, was viel plausibler ist und nur ca. 5-10 sec dauert.

Meine Frage: Kann mir jemand dieses seltsame Verhalten erklären und wie kann ich es ggf. beeinflussen?

Gruß
Mitglied: onkel-ossi
31.08.2011 um 00:42 Uhr
Hallo Asci White,

da habe ich noch ein paar Fragen:

  • nutzt du unterschliedliche Netzwerkstrukturen zwischen NAS und Client? Dann würde ich mal auf das Kabel, den Switch oder ähnliches tippen.
  • Kannst du den Client der keine Probleme macht mal an das Netzwerkkabel des Clients anschliessen der Probleme macht? Dann liesse sich die Infrastruktur ausschliessen.
  • Tritt der Fehler immer auf?
  • Handelt es sich um immer die gleichen Dateien oder verschiedene?
  • Ist eine Kopie der Datei auch so schlecht aufzurufen?

Mit den Antworten kann man vielleicht schon mehr sagen.

Gruss
Thomas
Bitte warten ..
Mitglied: Joe2011
31.08.2011, aktualisiert 18.10.2012
Guten Morgen.
Sind die Probleme wirklich bei allen Dateien? Oder nur bei Office2003? Da gab es vor kurzem ein Update, welches lange Ladezeiten über das Netz verursachte. Siehe hier: https://www.administrator.de/wissen/excel-%c3%bcber-netzwerk-langsam-win ...

Gruß

Joe
Bitte warten ..
Mitglied: AsciWhite
31.08.2011 um 09:27 Uhr
Zitat von onkel-ossi:
Hallo Asci White,

da habe ich noch ein paar Fragen:

  • nutzt du unterschliedliche Netzwerkstrukturen zwischen NAS und Client? Dann würde ich mal auf das Kabel, den Switch oder
ähnliches tippen.

welche unterschiedlichen Netzwerkstrukturen meinst du da? das ist ein echt einfaches LAN mit 2 NB's und einem Desktop PC nem 100er switch und der NAS. Kabel und Switch wurden aber testweise schon ausgetauscht.
Das Problem zeigt sich aber auch in einem ganz anderen, als Testumgebung aufgebauten Netz.

* Kannst du den Client der keine Probleme macht mal an das Netzwerkkabel des Clients anschliessen der Probleme macht? Dann liesse
sich die Infrastruktur ausschliessen.
^^ leider nicht

* Tritt der Fehler immer auf?
  • Handelt es sich um immer die gleichen Dateien oder verschiedene?
  • Ist eine Kopie der Datei auch so schlecht aufzurufen?

ja, Fehler tritt an den ermittelten PCs/NBs immer und mit allen Officedateien auf


Mit den Antworten kann man vielleicht schon mehr sagen.

Gruss
Thomas

Danke erstmal für die Vorschläge, aber es erklärt ja alles nicht, wieso so extreme Unterschiede bei den Netzwerkpaketen herrschen. Könnte es vielleicht auch an sowas wie inkombatiblen oder defekten Netzwerkkarten liegen? Treiber hab ich jedenfalls schon mal erneuert, ohne Erfolg.
Außerdem hab ich grad mal mit dem Support von Buffalo gesprochen, aber was der mir da erklären wollte kommt mir sehr komisch vor. Er erklärte, dass das an "zu vielen Dateien auf der NAS" liegen soll und das das linux OS auf der NAS die Dateien alle cachen würde und deshalb so lahm wär. der zustand wäre in neueren geräten geändert, in der von mir verwendeten aber nicht zu ändern.... heißt also, buffalo lässt bekannte firmwarefehler in seinen geräten drin, damit der dumme kunde sich was neues kaufen muss .... klarer kaufanreitz, oder?
nichtsdestotroz, es hat bis vor kurzen auch mit dem teil funktioniert und bei knapp 12GB von 1000GB mit ~6000 Dateien kann ich auch die aussage mit den zu vielen dateien nicht aktzeptieren.

Gruß
Bitte warten ..
Mitglied: onkel-ossi
31.08.2011 um 13:16 Uhr
Hallo,

meine Ideen gingen dahin einen Hardwaredefekt auszuschliessen, daher die Kabeltausch und Umgebungsfrage.

Zitat von AsciWhite:
nichtsdestotroz, es hat bis vor kurzen auch mit dem teil funktioniert und bei knapp 12GB von 1000GB mit ~6000 Dateien kann ich
auch die aussage mit den zu vielen dateien nicht aktzeptieren.


Wie verhält es sich denn, wenn du das NAS leer räumst und nur einzelne Dateien dort liegen hast auch den Hem Hinweis von Joe2011 solltest du nachverfolgen.

Insgesamt klingt es aber wirklich eher nach einem Client-Problem. Wenn das NAS da etwas cachen würde, warum dann nur für die Notebooks?

Gruss
Thomas
Bitte warten ..
Mitglied: AsciWhite
31.08.2011 um 13:43 Uhr
Zitat von onkel-ossi:

Insgesamt klingt es aber wirklich eher nach einem Client-Problem. Wenn das NAS da etwas cachen würde, warum dann nur für
die Notebooks?


ja, das würde mich auch mal interressieren. nachdem ich nun mal weiter gesucht habe und mit dem netzwerkmonitor schon ma diese ungereimtheiten mit den TCP Paketen gefunden habe bin ich nun noch darauf gestoßen, dass mein Test NB, das im gleich Netz wie der funktionierende Test PC hängt, die Dateien scheinbar in nur 2 byte große häppchen zerlegt überträgt :-O erklärt zwar noch nicht, wieso dann bei soner kleinen 250kb datei fast 8 MB übertragen werden müssen, aber wenigstens ist klar, warum so viele pakete übertragen werden.
meine frage wäre nun, wo kann man diese "transportgröße" einstellen?
Bitte warten ..
Mitglied: AsciWhite
02.09.2011 um 13:42 Uhr
SOOO, also es hat mir zwar einige graue Haare bescheert, aber ich habe das Problem gefunden.
Leider hatte sich irgendwie doch das hier schon erwähnte "Office File Validation Tool" Update auf die betroffenen Systeme geschlichen und so dieses Verhalten verursacht. Nachdem ich dies entfernt habe geht alles wieder gewohnt fix.

Dank an alle, die Tipps geliefert haben und einen ganz besonderen Gruß an M$ ... vielleicht sollte man ja Updates und Patches auch mal prüfen, befor man sie auf die Allgemeinheit loslässt ;)
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid

Buffalo Linkstation LS-XL im Emergency Modus retten

gelöst Frage von HamburgerJung1975Festplatten, SSD, Raid14 Kommentare

Meine Buffalo Linkstation LS-XL lässt sich nicht mehr aus dem Emergency Modus holen. Habe diverse Male mit dem Buffalo ...

SAN, NAS, DAS

Buffalo Linkstation LS-WXL (2x 1TB) RAID 0 wiederherstellen

Frage von Woodstok79SAN, NAS, DAS9 Kommentare

Hallo Forum, ich verzweifle beim Versuch meine Daten von der Buffalo Linkstation LS-WXL mit 2x 1TB im RAID 0 ...

SAN, NAS, DAS

Buffalo LinkStation 220D wird nicht erkannt

gelöst Frage von 21243SAN, NAS, DAS6 Kommentare

Moin, moin. Eine neue LS 220D wurde ausgepackt und mit einer fabrikneuen WD 1TB HDD bestückt. Dann wurde die ...

SAN, NAS, DAS

Buffalo ls-qvl startet nicht mehr

Frage von Rocco72SAN, NAS, DAS6 Kommentare

Hallo Community, ich habe schon das Forum durchsucht, aber nicht brauchbares gefunden also werde ich hier meine Frage nochmal ...

Neue Wissensbeiträge
Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 1 StundeHumor (lol)

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Exchange Server

Exchange 2010-2019 Sicherheitslücke durch Regkey löschen schließen

Information von sabines vor 12 StundenExchange Server1 Kommentar

Unter ist eine Lücke im Exchange 2010-2019 beschrieben, die durch das Löschen eines reg keys geschlossen werden kann. In ...

Windows Server
Erneutes Release von WS2019 und Win10 v1809
Tipp von IT-Pro vor 1 TagWindows Server3 Kommentare

Hi, nachdem der Windows Server 2019 und Windows 10 in der Version 1809 aufgrund von verschwinden von Dateien nach ...

CPU, RAM, Mainboards
Spectre Update Tool für ältere PCs
Information von sabines vor 1 TagCPU, RAM, Mainboards6 Kommentare

Mit Hilfe eines Tools wird der betreffende PC permanent von einem USB Stick gestartet, der ein passendes Microcode Update ...

Heiß diskutierte Inhalte
Windows Server
Lohnt sich eine Domäne für uns?
Frage von BowsetteWindows Server15 Kommentare

Hallo, ich arbeite in einem kleinen Unternehmen mit mehr als 5 und weniger als 10 Mitarbeitern, also Small Business ...

Java
Testautomatisierung
gelöst Frage von WPFORGEJava15 Kommentare

Hallo, nehmen wir an, es gibt eine Webseite mit einer Karte und einem Suchfeld. Nun wird in das Suchfeld ...

Viren und Trojaner
Office365 Trojaner Analyse
Frage von ZeppelinViren und Trojaner12 Kommentare

Liebe Community, ich wende mich an euch, um mehr über den Office365 Trojaner zu erfahren, welcher grade seine Runden ...

Exchange Server
PST Datei enthält weder Betreff noch Absender
gelöst Frage von SSamuelExchange Server10 Kommentare

Hallo zusammen, ich versuche aus einer wiederhergestellten Exchange (SBS2011) .EDB mit dem Programm "Kernel for Exchange von Nucleus" eine ...