Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme bei RIS- Konfiguration

Mitglied: 25344

25344 (Level 1)

13.12.2006, aktualisiert 14.12.2006, 3771 Aufrufe, 11 Kommentare

Hallo Leute,

Wie der Titel schon sagt habe ich Probleme bei der RIS Konfiguration. Ich möchte nicht, dass RIS bei den Clients jeweils immer nur eine Partition einrichtet. Wir, bei uns in der Firma, haben da einen gewissen Standard, nämlich eine Systempartition (C und eine Datenpartition. Habe auch schon die Suchfunktion des Forums verwendet und eine Lösung gefunden aber irgendwie klappt die nicht so wirklich. Hier mal die ristndrd.sif:

[data]
floppyless = "1"
msdosinitiated = "1"
OriSrc = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
OriTyp = "4"
LocalSourceOnCD = 1
DisableAdminAccountOnDomainJoin = 0
Repartition = no
UnattendedInstall = yes
Autopartition = 0

[SetupData]
OsLoadOptions = "/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[Unattended]
UnattendedInstall = DefaultHide
Repartition = no
OemPreinstall = no
FileSystem = LeaveAlone
ExtendOEMPartition = 0
TargetPath = \WINDOWS
OemSkipEula = yes
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1

[UserData]
FullName = "Testumgebung"
OrgName = "projekt"
ComputerName = %Machinename%
ProductID = XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

[GuiUnattended]
OemSkipWelcome = 1
OemSkipRegional = 1
TimeZone = %TIMEZONE%
AdminPassword = "*"
EncryptedAdminPassword = Yes

[Display]
BitsPerPel = 32
XResolution = 1024
YResolution = 768
VRefresh = 75

[Networking]

[NetServices]
MS_Server=params.MS_PSched

[Identification]
JoinDomain = %MACHINEDOMAIN%
DoOldStyleDomainJoin = Yes

[RemoteInstall]
Repartition = Yes
UseWholeDisk = Yes



[OSChooser]
Description="Microsoft Windows XP Professional Deutsch Automatisiert"
Help="Microsoft Windows XP Professional wird automatisch installiert, ohne dass der Benutzer zur Eingabe aufgefordert wird."
LaunchFile="%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"
ImageType=Flat
Version="5.1 (2600)"


Desweiteren möchte ich, dass das lokale Adminkonto nicht deaktiviert wird. Diese Einstellungen müssten eigentlich stimmen. Hoffe jemand hat einen Tipp, wo mein Fehler liegen könnte.

Danke

Gruß Chiefus
Mitglied: Dani
13.12.2006 um 11:49 Uhr
Hi,
also du möchtest, dass die Datenpartition nicht gelöscht wird?!Wunderbar, dass gleiche Problem habe ich nämlich auch!

Dein lokaler Administrator wird ganz normal angelegt!


Gruß
Dani
Bitte warten ..
Mitglied: 25344
13.12.2006 um 11:53 Uhr
Nicht ganz, ich möchte einfach, dass eine Partition (C anlegt wird und den Rest der Festplatte in Ruhe lässt. Damit ich später eine weitere Partition (D) erstellen kann. Aber irgendwas stimmt nicht ganz in meiner ristndrd.sif....
Danke trotzdem!

Gruß Chiefus
Bitte warten ..
Mitglied: Dani
13.12.2006 um 12:07 Uhr
Hi,
dann schau dir das mal an:
http://www.twenty.at/docs/ris.html


Gruß
Dani
Bitte warten ..
Mitglied: 25344
13.12.2006 um 12:58 Uhr
Danke, ich werde mir mal die Anleitung genauer ansehen. Mal nebenbei, ich bin noch nicht ganz so glücklich mit der Vergabe der Client Namen. Bei uns im Betrieb heißen die Rechner domain-nachname1....
Wie könnte ich denn diese Variante auswählen oder erstellen?

Gruß Chiefus
Bitte warten ..
Mitglied: Dani
13.12.2006 um 20:48 Uhr
Hi,
du willst den Rechnername domain-nachname1 immer nennen!!

Also ich mache das anders. Ich nenne den neuen Rechner immer "NEU". Nach der Installation wird der lokale Admin angemeldet. Dort wird ein Batch gestartet. In diesem wird dann an Hand einer Textdatei der Rechnername vergeben. Danach wieder in die Domäne aufgenommen!


Gruß
Dani
Bitte warten ..
Mitglied: 25344
14.12.2006 um 08:17 Uhr
Hi,

Ja das habe ich mir so auch schon so überlegt. Allerdings würde ich eine weitere Batch für die TCP/IP Einstellungen anlegen, da wir hier nur statische IP-Adressen für die Clients verwenden.
Aber nochmal zurück zu den Computernamen. Du löschst dann aber schon die alten Einträge aus dem DNS, oder? Oder automatisierst du das ebenfalls?
Danke

Gruß Chiefus
Bitte warten ..
Mitglied: Dani
14.12.2006 um 10:02 Uhr
Hi,
Aber nochmal zurück zu denComputernamen. Du löschst dann aber
schon die alten Einträge aus dem DNS,boder? Oder automatisierst du das ebenfalls?
Das Problem habe ich nicht!*gg* Ich verwende immer einen DHCP Server. SOmit werden die DNS Einträge erstellt, wenn eine Adresse released wird bzw. wenn wieder eine frei ist, wird der DNS Eintrag gelöscht. Drum versteh ich net, warum du kein DHCP-Server verwendest.


Gruß
Dani
Bitte warten ..
Mitglied: 25344
14.12.2006 um 10:22 Uhr
Verstehen tu ich es auch nicht. Aber ich muss es verstehen . Ist nun mal bei uns so vorgeschrieben. Das Script für die TCP-/IP Einstellungen hab ich soweit mit netsh erstellt.
Jetzt brauch ich nur noch eine Batch um die Rechnernamen zu ändern.
Hast du nen Tipp?
Danke

Gruß Chiefus

Nachtrag:

Habe DNS in mein Active Directory integriert. Somit wird, so bald ich bei einem Client den Namen ändere, meine Forward- und Reverse- Lookupzone aktualisiert.

Gruß Chiefus
Bitte warten ..
Mitglied: Dani
14.12.2006 um 10:40 Uhr
Hi,
du kannst es einmal per VB Script lösen:
01.
Option Explicit 
02.
 
03.
Set ws = WScript.CreateObject("WScript.Shell") 
04.
Dim ws, t, p2, p3, p4, p5, n, g, j, h, f, k, cn, cg, cj 
05.
Dim itemtype 
06.
 
07.
p2 = "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\ComputerName\ComputerName\" 
08.
p3 = "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters\" 
09.
p4 = "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ComputerName\ComputerName\" 
10.
p5 = "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\" 
11.
 
12.
j = ws.RegRead(p2 & "ComputerName") 
13.
h = ws.RegRead(p3 & "NV Hostname") 
14.
f = ws.RegRead(p4 & "ComputerName") 
15.
k = ws.RegRead(p5 & "NV Hostname") 
16.
 
17.
t = "Change Utility" 
18.
 
19.
 cj = InputBox("Geben Sie den neuen Computernamen an und klicken auf OK." & vblf & "!! ACHTUNG !! Nach dem klicken auf OK wird der Computer SOFORT neugestartet!", t, j) 
20.
 
21.
If cj <> "" Then 
22.
  ws.RegWrite p2 & "ComputerName", cj 
23.
  ws.RegWrite p3 & "NV Hostname", cj 
24.
  ws.RegWrite p4 & "ComputerName", cj 
25.
  ws.RegWrite p5 & "NV Hostname", cj 
26.
 
27.
  wscript.echo SUCCESS, "Computername wurde erfolgreich geändert!" 
28.
  Ws.Run "shutdown.exe -r -f -t 0 -c ""Windows XP wird neu gestartet""", 1, False 
29.
End If
Gruß
Dani
Bitte warten ..
Mitglied: Dani
14.12.2006 um 10:46 Uhr
Hi,
so, nun hab ich doch noch mein Batch gefunden. *gg*
01.
@ECHO off 
02.
SET computername=test1234 
03.
 
04.
REG add "HKLM\SYSTEM\ControlSet001\Control\ComputerName\ComputerName" /v ComputerName /t REG_SZ /d %computername% /f 
05.
REG add "HKLM\SYSTEM\ControlSet001\Services\Tcpip\Parameters" /v "NV Hostname" /t REG_SZ /d %computername% /f 
06.
REG add "HKLM\SYSTEM\CurrentControlSet\Control\ComputerName\ComputerName" /v ComputerName /t REG_SZ /d %computername% /f 
07.
REG add "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters" /v "NV Hostname" /t REG_SZ /d %computername% /f
Gruß
Dani
Bitte warten ..
Mitglied: 25344
14.12.2006 um 11:44 Uhr
Danke, werde ich gleich mal ausprobieren! Werde dich auf dem laufenden halten.

Gruß Chiefus
Bitte warten ..
Ähnliche Inhalte
Server

Probleme bei der Konfiguration von Apache mit IPv6

gelöst Frage von DarkShadowServer2 Kommentare

Hallo, ich möchte gerne meinen Apache Webserver, der auf einem Windows 7 Enterprise PC läuft, IPv6 kompatibel machen. Zu ...

Netzwerkmanagement

Probleme bei der Konfiguration eines Netzwerks mit mehreren VLans

gelöst Frage von HauresNetzwerkmanagement12 Kommentare

Guten Tag, auf dem Bild seht Ihr meine aktuelle Netzwerkkonfiguration. In dem VLan 10 ist der DHCP 10.10.10.200 als ...

Switche und Hubs

Konfiguration des Heimnetzwerks

Frage von Force2611Switche und Hubs20 Kommentare

Hallo, ich habe mit massiven Perfomanceproblem in meinem Wlan zu kämpfen und hoffe, dass ihr mir einen guten Tipp ...

Windows Tools

ADSIEDIT - Wo Konfiguration?

gelöst Frage von emeriksWindows Tools1 Kommentar

Hi, weiß jemand, wo ADSIEDIT seine Konfiguration speichert? (die eingerichteten Verbindungen) E.

Neue Wissensbeiträge
Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 19 StundenHumor (lol)1 Kommentar

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 20 StundenExchange Server6 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 1 TagErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Vmware
VMware Updates gegen L1 Lücke
Information von sabines vor 2 TagenVmware

Für die Vmware Produkte vCenter Server, ESXi, Workstation und Fusion stehe Updates bereit um die L1 Lücke zu schließen. ...

Heiß diskutierte Inhalte
Windows Server
Domäne einsilbig mit nur einem Namen benannt - sowie AD und MX auf einer VM Kardinalsfehler?
Frage von TomTestWindows Server49 Kommentare

Hallo liebe Freunde gepflegter Probleme, seit kurzem soll ich eine Domäne verwalten die zuvor von einem IT-Dienstleister erstellt und ...

DSL, VDSL
Router Neustarts
Frage von XerebusDSL, VDSL16 Kommentare

Hallo an alle, ich hab eine Problem mit dem Neustart von meiner Fritz Box wo ich einfach nicht mehr ...

Windows Server
Windows Server per Web auf Daten zugreifen und verwalten
Frage von matze2090Windows Server16 Kommentare

Hallo, ich würde gerne von außen auf meinem Windows Server zugreifen um auf meine Daten zu verwalten. Meine frage ...

DNS
Gibt es eine Art DNS Proxy?
Frage von icepietDNS16 Kommentare

Hallo Nerds, Ich würde gerne folgendes machen: ts.domain.de:3389 soll auf 1.2.3.4:3389 auflösen ts2.domain.de:3389 soll auf 1.2.3.4:3390 auflösen Gibt es ...