Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme bei RPC-over-HTTP auf SBS2011 (Exchange2010)

Mitglied: DerSchorsch

DerSchorsch (Level 2) - Jetzt verbinden

12.09.2011 um 12:20 Uhr, 7237 Aufrufe, 6 Kommentare

Bei Nutzung von RPC-over-http bei einem SBS2011 wird das OfflineAddressbuch nicht geladen.

Hallo,

wir haben bei uns von einem SBS2003 auf SBS2011 migriert (gemäß Anleitung von MS).
Das ganze hat auch soweit funktioniert.
Die Domänen-Rechner laufen sauber, der Zugriff auf den Exchange läuft problemlos.
Verwendet wird Outlook 2007 und 2010.

Nun haben wir aber auch 2 externe Rechner, die nicht Mitglied der Domäne sind (sprich: die stehen bei 2 Leuten zuhause).
Der Zugriff erfolgt über RPC-Over-https mit Outlook 2010.
Inhalte (also Mails, Kalender, etc..) gehen, jedoch wird das OfflineAddressBuch (OAB) nicht aktualisiert. Mit dem alten Server ging das noch. Auch Outlookprofil neu machen ändert nichts.

Bei Synchronisierungsprobleme findet sich folgender Eintrag.
"Fehler bei Synchronisierung des Ordners: [8004011D-526-80040115-0]
Microsoft Exchange ist nicht verfügbar. Es bestehen Netzwerkprobleme, oder der Servercomputer mit Exchange wurde für Wartungsarbeiten heruntergefahren."

Bisher habe ich nur Anleitungen gefunden, wenn RPC-over-https oder OAB gar nicht gehen.
Trifft aber beides so nicht zu:
Das OAB geht bei den Domänen-Clients, RPC-over-https synchronisiert Inhalte.

Hat irgendjemand eine Idee, was ich machen könnte?

Danke im vorraus
Schorsch
Mitglied: Patriot
12.09.2011 um 14:44 Uhr
Ausgeschlossen, das es andere Komponenten sein könnten (Firewall) die die Anfrage blocken?
Was sagt denn das Log vom Exchange, kommen Anfragen an? Blockiert die Windows Firewall vll externe Anfragen?
Bitte warten ..
Mitglied: DerSchorsch
12.09.2011 um 16:58 Uhr
Hallo,

ich denke, die Firewall kann ich ausschliessen. Sowohl die "richtige" als die die Windows-eigene.
Eingehend macht die nur ein Portforwarding tcp/443 auf den SBS. Ist kein ReverseProxy oder so.
Und eigentlich sollte bei dieser Art der Verbindung ja alles über https getunnelt werden. Ist übrigends das gleiche Setup wie beim alten SBS2003, da ging noch alles.

Der Witz ist ja auch, man bekommt Emails, der Kalender wird aktualisiert, etc.. Nur kommt leider auch ein Übermittlungsfehler, weil das OAB nicht geladen werden kann.
Die RPC-over-https-Verbindung geht also schon "irgendwie", nur geht halt nicht alles. (OWA geht übrigends auch.)

Man kann auch senden, aber wenn man die Adressliste aufmacht, sieht man halt auch alte Konten, die im Zuge der Migration gelöscht wurden, neuere hingegen nicht. Kennt man die Email, geht es trotzdem, ist aber halt unbequem.

Am Server sehe ich in der Ereignisanzeige nichts, was ich dem zuordnen könnte. Jedenfalls nicht während der Zeit einer Verbindung. Und lokal die bereits gepostete Meldung.

Gruß,
Schorsch
Bitte warten ..
Mitglied: xcabur
05.12.2011 um 16:31 Uhr
falls dein problem noch nicht gelöst ist, erstelle einmal auf dem externen Client im hostfile einen eintrag mit autodiscover.domain.tld mit der öffentlichen IP unter welcher auch dein OWA verfügbar ist, wenn es dann klaptt, dass ganze einfach in deine öffentliche DNS Zone übertragen, damit es auch für alle verfügbar ist.
Bitte warten ..
Mitglied: DerSchorsch
05.12.2011 um 22:29 Uhr
Hallo,

das geht soweit, allerdings gibts eine Fehlermeldung, weil der Name des Zertifikats falsch ist (es geht ja nicht auf autodiscover.unseredomain.de). Wenn man das bestätigt, macht er weiter. Und dann synct er tatsächlich auch das OAB.

Ich habe noch dies hier gefunden:
http://support.microsoft.com/kb/940881/de
Da wir gerade sowieso unseren Provider wechseln und beim neuen das Anlegen von SRV-Einträgen in den DNS möglich sein wird, wollte ich das dann testen.

Gruß,
Schorsch
Bitte warten ..
Mitglied: xcabur
06.12.2011 um 09:16 Uhr
ehm ja das sollte auch gehen, habe ich zwar noch nie ausprobiert (ein feedback würde mich interessieren). Der Grund wieso ich es noch nie so gemacht habe ist, weil mich folgender Punkte aus dem oben erwähnten Technet Artikel abgeschreckt hat:

5.Der Benutzer wird von Outlook aufgefordert zu bestätigen, dass Autodiscover weiterhin an "https://mail.contoso.com/autodiscover/autodiscover.xml" senden soll.

Hast du ein ofizielles Zertifikat oder hast du eines von deiner eigenen CA ausstellen lassen?
Falls du eines von deiner eigenen CA ausgestellt hast, kannst du einfach ein neues Zertifikat inkl. autodiscover.domain.tld ausstellen, und auf deinen "nicht Domänen Clients" das Stammstellenzertifikat deiner CA manuell installieren. Falls du eine offizielle CA verwendest, dann müsstest du notfalls nocheinmal eins kaufen. Natrülcih nur, wenn die Sache mit dem SRV-Record nicht funktioniert.
Bitte warten ..
Mitglied: DerSchorsch
06.12.2011 um 19:02 Uhr
Hallo,

wir haben das vom SBS selbst generierte. Allerdings auch nur 1 öffentliche IP. Ich bin mir nicht sicher ob so das mit 2 Zertifikaten korrekt funktioniert.
Ich muss meinen Kollegen fragen, wann er den Domainumzug fertig hat. Dann kann ich das mit dem SRV testen.

Wenn man die Abfrage nur einmal bestätigen muss, wäre das bequemer als im Moment. Man muss den Zertifikatsfehler bei jedem Aufruf erneut bestätigen.

Ich geb Bescheid, wie das mit dem SRV funktioniert.

Gruß,
Schorsch
Bitte warten ..
Ähnliche Inhalte
Exchange Server

RPC over HTTP - gesendete Nachricht nicht auf Server angekommen. Nachrichtenverfolgung?

Frage von viragomannExchange Server2 Kommentare

Hallo! Einer unserer Nutzer hat von extern mit Outlook eine Mail an einen anderen Exchange Nutzer gesendet, die nie ...

Windows Server

Im Exchange2010 (SBS2011) .log versehentlich gelöscht

Frage von helmuthelmut2000Windows Server6 Kommentare

Hallo, Ich habe folgende Frage. Ich habe an meinem SBS2011 ca. 25 Clients mit Mailpostfacher. Dort wurde die Mailbox ...

Exchange Server

Outlook 2010 mit Exchange 2013 verbinden. Nur RPC over HTTP?

gelöst Frage von wixmixbinExchange Server2 Kommentare

Hallo zusammen, Outlook 2010 kann man mit Exchange 2007 per MAPI verbinden. Exchange 2013 unterstützt ja MAPI nicht mehr. ...

Exchange Server

RPC over HTTPS Einstellung wird nur unter Win 8.1 nicht gespeichert

gelöst Frage von PressmarExchange Server2 Kommentare

Hallo zusammen, wir haben hier einen kleinen Exchange Server 2010 mit aktuellen Update-Stand. Dieser funktioniert mit etlichen Windows 7 ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 23 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...