Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Probleme bei SSO mittels ADFS

Mitglied: soljah

soljah (Level 1) - Jetzt verbinden

06.08.2013, aktualisiert 13:50 Uhr, 2881 Aufrufe, 3 Kommentare

Hallo zusammen,

Wie der Titel schon sagt, habe ich ein paar Probleme (vielleicht fehlt mir auch nur ein wenig Verständniss) mit ADFS (Active Directory Federation Services) und ich hoffe das mir hier jemand helfen, oder den richtigen Denkanstoß geben kann.

Konkret geht es darum sich bei dem Tool/Website "Solarwinds Web Help Desk" über ADFS / Saml zu authentifizieren.
Ich habe eine wirklich sehr kurze Anleitung auf http://knowledgebase.solarwinds.com/kb/questions/4204/How+To+Configure+ ... gefunden.
Weiters habe ich jetzt schon mehrere Tage div Tutorials zu ADFS SSO gelesen, geschaut und mitgemacht.

Eigentlich funktioniert das SSO und ich authentifiziere mich am Help Desk mit den Anmeldeinformationen von Windows. Das ganze funktioniert aber nur über diesen Link: https://adfs.firma.local/adfs/ls/IdpInitiatedSignOn.aspx -> dort wähle ich dann "Helpdesk" aus - und ich werde auf die WebhelpDesk Seite weitergeleitet und auch angemeldet.

Meinem Verständnis nach, müsste / sollte es doch auch funktionieren, wenn ich direkt die Webhelpdesk Seite aufrufe. Im WebhelpDesk - habe ich ADFS konfiguriert und wenn ich den Link https://helpdesk.firma.local aufrufe werde ich auch zum ADFS Server weitergeleitet. Es kommt auch das Anmeldefenster (von "Windows") , nur wenn ich hier meine Daten eingebe, bzw den IE so einstelle dass sie automatisch weitergegeben werden, werde ich nicht wieder zurück auf die Webhelpdesk Seite geleitet, sondern bekomme den im Bild ersichtlichen Fehler.
5eda31fae6e5602933933f32b0b93f0d - Klicke auf das Bild, um es zu vergrößern

Hat hier eventuell jemand eine Idee warum das so ist, bzw wieso mein ADFS nicht wieder zurück auf die Helpdeskseite verweist ?
Falls ihr für eine Antwort noch Zusatzinformationen benötigt lasst es mich wissen.

Ich bin für jeden Tipp dankbar


edit: Der Fehler kommt auch wenn ich z.B. https://adfs.firma.local/adfs/ls/irgendeineadressedieesnichtgibt eingebe. - also wird zwar auf irgendetwas weitergeleitet (denke ich) aber ich habe keine Ahnung auf was - aus der URL ist nichts herauszufinden und alle Einstellungen im ADFS haben die richtige Helpdeskadresse eingetragen.





Mitglied: Dani
06.08.2013 um 18:05 Uhr
Moin,
kannst du bitte kurz aufzeichnen wie deine Infrastruktur aussieht? Sprich stehen WHD, ADFS im LAN nebeneinander oder gibt es noch einen ADFS-Proxy, etc...?! Laufen ADFS und WHD auf einem Server, sprich IIS oder seperate Server (Stichwort: Tomcat). Einfach die Rahmendaten damit wir uns das nicht ausdenken müssen.

Zitat von Solarwinds:
Active Directory Federation Services (AD FS) implements SAML 2.0, which is supported in Web Help Desk 10.2.0.22 and later. 
Was mich in deinem Link wundert, sind die Aussagen:
Identifier:https://www.mydomain.com/helpdesk/WebObjects/Helpdesk.woa 
Signature: use the same certificate as above
D.h. würde heißen, beides läuft auf einem Server. Ansonsten kann ich doch nicht das selbe Zertifikat nutzen.


Grüße,
Dani
Bitte warten ..
Mitglied: soljah
06.08.2013 um 20:12 Uhr
Hallo,

Sry, das hatte ich vergessen zu erwähnen.

Der WHD läuft auf einem Linux Server, das Programm hat einen integrierten Webserver (es ist kein Apache installiert)
ADFS läuft auf einem W2k8r2 und der DC ist ebenfalls ein eigener W2k8r2 Server.

Jetzt wo du das mit dem Zertifikat erwähnst, kling es schon komisch , muss das Morgen nochmal checken. Habe einfach das Cert vom ADFS exportiert und per Webinterface auf den WHD hochgeladen (so steht es ja in der Anleitung )

Alles zusammen ist eine Virtuelle Testumgebung um das ganze mal auszuprobieren, bevor ich/wir auf die Produktivserver gehen.
Alles ist im selben LAN und es gibt auch keinen Proxy

Wie gesagt, theoretisch bzw auch praktisch funktioniert das SSO ja, nur eben nicht wenn ich die WHD Seite aufrufe, wenn ich mich direkt an den ADFS wende und dort dann den Link auf den WHD auswähle funktioniert alles wunderbar.
Bitte warten ..
Mitglied: soljah
07.08.2013 um 14:17 Uhr
So, falls es jemand interessiert, ich bin endlich auf die Lösung gekommen.

Eigentlich ein recht dummer Fehler, aber den muss man dann auch erst mal finden

Also: Das Problem lag nicht am ADFS sondern am WHD -> in den Settings bei WHD steht Server DNS Name - und ich hab das beim Einrichten natürlich nur "überflogen" und den DNS Server Namen eingetragen. Wenn jetzt ADFS versucht hat auf WHD zurückzuleiten, wurde auf den DNS Server weitergeleitet, da in der Metadaten.xml die vom WHD mitgeschickt wurde eine falsche URL : also z.B. https://dns1.firma.loca /..... usw eingetragen war. - Deshalb kam dann der im ersten Post ersichtliche Fehler.

Danke dennoch.


Vl hilfts nochmal jemanden wenn es hier steht
Bitte warten ..
Ähnliche Inhalte
Windows Server
ADFS Design
gelöst Frage von pppp666Windows Server2 Kommentare

Hallo zusammen, ich hoffe jemand von euch kann mir meine Frage beantworten. Unsere ADFS Seite sieht so aus Wir ...

Windows Server
ADFS + FTP in DMZ?
gelöst Frage von mcmaccaWindows Server5 Kommentare

Hallo zusammen, ich stehe aktuell vor dem Problem einige Server neu aufzusetzen, unter anderem einen FTP Server. Gleichzeitig stellen ...

Drucker und Scanner
Multifunktionsgerät mit Duplex ADF
Frage von TerminatorthreeDrucker und Scanner6 Kommentare

Hallo liebe Administrator.de Gemeinde, nachdem ich jetzt lange Zeit nur still mitgelesen habe, muss ich nun eine eigene Frage ...

Microsoft Office

Automatische Aktivierung von Office365 über SSO

Frage von derLenhartMicrosoft Office

Hallo, mir fehlt leider irgendwie das grundsätzliche Verständnis zu SSO und Office 365 bzw. mein Wünsch wäre eine SSO ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...