Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Probleme beim Umzug von XAMPP nach IIS

Mitglied: Maik87

Maik87 (Level 2) - Jetzt verbinden

13.10.2010, aktualisiert 20.10.2010, 3352 Aufrufe, 1 Kommentar

Hallo zusammen,

ich bin grad dabei eine Webside von einem XAMPP-Server auf einen IIS-Server umziehen zu lassen. Scheinbar scheint hier aber die Programmierung nicht ganz zu passen. Das erste Prob war folgende Zeile:

header('Location: http://'.$_SERVER['SERVER_ADDR'].INTERN_URL.(($session!==NULL)?'?session='.$session:''));

Nach ein bischen googlen hab ich SERVER_ADDR gegen SERVER_NAME ausgetauscht, dann lief es.


Was mir noch ein wenig Kummer macht ist folgende Zeile:

$tmp.='<form action=""'.(($this->enctype!==NULL)?' enctype="'.$this->enctype.'"':'').' method="'.$this->method.'">';

Problem ist einfach, dass wenn ich das Formular abschicke, ich den Fehler 405 bekomme. Setze ich bei form action "index.php" in die Anführungsdinger, so läuft es. (Deswegen weiß ich ja auch, wieso es in dieser Zeile knallt). Das Problem ist aber, dass diese Zeile in einer Klasse vorkommt und dadurch das index.php nichti mmer stimmt. Kann es also nicht hart reinsetzen.


Weiß jemand, was ich hier umscripten muss oder welche Einstellung ich am IIS ändern muss, damit die Sache sauber gelöst ist und funktioniert?


Denke für eure Antworten

Edit:
Oder kann es auch an einer Einstellung von PHP liegen? Das habe ich ja auch neu installiert.
Mitglied: Maik87
19.10.2010 um 09:12 Uhr
Für alle, die mal ähnliches Problem haben:

$tmp.='<form action="' .$SERVER['PHP_SELF'] .'?session=' .SESSION .'"'.(($this->enctype!==NULL)?' enctype="'.$this->enctype.'"':'').' method="'.$this->method.'">';

ist die Lösung.
Bitte warten ..
Ähnliche Inhalte
Webbrowser

WPAD.dat - Probleme nach Umzug und Umstellung

Frage von Chaos83Webbrowser2 Kommentare

Moin, in unserem betrieblichem Umfeld nutzen wir eine WPAD.dat um interne, externe und dritt-Netzbereiche sauber durchzuleiten. Nun haben wir ...

Windows Netzwerk

Probleme mit IIS und Virtual Box

Frage von zeroo0Windows Netzwerk7 Kommentare

Sry erst mal wegen dem Titel wusste nicht wie ich das Problem kurz zusammen fassen soll. Folgendes habe ich ...

Informationsdienste

IIS 7.5 Probleme mit Bindung

gelöst Frage von Leo-leInformationsdienste9 Kommentare

Hallo Forum, ich hoste eine Website per IIS 7.5. Die 'Seite wird sauber per A-Record aufgelöst und ich habe ...

Apache Server

PfSense und XAMPP

gelöst Frage von micsonApache Server2 Kommentare

Hallo, zuerst wünsche ich euch allen ein frohes Osterfest! Folgendes Problem: Habe pfSense auf einem ALIX-Board laufen. Dort hängt ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 51 MinutenHumor (lol)

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Olle Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 9 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 22 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit14 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless14 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...