Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Proxykonfiguration für 2 Standorte

Mitglied: Stelli

Stelli (Level 1) - Jetzt verbinden

15.03.2011, aktualisiert 10:33 Uhr, 5030 Aufrufe, 7 Kommentare

Hallo,

ich habe folgendes Problem. Wir besitzen in unserer Firma 2 Standorte. Die beiden Standorte sind miteinander verbunden und die Domaincontroller auf beiden Standorten gleichen sich ab (sind in der gleichen Domain). Dennoch hat jeder Standort seinen eigenen Proxy Server, der an jedem Standort eine unterschiedliche Adresse hat. Ich habe mir jetzt überlegt, das ganze mit einem konfigurationsscript zu lösen. Das Script liegt auf der netlogon Freigabe und ist somit erreichbar.
Wenn ich das Script in Firefox eintrage funktioniert es ohne Probleme und er speichert es mir im Firefox so ab: file://///domain-name.de/netlogon/proxy.pac
Wie muss ich das Script in den Internet Explorer eintragen, damit es auch hier Funktioniert?? Ich habe es schon mit folgenden Schreibweisen probiert: file://///domain-name.de/netlogon/proxy.pac und \\domain-name.de\netlogon\proxy.pac und mit keinem lässt sich mit dem IE surfen.

Hier noch das Script:

function FindProxyForURL(url, host)
{
return "PROXY 192.168.17.254:8080; DIRECT";
}

So das nächste Problem ist, dass ich die Proxy Einstellungen ja für 2 Standorte machen muss. Hierzu habe ich mir jetzt folgendes Script überlegt. Allerdings funktioniert das weder im IE noch im Firefox. Kann mir jemand sagen wo hier mein Fehler liegt??


function FindProxyForURL(url, host)
{
if (isInNet(myIpAddress(), "192.168.17.0", "255.255.255.0"))
return "PROXY 192.168.17.254:8080; DIRECT";

if (isInNet(myIpAddress(), "192.168.18.0", "255.255.255.0"))
return "PROXY 192.168.18.11:8080; DIRECT";;
}

Danke

Gruß Stelli
Mitglied: Mike.ekiM
15.03.2011 um 11:39 Uhr
Hi,

Wenn du Active Directory hast ist das ganz easy. Du bildest enstprechende OU´s nach den Standorten und legst Policies mit den entsprechenden Proxyeinstellungen fest.
Die verlinkst du dann auf die gewünschte OU.

Gruß
Bitte warten ..
Mitglied: Stelli
15.03.2011 um 11:56 Uhr
Das habe ich auch schon probiert... Nur übernimmt er mir die Einstellungen nicht... Wenn ich in der Default Domain Policy aber was eintrage dann übernimmt er das.. Das problem hier ist das das domänenweit gilt und ich es so nicht auf 2 Standorte aufteilen kann... Sobald ich aber eine Gruppenrichtlinie bilde. Übernimmt er mir aus der Default Domain Policy den nicht gesetzten Haken und nicht den aus dem Gruppenrichtlinienobjekt indem der Proxy konfiguriert ist...

Aus diesem Grund habe ich ja erst versucht das ganze über ein Skript zu machen...

Bei den Gruppenrichtlinienobjekt habe ich es einmal mit der Einstellung: Benutzerkonfiguration --> Richtlinien--> Windows-einstellungen-->Internet Explorer Wartung--> Verbindung--> Proxyeinstellungen. Probiert aber ohne Erfolg

Dann habe ich es noch mti der Einstellung unter Benutzerkonfiguration --> Einstellungen --> Systemsteuerungseinstellungen --> Interneteinstellungen mit der Einstellung für Internet explorer 7 probiert (müsste auchb ei IE 9 funktionieren oder?) auch wiederum ohne Erfolg (Die Sache mit den grünen und roten linien ist mir bekannt)

er hat mir einfach nicht die einstellungen übernommen. Ich habe dann im GPResult nachgeschaut welche gruppenrichtlinien verarbeitet werden.. Da stand diese Gruppenrichtlinie für den Proxy drin.. Ich habe die Richtlinie dann noch um ein Netzlaufwerkzuordnung erweitert um zu schauen ob sie durchläuft. Das Netzlaufwerk aus diesem Objekt wurde verbunden.. die Proxyeinstellungen aber nicht angewendet

Hast du vielleicht hierfür einen Lösungsansatz?

Gruß
Stelli
Bitte warten ..
Mitglied: Mike.ekiM
15.03.2011 um 13:08 Uhr
Vielleicht hilft dir das hier weiter: http://support.microsoft.com/kb/316702/en-us
Bitte warten ..
Mitglied: Stelli
16.03.2011 um 10:18 Uhr
Die beschriebenen Einstellungen gibt es bei mir nicht in der Gruppenrichtlinienverwaltung....

Des Weiteren tritt das Problem ja nicht nur bei einem PC auf.. die Proxy Einstellungen werden überall nicht übernommen. Habe auch eine frisch installiert Windows 7 Workstation hier an der noch keine Einstellungen vorgenommen wurden. Auch hier werde keine Proxy Einstellungen eingetragen...
Bitte warten ..
Mitglied: Mike.ekiM
16.03.2011 um 12:13 Uhr
Hi,

Hast du schonmal die Rangfolge der Gruppenrichtlinien überprüft. Hast du irgendeine Richtlinie mit höheren Rang welche die Einstellungen des IE wieder auf 0 setzt?
Bitte warten ..
Mitglied: Stelli
16.03.2011 um 12:17 Uhr
naja wie gesagt, in der Default domain Policy steht kein Proxy drin... und diese "kein Proxy" Einstellung bekomme ich auch immer wieder zugewiesen (auch wenn ich am pc vorher was eingestellt habe bekomme ich das wieder gelöscht und es steht kein Proxy mehr drin)... Wie kann ich denn eine Gruppenrichtlinie einen höheren Rang als der Default Domain Policy geben???
Bitte warten ..
Mitglied: FourHead
02.12.2011 um 15:31 Uhr
Hi,
ich weiß, dass dieser Beitrag schon ein paar Tage alt ist, aber ich bin gerade dabei quasi das Gleiche zu machen. Ich hab zwei PAC Files, IE8 und FF6. Am sinnvollsten für alle ist es, die PAC Files ins NETLOGON Verzeichnis zu legen, denke ich, da ich keinen Webserver zur Verfügung habe.

Der Aufruf mit IE klappt mit file://\\domänenname\netlogon\pacfile.pac problemlos, allerdings klappt bei mir der Aufruf für FF mit file://////domänenname/netlogon/pacfile.pac nicht. Hat sich da bei FF inzwischen was geändert und ich muss die URL anders schreiben?

Vielen Dank und viele Grüße
Manuel
Bitte warten ..
Ähnliche Inhalte
Windows Server

Aus einem Standort 2 Standorte machen (Exchange, DC)

Frage von HakketasWindows Server1 Kommentar

Hallo! Aktuell haben wir alle Server quasi als Cluster in einem Serverraum. Wir möchten den Serverraum trennen und die ...

Netzwerke

Kleines Unternehmensnetzwerk mit 2 Standorten

Frage von FreshmaticsNetzwerke5 Kommentare

Moin erstmal! Zu mir: Bin recht neu in dem Bereich, habe IT-Systemelektroniker gelernt und noch keine nennenswerte Erfahrung im ...

Router & Routing

Routing über VPN zu 2 Standorten

Frage von OF2697Router & Routing8 Kommentare

Hallo zusammen, ich habe eine Frage bezgl. Routing. Ich habe zwei Standorte per VPN über die beiden Router miteinander ...

Exchange Server

Exchange 2013 fragt nach Proxykonfiguration

gelöst Frage von ukulele-7Exchange Server2 Kommentare

Sry für die vielen Posts, mein Exchange macht mich langsam irre. Ich habe einen Exchange 2013 auf Windows 2012 ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 3 StundenWindows 102 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 6 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 23 StundenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...