Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Quaqqa - Routenverteilung über ripd an einen Cisco 876

Mitglied: psyrax

psyrax (Level 1) - Jetzt verbinden

14.11.2011, aktualisiert 13:32 Uhr, 3626 Aufrufe, 12 Kommentare, 1 Danke

Hallo,

die Routingverteilung vom Zentralen Router an einem Cisco 876 funktioniert leider nicht. Die Verteilung auf andere Cisco Geräte zB.: 1812, Pix501 funktioniert. Alle Geräte sind im selben Netzwerkbereich.

Ich hab die Suche benutzt und nach ripd, ripd.conf, quaqqa, zebra, zebra ripd.conf, routingverteilung unix gesucht aber leider nichts gefunden.

Die ripd.conf sieht wie folgt aus

01.
hostname router2 
02.
password xxxxxx 
03.
04.
debug rip events 
05.
debug rip packet 
06.
07.
router rip 
08.
redistribute static 
09.
redistribute connected 
10.
version 2 
11.
12.
13.
!route 10.49.0.2/32 
14.
!hesterm 
15.
route 192.168.1.80/32 
16.
route 10.55.44.0/24 
17.
18.
network eth1 
19.
!network eth1.2 
20.
!network eth1.3 
21.
!network eth1.4 
22.
!network eth1.5 
23.
!network eth1.6 
24.
!network eth1.7 
25.
!network eth1.8 
26.
!network eth1.9 
27.
!network eth1.10 
28.
!network eth1.11 
29.
network eth1.20 
30.
network eth1.99 
31.
network eth1.98 
32.
33.
neighbor 10.44.33.1 
34.
neighbor 10.20.39.3 
35.
neighbor 10.20.39.6 
36.
neighbor 10.20.39.5 
37.
neighbor 10.20.39.4 
38.
neighbor 10.20.39.3 
39.
neighbor 192.56.14.22 
40.
neighbor 10.20.49.1 
41.
neighbor 192.56.14.73 
42.
neighbor 10.40.0.2 
43.
neighbor 10.49.0.1 
44.
neighbor 10.50.0.1 
45.
neighbor 10.49.0.1 
46.
!neighbor 10.20.32.2 
47.
neighbor 10.34.3.2 
48.
49.
!interface eth1.8 
50.
!no ip rip authentication mode 
51.
interface eth1 
52.
no ip rip authentication mode 
53.
interface gre1 
54.
no ip rip authentication mode 
55.
!interface gre2 
56.
!no ip rip authentication mode 
57.
interface gre5 
58.
no ip rip authentication mode 
59.
!interface eth1.98 
60.
!no ip rip authentication mode 
61.
interface eth1.99 
62.
!ip rip authentication mode xxx 
63.
!ip rip authentication key-chain xxxx 
64.
no ip rip authentication mode 
65.
66.
line vty 
67.
68.
!log file /var/log/quagga/ripd.log

router der ripd.conf verteilen soll 10.20.39.2, cisco 876 der die ripd.conf nicht bekommt 10.20.39.4

eth1.99 10.20.39.0/24


routen werden in zebra.conf eingetragen mittels

ip route ........

quaqqa anschließend neu gestartet


im ripd.log sehe ich auch das er ip-adressen an 10.20.39.4 verteilt.. aber nicht die welche ich brauche..

wir übersiedeln gerade ein paar interfaces auf ein anderes endgerät.. deswegen sind die ganzen interfaces auskommentiert.



im internet habe ich die info gefunden, das wenn möglich man nichts an der ripd.conf verändern soll da sonst der dienst sich gar nicht mehr startet.. über ps -ef | grep rip sehe ich aber das folgendes läuft

quagga 1102 1 0 12:42 ? 00:00:00 /usr/lib/quagga/ripd --daemon -A 127.0.0.1


habe ich eventuell etwas in der config falsch gemacht? das er die verteilung nicht mehr macht?

oder hat vielleicht jemand ein paar tips woran das noch liegen könnte?

Danke im Voraus
Mitglied: aqui
14.11.2011 um 13:10 Uhr
OK, und wie sieht die andere (Cisco) Seite aus ? Wenn du einmal die RIP Config des 876 hier posten könntest wäre das sehr hilfreich ?
Vorweg:
  • Was sagt ein show neigbors
  • Hast du mal RIP Debugging aktiviert auf dem 876 ??
Gerade letzteres zeigt dir sofort wo der Hase im Pfeffer liegt !! Irgendeinen Grund muss er ja haben um die gesendeten Routen nicht in seine Routing Tabelle zu übernehmen ?!
Bitte warten ..
Mitglied: brammer
14.11.2011 um 13:28 Uhr
Hallo,

hast du hier Zeilen auskommentiert?
Bitte die Code Formatierung verwenden, das macht es einfacher den Code zu lesen. <code> <./.code> (Punkte weglassen)

!neighbor 10.20.32.2

!
!interface eth1.8
!no ip rip authentication mode


!interface gre2
!no ip rip authentication mode
interface gre5
no ip rip authentication mode
!interface eth1.98
!no ip rip authentication mode
interface eth1.99
!ip rip authentication mode xxx
!ip rip authentication key-chain xxxx
no ip rip authentication mode


Dir ist klar das du hier public und private IP's mischt...

neighbor 192.56.14.22

neighbor 192.56.14.73


Ansonsten folge ich den Thread rein aus Interesse..

brammer
Bitte warten ..
Mitglied: psyrax
14.11.2011 um 13:31 Uhr
rip config 876

01.
router rip 
02.
 passive-interface Vlan1 
03.
 network 10.0.0.0 
04.
 no auto-summary

ich hoffe das ist alles, bin im cisco und unix bereich nicht wirklich ein spezialist

show neighbors auf dem cisco 876 sagt mir leider gar nichts... bin im # modus nur leider kennt er kein show neighbors,

rip ip debug hab ich jetzt einmal aktiviert. lass das ein paar minuten laufen, dann deaktiviere ich es wieder. danach werte ich einmal alles aus und sehe ob ich einen fehler finde bzw. einen neuen anhaltspunkt..


aber danke schonmal
Bitte warten ..
Mitglied: psyrax
14.11.2011 um 13:34 Uhr
hallo brammer,

hab das mit dem code /code eingetragen, liest sich jetzt eindeutig leichter ;)

ja ist mir klar.
Bitte warten ..
Mitglied: brammer
14.11.2011 um 14:23 Uhr
Hallo,

das "passive -interface" commando" sorgt dafür das der Router über dieses Interface keine Rotuing Updates verschickt.

mit folgendem Befehel bekommst du das ausgeschaltet

01.
conf t 
02.
router rip 
03.
no passsive-interface vlan1  
04.
end  
05.
wr me 


brammer
Bitte warten ..
Mitglied: aqui
14.11.2011 um 15:26 Uhr
Du hast in der Cisco Konfig:
router rip
version 2

vergessen !
Dein Quagga macht RIPv2 und dein Cisco so nur RIPv1 !!
Kein Wunder das die sich also nicht sehen...!
Das es problemlos rennt kannst du hier an einem Cisco 831 sehen der mit Quagga spricht ! (Debug RIP aktiviert mit "debug rip packet" (Quagga) bzw. "debug ip rip" (Cisco) !)
Cisco 831:
Nov 14 14:23:36.163: RIP: received v2 update from 192.168.7.3 on Ethernet0
Nov 14 14:23:36.163: 192.168.2.0/24 via 0.0.0.0 in 1 hops
Nov 14 14:23:39.839: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.1.1)
Nov 14 14:23:39.839: RIP: build update entries
Nov 14 14:23:39.839: 192.168.2.0/24 via 0.0.0.0, metric 2, tag 0
--->> Netzwerk per RIP vom Quagga !
Nov 14 14:23:39.839: 192.168.7.0/24 via 0.0.0.0, metric 1, tag 0

Cisco Konfig:
!
router rip
version 2
network 10.0.0.0
network 192.168.10.0
no auto-summary
!

Quagga:
RIP: SEND RESPONSE version 2 packet size 24
RIP: 192.168.2.0/24 -> 0.0.0.0 family 2 tag 0 metric 1
RIP: rip_send_packet 192.168.2.1 > 224.0.0.9 (eth1)
RIP: SEND RESPONSE version 2 packet size 24
RIP: 192.168.7.0/24 -> 0.0.0.0 family 2 tag 0 metric 1
RIP: ignore packet comes from myself
RIP: ignore packet comes from myself
RIP: RECV RESPONSE version 2 packet size 24
---> Das ist der Cisco mit der 10.1.1.1 auf dem Loopback Interface !!
RIP: 10.1.1.1/32 -> 0.0.0.0 family 2 tag 0 metric 1

Quagga Konfig:
!
Current configuration:
!
hostname midge_rip
password admin
!
router rip
version 2
network 192.168.2.0/24
network 192.168.10.0/24
!
line vty
!
end

Änder also deine Konfig auf RIP Version 2 im Cisco und dann rennt das auch !!
Bitte warten ..
Mitglied: psyrax
14.11.2011 um 15:53 Uhr
Danke..

funktioniert.. einwandfrei

gut zu wissen das die nur in der version 2 kommunizieren
Bitte warten ..
Mitglied: brammer
14.11.2011 um 16:08 Uhr
Hallo,

das liegt daran das RIP Version 1 nur Classfull kann und daher das gesamte Netz 10.x.x.x /8 als ein Netz betrachtet.
Wieso sollte RIP also die Routen verteilen... ist doch alles mit dem 10er Netz erschlagen.

Aber...

@aqui
Hätte nicht zumindest die 192er Route verteilt werden müssen?

brammer
Bitte warten ..
Mitglied: aqui
14.11.2011 um 16:24 Uhr
Nein, RIPv1 und v2 sind nicht kompatibel bzw. Cisco dropped sie bei einem Protokoll Mismatch.
In sofern ist die Aussage von psyrax "gut zu wissen das DIE nur in der Version 2 kommunizieren" natürlich totaler Blödsinn, denn ein Umschalten von Version 1 und 2 supporten sowohl Quagga als auch Cisco ! Und... wer soll auch "DIE" denn sein ?? Außerirdische... ??
Ein Blick in die bestehende Cisco Konfig der Router bei denen es klappt hätte das Rätsel auch ohne den hier (eigentlich überflüssigen) Thread gelöst !
Aber egal...so lernen dann wenigstens alle was
Bitte warten ..
Mitglied: psyrax
15.11.2011 um 09:24 Uhr
glaubst du etwa das ich das nicht gemacht hab?

die config ist gleich wie auf dem anderen gerät.


und ja ich meinte außerirdische


überflüssig für dich vielleicht die sich in diesem bereich sehr gut auskennen, aber mir hat es geholfen
Bitte warten ..
Mitglied: brammer
15.11.2011 um 12:31 Uhr
Hallo,

nun beim Vergleich der configs ist aber wohl was schief gegangen.

am einfachsten ist sowas mit Notepad++ mit der Option "compare".
Da wird farblich unterlegt worin sich zwei Textfiles unterscheiden.

Was im einen mehr ist, dürft eim anderen fehlen...

brammer
Bitte warten ..
Mitglied: aqui
15.11.2011 um 17:44 Uhr
Ja, das sagen immer alle das der Fehler immer was esotherisches ist
Wenns nun klappt ist ja alles gut !

P.S.: Deine Shift Taste ist defekt...solltest du auch mal reparieren !
Bitte warten ..
Ähnliche Inhalte
Firewall
Cisco cisco small business rv215w
Frage von bunticFirewall1 Kommentar

Hallo, ich habe mir vor kurzem ein cisco small business rv215w zugelegt, jetzt zur meine Frage: ich hab 3 ...

Switche und Hubs

Cisco Meraki oder klassische Cisco Switche?

Frage von TiTuxSwitche und Hubs12 Kommentare

Guten Morgen, wir werden unsere Switch-Infrastruktur zeitnah austauschen und stehen jetzt vor der Entscheidung, ob wir Cisco Meraki oder ...

LAN, WAN, Wireless

Gibts da auch was von Cisco?

Frage von VancouveronaLAN, WAN, Wireless5 Kommentare

Hallo zusammen, ich brauche für einen unsrer Standorte mehrere Access Points (ca. 6-8), um dort ein leistungsfähiges W-LAN aufzubauen ...

Router & Routing

Cisco 886VA

gelöst Frage von bintesRouter & Routing2 Kommentare

Hallo Community, ich habe ehrlichgesagt noch nie mit einem Cisco C880 series Router zutun gehabt. Jetzt bin ich gezwungen ...

Neue Wissensbeiträge
Datenschutz

Die Datenkrake Google verlängert ihr Arme mal wieder ein wenig, automatische Anmeldung

Tipp von magicteddy vor 3 StundenDatenschutz

Benutzer mit einem Google Account und gespeicherten Zugangsdaten werden von chrome 69 automatisch bei Google angemeldet, natürlich alles zum ...

Verschlüsselung & Zertifikate
Meine Wissenssammlung zu Bitlocker
Erfahrungsbericht von DerWoWusste vor 1 TagVerschlüsselung & Zertifikate3 Kommentare

Die Motivation für diesen Beitrag waren die vielen Posts rund um dieses Thema, die deutlich machen, wie viele Einzelaspekte ...

E-Mail
Email-Apps und Verhalten bei Pop3
Erfahrungsbericht von kfranzk vor 3 TagenE-Mail11 Kommentare

Hallo Freunde, da mir mein diesbezüglicher Faden als gelöst markiert wurde, muss ich hier neu aufsetzen. Ich arbeite bewusst ...

Hyper-V

Optimiertes Ubuntu per Microsoft Hyper-V-Schnellerstellung verfügbar

Anleitung von Frank vor 3 TagenHyper-V1 Kommentar

Für Microsofts Virtualisierungssoftware Hyper-V ist ab sofort auch ein optimiertes Ubuntu 18.04.1 LTS verfügbar. In der "Hyper-V-Schnellerstellung" App, die ...

Heiß diskutierte Inhalte
Hardware
Sophos SG135 - Routing
gelöst Frage von Xaero1982Hardware22 Kommentare

Moin Zusammen, ich ersetze gerade nen alten Cisco DualWAN Router durch eine SG 135. Ich muss bestimmte Ziele über ...

Datenschutz
Gilt ein Ransomware-Befall als Datenpanne nach DSGVO?
Frage von MOS6581Datenschutz22 Kommentare

Moin Kollegen, wenn sich jemand Ransomware einfängt und dadurch bspw. Kundendaten verschlüsselt werden; gilt dies dann als meldepflichtige Datenpanne ...

Windows 7
Mit gpedit gesetzte Richtlinien in rsop.msc nicht definiert und ausgegraut
gelöst Frage von 137006Windows 715 Kommentare

Hallo zusammen, anfangs verweise ich fairerweise daruf dass ich dieses Thema bereits im Forum angeschnitten habe, nachdem ich hier ...

Netzwerke
Hilfe bei der Planung meines Heimnetzwerks
Frage von DHD082Netzwerke15 Kommentare

Hallo zusammen, wir bauen gerade ein Einfamilienhaus, welches ich mit einem Heimnetzwerk ausstatten möchte. Da ich zwar auch in ...