Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Rückgabe String aus Subroutine geht nicht !

Mitglied: Randolph

Randolph (Level 1) - Jetzt verbinden

22.09.2013 um 15:16 Uhr, 1546 Aufrufe, 8 Kommentare

Hallo allerseits,

ich kämpfe damit einen String aus einer Subroutine an die aufrufende Routine zurückzugeben.
Kann mir jemand sagen was ich falsch mache ?

String aus der Subroutine soll über call-paramter %3 zurückgegeben werden.

01.
@ECHO off  
02.
SETLOCAL 
03.
 
04.
SET "searchstring1='CONTACT_FORMAT_GREETING_COMMON'," 
05.
SET "searchstring2=CONTACT_FORMAT_GREETING_MR'," 
06.
SET "linestart=START" 
07.
 
08.
FOR /f "delims=" %%i IN (inputfile.txt) DO ( 
09.
	SET "textline=%%i" 
10.
	SETLOCAL enabledelayedexpansion 
11.
	if "!textline!" neq "!textline:%searchstring1%=!" ( 
12.
		CALL :findString "!textline!" %searchstring1% %linestart% 
13.
		echo !linestart! 
14.
		REM Write the modified line 
15.
		) ELSE ( 
16.
		REM Write the unmodified line 
17.
18.
	if "!textline!" neq "!textline:%searchstring2%=!" ( 
19.
		CALL :findString "!textline!" %searchstring2% %linestart% 
20.
		echo !linestart!	 
21.
		REM Write the modified line 
22.
		) ELSE ( 
23.
		REM Write the unmodified line 
24.
25.
	ENDLOCAL 
26.
27.
GOTO :ENDE 
28.
 
29.
:findString -- returns position of first occurrence of a string in another string 
30.
 
31.
SETLOCAL ENABLEDELAYEDEXPANSION 
32.
set "mainstring=%1" 
33.
set "substring=%2" 
34.
 
35.
Set "rest=!mainstring:*%substring%=!" 
36.
echo Rest: %rest% 
37.
 
38.
Set "anfang=!mainstring:%rest%=!" 
39.
echo Anfang: %anfang% 
40.
 
41.
ENDLOCAL &set "%3=!anfang!" 
42.
GOTO :EOF 
43.
 
44.
:ENDE 
45.
ECHO Done^^!
Bin für jeden Hinweis dankbar.

Grüsse
Randolph

Mitglied: rubberman
22.09.2013, aktualisiert um 15:37 Uhr
Hallo Randolph,

so wie ich es lese, ist lediglich eine Referenz (der Variablenname) zu übergeben. Teste mit
echo !%linestart%!
da %linestart% zu START aufgelöst wird und es nach dem Aufruf eine Variable !START! geben sollte.

Grüße
rubberman
Bitte warten ..
Mitglied: Randolph
22.09.2013 um 15:39 Uhr
Sorry, das war eine alte Version des Codes, hier kommt die richitge:

01.
@ECHO off  
02.
SETLOCAL 
03.
 
04.
SET "searchstring1='CONTACT_FORMAT_GREETING_COMMON'," 
05.
SET "searchstring2=CONTACT_FORMAT_GREETING_MR'," 
06.
SET "linestart=START" 
07.
 
08.
FOR /f "delims=" %%i IN (inputfile.txt) DO ( 
09.
	SET "textline=%%i" 
10.
	SETLOCAL enabledelayedexpansion 
11.
	IF "!textline!" neq "!textline:%searchstring1%=!" ( 
12.
		CALL :findString "!textline!" %searchstring1% %linestart% 
13.
		echo !linestart! 
14.
		REM Write line replacement1 
15.
		) ELSE ( 
16.
				IF "!textline!" neq "!textline:%searchstring2%=!" ( 
17.
					CALL :findString "!textline!" %searchstring2% %linestart% 
18.
					echo !linestart!	 
19.
					REM Write line replacement2 
20.
				) ELSE ( 
21.
						REM Write original line 
22.
						)) 
23.
ENDLOCAL 
24.
25.
GOTO :ENDE 
26.
 
27.
:findString -- returns left part of the string until search substring end 
28.
 
29.
SETLOCAL ENABLEDELAYEDEXPANSION 
30.
set "mainstring=%1" 
31.
set "substring=%2" 
32.
 
33.
Set "rest=!mainstring:*%substring%=!" 
34.
echo Rest: %rest% 
35.
 
36.
Set "anfang=!mainstring:%rest%=!" 
37.
echo Anfang: %anfang% 
38.
 
39.
ENDLOCAL &set "%3=!anfang!" 
40.
GOTO :EOF 
41.
 
42.
:ENDE 
43.
ECHO Done^^!
Warum klappt die Rückgabe des %3 parameters nicht ?
echo !linestart! führt immer zur Ausgabe von "START"

Randolph
Bitte warten ..
Mitglied: bastla
22.09.2013 um 15:44 Uhr
Hallo Randolph!
Bin für jeden Hinweis dankbar.
Bitte sehr: Vermeide das Unterprogramm.

Grüße
bastla
Bitte warten ..
Mitglied: rubberman
22.09.2013 um 15:54 Uhr
Hallo Randolph,

wie oben beschrieben
echo !%linestart%!
statt
echo !linestart!
Ansonsten weiß ich nicht was das Ding eigentlich macht ...

Grüße
rubberman
Bitte warten ..
Mitglied: bastla
22.09.2013 um 15:58 Uhr
@ rubberman
Ansonsten weiß ich nicht was das Ding eigentlich macht ...
Das soll die Position eines Substrings finden, damit danach ab dieser Position der Zeileninhalt ersetzt werden kann (siehe dazu auch den Ausgangsthread) ...

Grüße
bastla
Bitte warten ..
Mitglied: Randolph
22.09.2013 um 23:34 Uhr
@rubberman:

Dein Vorschlag hat leider nichts geändert. Ich bin jetzt tatsächlich dem Vorschlag von bastla gefolgt und mach das ganze ohne Subroutine/Call.
Warum's nicht geht hätte ich dennoch gern gewusst.

Ich habe jetzt eine für mich funktionierende Lösung, siehe Ausgangsthread:
1

Beitrag könnte man demnach schliessen.
Wer macht das? Ich? Wie?

Vielen dank und viele Grüsse
Randolph
Bitte warten ..
Mitglied: Endoro
22.09.2013 um 23:51 Uhr
Zitat von Randolph:
Warum's nicht geht hätte ich dennoch gern gewusst.
01.
ENDLOCAL &set "%3=!anfang!" 
Der cmd Interpreter wertet von links nach rechts aus.
Mit dem Kommando ENDLOCAL wird der Geltungsbereich von EnableDelayedExpansion beendet.
Das heisst, wenn der Interpreter !anfang! erreicht, gelten die erweiterten Syntaxregeln mit dem Ausrufezeichen gar nicht mehr.
Aus !anfang! ist dann wieder eine 'ordinäre' Zeichenkette geworden.
lg.
Bitte warten ..
Mitglied: 106543
23.09.2013 um 08:55 Uhr
Zitat von Randolph:
Beitrag könnte man demnach schliessen.
Wer macht das? Ich? Wie?
Siehe https://www.administrator.de/faq/32

Grüße
Exze
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Rückgabe aus Terminal in mail schreiben

gelöst Frage von newit1Batch & Shell2 Kommentare

Servus, ist es möglich, dass ich die Rückgabe des Terminals in Unix (z.B. Fehlermeldung) in eine Mail schreiben kann ...

C und C++

C-Sharp - Backgroundworker - Rückgabe - Verständnis

gelöst Frage von TheVo1dC und C++3 Kommentare

Hallo zusammen Ich arbeite an einer grösseren Applikation welche an einer bestimmten Stelle, eine zweite Form öffnet in der ...

VB for Applications

VBA: Verständnisfrage bei Funktionen, Rückgabe von Werten

gelöst Frage von AximandVB for Applications3 Kommentare

Hallo, ich bekomm gerade etwas nicht in meinen Schädel. Ich habe eine Funktion erstellt, die eine SQL-Abfrage zusammenstellt: Diese ...

Java

Von Delphi String zu Java String

Frage von GreenDinoJava1 Kommentar

Hallo zusammen! Ich bin dabei Delphicode in Javacode zu übertragen. Frage: ist '<text>' in Delphi equivalent zu "<text>" in ...

Neue Wissensbeiträge
Suche Projektpartner
Chung cu vincity tay mo dai mo
Anleitung von vincityhn vor 1 StundeSuche Projektpartner1 Kommentar

Xem thêm: <a href=" <img src="

Sicherheit
Adminrechte dank Bug in Intel HD Graphics Treiber
Information von DerWoWusste vor 19 StundenSicherheit

Intel HD graphics 4200 und neuer (4400, 4600 520,530,620, 630,) sind auf jeden Fall betroffen und bereinigte Treiber sind ...

Router & Routing

Endlich: Reines Kabel-TV Modem in D erhältlich !

Information von aqui vor 3 TagenRouter & Routing11 Kommentare

Mit dem Technicolor TC4400-EU Modem sind nun auch Breitband Router ohne integriertes Modem oder Firewalls wie z.B. die pfSense ...

Netzwerkgrundlagen
The Illustrated TLS Connection
Information von Lochkartenstanzer vor 4 TagenNetzwerkgrundlagen1 Kommentar

Moin, Unter findet man eine gelungene Erläuterung von TLS. Fördert sehr das verständnis darüber, was da passiert. lks

Heiß diskutierte Inhalte
Windows Server
AD User wird immer wieder gesperrt
Frage von YellowcakeWindows Server20 Kommentare

Hey ich habe einen User (ein GL User - Natürlich was denn sonst) der immer wieder gesperrt wird. Ich ...

Windows Netzwerk
Gruppenrichtlinie für einen PC deaktivieren
gelöst Frage von Florian961988Windows Netzwerk14 Kommentare

Hallo, kleines Problem und immoment finde ich dazu keine Lösung oder mir fällt nicht ein, wie ich es suche ...

Debian
Linux debian 9 Installation
Frage von Green14Debian13 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...

Switche und Hubs
OpenSource oder Freeware zur Verwaltung von Switchen
gelöst Frage von JonskezSwitche und Hubs12 Kommentare

Hallo, gibt eine kostenlose Verwaltungssoftware für Switche (überwiegend HP/Aruba)? Es sollte möglich sein, aus der Ferne z.B. die Firmware ...