Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Raid5 Problem

Mitglied: BlinderWaechter

BlinderWaechter (Level 1) - Jetzt verbinden

29.01.2009, aktualisiert 10:24 Uhr, 5057 Aufrufe, 3 Kommentare

Hallo zusammen,

ein Bekannter hat an seinem Rechner einen Software-Raid (5) mit drei 120 GB Raptoren. (Intel P965 + ICH8DH-Chipsatz). Er bekam die Meldung dass eine der Platten defekt sei, hat die Meldung resetet (so schrieb er es mir), was der Rechner mit einem Bluescreen quittierte und anschließend nicht mehr bootete.

Wenn er ins Raid-Menü beim Start geht, erscheint die Meldung: "volumes rebuild status will be rebuilt within the operating system".

Der Rechner hat eine neue Platte spendiert bekommen, das Problem bleibt aber das selbe.

Man kommt in den Intel Matrix Storage Manager rein und hat exakt vier Möglichkeiten.
1. Create RAID Volume
2. Delete RAID Volume
3. Reset Disks to Non-RAID
4. Exit

Alles nichts, wo ich jetzt gerne drauf klicken würde (von Exit mal abgesehen).

Im Info-Fenster wird das RAID-Volume aufgeführt
Status: Rebuild
Bootable Yes

Bei den aufgeführten Physical Disks sind die 3 Platten vorhanden, bei allen steht Member Disk (0)

Ganz unten drunter steht, dass die Volumes im OS wiederhergestellt werden.
Auf der Intel-Seite habe ich die folgende Anleitung gefunden:
1. Vergewissern Sie sich, dass das System ausgeschaltet ist.
2. Ersetzen Sie das ausgefallene Festplattenlaufwerk mit einem neuen Laufwerk, das die gleiche oder eine höhere Kapazität hat.
3. Schalten Sie das System ein.
4. Wenn das Betriebssystem ausgeführt wird, wählen Sie im Startmenü Intel® Matrix Storage Console aus, oder klicken Sie auf das Symbol für den Intel® Matrix Storage Manager auf der Taskleiste.
5. Klicken Sie auf das Menü View (Ansicht), und wählen Sie die Option Advanced Mode (Erweiterter Modus) aus.
6. Klicken Sie mit der rechten Maustaste auf das Nicht-RAID-Festplattenlaufwerk in der Geräteliste, und wählen Sie Rebuild to this Hard Drive (Zu diesem Festplattenlaufwerk neu organisieren) aus.
So weit gehts aber gar nicht. Punkt 4 wird nicht erfüllt. Wenn man im Bootmenü das RAID-LW auswählt, wird der Bildschirm einfach schwarz und das bleibt er auch. (Zumindest wenn mans 48 Stunden stehen lässt, wenn ich den Besitzer richtig verstanden habe).
Man kommt also gar nicht ins Betriebssystem rein (XP32 SP3). Ich hab mal jede Platte abgezupft und einzeln getestet aber das Problem bleibt das gleiche. Er bootet einfach nicht. Bildschirm wird schwarz nachdem man die RAID-Console verlassen hat, man hört die Platten kurz anlaufen, dann ist Ende.

Hat jemand einen Vorschlag was man noch machen könnte?
Die erste Frage wäre: Bekomme ich das System so wieder ans laufen?
Die Zweite Frage: Kommt man an die Daten ran, wenn man eine einzelne Platte einfach in einen anderen Rechner anschließt? Lassen sich die Daten normal auslesen?
Wird dadurch irgendwas an Raid-Infos auf der Platte gelöscht, was dazu führen könnte, dass die Platte im Raid nicht mehr korrekt erkannt wird?

Ich, bzw. mein Freund wäre für jeden Tipp dankbar.
Mitglied: VW
29.01.2009 um 22:26 Uhr
Zitat von BlinderWaechter:
Ich hab mal jede Platte abgezupft und einzeln getestet aber das Problem bleibt das gleiche.
Moment, was hast du mit jeweils 1 HDD weniger getestet? Wenn in einem RAID5 eine HDD fehlt, hast du zwar keine Redundanz mehr, das System sollte aber noch laufen. Da ich den Intel Matrix Storage Manager nicht kenne, weiß ich leider nicht, welche Meldung er resettet hat.
Wenn du nun noch eine HDD abziehst und versuchst, zu starten, wirst du vermutlich endgültig einen inkonsistenten Datenstand haben, da 1 HDD mehr außer Betrieb ist, als Redundanz gewährleistet ist.

Hat jemand einen Vorschlag was man noch machen könnte?
Da es vermutlich wie bei so vielen Leuten kein Backup gibt, würde ich eine Neuinstallation empfehlen.
Die erste Frage wäre: Bekomme ich das System so wieder ans
laufen?
Wenn du tatsächlich mit noch einer HDD weniger versucht hast, zu booten, wohl eher nicht. Ansonsten würde ich versuchen, ob eine BartPE-CD mit den entsprechenden RAID-Treibern noch auf die Daten zugreifen kann, um diese vor einer Neuinstallation und neu erstellen des RAID5 zu sichern.
Die Zweite Frage: Kommt man an die Daten ran, wenn man eine einzelne Platte einfach in einen anderen Rechner anschließt? Lassen sich die Daten normal auslesen?
Bei Dateien, die kleiner als die Datenblock-Verteilung (meist ca. 32-512KB) sind, kannst du Glück haben, ansonsten wirst du da nicht rankommen, da die Dateien ja auf 2 HDDs aufgeteilt sind, während die dritte die Redundanz-Infos speichert.
Wird dadurch irgendwas an Raid-Infos auf der Platte gelöscht, was dazu führen könnte, dass die Platte im Raid nicht mehr korrekt erkannt wird?
Bei dem Versuch, die HDD an einem anderen Controller auszulesen läufst du immer gefahr, dass dieser Controller bzw. das OS einen "Erkennungs-Sektor" überschreiben, da dieser andere Controller bzw. das OS damit nichts anfangen können. Auch kann es sehr gut sein, dass die HDD von einem anderen Controller nicht (korrekt) erkannt wird, da die Informationen ja immernoch auff RAID hindeuten.
Ich, bzw. mein Freund wäre für jeden Tipp dankbar.

MfG,
VW
Bitte warten ..
Mitglied: BlinderWaechter
31.01.2009 um 16:21 Uhr
Hallo VW,

vielen Dank für die Antwort. Das war der entscheidende Hinweis. Ich hab einfach ne IDE-Platte genommen, Windows und anschließen die Storage Console installiert. Der RAID-Verband wurde danach sofort erkannt und wiederhergestellt.
Bitte warten ..
Mitglied: VW
01.02.2009 um 13:16 Uhr
Moin,

wenn es das dann war, markiere den Beitrag bitte auch noch als gelöst.
Danke.

VW
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
Raid5 im Vergleich zu Raid10
Frage von hellasFestplatten, SSD, Raid9 Kommentare

Hallo, ich denke mal die Frage wurde schon häufiger gestellt aber ich versuche es trotzdem nochmal :-) Möchte ein ...

Linux Desktop
Software Raid5 wiederherstellen
Frage von ClustermanLinux Desktop12 Kommentare

Hallo, bis jetzt habe ich immer nur Fragen und Antworten gelesen, das hilft echt weiter Danke! Allerdings ist mein ...

SAN, NAS, DAS
Während RAID5 Aufbau Stromausfall
gelöst Frage von istike2SAN, NAS, DAS

Hallo, ich habe hier einen Thecus 7700 Pro, wo ich einen RAID5 Verbund mit einer 7. Platte erweitert habe. ...

Festplatten, SSD, Raid

SQL Entwicklungsserver mit RAID1 oder RAID5

Frage von AndreasOCFestplatten, SSD, Raid7 Kommentare

Hallo, wir haben einen neuen Server und ein neues SAN. Im SAN sind 6x 1,2TB Platten. Es sollen zwei ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Tipp von hardykopff vor 1 StundeWindows 10

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 4 StundenAdministrator.de Feedback8 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 21 StundenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...