Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Redhat HTTPD Nur Unterverzeichnis erreichbar

Mitglied: pixelflat

pixelflat (Level 1) - Jetzt verbinden

26.02.2009, aktualisiert 14:52 Uhr, 3200 Aufrufe, 3 Kommentare

Habe hier einen Redhat Server mit Apache.

Leider kann ich über die IP des Server den Webserver nicht erreichen. Allerdings komme ich auf beliebige(!) Unterverzeichnisse (http://123.123.123.123/Unterverzeichnis).
Die httpd.conf sieht so aus.

Leider kann ich keine Probleme damit erkennen. Kann es auch noch an einer anderen Konfigurations-Datei liegen?

Edit: Wichtiger Hinweis: Über localhost komme ich auf die Startseite. Extern jedoch nicht!

Danke
Mitglied: Cubic83
26.02.2009 um 22:04 Uhr
Hallo,

warum postest du die Datei nicht hier? In einem Jahr werden deine Links ins Nirwana führen.

Aufgefallen sind mir in deiner config:

01.
 
02.
#ServerName www.example.com:80 
03.
 
04.
besser:  
05.
 
06.
ServerName www.example.com 
07.
 
08.
============================ 
09.
 
10.
#NameVirtualHost *:80 
11.
 
12.
besser: 
13.
 
14.
NameVirtualHost *:80 
15.
 
16.
============================ 
17.
 
18.
 
19.
#<VirtualHost *:80> 
20.
#    ServerAdmin webmaster@dummy-host.example.com 
21.
#    DocumentRoot /www/docs/dummy-host.example.com 
22.
#    ServerName dummy-host.example.com 
23.
#    ErrorLog logs/dummy-host.example.com-error_log 
24.
#    CustomLog logs/dummy-host.example.com-access_log common 
25.
#</VirtualHost> 
26.
 
27.
besser 
28.
 
29.
<VirtualHost *:80> 
30.
    ServerAdmin webmaster@dummy-host.example.com 
31.
    DocumentRoot /www/docs/dummy-host.example.com 
32.
    ServerName dummy-host.example.com 
33.
    ErrorLog logs/dummy-host.example.com-error_log 
34.
    CustomLog logs/dummy-host.example.com-access_log common 
35.
</VirtualHost> 
36.
 
wobei example.com deine Domain ist. Ich weiss nicht ob das hilft; ist mir halt aufgefallen. Weiter kannst du ja die Logs löschen und nach einem Aufruf der Seite die logs anzeigen lassen.

Die Logs liegen bei Debian unter /var/log/apache2/error.log und access.log.


Weiter fällt mir auf dass du "etwas" auf den Port 3443 laufen lassen willst. 443 ist ein SSL Port, deswegen könnte ich mir vorstellen dass du SSL laufen lassen willst? Wenn ja: SSL funktionniert (meines Wissens) nicht IP bassiert sondern domain bassiert.

mfG
Bitte warten ..
Mitglied: pixelflat
27.02.2009 um 08:22 Uhr
Hallo, danke für die Antwort.
Habe die Config nicht hier gepostet, weils doch etwas viel Text ist (und es in einem Jahr nicht mehr relevant ist ;) ).

Mittlerweile funktionierts. Ich kann aber nicht sagen, wo es gehakt hat, da sich jemand anders daran gesetzt hat.

PS: Auf Port 3443 läuft kein SSL, einfach nur eine andere Seite.
Bitte warten ..
Mitglied: Cubic83
27.02.2009 um 08:39 Uhr
Könntest du vielleicht trotzdem mal die httpd.conf pasten? Würde mich interessieren worans lag.

mfG
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Unterverzeichnis für Unterverzeichnis via Batch-Datei durchsuchen

gelöst Frage von dhc-beaverBatch & Shell4 Kommentare

Hallo Forum. Obgleich es viele Werkzeuge gibt, um Bilder von 5MP-Handykameras kleiner zu machen, scheitert man an der Faulheit ...

Batch & Shell

Unterverzeichnis löschen

gelöst Frage von sanaitBatch & Shell4 Kommentare

Moin Moin, echo off rmdir /s /Q D:\Transfer\ diese Batch löscht ja das gesamte Verzeichnis inklusive des Ordners Transfer. ...

Batch & Shell

Unterverzeichnis zählen

gelöst Frage von karla123Batch & Shell20 Kommentare

Hallo liebes Forum, ich habe ein Problem und möchte Euch bitten mir zu helfen. Benötigt wird ein Batch mit ...

Server

Kann httpd Dienst nicht starten.

gelöst Frage von Mr.FSB311Server13 Kommentare

Ich habe bei 1blu einen vServer mit dem OS:centos-6-x86_64 Der httpd Dienst wird mir im Virtuzzo Panel als gestoppt ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 12 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 20 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit17 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...

Windows Installation
Kleines Büro - wie PCs einrichten? Domaincontroller sinnvoll?
Frage von Jonas42Windows Installation13 Kommentare

Hallo zusammen, ich überlege derzeit mal wieder, ob ich unsere IT ändern sollte. Es handelt sich um ein Ingenieurbüro ...