Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst REN - Problem nicht absoluter Pfad

Mitglied: Julian57

Julian57 (Level 1) - Jetzt verbinden

13.06.2011, aktualisiert 10:15 Uhr, 3981 Aufrufe, 9 Kommentare

Hallo,

ich habe im Moment ein Problem mit Umbenennen(Ren) von einer Datei,

Und zwar ich habe folgenden Batch:

01.
@echo off 
02.
Title Setup 
03.
if not exist InfoManager2.xprf exit 
04.
echo. 
05.
echo Update wird installiert... 
06.
@ping localhost -n 2 >NUL  
07.
DEL InfoManager.xprf /F || goto Fail 
08.
REN C:\Users\Julian\Desktop\InformationsManagement\InfoManager2.xprf InfoManager.xprf || goto Fail 
09.
echo. 
10.
echo Update erfolgreich installiert!!! 
11.
@ping localhost -n 2 >NUL  
12.
echo.  
13.
echo Programm wird gerstartet 
14.
XProfan.exe "InfoManager.xprf" 
15.
@ping localhost -n 2 >NUL  
16.
exit 
17.
 
18.
:Fail 
19.
cls 
20.
echo. 
21.
echo Installation des Updates ist Fehlgeschlagen! 
22.
echo. 
23.
pause 
24.
exit
Und zwar ist mein Problem das der Pfad des Batches und die zu umbenennende Datei nicht absolut, sprich variabel sind.
Nun wüste ich gerne wie ich die Zeile...
01.
REN C:\Users\Julian\Desktop\InformationsManagement\InfoManager2.xprf InfoManager.xprf || goto Fail
...so umschreibe das der Pfad in dem die Dateien liegen keine Rolle mehr spielt.

Wie macht man sowas?

Wenn ich die Pfadangabe einfach weglasse funktioniert es leider nicht!


LG

Julian57
Mitglied: DONNobre
13.06.2011 um 10:44 Uhr
REN "C:\Users\Julian\Desktop\InformationsManagement\InfoManager2.xprf" InfoManager.xprf || goto Fail

das sollte glaube ich gehen in deinem Pfad war etwas 2 mal eingegeben (InfoManager.xprf ) ... weiß nicht ob das so sein sollte ...
längere verzeichnisse sollte man in "" angeben ....
Bitte warten ..
Mitglied: Xaero1982
13.06.2011 um 11:13 Uhr
Moin,

wo liegt denn die Batch?

VG
Bitte warten ..
Mitglied: Julian57
13.06.2011 um 11:21 Uhr
Zitat von DONNobre:
REN "C:\Users\Julian\Desktop\InformationsManagement\InfoManager2.xprf" InfoManager.xprf || goto Fail

das sollte glaube ich gehen in deinem Pfad war etwas 2 mal eingegeben (InfoManager.xprf ) ... weiß nicht ob das so sein
sollte ...
längere verzeichnisse sollte man in "" angeben ....



Ich glaube ihr habt mich falsch verstanden, der Batch oben funktioniert klasse!

Nur das Problem ist das der Batch nicht immer in "C:\Users\Julian\Desktop\InformationsManagement\*.*" sondern auch manchmal auch in anderen Verzeichnissen liegt.
Nun suche ich eine Möglichkeit den Batch so umzuschreiben das es vollkommen egal ist wo der Batch und die zu umbenennenden Dateien liegen.
Der Bach soll also von Pfad unabhängig funktionieren!

LG

Julian57
Bitte warten ..
Mitglied: Xaero1982
13.06.2011 um 11:46 Uhr
Ich hab dich nicht falsch verstanden - keine Sorge....

Die Batch und die umzubenennenden Dateien liegen aber immer im gleichen Ordner?

VG
Bitte warten ..
Mitglied: Julian57
13.06.2011 um 11:52 Uhr
Jo, genauso wie die Datei die gelöscht wird
Bitte warten ..
Mitglied: Xaero1982
13.06.2011 um 11:59 Uhr
Moin,

dann lass die Pfadangaben weg

01.
REN InfoManager2.xprf InfoManager.xprf || goto Fail 
Edit: Dass es ohne Pfadangaben nicht gehen soll wie du im ersten Post schreibst kann ich nicht bestätigen. Habs gerade getestet und geht problemlos.
Edit2: Ansonsten siehe Dieters Vorschlag!

VG
Bitte warten ..
Mitglied: 76109
13.06.2011 um 12:01 Uhr
Hallo Julian57!

Siehe Dir hierzu mal die Befehle 'Pushd' und 'Popd' an.

Gruß Dieter
Bitte warten ..
Mitglied: Xaero1982
13.06.2011 um 14:02 Uhr
Gelöst? Und wie ist die Lösung?

VG
Bitte warten ..
Mitglied: Julian57
13.06.2011 um 14:38 Uhr
Hat mich selber verwundert, ich habe einfach nochmal den Pfad weggelassen und es hat dieses mal funktioniert

Gruß
Bitte warten ..
Ähnliche Inhalte
Visual Studio

Vb.net Relativen Pfad in Absoluten Pfad umwandeln

Frage von ahstaxVisual Studio2 Kommentare

Hallo, Ich versuche mit VB (vb.net 2010), eine MSG-Datei in ein PDF umzuwandeln. Das klappt ganz gut, wenn man ...

Batch & Shell

Problem mit UNC-Pfad ? powershell-skript

Frage von today12Batch & Shell2 Kommentare

Hallo liebe Community, ich hab ein kleines Verständnis Problem mit UNC-Pfade. ich möchte mein Skript auf ein Netzlaufwerk legen, ...

HTML

Position Absolut in Div einsperren jQUERY

gelöst Frage von 94451HTML2 Kommentare

Hallo Ihr, ich habe hier "Fertigen" Code nur minimal verändert genau so aus dem Netz: das ganze script macht ...

Batch & Shell

Leerzeichen im Pfad

Frage von JallioBatch & Shell4 Kommentare

Hallo erneut, ich werde hier echt noch zum Stammkunden Wenn ich den Befehl $body in der WindowsPowerShell ISE ausführe, ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 8 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 8 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 11 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...