Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RIS - SCSI Treiber hinzufügen danach cannot find a CD-ROM drive

Mitglied: Mallet

Mallet (Level 1) - Jetzt verbinden

14.09.2007, aktualisiert 02.10.2007, 5648 Aufrufe, 3 Kommentare

Ich habe die Aufgabe erhalten einen RIS - Server für verschiedene Server mit unterschiedlicher Hardware zu installieren. In meinem speziellen Fall soll keine weitere Software installiert werden, "nur" Windows 2003 Standard oder Enterprise Edition.

Mittlerweile habe ich es auch schon geschafft, verschiedene SCSI-Raid-Controller einzubinden. Leider habe ich aber folgendes Problem:
Um die Treiber einzubinden habe ich gelesen, dass man den Parameter OemPreinstall=Yes im Unattended Bereich setzen muss. Wenn ich diesen Parameter in meine ristndrd.sif bringe und eine Remote Installation starte, bekomme ich nach dem Start von Windows die Meldung "Setup cannot find a CD-ROM drive". Wenn ich diesen Parameter auf No stelle (und die Installation auf einem Rechner ohne SCSI-Controller durchführe) kommt die Meldung: "Insert the CD labeled: Windows Server 2003, Standard Edition CD-ROM...". Beide Meldungen kommen zum gleichen Zeitpunkt: kurz bevor die HDD formatiert werden soll.
Wenn ich den Parameter nicht setze läuft die Installation auf einem Rechner ohne SCSI-Controller durch.

Hier mein ristndrd.sif:

[data]
floppyless = "1"
msdosinitiated = "1"
OriSrc = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
OriTyp = "4"
LocalSourceOnCD = 1
DisableAdminAccountOnDomainJoin = 1
Autopartition = 0

[SetupData]
OsLoadOptions = "/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[Unattended]
FileSystem = LeaveAlone
Repartition = no
ExtendOEMPartition = 0
ConfirmHardware = no
TargetPath = \WINDOWS
OemSkipEula = yes
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
DriverSigningPolicy=Ignore
OverwriteOemFilesOnUpgrade = yes
UnattendSwitch=yes
OemPreinstall=No
OemPnPDriversPath="\Drv\ca;\Drv\cb;\Drv\cc;\Drv\cd;\Drv\ce;\Drv\cf;\Drv\cg;\Drv\ch;\Drv\ci;\Drv\cj;\Drv\ck;\Drv\cm;\Drv\cn;\Drv\co;\Drv\cp;\Drv\cq;\Drv\cr;\Drv\cs;\Drv\ct;\Drv\3a;\Drv\3b;\Drv\3c"

[MassStorageDrivers]
"Adaptec HostRAID U320 Driver Ver 1.02 For Windows 2000/XP/2003"=OEM
"Adaptec Ultra320 SCSI Cards (Win XP/Server 2003 IA-32)"=OEM

[OEMBootFiles]
"Adaptec HostRAID U320 Driver Ver 1.02 For Windows 2000/XP/2003"
"Adaptec Ultra320 SCSI Cards (Win XP/Server 2003 IA-32)"
a320raid.cat
a320raid.inf
a320raid.sys
adhraid.cat
adhraid.inf
adpu320.sys
adpu320.inf
adpu320.cat
txtsetup.oem

[UserData]
ProductKey = XXXXX-XXXXX-XXXXX-XXXXX
FullName="Firma"
OrgName="Abteilung"
ComputerName = %MACHINENAME%

[GuiUnattended]
OemSkipWelcome = 1
OemSkipRegional = 1
TimeZone = %TIMEZONE%
AdminPassword = "*"

[LicenseFilePrintData]
AutoMode = PerSeat

[Display]
BitsPerPel = 16
XResolution = 800
YResolution = 600
VRefresh = 60

[Networking]

[NetServices]
MS_Server=params.MS_PSched

[Identification]
JoinDomain = %MACHINEDOMAIN%
DoOldStyleDomainJoin = Yes

[RemoteInstall]
Repartition = No
UseWholeDisk = Yes

[OSChooser]
Description ="Windows Server 2003, Standard"
Help ="Automatically installs Windows Server 2003, Standard without prompting the user for input."
LaunchFile = "%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"
ImageType =Flat
Version="5.2 (3790)"

[Disks]
d1 = "Adaptec HostRAID U320 Driver Ver 1.02 For Windows 2000/XP/2003", \hraidsk1, \
d2 = "Adaptec Ultra320 Family Manager Set - Microsoft Disk", \u320dsk1, \

[Defaults]
scsi = a79xxNTIA32

[scsi]
ADAPTEC_U320RAID_W2K = "Adaptec HostRAID U320 Driver Ver 1.02 For Windows 2000/XP/2003"
a79xxNTIA32 = "Adaptec Ultra320 SCSI Cards (Win XP/Server 2003 IA-32)"

[Files.scsi.ADAPTEC_U320RAID_W2K]
driver = d1,a320raid.sys, a320raid
inf = d1,a320raid.inf
inf = d1,adhraid.inf
catalog = d1,a320raid.cat
catalog = d1,adhraid.cat

[Config.scsi.ADAPTEC_U320RAID_W2K]
value = "", Group, REG_SZ, "SCSI Miniport"
value = "", Start, REG_DWORD, 0
value = "", Tag, REG_DWORD, 1
value = "", Type, REG_DWORD, 1
;value = "Parameters\Device","DriverParameter",REG_SZ,"MAXLUNS=8 HSREnabled=FALSE"

[Config.a320raid]
value = "", Group, REG_SZ, "SCSI Miniport"
value = "", Start, REG_DWORD, 0
value = "", Tag, REG_DWORD, 1
value = "", Type, REG_DWORD, 1
value = "Parameters\Device","DriverParameter",REG_SZ,"MAXLUNS=8 HSREnabled=FALSE"

;[HardwareIds.scsi.ADAPTEC_U320RAID_W2K]
;id = "PCI\VEN_9005&DEV_00c4","ADAPTEC_U320RAID_W2K"
;id = "PCI\VEN_9005&DEV_8011","ADAPTEC_U320RAID_W2K"

[Files.scsi.a79xxNTIA32]
driver = d2, adpu320.sys, adpu320
inf = d2, adpu320.inf
catalog = d2, adpu320.cat

[Config.adpu320]
value = "", tag, REG_DWORD, 20
#value = Parameters\PnpInterface,5, REG_DWORD,1

[HardwareIds.scsi.a79xxNTIA32]
id = "PCI\VEN_9005&DEV_801D", "adpu320"
id = "PCI\VEN_9005&DEV_801E", "adpu320"
id = "PCI\VEN_9005&DEV_801F", "adpu320"
id = "PCI\VEN_9005&DEV_800F", "adpu320"
id = "PCI\VEN_9005&DEV_800F&SUBSYS_005F9005", "adpu320"
id = "PCI\VEN_9005&DEV_8000&SUBSYS_00609005", "adpu320"
id = "PCI\VEN_9005&DEV_8010&SUBSYS_00409005", "adpu320"
id = "PCI\VEN_9005&DEV_8011&SUBSYS_00419005", "adpu320"
id = "PCI\VEN_9005&DEV_8012&SUBSYS_00429005", "adpu320"
id = "PCI\VEN_9005&DEV_8014&SUBSYS_00449005", "adpu320"
id = "PCI\VEN_9005&DEV_8015&SUBSYS_00409005", "adpu320"
id = "PCI\VEN_9005&DEV_8016&SUBSYS_00409005", "adpu320"
id = "PCI\VEN_9005&DEV_8017&SUBSYS_00449005", "adpu320"


Hier meine Filestruktur:

E:\RemoteInstall\Setup\English\Images\W2k3Std\

E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\
E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$1\
E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$1\Drv\
E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$1\Drv\3a\
E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$1\Drv\3b\
E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$1\Drv\3c\
E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$1\Drv\CA\ usw...

E:\RemoteInstall\Setup\English\Images\W2k3Std\$oem$\$textmode\
hier liegen alle inf, cat und sys Dateien der einzelnen Geräte
und die txtsetup.oem, zusammenkopiert von allen Treibern.

E:\RemoteInstall\Setup\English\Images\W2k3Std\i386\
E:\RemoteInstall\Setup\English\Images\W2k3Std\i386\template\ristndrd.sif


Ich würde mich sehr freuen, wenn mir jemand helfen könnte dieses Problem zu lösen...
Mitglied: Mallet
16.09.2007 um 15:14 Uhr
Hier ein kleines Update:

dank folgender Seite weiß ich nun, dass ich die IDE Treiber für das CD-Rom nachladen muss:
http://support.microsoft.com/kb/288344/en-us

Hier der Ausschnitt:
NOTE: If you also use this same unattend file on systems with IDE controllers that start using the in-box drivers, then also add the following to the [MassStorageDrivers] section, otherwise you receive an "Inaccessible Boot Device" blue screen error message during the text mode setup:

"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"


Ich denke dass meine Clients die Windows CD brauchen, weil sie keine End User Licensing Agreement (EULA) finden. Bisher habe ich aber noch keine Ahnung, warum die Clients die EULA nicht finden können. Es ist auf jeden Fall im I386 Verzeichnis eine eula.txt.
Bitte warten ..
Mitglied: Mallet
18.09.2007 um 16:57 Uhr
Nun habe ich herausgefunden, dass ich nur eine CD brauche, wenn ich zusätzliche SCI Treiber lade. Ab diesem Zeitpunkt will der Client die kompletten Installations - Files von der CD haben. Ich will aber die Clients über Netzwerk installieren lassen. Hat jmd eine Ahnung oder einen Tipp für mich, was ich falsch mache? Werden meine Netzwerkkartentreiber oder Netzwerkkomponenten nicht mehr geladen, wenn ich SCSI - Controler angebe?

Besten dank für eure Unterstützung.
Bitte warten ..
Mitglied: Mallet
02.10.2007 um 09:08 Uhr
Endlich habe ich die Lösung für mein Problem gefunden:

eindfach folgende Zeilen aus der *.sif entfernen:

[Disks]
d1 = "Adaptec HostRAID U320 Driver Ver 1.02 For Windows 2000/XP/2003", \hraidsk1, \
d2 = "Adaptec Ultra320 Family Manager Set - Microsoft Disk", \u320dsk1, \

und dann funktionierts.
Bitte warten ..
Ähnliche Inhalte
Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware10 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Windows 7
Acer Treiber CD zeigt keine Treiber an?!
Frage von B-freeWindows 719 Kommentare

Hallo, ich habe das Problem, das offensichtlich sehr wenige Treiber auf meinem Acer Laptop* installiert sind. "Kein Problem!" dachte ...

Drucker und Scanner

Kernel-mode print driver Fehler beim hinzufügen der Treiber

Frage von Michael89Drucker und Scanner2 Kommentare

Hiho und guten Abend, ich hoffe das jemand noch schlagkräftige Ideen bezüglich folgendes Fehlers hat: Bei der Installation der ...

Router & Routing

Ersatz für m0n0wall 1.32 Generic PC (CD-ROM)

gelöst Frage von runasserviceRouter & Routing14 Kommentare

Hallo, Ich habe hier einen Desktop-PC mit vier Netzwerkkarten mit m0n0wall Version 1.32 Generic PC (CD-ROM) und Diskettenlaufwerk. Meine ...

Neue Wissensbeiträge
Suche Projektpartner

PC Recycling Projekte mit Flüchtlingen und Kids suchen Materialspenden und Mitmacher!

Erfahrungsbericht von NettePCyclePiraten vor 14 StundenSuche Projektpartner2 Kommentare

Hallöchen liebe Kollegen, ich betreue zwei PC-Gruppen im Raum Dortmund: "Ne#e PCycle Pir@ten" & "PCschr@uber Br@mbauer" Wir sind eine ...

iOS
IOS 12.2 beta und OpenVPN iPad und iPhone
Erfahrungsbericht von magicteddy vor 21 StundeniOS

Moin, kleiner Hinweis an die experimentierfreudigen unter Euch: Bei der aktuellen beta gibt es ein Problem im Zusammenspiel zwischen ...

Vmware
VMware Tools 10.3 verfügbar
Information von sabines vor 1 TagVmware

Eine Sicherheitslücke wird mit den Tools der Version 10.3 geschlossen, die Tools müssen auf jeder VM aktualisiert werden. Näheres ...

Apple

Apple aktualisiert MacBook Pro, mit bis zu sechs Kernen

Information von Vision2015 vor 3 TagenApple

Jawohlchen das Warten hat sich gelohnt :-) Apple aktualisiert MacBook Pro Frank

Heiß diskutierte Inhalte
Microsoft
Dringend: Nach neustart kein zugriff mehr per RDP möglich - vermutlich wegen gelöschter SID in AD
gelöst Frage von sven784230Microsoft30 Kommentare

Hallo zusammen, gerade hat ein Server 2012 (terminalserver + Active directory) einen geplanten Neustart durchgeführt, wenn ich mich jetzt ...

Exchange Server
Exchange 2013 - Update schlägt fehlt
gelöst Frage von chb1982Exchange Server20 Kommentare

Hallo zusammen, kann sich jemand einen Reim auf die unten stehenden Fehlermeldung machen? Sie tritt auf beim Update von ...

Firewall
Pfsense - Package Manager - Unable to retrieve package information
Frage von nubyFirewall12 Kommentare

Hallo! Ich habe mit verschiedenen Versionen von Pfsense Probleme neue Packages herunterzuladen. Bei Pfsense 2.3.1 oder 2.3.5 heißt es: ...

Verschlüsselung & Zertifikate
Windows PKI root Zertifikate werden nicht aktualisiert
gelöst Frage von Chaser21aVerschlüsselung & Zertifikate10 Kommentare

Hallo Community, wir haben eine eigene Unternehmens PKI im Einsatz. Aktuell gibt es das Problem, dass mehrere ROOT- und ...