Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Robocopy unter Windows 7

Mitglied: HannesPeter

HannesPeter (Level 1) - Jetzt verbinden

25.11.2009 um 12:21 Uhr, 12437 Aufrufe, 9 Kommentare

Probleme unter Windows 7 x64 mit Robocopy

Hallo zusammen .
Ich habe ein NAS ( FAT32) auf welchem ich bis dato meine Backups mit Robocopy erstelle. ( WINDOWS XP / WIN2000 / WIN2003 SERVER)
Klappt alles soweit bis auf den WINDOWS 7 Rechner.

Der kopiert es nicht und bringt nur Fehlermeldungen oder sagt ek kann den Pfad nicht finden ( falls UNC PFAD angegebn wird)

Zugreifen über UNC funktioniert aber bestens.
Alles andere geht auch auf diesem Laufwerk, nur Robocopy will halt nicht.

Jemand eine Idee ?

Danke im voraus
Mitglied: Pimpermann
25.11.2009 um 14:02 Uhr
Wie wär es mit einem Auszug aus deinem Robocopy befehl?
Bitte warten ..
Mitglied: Pjordorf
25.11.2009 um 14:14 Uhr
Und dann noch mindestens 1 Fehlermeldung.

Sonst kann dir nicht geholfen werden.
Bitte warten ..
Mitglied: HannesPeter
25.11.2009 um 16:11 Uhr
Ok Ok
Hier kommt die Meldung und der Aufruf

robocopy "C:\Users\hannes\AppData\Local\Microsoft\Outlook" \\nas01\backup\test /MIR

New Dir 8 C:\Users\hannes\AppData\Local\Microsoft\Outlook\
00% New File 1297 ~last~.sharing.xml.obi
009/11/25 16:08:12 ERROR 32 (0x00000020) Changing File Attributes C:\Users\hannes\AppData\Local\Microsoft\Outlook\~last~.sharing
xml.obi
er Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.
aiting 30 seconds...^CBatchvorgang abbrechen (J/N)?
Bitte warten ..
Mitglied: Pjordorf
25.11.2009 um 16:44 Uhr
Hallo HannesPeter,

Ok Ok
Du willst doch etwas.

Hier kommt die Meldung und der Aufruf

robocopy "C:\Users\hannes\AppData\Local\Microsoft\Outlook"
\\nas01\backup\test /MIR

New Dir 8
C:\Users\hannes\AppData\Local\Microsoft\Outlook\
00% New File 1297
~last~.sharing.xml.obi
009/11/25 16:08:12 ERROR 32 (0x00000020) Changing File Attributes
C:\Users\hannes\AppData\Local\Microsoft\Outlook\~last~.sharing
xml.obi
er Prozess kann nicht auf die Datei zugreifen, da sie von einem
anderen Prozess verwendet wird.
Und das hast du definitiv nicht gelesen. Da steht es doch sogar noch in Deutsch.

Du solltest dich mal fragen, wie geöffnete Dateien überhaupt kopiert werden könnten.

Peter
Bitte warten ..
Mitglied: HannesPeter
25.11.2009 um 16:53 Uhr
Also zuersteinmal muss Du keinen daurauf hinweisen das es dort in Deutsch steht.
Das kann jeder lesen und zum zweiten sind die Dateien nicht geöffnet
und zum dritten wenn man schon so schlau ist, man kann auch geöffnete Dateien kopieren.

Das ist hier aber nicht das Thema.
Wenn Du meine Frage richtig lesen würdest, könnte man sich sowas sparen.
Robocopy funktioniert auf allen anderen Laufwerken mit dem gleichen Aufruf, nur nicht auf das NAS mit FAT32
und das auch nur nicht mit dem WINDOWS 7 Client.
Bitte warten ..
Mitglied: Pimpermann
26.11.2009 um 07:13 Uhr
Hast du es mal mit dem Parameter /ZB probiert?
Bitte warten ..
Mitglied: HannesPeter
26.11.2009 um 07:36 Uhr
Nein ZB habe ich noch nicht versucht.
Ich werde es mal testen und dann Bescheid geben.

Danke
Bitte warten ..
Mitglied: Janno100
18.02.2010 um 06:57 Uhr
Was ist daraus geworden ???
Ich stehe zufällig vor dem selben Problem bei Windows 7.
Behauptet immer das ein anderer Prozess darauf zugreifen würde...


... etwas später
einige Dateien sind wohl locked.. klar.
mit robocopy c:\users\12345\ d:\grobe_sicherung\ /MIR /TEE /ETA /R:0 /w:1000 /LOG:backup.log /XF history.db funktioniert es jetzt

Die Systemdateien die locked sind, sind für mich sowieso uninteressant gewesen.
Bitte warten ..
Mitglied: VWenning
14.03.2011 um 23:15 Uhr
Ich habe das gleiche Problem: Die Sicherung auf eine USB-Platte funktioniert ohne Probleme; es werden nur die Dateien kopiert, die noch nicht vorhanden sind ("robocopy C:\Users\Public\Pictures\Fotos J:\Fotos /E").

Das gleiche probieren ich mit dem Ziel einer NAS-Platte:
„robocopy C:\Users\Public\Pictures\Fotos n:\ /E /LOG:SichernAufNas.log“

Hier erhalte ich folgende Log-Datei:
ROBOCOPY :: Robustes Dateikopieren fr Windows
Gestartet: Mon Mar 14 21:24:12 2011

Quelle : C:\Users\Public\Pictures\Fotos\
Ziel = n:\

Dateien : *.*

Optionen: *.* /S /E /COPY:DAT /R:1000000 /W:30

0 C:\Users\Public\Pictures\Fotos\
*ZUS. Verz. -1 n:\\
*EXTRA Datei 332
Neues Verz. 0 C:\Users\Public\Pictures\Fotos\Canon\
Neues Verz. 0 C:\Users\Public\Pictures\Fotos\Canon\2008\
Neues Verz. 0 C:\Users\Public\Pictures\Fotos\Canon\2008\06\
Neues Verz. 58 C:\Users\Public\Pictures\Fotos\Canon\2008\06\2008_06_13\
Neue Datei 3.5 m 2000_01_01_0001.JPG
0% … 100%
2011/03/14 21:24:15 FEHLER 32 (0x00000020) Zieldatei wird mit Zeitstempel versehen C:\Users\Public\Pictures\Fotos\Canon\2008\06\2008_06_13\2000_01_01_0001.JPG
Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.

30 Sekunden wird gewartet...“

Die Datei, die hier kopiert wurde, existierte allerdings bereits und hätte daher gar nicht kopiert werden müssen.
Abgesehen davon verstehe ich den „FEHLER32“ nicht.
Hat jemand dazu eine Idee????
Vielen Dank im Voraus und viele Grüße
Volker
Bitte warten ..
Ähnliche Inhalte
Backup
Robocopy auf windows nt 4.0
gelöst Frage von simonfcz1996Backup4 Kommentare

Funktioniert robocopy auf Windows NT 4.0? Und wenn ja, ich habe leider keine Ahnung von Robocopy und würde gerne ...

Netzwerke
Kopiert Robocopy oder Windows schneller?
Frage von multitalentd99Netzwerke4 Kommentare

HAllo, bis heute dachte ich immer das Robocopy 100% zuverlässig schnell kopiert und zudem den Vorteil hat, die Übertragungsgeschwindigkeit ...

Backup

Robocopy Inkrementelle Sicherung Windows Share

Frage von firevegetaBackup3 Kommentare

Hallo zusammen, ich habe folgende Konstellation. Ich habe eine neue Windows Umgebung aufgebaut, dazu auch einen neuen Windows-Fileserver. Wir ...

Batch & Shell

Move mit Robocopy

gelöst Frage von 0xC0FFEBatch & Shell2 Kommentare

Hallo zusammen, ich würde gerne Bilder von einem Verzeichnis in ein anderes Verschieben mit Folgenden Ausschlusskriterien: Dateiendung : .jpg ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 16 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...