Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Router erreichen durch arp befehl möglich?

Mitglied: Miischiii

Miischiii (Level 1) - Jetzt verbinden

20.04.2007, aktualisiert 14:03 Uhr, 8069 Aufrufe, 12 Kommentare

Hallo zusammen,

ich habe hier im Forum gelesen das man den arp Befehl dazu nutzen kann einen Router zu errechen dessen IP man nicht kennt, stimmts?

also ich habe die MAC des Routers nun gebe ich den Befehl ein

arp -s 192.168.100.100 00-11-22-33-44-55

nun sollte der Router eigentlich unter der IP 192.168.100.100 erreichbar sein oder etwa nicht?
liegt es an einem Fehler den ich mache oder woran sonst?

Und noch die frage funktioniert das nur bei Routern oder kann ich das allgemein benutzen um z.B. einen Mailserver im Netzwerk unter einer anderen IP zu erreichen?

gruss
Miischiii
Mitglied: AndreasHoster
20.04.2007 um 09:17 Uhr
>also ich habe die MAC des Routers nun gebe ich den Befehl ein
>arp -s 192.168.100.100 00-11-22-33-44-55
>nun sollte der Router eigentlich unter der IP 192.168.100.100 erreichbar sein oder etwa nicht?
Im Prinzip ja, aber ...
>liegt es an einem Fehler den ich mache oder woran sonst?
Liegt was an einem Fehler? Vermutlich willst Du sagen, daß es nicht tut, oder wie?

Also:
Mit dem arp -s 192.168.100.100 00-11-22-33-44-55 Befehl schickt der Rechner IP Pakete mit Adresse 192.158.100.100, sofern das Subnetz so definiert ist, das diese Adresse als lokale Adresse erkannt wird, ins lokale Netz an die Netzwerkkarte mit der MAC 00-11-22-33-44-55. Soweit, so gut, die Pakete dürften dann beim Router ankommen.
Aber: Es gibt Programme die die IP in den Paketen nachkontrollieren und nicht passende IPs einfach nicht verarbeiten.
Aber: Kommunikation ist ein Dialog, kein Monolog. Die Antwortpakete kommen unter Umständen bei Dir nicht wieder an, weil das Routing zurück nicht passt. Was meine Vermutung ist, warum es bei Dir nicht tut. Wenn man die IP nicht kennt, dürfte auch das Subnetz nicht passen.

Man kann das prinzipiell für alle IP Geräte verwenden, allerdings ist das ein recht tiefer Eingriff, da sollte man genau wissen was man tut, damit es funktioniert.
Bitte warten ..
Mitglied: Miischiii
20.04.2007 um 09:44 Uhr
naja gut ich habe es ja selbst mal am Router getestet gleiches Subnetz alles...aber es hat halt nicht geklappt! Hatte die IP halt geändert aber da kam nichts zurück. Habe auch einen ping gesendet an die geänderte IP und es kam nichts zurück...
Subnetz passt
255.255.255.0
Standard eben.
Aber an welche IP schickt er dann die Daten zurück wenn nich an meine von der der ping ausgeführt worden ist?

Und danke für die schnelle Antwort =)
Bitte warten ..
Mitglied: AndreasHoster
20.04.2007 um 11:13 Uhr
Er schickt die Daten schon an Deine IP Adresse zurück, aber ja nach Routing Tabellen könnte er ja der Meinung sein, daß diese IP Adresse nicht im lokalen Netz ist, dann gehts ans entsprechende Gateway und kommt nicht zu Dir zurück.

Ich habe es hier mal ausprobiert, Windows macht IP Überprüfung und reagiert nicht auf Pakete mit der falschen Ziel IP, bei unseren Printservern dagegen funktioniert es.
Bitte warten ..
Mitglied: Miischiii
20.04.2007 um 11:24 Uhr
ich versteh das nicht...hab es hier an unserem AP ausprobiert und am Printserver am Mailserver auch...nie kommt nen ping zurück und erreichen tu ich die unter der IP auch nicht...
naja gut bei dir scheint es zu klappen. nur würde es hier halt auch gerne mal versuchen um zu sehen das es auch wirklich hier funktioniert...

und die IP bereiche sind gleich gleiche subnetzmask, IP bereich und Gateway. das ist echt mal zum haare raufen...

wo kann ich das denn noch testen?
Bitte warten ..
Mitglied: AndreasHoster
20.04.2007 um 11:45 Uhr
Bei mir klappt das beim Printserver sogar mit HTTP.
Also Dein Rechner und das Gerät das Du anpingen willst sind im gleichen Subnetz?
Und ein tracert (traceroute) auf die IP bringt auch keine Geräte dazwischen?
Bitte warten ..
Mitglied: Miischiii
20.04.2007 um 12:10 Uhr
hab ich gerade gemacht und da is nichts zwischen er zeigt mir direkt beim ersten eintrag den printserver wenn ich ihn direkt auf seine "echte" ip anfrage. auf die andere kommt nichts nur eine zeitüberschreitung der anforderung.

kann es sein das es an dem printserver liegt der der da ein problem mit hat?
wenn ich arp -a eingebe zeigt er mir ja beide einträge an

192.168.100.99 00-11-22-33-44-55 dynamisch
192.168.100.100 00-11-22-33-44-55 statisch

auf der 99 erreich ich ihn ganz normal und auf die 100 kommt rein garnichts...

ja das subnetz ist 255.255.255.0
Bitte warten ..
Mitglied: AndreasHoster
20.04.2007 um 13:20 Uhr
Da kann ich auch nur vermuten, daß der Printserver die IP überprüft und auf falsche nicht reagiert.
Bitte warten ..
Mitglied: Miischiii
20.04.2007 um 13:28 Uhr
das glaub ich auch so langsam...an unserem AP klappts auch nicht. hmmm eine idee wo es zu 100% funktionieren könnte?
mal ne frage hast du da einen neueren oder älteren printserver?
Bitte warten ..
Mitglied: AndreasHoster
20.04.2007 um 13:41 Uhr
Einen billigen, ca. 3 Jahre alten Printserver von LevelOne.
Bitte warten ..
Mitglied: Miischiii
20.04.2007 um 13:51 Uhr
nagut hier ist es ein intel netport express...könnte sein das der sowas nicht zulässt ;)
hmmm ma sehen ob ich hier in der werkstatt was altes finde wo ich das mal testen kann...
also kann ich davon ausgemehhen das der befehl bei neueren geräten nicht mehr funktionieren dürfte oder?
Bitte warten ..
Mitglied: AndreasHoster
20.04.2007 um 13:59 Uhr
Möglich. Kommt auf das Gerät an. Kann daher nichts genaues sagen.
Bitte warten ..
Mitglied: Miischiii
20.04.2007 um 14:03 Uhr
gut da bin ich wieder um so einiges schlauer ;)
und vielen dank für deine schnellen antworten das gibt glatte zwei daumen hoch ;)

gruss
Miischiii
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Router über einen anderen Router erreichen

gelöst Frage von heisenberg4Router & Routing5 Kommentare

Hallo, Blöde Überschrift gewählt aber wusste nicht genau wie ich es kurz beschreiben sollte. Also, wir haben eine Easybox ...

DNS

Nachgelagerten Router von extern erreichen

gelöst Frage von ZentralenteufelDNS3 Kommentare

Hallo, ich habe folgende Situation zuhause. 1. Anschluss Vodafone/KD - 400 MBit (FB6490 eigene) - interne IP 192.168.177.1 2. ...

Router & Routing

Erreichen von einem zweiten Netzwerk via Router

Frage von deschisdoRouter & Routing6 Kommentare

Hallo Zusammen, aus Sicherheitsgründen möchte ich unser Netzwerk in mehrerer Segmente aufteilen. Zur Vorbereitung auf dieses Splitten des Netzwerkes ...

LAN, WAN, Wireless

Server in Subnetz über VPN Router erreichen

Frage von mrpinappleLAN, WAN, Wireless7 Kommentare

Hallo :) ich habe dank der tollen Anleitung unter: erfolgreich einen VPN Zugang zu meinem Heimnetzwerk aufgebaut. Nun hänge ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 3 StundenWindows 102 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 6 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 23 StundenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...