Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Router schickt SMTP Anfrage mit interner / privater IP

Mitglied: mechworm

mechworm (Level 1) - Jetzt verbinden

06.06.2006, aktualisiert 08.06.2006, 8691 Aufrufe, 7 Kommentare

Hallo!

Habe volgendes Problem,

bei einem Kunden setze ich einen Tobit Mailserver ein (David V8).
Als Mailprovider dient knallhart.de.

Der Mailabruf funktioniert per pop3 über den Port 110 wunderbar, jedoch wenn ich per smtp (port 25) Mails abrufen möchte sagt er immer "Absender unbekannt". Wenn ich mir den Portmonitor genau ansehe sieht man auch direkt warum. Er schickt die SMTP Anfrage an smtp.knallhart.de mit der Absender IP 192.168.2.129 also einer privaten IP (Class C). Die IP ist die der 3COm Karte des Tobit Servers.

Als Router wird ein Hardwarerouter der Firma SMC eingesetzt. Bis letzten Freitag ging alles wunderbar, doch dann wurde der Router resetet (nicht Auslieferungszustand, sondern nur kurz vom Strom weg) und seitdem gehen keine Mails mehr raus. Abrufen geht nach wie vor wunderbar.

Wie bringe ich nun den Windows Server (2000) bzw. Tobit oder den Router dazu die smtp Anfrage nicht mit der internen LAN ip, sondern mit der WAN ip zu machen?

Schonmal vielen Dank!
Mitglied: aqui
06.06.2006 um 19:24 Uhr
Wo hat dein Portmonitor denn das Packet gesehen ?? Im internen Netz ist es ja ganz klar das der Tobit Server mit einer internen RFC 1918 IP Adresse sendet. Solange du keine registrierten öffentlichen Adressen hast ist das auch normal. Der Adressumsetzungsprozess (NAT) findet immer im Router statt ! Wenn du also hinter dem Router am WAN Port dir das Packet angesehen hättest, wäre es mit der Öffentlichen IP deines Providers zum SMTP Mailserver gegangen.
Da du per POP Mails abrufen kannst, kann der NAT Prozess auch nicht fehlerhaft sein, sonst würde das auch nicht klappen. Es sieht also so aus als ob der Router seine Konfig noch hat. Allerdings würde ich das auf alle Fälle noch einmal kontrollieren. Routerprobleme und Resetts bei SMC Produkten sind hier im Forum häufig zu finden.
Ich vermute das "knallhart" eine Domain Abfrage bei eingehenden Mails macht und es ggf. dort zu Problemen kommt wenn diese nicht übereinstimmen.
Denn wenn der "Knallhart" SMTP Server dir eine Fehlermeldung zurückgibt hat er ja schon eine Kommunikationsbeziehung zu deinem Server aufgebaut, folglich kann es also niemals an falschen IP Adressen liegen, denn dann wäre diese Verbindung gar nicht erst zustande gekommen...
Bitte warten ..
Mitglied: mechworm
06.06.2006 um 19:45 Uhr
Habe den Portmonitor von Tobit verwendet.
Habe leider von hier keinen Zugriff drauf, aber die Fehlermeldung besagt:

Adress rejected. und es folgt die interne IP.

Also er meldet sich am server an, logged sich ein, alles ok, aber dann blockt halt knallhart.de ab, mit der Begründung, das der Absender unbekannt ist (interne ip) und bricht dann ab, weil er eine wan ip (logischerweise) erwartet.

Schade, dass ich die Fehlermeldung nicht mehr komplett zusammen bekomme

Steht halt ncoh was, das die Absender adresse nicht mit rcp 1234 (vierstellige Zahl) übereinstimmt, was wohl auch darauf schliessen lässt, das er alles andere, als ne Klasse C IP erwartet...

Edit: Kenne leider nicht die Einstellungen des Routers, wie sie vorher waren, da das System vorher von jemand andern betreut wurde. Aber alle möglicheen Daten, wie die des ISP sind korrekt eingetragen und Internet funktioniert ja auch wunderbar, deshalb kann ich mir nciht vorstellen, das der Router nur einen Teil seiner Konfiguration vergessen hat, sondern alles so ist wie vorher (warum auch immer dann der Mail Versand nicht mehr geht).
Bitte warten ..
Mitglied: aqui
06.06.2006 um 21:07 Uhr
Das wird auch wie gesagt nicht der Router sein, sonst würde Internet gar nicht gehen. RFC 1918 Adressen wie deine interne Adresse werden im Internet gar nicht geroutet und außerdem an den Eingangssystemen mit Filterlisten geblockt, können also folglich niemals bei einem Internet Dienstleister auftauchen. Deshalb ist die Annahme das diese Packete deinen Dienstleister über ein öffentliches Netz erreichen mehr als unwahrscheinlich.
Ich vermute vielmehr das irgendwo im SMTP Authentisierungsprozess ein Fully qualified Domain Name fehlt und dafür stattdessen die nackte IP als Domainname übermittelt wird. Fast alle Carrier prüfen eingehende Mailsendungen ob sie von ihnen bekannten oder eigenen Domains kommen. Tun sie das nicht werden sie rejected. D.h. irgendow fehlt wahrscheinlich ein Domain Eintrag wo die Mail SW dann in Ermangelung die IP Adresse nimmt. Das damit der Mailcarrier die Mails nicht annimmt und einen Spam Mailer vermutet ist klar...
Bitte warten ..
Mitglied: mechworm
07.06.2006 um 09:10 Uhr
Guten Morgen!

Die genaue Fehlermeldung war

550 <192.168.120.254>: Helo command rejected: Your client is not RFC 2821 compliant

Die Support Antwort von knallhart.de lautet:

Ein HELO hat ein fqdn zu sein, er muss seinen Hostnamen in der Form host.domain.tld
mitschicken und nicht eine IP aus einem privaten Class-C Netz (192.168 etc.pp) Dies ist eine
nicht routingfähige Adresse, ergo von dieser KANN keine Mail kommen.
Desweiteren, wenn ein Mailserver/Mailclient beim HELO seine Adresse mitschickt statt seines > Hostnamens geht das...dann hat sie aber in [] eckigen Klammern zu sein.

Ist ja alles verständlich, nur WIE stelle ich das an?
Bitte warten ..
Mitglied: aqui
07.06.2006 um 13:42 Uhr
Gib deinem Rechner einfach in den Einstellungen einen Hostnamen wie "deinkundennamemail.knallhart.de". Das sollte reichen. Ggf. ist das auch in den Settings zur Tobit SW einstellbar unabhängig vom Hostnamen auf dem die Tobit SW residiert. Das Manual oder die Tobit FAQs sollten da eigentlich weiterhelfen...
Bitte warten ..
Mitglied: mechworm
07.06.2006 um 15:54 Uhr
Ich habe den Hostname Eintrag in der Mailsoftware mehrfach (mindestens 10 mal) überprüft und neu eingetragen.

Im David unter: "PostMan > System > Generell" bei Hostname steht "meinefirma.com"

Dienste etc natürlich neu gestartet danach, sobald ich absende erscheint wieder:

(1) Connection established (640)
(1) 220 mx-01.knallhart.de ESMTP Postfix
(1) EHLO 192.168.2.119
(1) 250-mx-01.knallhart.de
(1) 250-PIPELINING
(1) 250-SIZE 26214400
(1) 250-ETRN
(1) 250-AUTH LOGIN PLAIN DIGEST-MD5 CRAM-MD5
(1) 250-AUTH=LOGIN PLAIN DIGEST-MD5 CRAM-MD5
(1) 250 8BITMIME
(1) MAIL FROM: <info@firmenname.com>
(1) 250 Ok
(1) RCPT TO: <B.Mustermann@firmenname.de>
(1) 550 <192.168.2.119>: Helo command rejected: Your client is not RFC 2821 compliant
(1) SMTP Server: Wrong Receiver Name! (B.Mustermann@firmenname.de)
(1) RSET
(1) 250 Ok
(1) QUIT
(1) 221 Bye
(1) Mail Transmission aborted

Evtl fällt ja noch jemanden etwas ein
Bitte warten ..
Mitglied: aqui
08.06.2006 um 18:42 Uhr
Dann ist diese Domain "meinfirmenname.de" nicht als akzeptierte Domain bei knallhart.de registriert. Der Knallhart.de Mail Relay Host denkt da ist ein Spammer der sich verbinden will von einer Domain die er nicht kennt und weisst den SMTP Connect Versuch ab.
Wenigstens hat er ja jetzt den Domainnamen im Log drin. Da musst du wohl den Kanllhart.de Admin kontakten und ihm sagen das eure Domains bzw. Mails davon abgewiesen werden.
Schätze das das Problem auf deren Seite ist das die eure Domain als "freundlich" bekanntgeben müssen.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Pop3 und Smtp Anfragen weiterleiten???
Frage von djakovRouter & Routing3 Kommentare

Hallo Freunde, Ich bin neu in der Gruppe und möchte gleich mal ne Frage loswerden. Ich arbeite zurzeit als ...

Server

Alle Anfragen aus internem Netz auf lokale Webseite umleiten

Frage von gandalf23Server

Hallo, leider habe ich zu meiner Thematik schon viele ähnliche Fragen gefunden, aber keine Lösungsvorschläge, die mir bei meiner ...

Firewall

Private IP wird öffentlich gerouted

Frage von whitbreadFirewall9 Kommentare

Wie kann es sein, dass eine eigentlich private IP (10.196.0.1) öffentlich gerouted wird? Jedenfalls kann ich diese aus dem ...

DNS

Private IP in öffentlichem DNS

gelöst Frage von killtecDNS14 Kommentare

Hallo, ich habe eine Domain TLD .de die öffentlich im Netz ist. Nun möchte ich von einem anderem Standort ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 2 TagenHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Informationsdienste
Probleme auf dem Server
Frage von LangeLangeInformationsdienste9 Kommentare

Hallo zusammen, ich betreibe die Seite Keine Werbelinks. In der Analyse stellen wir fest, dass die Ladezeit in der ...