Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing Problem....

Mitglied: szumbusch

szumbusch (Level 1) - Jetzt verbinden

19.10.2005, aktualisiert 17.10.2012, 7544 Aufrufe, 11 Kommentare

Hi Folks,

nachdem mir Rene mir zum Thema Netzwerk-Design ein paar gute Tips geben konnte, schlage ich mich permanent mit routing problemen rum.

Drei Netze:

192.168.0.0 255.255.255.0

192.168.10.0 255.255.255.0

192.168.20.0 255.255.255.0

Zwei W2K3-Server mit jeweils zwei NIC's
Eine zeigt ins 0.0, eine ins 10.0 bzw. 20.0

Router: IP: 192.168.0.1
Statische Routen: 192.168.10.0 Mask 255.255.255.0 192.168.0.90
192.168.20.0 Mask 255.255.255.0 192.168.0.92


Server-1:
Nic 1: IP:192.168.0.90
Mask:255.255.255.0
GW: 192.168.0.1
DNS: 192.168.0.1

Nic 2: IP: 192.168.10.250
Mask: 255.255.255.255.0
GW: 192.168.0.90
DNS: 192.168.10.250 (DNS-Server aktiv, reicht Anfragen an 192.168.0.1 weiter)

Statische Routen: 192.168.20.0 Mask 255.255.255.0 192.168.0.90
192.168.10.0 Mask 255.255.255.0 192.168.10.250
0.0.0.0 Mask 0.0.0.0 192.168.0.1 (Default route)

Server-2:
Nic 1: IP:192.168.0.92
Mask:255.255.255.0
GW: 192.168.0.1
DNS: 192.168.0.1

Nic 2: IP: 192.168.20.250
Mask: 255.255.255.255.0
GW: 192.168.0.92
DNS: 192.168.10.250 (DNS-Server aktiv, reicht Anfragen an 192.168.0.1 weiter)

Statische Routen: 192.168.20.0 Mask 255.255.255.0 192.168.20.250
192.168.10.0 Mask 255.255.255.0 192.168.0.92
0.0.0.0 Mask 0.0.0.0 192.168.0.1 (Default route)


Clients-Netz1: IP: 192.168.10.x
Mask: 255.255.255.0
GW: 192.168.10.250
DNS: 192.168.10.250

Clients-Netz2: IP: 192.168.20.x
Mask: 255.255.255.0
GW: 192.168.20.250
DNS: 192.168.20.250

Problem: Die Clients kommen nicht raus...
DNS Auflösung funktioniert, aber auf den Gateway-Servern werden die Pakete verschluckt.
PATHPING/TRACERT läßt die Pakete bis zum Server-NIC (x.x.x.250), dann ist Schluss.

Auf den Servern selber funktioniert es wunderbar.

Ich habe sicherlich einen Denkfehler, aber wo? Ich sewh' den Wald vor lauter Bäumen nicht mehr...

Danke für jede Hilfe!

Sascha
Mitglied: itmika
19.10.2005 um 12:44 Uhr
Hallo, es könnte daran liegen dass du auf dem server2 eine nic im falschen netz hast.
Probier mal die nic1 mit der 192.168.10.92. Dann kommen die Packete von 20.0 über 10.0 in das 0.0 Netz und zurück. Den Gateway auch entsprechend abändern. Probiers mal so rum. Gruss itmika
Bitte warten ..
Mitglied: szumbusch
19.10.2005 um 12:52 Uhr
Hallo, vielen Dank erstmal für Deine Mühe.
Aber ich verstehe Deine Antwort nicht so ganz.

Die Clients in beiden Netzen (10 und 20) können nicht über die Server hinaus.
Was soll das bringen, wenn ich die Netze vom 20er ins 10er route, wenn das auch nicht geht?

Sascha
Bitte warten ..
Mitglied: Midivirus
19.10.2005 um 13:03 Uhr
du musst dein Netz so aufbauen:

Internetrouter > Netz 192.168.0.0 > Router1 > 192.168.10.0 > Router2 > 192.168.20.0

Du musst den Clients in 10 klar machen, dass sie über Router 1 ins Internet kommen.

Du musst den Clients in 20 klar machen, dass sie über Router 2 ins Internet kommen, da aber Router 2 den Router 1 kennt, leitet der die Anfrage weiter!


Der Standardgateway in 10 lautet die IP von Router1
Der Standardgateway in 20 lautet die IP von Router2

Jetzt musst du in Router 2 statischen Routen eintragen, das 0.0.0.0 nach Router1 geschickt wird. 192.168.0.0 an Router1 und 192.168.10.0 an das andere interface geht.

Oder du baust einen Internetrouter mit mehreren NICs!


<Midivirus>
Bitte warten ..
Mitglied: Atti58
19.10.2005, aktualisiert 17.10.2012
Statische Routen auf den Servern musst Du nicht setzen, die werden alleine vom BS eingestellt, weil das BS ja die beiden Netzwerkkarten "kennt". Was Du brauchst, sind statische Routen auf den Clients in den "Fremdnetzen" und eventuell auf einem Router. Sieh Dir doch mal mein Tutorial

https://www.administrator.de/wissen/routing-fremdnetz-in-vorhandenes-net ...

an, vielleicht hilft Dir das,

Gruß

Atti.
Bitte warten ..
Mitglied: Midivirus
19.10.2005 um 13:19 Uhr
Und Atti58 hat das genauso gebaut wie ich das immer denke .... nur hat Atti eine Workstation als Router umfunktioniert und keinen Hardwarerouter benutzt, das ist der einzige Unterschied!

Wenn du jetzt dein Netz genauso aufbaust, dürftest du keine Schwierigkeiten bekommen!


<Midivirus>
Bitte warten ..
Mitglied: szumbusch
19.10.2005 um 17:01 Uhr
Hi.

Sorry, aber nach so langer Beschäftigung bin ich offensichtlich völlig blockiert...
Bitte nehmt es mir nicht übel, wenn ich mich total blöd anstelle...

Ich dachte, ich hätte genau das getan, was Ihr mir sagt.

Netz 10: default GW 192.168.10.250 (NIC Adresse [innen] vom Server)

Netz 20: default GW 192.168.20.250 (NIC Adresse [innen] vom Server)

Die Pakete kommen also auf jeden Fall am Server an, egal, wo sie hinmüssen. Oder?


Netz 0: default GW 192.168.0.1 (NIC Adresse Internet Router)

Welche Routen müssen auf Server 1 eingetragen sein, damit die Mitglieder aus dem Netz 10
auf das Internet zugreifen können?

Sascha
Bitte warten ..
Mitglied: Midivirus
19.10.2005 um 18:44 Uhr
Gehen wir jetzt mal davon aus, dass du alles in Reihe geschaltet hast:

Internetrouter:
Interface1 = DHPC
Interface2 = 192.168.0.1
route add -p 192.168.0.0 mask 255.255.255.0 192.168.0.1 )*
route add -p 192.168.10.0 mask 255.255.255.0 192.168.0.254 )
route add -p 192.168.20.0 mask 255.255.255.0 192.168.0.254 )
*

)* = eigentlich überflüssig, Pakete werden in das eigene Netz geschickt
) = Pakete für das 10er Netz werden an den nächsten Router geschickt
)
* = Pakete für das 20er Netz werden an den nächsten Router geschickt

RouterPC1
Interface1 = 192.168.0.254
Interface2 = 192.168.10.1
route add -p 192.168.0.0 mask 255.255.255.0 192.168.0.254 )*
route add -p 192.168.10.0 mask 255.255.255.0 192.168.10.1 )
route add -p 192.168.20.0 mask 255.255.255.0 192.168.10.254 )
*

)* = Pakete für 0er Netz an IF1
) = Pakete für 10er Netz an IF2
)
* = Pakete für 20er Netz an IF2 und an nächsten Router

RouterPC2
Interface1 = 192.168.10.254
Interface2 = 192.168.20.1
route add -p 192.168.0.0 mask 255.255.255.0 192.168.10.1 )*
route add -p 192.168.10.0 mask 255.255.255.0 192.168.10.254 )
route add -p 192.168.20.0 mask 255.255.255.0 192.168.20.1 )
*

)* = Pakete für das 0er Netz an nächsten Router
) = Pakete für das 10er Netz an IF1
)
* = Pakete für das 20er Netz an IF2

Clients:
0er Netz:
IP 192.1686.0.x
SM 255.255.255.0
GW 192.168.0.1 < das Gateway kennt durch die Routen die anderen Netze

10er Netz:
IP 192.168.10.x
SM 255.255.255.0
GW 192.168.10.1 < das Gateway kennt durch die Routen die anderen Netze

20er Netz:
IP 192.168.20.x
SM 255.255.255.0
GW 192.168.20.1 < das Gateway kennt durch die Routen die anderen Netze

Ich gehe davon aus, das du es folgendermaßen verkabelt hast:

http://midivirus.homeftp.net/administrator/routing.jpg

<Midivirus>
Bitte warten ..
Mitglied: szumbusch
19.10.2005 um 20:05 Uhr
Danke sehr für die Mühe, die Du Dir gemacht hast!

Nein, es ist nicht in Reihe geschaltet.

Netz1---Server 1 --- Switch1 -> Router
Netz2---Server 2 ----|

Man kann also davon ausgehen, daß die Netze unabhängig voneinander sind.
Wenn Sie sich erreichen können, ist das gut, aber das Netz1 und Netz2 ins Internet können
ist definitiv wichtiger.

Also werde ich mir die Konfig bezüglich Netz1 genauer betrachten. Denn das entspricht
dem tatsächlichen Zustand.

Netz2 wäre dann analog, nur mit anderen Adressen.


Sascha
Bitte warten ..
Mitglied: Midivirus
19.10.2005 um 22:00 Uhr
Okay, einfacher wäre es, wenn man es in Reihe schaltet!

So hab ich das zumindest im Berufschulunterricht aufgenommen ... aber ich habe keine mittel, das mal real auszuprobieren, sonst hätte ich das gern gemacht!

<Midivirus>


PS: ich versuche mir mal Gedanken zu machen, aber morgen mehr!
Bitte warten ..
Mitglied: Atti58
19.10.2005 um 22:01 Uhr
Du musst folgende Routen setzen:

auf dem Router:

finde Netz 192.169.10.0 Maske 255.255.255.0 über NIC 192.168.0.90
finde Netz 192.169.20.0 Maske 255.255.255.0 über NIC 192.168.0.92

auf den Clients im 10-ner Netz:

route add -p 192.168.0.1 mask 255.255.255.255 192.168.10.250

auf den Clients im 20-ner Netz:

route add -p 192.168.0.1 mask 255.255.255.255 192.168.20.250

Die Server bekommen keine statischen Routen und die internen Karten kein Gateway, DNS ist ok,

Gruß

Atti.
Bitte warten ..
Mitglied: szumbusch
20.10.2005 um 09:50 Uhr
Hallo, allen vielen Dank für die Mühen!

Heute morgen 3:15 Uhr ist der Knoten geplatzt.

Es war in der ursprünglichen Konfig alles richtig, aber:

Entweder habe ich mich verklickt, oder einfach etwas falsches gemacht.

Ich hatte ursprünglich RIP aktiviert. Da die Telekom (Schulen ans Netz...) aber dauernd die Verbindung abgebaut hat und deshalb die Routing tables höchst unzuverlässig waren, wollte ich RIP deaktivieren.

Dabei ist das komplette IP Routing hinten 'runter gefallen.

'Routing und RAS' war auf den Servern einfach nicht mehr vorhanden.

Neu aktiviert, aber ohne RIP und alles lief.

So kanns gehen.....

Dank an alle, die sich viel Mühe gemacht haben.

Ich hoffe, ich kann auch mal behilflich sein.

Sascha
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Cisco SG300 - Routing Problem
Frage von StandardpasswortSwitche und Hubs15 Kommentare

Okay, wie erwartet bekomme ich die das Routen mit dem SG300 nicht hin. Hier nochmal die gewünschte Zielkonfiguration: VLAN10: ...

Router & Routing
Routing Problem VLANS Internet
Frage von CyberurmelRouter & Routing74 Kommentare

Hi all , nachdem die Kiste Thread (danke Aqui! ) jetzt einigermaßen läuft für TV und Internet habe ich ...

Router & Routing
OpenVPN Installation Routing Problem
Frage von intaneRouter & Routing48 Kommentare

Huhu, ich habe Schwierigkeiten bei der Installation von OpenVPN auf einen Win10 Rechner. Auf dem Rechner ist eine Software ...

Router & Routing
PFsense Routing Problem
Frage von daMopsiRouter & Routing

Hallo Zusammen, vorab ein paar Informationen. Als Firewall haben wir eine PFSense (aktuelle Firmware) im Einsatz. Diese reicht soweit ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 7 StundenErkennung und -Abwehr1 Kommentar

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Vmware
VMware Updates gegen L1 Lücke
Information von sabines vor 14 StundenVmware

Für die Vmware Produkte vCenter Server, ESXi, Workstation und Fusion stehe Updates bereit um die L1 Lücke zu schließen. ...

Drucker und Scanner
HP-MF-Drucker per Fax angreifbsr
Information von Lochkartenstanzer vor 2 TagenDrucker und Scanner3 Kommentare

Endlich eine sinnvolle Verwendung für Faxe: Damit kann man offensichtlich den Drucker übernehmen. lks

Router & Routing

Das pfSense Buch ist jetzt für jeden kostenlos zu beziehen

Tipp von magicteddy vor 3 TagenRouter & Routing2 Kommentare

Bisher war das Buch nur für zahlende Unterstützer verfügbar, jetzt steht für Jedermann kostenlos zur Verfügung. Siehe auch The ...

Heiß diskutierte Inhalte
Microsoft
VPN Verbindung kann nicht aufgebaut werden
Frage von AlexderITlerMicrosoft35 Kommentare

Hallo, Ich möchte an einem unserer PCs in unserer Tochterfirma eine VPN zu unserem Netzwerk einrichten. Das schlägt allerdings ...

Windows Server
Domäne einsilbig mit nur einem Namen benannt - sowie AD und MX auf einer VM Kardinalsfehler?
Frage von TomTestWindows Server27 Kommentare

Hallo liebe Freunde gepflegter Probleme, seit kurzem soll ich eine Domäne verwalten die zuvor von einem IT-Dienstleister erstellt und ...

Datenbanken
MySQL Datenbank Import Aufgabe für mehrere .csv dateien
gelöst Frage von Marcel1989Datenbanken19 Kommentare

Hi, ich komm nicht weiter. Ich hab auf einem Windows Server 2012 r2 eine MariaDB/MySQL laufen. Nun soll diese ...

DNS
Gibt es eine Art DNS Proxy?
Frage von icepietDNS15 Kommentare

Hallo Nerds, Ich würde gerne folgendes machen: ts.domain.de:3389 soll auf 1.2.3.4:3389 auflösen ts2.domain.de:3389 soll auf 1.2.3.4:3390 auflösen Gibt es ...