Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing zwischen VLANs teilweiße blockieren - Procurve 2626

Mitglied: shitcake22

shitcake22 (Level 1) - Jetzt verbinden

25.10.2007, aktualisiert 03.11.2007, 10395 Aufrufe, 2 Kommentare

Routing nur zum Uplink-VLAN und nicht zu allen

Hallo zusammen,

ich bastel gerade an einer Anbindung an eine Standleitung für 3 eigentlich getrennte Netze in einem Hotel. Die Benutzergruppen/VLANs sind:
- Gäste (über WLAN-AccessPoints)
- Hotelverwaltung
- Personal
Die Drei Gruppen sollen über VLANs getrennt werden und gemeinsam über die Standleitung ins Internet.
Meine bisheriger Stand int folgender:

Die oben genannten VLANs sind auf einem HP Procurve 2626 eingerichtet. Ein 4. VLAN für den Uplink ist auch konfiguriert. Das Routing auf dem Switch ist aktiviert, wodurch sich User aus verschiedenen VLAN erreichen können. An dem Uplink-VLAN hängt ein Linksys WRT54gl, der mit NAT die Anfragen an den Company-Connect-Router der Telekom weiterreicht. Auf dem Procurve ist die Default-Route zu dem Linksys eingetragen und auf dem Linksys die Rückrouten jeweils in die VLAN zurück. Hier mal die Konfig des Procurve:

hostname "VerteilerWB"
ip default-gateway 192.168.0.1 -> IP des Linksys
ip routing
vlan 1
name "Uplink"
untagged 25-26
ip address 192.168.0.3 255.255.255.0
no untagged 1-24
exit
vlan 2
name "Gaeste"
untagged 1-8
ip address 192.168.2.1 255.255.255.0
exit
vlan 3
name "Verwaltung"
untagged 9-16
ip address 10.0.10.1 255.255.255.0
exit
vlan 4
name "Personal"
untagged 17-24
ip address 192.168.1.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.0.1

Bis hier funktioniert alles wunderbar. Das Problem liegt nun darin, dass die 3 Benutzergruppen sich so jetzt noch erreichen, weil der Procurve die Direktangeschlossenen Netze immer routet. Mein Ansatz war über ACLs die IP-Bereiche gegenseitig zu sperren, musste dann aber feststellen, dass der 2626 keine ACLs kann. Ich habe die Source-Port Filter ausprobiert, mit denen man die Verbindungen zwischen einzelnen Ports sperren kann. Offensichtlich funktioniert das aber aber nicht bei eingeschaltetem Routing. Steht irgendwie so auch zimlich undeutlich in den Manuals.

==> Wie unterbinde ich, dass sich die 3 Benutzergruppen erreichen?

Ein 2. Problem wäre die Bandbreite des Anschlusses zur Standleitung zu beschränken. An der Standleitung hängt noch ne Firma dran, denen ich nicht die gesamte Bandbreite klauen darf. Soll heißen, ich sollte irgendwo (ProCurve oder Linksys) die Bandbreite auf z.B. 400kbit/s beschränken.

Viel Dank
shitcake
Mitglied: aqui
02.11.2007 um 13:46 Uhr
Source Port Filter funktionieren NUR auf Layer 2 nicht für Layer 3 Traffic, helfen dir also leider nicht bei deinem Problem.
Schade, ein sehr gutes Konzept mit dem richtigen Ansatz und Konfiguration aber leider dem Reiz des Billigen erlegen bei der Switchhardware oder vor dem Kauf vergessen zu fragen...
Andere Switchhersteller am Markt supporten problemlos Accesslisten auf den IP Interfaces die dann eine detailierte Steuerung des Zugriffs zwischen den VPLANs kinderleicht zulassen.
Mit dem HP Switch hast du technisch keine Chance das zu realisieren...leider !
Was du machen kannst ist die IP Adressen entfernen und über eine externe Firewall wie z.B. IPCop oder M0n0wall die Zugriffssteuerung erledigen.
Dann hätte aber ein noch billigerer Layer2 VLAN Switch ohne L3 Option gereicht so das das Geld was man in den 2626 mit L3 gesteckt hat für die Katz ist...
Bitte warten ..
Mitglied: shitcake22
03.11.2007 um 14:23 Uhr
Hallo,
jo, so hab ich das befürchtet. In dem Fall, vielen Dank für die Bestätigung, is zwar nicht schön, aber jetzt weiß ich es wenigstens sicher.
Mittlerweile ist mein Ansatz auch dein oben beschriebener. Ich will den Linksys WRT54GL mit DD-WRT frisieren und dann die VLANs über nen Trunk auf den Linksys schicken, dort routen und filtern. Hat damit jemand Erfahrung?
Schöne Grüße und vielen Dank
Shitcake
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
HP Procurve VLAN und Routing
gelöst Frage von Fisch2005LAN, WAN, Wireless3 Kommentare

Hallo, ich bin gerade bei einer Aufgabenstellung an der ich nicht weiter komme. Zur Ausgangssituation: Zentral habe ich ein ...

Netzwerkmanagement
HP ProCurve 2626 Default Anmeldung
gelöst Frage von ukulele-7Netzwerkmanagement2 Kommentare

Ich habe zwei gebrauchte ProCurve 2626 Switches erstanden und beide scheinen einwandfrei zu laufen. Allerdings ließ sich nur einer ...

Netzwerkgrundlagen

Netzwerkaufbau und Routing mit HP ProCurve

Frage von westberlinerNetzwerkgrundlagen16 Kommentare

Hallo zusammen, ich habe hier parallel zum alten Netzwerk ein neues aufgebaut, aber habe jedoch alle 4-5 Tage mal ...

Router & Routing

Routing auf Router-IP in anderen Subnets blockieren

gelöst Frage von BinaryBearRouter & Routing4 Kommentare

Gehen wir mal davon aus ich habe einen PC mit der IP 192.168.0.2, der Router hat in dem Netz ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 2 StundenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 12 StundenSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 12 StundenMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 13 StundenHardware11 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux23 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
solved Frage von wusa88DSL, VDSL18 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...

Windows Server
Domänencontroller trennen
Frage von Akit57Windows Server13 Kommentare

Hallo, ich hoffe das mir hier jemand meine Frage trotz der spärlichen Informationen die ich geben kann beantworten kann: ...

LAN, WAN, Wireless
Kommunikation zwischen verschiedenen IP-Bereichen
Frage von DirkHoLAN, WAN, Wireless13 Kommentare

Hallo zusammen, von Unitymedia habe ich ein neues Modem (Connect Box) erhalten, das u.a. IPv4 aber keinen Bridge Mode ...