Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RunAs unter Windows NT

Mitglied: Der-Phil

Der-Phil (Level 2) - Jetzt verbinden

25.01.2006, aktualisiert 09.12.2008, 11671 Aufrufe, 14 Kommentare

Guten Tag,


ich habe hier das Problem, dass ich auf WinNT-Rechnern einen Ersatz für den RunAs-Befehl von Windows XP bräuchte.

Ich müsste einzelne Programm als Administrator starten.

Gibt es hier eine Möglichkeit?

Vielen Dank im Voraus

Gruß
Phil
Mitglied: Der-Phil
26.01.2006 um 16:14 Uhr
Hi!

Das Programm ist wirklich genial. Hat mir zwar in diesem Fall nicht geholfen, aber vielen Dank!


Problem ist, dass ich auch in einer SU-Sitzung es irgendwie nicht schaffe, ein Netzlaufwerk für den Superuser zu mappen.

Danke trotzdem. Das Tool werde ich sicher noch gut gebrauchen können.

Phil
Bitte warten ..
Mitglied: meinereiner
26.01.2006 um 17:19 Uhr
Hmm, was geht denn beim mappen des Laufwerks schief??
Bitte warten ..
Mitglied: Der-Phil
26.01.2006 um 19:13 Uhr
Hi!

Das Mappen an sich geht meist.
Dann ist aber das gemappte Lauwerk auch für den User sichtbar im Arbeitsplatz.

Genau das möchte ich aber umgehen...

Phil
Bitte warten ..
Mitglied: gijoe
26.01.2006 um 19:25 Uhr
hi, schon mal mit AutoIt probiert? Befehl RunAs(..)
Grüsse GI
Bitte warten ..
Mitglied: jap
30.01.2006 um 20:43 Uhr
schau dir mal
http://www.lansweeper.com/ls/lsrunasold.aspx
an.

LSrunas can be used to run a command using another user account
and passing the password as a parameter

LSrunasE
This is almost the same version as lsrunas only now it's possible to pass your password encrypted. There is a tool included to encrypt your password.

.. oder
http://www.robotronic.de/runasspc.html

bin mir nicht sicher ob´s unter NT auch läuft - testen!

Have fun
Jap
Bitte warten ..
Mitglied: freibadschwimmer
09.12.2008 um 16:49 Uhr
Hi Phil,

das ist ja schon einige Tage her. !!! Heute !!! stehe ich vor dem gleichen Problem (alte Umgebung), leider darf ich auf den Maschinen keine neue SW installieren.
Hast Du eine Lösung für mich?

Danke
Bitte warten ..
Mitglied: Der-Phil
09.12.2008 um 17:14 Uhr
Hi!

Was ist denn genau Dein Problem? Der Tipp im ersten Post startet grundsätzlich als "RunAs", aber das gemappte Netzlaufwerk ist eine andere Baustelle.

Gruß
Phil
Bitte warten ..
Mitglied: freibadschwimmer
09.12.2008 um 17:30 Uhr
Danke für die schnelle Reaktion.
Ich muss ein Programm starten, das für den Start noch ein Konfig-File mitbekommt und einige Reg-Einträge nachzieht. Leider verkraftet SupSU den Programmaufruf auch nicht. RunAs funktioniert gar nicht ("CreateProcessWithLogonW" konnte i d dll "adavapi32.dll" nicht gefunden werden).

Momentan versuche ich mich an AutoIt, da funktioniert der RunAs und RunAsWait Befehl aber auch nicht.

Gruss,
Volko
Bitte warten ..
Mitglied: Der-Phil
09.12.2008 um 17:41 Uhr
Hi!

Geht es denn überhaupt um Windows XP?
Läuft das Ganze mit dem XP-RunAS?

Phil
Bitte warten ..
Mitglied: freibadschwimmer
09.12.2008 um 17:56 Uhr
Nein, der Thread heißt doch "RunAs unter Windows NT".
Somit handelt es sich um das legendäre MS windows NT 4 WS SP6. Da dachte ich mir, dass ich hier in guten Händen bin.

LG,
Volko
Bitte warten ..
Mitglied: Der-Phil
09.12.2008 um 18:14 Uhr
Hi!

Interessant wäre eben, wie sich das Ganze unter XP mit RunAs verhält.

Gruß
Phil
Bitte warten ..
Mitglied: freibadschwimmer
09.12.2008 um 18:38 Uhr
Interessant wäre das sicherlich, hilft mir jedoch nicht bei der Lösungsfindung, da NT 4. Ist auch nicht so ganz einfach die ganze Sache nachzustellen, da es sich um eine Speuial-SW handelt, die dann auch noch Dinge mittels der DCOM-Komponente initiert und ausführt ...

Haste einen Tipp für NT? Wie hast Du Dein damaliges Prob in den Griff bekommen? Mit SupSU?

Greets,
Volko
Bitte warten ..
Mitglied: Der-Phil
09.12.2008 um 19:25 Uhr
Hi!

Ich befürchte, dann kann ich Dir nicht helfen...

Damals habe ich das Problem nur umgehen können, indem ich es ganz anders gelöst habe. Mit SuperSu liefen dann alle anderen Sachen.

Gruß
Phil
Bitte warten ..
Ähnliche Inhalte
Windows 10
Phänomen von Windows 10 runas
gelöst Frage von DerWoWussteWindows 1012 Kommentare

Moin Kollegen. Eigentlich zu früh am Nachmittag für Denksport, ich versuch's trotzdem: Ich habe hier meine administrative Workstation, (Win10 ...

Verschlüsselung & Zertifikate

NT-Password (NT Hash) unter Windows generieren

gelöst Frage von PedantVerschlüsselung & Zertifikate7 Kommentare

Hallo, es muss doch irgendwie möglich sein ein NT-Password (einen NT-Hash) unter Windows zu erzeugen!? Es ist doch ein ...

Windows 10

Seit Windows 10 1511 ist "runas" nicht mehr nutzbar

gelöst Frage von FireWALLWindows 1013 Kommentare

Hallo zusammen! Nach dem Update auf Windows 1511 (unfassbar, dass so etwas "Update" genannt werden darf, es wird dabei ...

Windows Server

Audit RunAS Administrator

Frage von Woznafi01Windows Server7 Kommentare

Hallo, ich möchte gerne in meinem Unternehmen das Protokollieren des RunAS Administrator/RunAS anderen Benutzer aktivieren bzw. filtern. Mein Ziel: ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 1 TagPeripheriegeräte2 Kommentare

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 2 TagenWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 2 TagenWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 4 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Humor (lol)
Freitagsfrage: Was tun, wenn der Admin der DAU ist?
gelöst Frage von VoiperHumor (lol)32 Kommentare

Moin Zusammen, Eine nicht ganz ernst gemeinte Frage an die Außendienstler unter uns. Zusammenfassung: Ein Inhouse Admin ruft bei ...

Windows Netzwerk
LTE Modul - Kein Internet trotz Verbindung
Frage von killtecWindows Netzwerk19 Kommentare

Hallo, ich habe hier ein Dell 7390 2-in-1 mit W10 Pro wo ich nachträglich eine LTE-Karte (Original Dell DW5811e ...

LAN, WAN, Wireless
HP Probook 470 G4 - abbrechende Downloads
Frage von joern1LAN, WAN, Wireless19 Kommentare

Folgendes Problem, für einen Tipp wäre ich dankbar: Bei WLAN-Verbindung zum Internet (nicht LAN) kommt es bei etwas größeren ...

Router & Routing
Routing Problem mit Kaskade FritzBox und pfsense zugeriff nur von der firewall auf die clients und 0.0.0.0
Frage von ukl1967Router & Routing18 Kommentare

Hallo, ich habe ein an sich triviales Problem elches ich allerdings nicht gelöst bekomme. NAS 10.5.10.53 Mein Netz baut ...