Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Runas unter Windows XP Embedded

Mitglied: IziBizi

IziBizi (Level 1) - Jetzt verbinden

20.07.2011 um 13:42 Uhr, 3533 Aufrufe, 2 Kommentare

Hallo Community,

ich habe ein Problem mit der Implementierung von dem RunAs-Kommando unter Windows XP Embedded.
In unserem XPE System ist die Datei RunAs.exe leider nicht vorhanden. Da kam mir die Idee sie einfach von einem
Windows XP PC auf den XPE PC zu kopieren. Allerdings hat dies nicht ganz so funktioniert wie gedacht, denn das RunAs
Kommando benötigt des weiteren die Datei seclogon.dll. Also habe ich diese auch auf das XPE System kopiert und als
Service registriert. Wenn ich nun im Service Manager (services.msc) nachschaue wird der Dienst (Secondary Logon) auch aufgelistet,
allerdings ist er nicht aktiv. Bei der Aktivierung des Dienstes bekomme ich folgenden Fehler:

Could not start the Secondary Logon service on Local Computer.
Error2 : The System cannot find the file specified.

Bei der Suche nach dem Fehlers bei Google bin ich darauf gestoßen, dass dieser Fehler durch eine Fehlerhafte Pfadangabe
in der Registry verursacht werden könnte. Dies habe ich überprüft und der einzige Pfad im Zusammenhang mit
seclogon verweist auf die svchost.exe, welche im richtigen Ordner (WINDOWS/system32) vorhanden ist.

Eine Frage wäre nun ob noch andere Dateien von RunAs benötigt werden. Wenn ja welche?

Oder hat jemand eine andere Idee?

Gruß
Mitglied: HStumpf
20.07.2011 um 16:56 Uhr
Hallo,

vieleicht hilft es im Target Designer nur das Paket RunAs zu paketieren und schauen
was registriert wird. (werden muss)

Horst
Bitte warten ..
Mitglied: IziBizi
21.07.2011 um 08:00 Uhr
Hallo Horst,

danke für die Antwort. Allerdings habe ich keine Möglichkeit den Target Designer zu benutzen,
da das System von einer Fremdfirma installiert wurde und ich nur ein Image des ganzen Rechners habe,
das immer auf den/die Rechner spielen.
Oder gibt es einen anderen Weg den Designer zu verwenden außer bei der Installation?

Gruß
Bitte warten ..
Ähnliche Inhalte
Microsoft

Windows XP Embedded Partition verschwunden

Frage von TiloklomMicrosoft4 Kommentare

Hallo, Auf der Arbeit haben wir ein ganz großes Problem, welches mit Windows XP Embedded zusammen hängt. Ich hoffe ...

Windows XP

SP3 für Windows XP Embedded Version 2002

Frage von Michael-24Windows XP4 Kommentare

Hallo Gemeinde, ich bräuchte für Windows XP Embedded Version 2002 das Servicepack 3 zum download? Hat jemand von euch ...

Windows 10

Phänomen von Windows 10 runas

gelöst Frage von DerWoWussteWindows 1012 Kommentare

Moin Kollegen. Eigentlich zu früh am Nachmittag für Denksport, ich versuch's trotzdem: Ich habe hier meine administrative Workstation, (Win10 ...

Windows 7

Windows 7 Embedded sichern

Frage von GarnalothWindows 71 Kommentar

Hallo, ich würde gerne von unseren Futro S700 mit Windows 7 Embedded Std. eine Sicherung machen. Mich würde interessieren ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 15 StundenHumor (lol)3 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 1 TagSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...

Windows Netzwerk
Backup über WAN
Frage von petereWindows Netzwerk11 Kommentare

Hallo, ich muss aus einem entfernten WAN (synchrone 1Gbit) Daten sichern. Dabei handelt es sich sowohl um wenige große ...