Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst [Samba] NT STATUS BAD NETWORK NAME - Kein Zugriff mehr

Mitglied: StefanHoth

StefanHoth (Level 1) - Jetzt verbinden

26.02.2007, aktualisiert 28.02.2007, 25364 Aufrufe, 5 Kommentare

Debian-System - Der Zugriff funktioniert weder von Remote-Clients noch von der Konsole auf der gleichen Maschine...

Hallo!

Nach vielen Monaten ohne Probleme möchte mein Samba einfach nicht mehr arbeiten. Dabei stellt es sich sehr clever an, denn es gibt einfach keine Fehlermeldung aus und somit habe ich auch keine Ahnung, wo ich ansetzen soll.

Ich schätze, dass es nach einem Update (SWAT? Samba?) nicht mehr funktionierte, aber ich bin mir nicht sicher und kann es leider nicht mehr ganz nachvollziehen.

Das Verhalten stellt sich wie folgt dar:

Egal, ob von einem remote-client oder von localhost auf der Konsole erhalte ich nach korrektem Login:


tree connect failed: NT_STATUS_BAD_NETWORK_NAME


Ich habe bereits samba in meiner Verzweifelung komplett gelöscht (--purge) und neu installiert. Leider brachte dies keine Änderung. Meine derzeitige Miniconfig lautet wie folgt:


server:/tmp# testparm -s
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
  1. Global parameters
[global]
workgroup = JS
server string = %h server (Samba %v)
obey pam restrictions = Yes
passdb backend = tdbsam, guest
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
wins support = Yes
panic action = /usr/share/samba/panic-action %d
invalid users = root

[homes]
comment = Home Directories
read only = No
create mask = 0700
directory mask = 0700
browseable = No

[printers]
comment = All Printers
path = /tmp
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers


Ich würde gern noch einen Tip bekommen, wie ich hiermit etwas aufgelistet bekomme:

server:/tmp# smbclient -L //localhost -U stevie
Password:
Domain=[SERVER] OS=[Unix] Server=[Samba 3.0.14a-Debian]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME


Danke,

stevieboy

PS: Wenn noch Files oder Dumps fehlen reiche ich sie gern nach...

PPS: Debian Sarge mit Samba ( 3.0.14a-3sarge4 )
Mitglied: Alfredus
26.02.2007 um 16:47 Uhr
1. Vermutung: WinNS geht nicht. Mach mal nmblook <NETBIOS-Name des Servers>. Melde bitte die Ergebnisse.
2. Vermutung: nmbd und/oder winbindd läuft nicht. Melde bitte den Status
3. Benutze erst mal den Netbios-Namen anstatt die IP oder den DNS-Alias. Das hilft Fehler auszuschließen.
4. Füge deiner smb.conf den parameter netbios name = SERVERXY hinzu. Der fehlt bei dir und ist Quell ewiger Freude...wenn er fehlt.
5. Check mal ob dein Nutzer setvie überhaupt vorhanden ist. Vielleicht hat SWAT ihn ja irgendwie mitgerissen.
6. In der Sektion [homes] fehlt noch eine Pfadangabe wo sich die Homeverzeichnisse der Nutzer befinden.

Gruß und viel Glück
Alfredus

BTW: apt-get --purge <paket> entfernt nicht unbedingt alle Dateien/abhängige Pakte. Aber das ist hier scheinbar nicht so das Problem.

BTW 2: SWAT und samba würde ich nur bedingt empfehlen. Auch wenn es am Anfang sehr verlockend erscheint, mit SWAT einen Fileserver aufzusetzen.
Bitte warten ..
Mitglied: StefanHoth
26.02.2007 um 17:14 Uhr
1. Vermutung: WinNS geht nicht. Mach mal
nmblook <NETBIOS-Name des Servers>.
Melde bitte die Ergebnisse.

Die Namensauflösung funktionierte, nachdem ich die Option "netbios name = SERVER" in die config übernahm.

Leider hilft es nicht bei der Problemlösung.

2. Vermutung: nmbd und/oder winbindd
läuft nicht. Melde bitte den Status

Also nmbd läuft, aber winbindd war nicht installiert. Habe es via apt-get nachinstalliert. Nun läuft es, habe auch Dienste neu gestartet, aber es ändert leider trotzdem nichts am Fehlerbild.

3. Benutze erst mal den Netbios-Namen
anstatt die IP oder den DNS-Alias. Das hilft
Fehler auszuschließen.
4. Füge deiner smb.conf den parameter
netbios name = SERVERXY hinzu. Der fehlt
bei dir und ist Quell ewiger Freude...wenn er
fehlt.


Wie bereits unter 1. geschrieben habe ich das nachgetragen, aber es nützt nix.

BTW: apt-get --purge <paket> entfernt
nicht unbedingt alle Dateien/abhängige
Pakte. Aber das ist hier scheinbar nicht so
das Problem.


Ja, das ist mir bewusst und daher habe ich auch alle Spuren in /usr/share und /var/lib gelöscht, bevor ich neu installiert habe.

BTW 2: SWAT und samba würde ich nur
bedingt empfehlen. Auch wenn es am Anfang
sehr verlockend erscheint, mit SWAT einen
Fileserver aufzusetzen.


Ja, am Anfang hat es geholfen, aber nun mach ichs ja auch schon länger in der Config direkt.


Gibt es noch weitere Ansätze? Wäre für jeden Hint dankbar...

Danke,

Stefan
Bitte warten ..
Mitglied: Alfredus
27.02.2007 um 07:17 Uhr
Gibt es noch weitere Ansätze? Wäre für jeden Hint dankbar...

Hmmm... NT_STATUS_BAD_NETWORK_NAME bekommt man eigentlich, wenn der Nutzer nicht im Samba vorhanden ist. Lege mal einen neuen Nutzer im samba an.

Vorletztes Mittel:
01.
log level = 1 
02.
log file = /var/log/sambalog.%m
Füge das in die smb.conf ein. Die Logs sind vom Server, welcher meist geschwätziger bzgl. Fehlermeldungen als smbclient ist. Check mal die Logs wenn du wieder einen NT_STATUS_BAD_NETWORK_NAME bekommst.

Letztes Mittel:

Mein Vorschlag wäre, dass du dir eine funktionierende smb.conf aus dem Netzt ziehst. Beispiele gibt es reichlich. Ich vermute nämlich, dass du auf einer (zerschossenen) Konfiguration von SWAT arbeitest. Alternativ kannst du mit dpkg-reconfigure <package> dir auch eine neue Konfiguration erstellen. Egal wie, lösche bitte vorher die smb.config bzw. benenne sie um. Zusätzliche würde ich auch noch die start-stop-skripte von samba entfernen. Vorher noch mit locate tdbsam die Passwortdatei von Samba suchen und umbenennen/löschen.

Gruß
Alfredus
Bitte warten ..
Mitglied: StefanHoth
28.02.2007 um 16:01 Uhr
Hallo Alfredus!

Vielen Dank für Deine Hilfe!

Ich habe das Problem endlich lokalisieren können:

Die Zugriffsrechte des ROOT "/" wurden durch ein Script versehentlich geändert (nicht von mir)... Da die Rechte dann auf 700 mit einem Benutzer "Postfix" standen, ging gar nichts mehr.

Leider bin ich erst darauf gekommen, nachdem ein Hinweis im Apache-Log zufinden war... der ging nämlich auch nicht mehr.

Nun geht wieder alles.

Vielen Dank trotzdem.

Stefan
Bitte warten ..
Mitglied: Alfredus
28.02.2007 um 16:32 Uhr
Die Zugriffsrechte des ROOT "/" wurden durch ein Script versehentlich geändert

Das ist ja ein dickes Ding. Auweia, an so einem Fehler kann man echt verzweifeln. Freut mich, dass wieder alles geht.

Gruß
Alfredus
Bitte warten ..
Ähnliche Inhalte
Windows 8

Windows 8 - Samba mehrere network share Verbindungen

Frage von xseven7Windows 83 Kommentare

Hallo, Ich habe windows 8.1 und habe zwei samba shares: 1.) \\ip\mystuff1 2.) \\ip\mystuff2 Nun möchte ich diese beiden ...

Apache Server

Bad Request

Frage von HacktoxXApache Server6 Kommentare

Guten Tag, habe seit einigen Tagen das Problem, dass wenn ich über http auf meine Website zugreifen will, einen ...

Windows Userverwaltung

Trotz Status "Besitzer" kein Recht dir-name zu ändern

gelöst Frage von RaidManWindows Userverwaltung6 Kommentare

Hallo Leutz, ein WIN 7 Rechner mit 2 4TB HD nervt mich mit seinen Berechtigungen Sch auf einer HD ...

Samba

RedHat Samba User-Zugriffe loggen

gelöst Frage von AkroshSamba6 Kommentare

Hallo zusammen, ich habe einen RedHat 6 Fileserver mit Samba, das gute Stück ist locker 10 Jahre alt und ...

Neue Wissensbeiträge
Windows Server
DP mit Benutzerdatenträger und VDS-SAN-policy
Tipp von lcer00 vor 10 StundenWindows Server

Hallo zusammen, ich habe gerade einen halben Tag mit Recherche zu dem Thema hinter mir und endlich ein Ergebnis. ...

Internet

Europa baut Zensurinfrastruktur auf: EU-Parlament stimmt für Upload-Filter, Leistungsschutzrecht und gegen KI-Forschung

Information von Frank vor 3 TagenInternet9 Kommentare

Eine sehr schlechte Entscheidungen für die Zukunft Europas ist gefallen: Der Rechtsausschuss im EU-Parlament stimmte heute morgen in einer ...

Windows 10

Mikrofon von Headset geht nach Update auf Windows 10 1803 nicht mehr

Tipp von Deepsys vor 5 TagenWindows 102 Kommentare

Ich verwende ein Plantronics Headset das per USB mit dem Windows 10 PC verbunden ist. Damit kann ich auch ...

Video & Streaming

Ruckelfreies Fernsehen auf Smartphone oder Tablet - in SD oder gar HD - Eine Alternative zum Fritz DVB-C Receiver

Anleitung von power-user vor 6 TagenVideo & Streaming10 Kommentare

Wer kennt das nicht: Man möchte gemütlich auf dem Balkon sitzen und vielleicht grillen und dabei das WM-Spiel gucken ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Sophos UTM 110 120 in Betrieb nehmen und IP Adresse am Cisco Switch herausfinden
Frage von KabuntelLAN, WAN, Wireless11 Kommentare

Hallo, ich mache in Rahmen meiner Umschulung zum Fachinformatiker - Systemintegration ein Praktikum. Gestern hat mir mein Chef gleich ...

Switche und Hubs
VPN Router empfehlung
Frage von mstSwitche und Hubs9 Kommentare

Moin Leute ich hab mal eine Frage an die VPN und Netzwerkprofis unter euch. Folgendes Szenario, ich habe einen ...

Hardware
Neue Hardware für meine pfSense - APU2 apu4b4?
Frage von jokru1Hardware8 Kommentare

Hallo zusammen, ich betreibe aktuell meine pfSense auf einer APU2-Hardware (3 NICs, 4GB RAM) ohne AES-NI-Unterstützung. Diese möchte ich ...

Firewall
Firewall Vorteil und Nachteil
gelöst Frage von vegeta500Firewall7 Kommentare

Hallo , ich habe eine Fragen (Theoretische), Welches Sicherheitsproblem kann eine gewöhnliche Firewall nicht lösen