Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Samba - Problem mit den Profilen

Mitglied: Vatras

Vatras (Level 1) - Jetzt verbinden

24.09.2006, aktualisiert 26.09.2006, 4861 Aufrufe, 7 Kommentare

Guten Abend zusammen,

ich habe folgendes Problem mit meinem Samba Server:

Es existiert eine Domäne "Servus" an dich ich mich bereits mit einem Client erfolgreich angemeldet habe. Jedoch kann ich mich nur mit einem Benutzer z.B. "Client" erfolgreich an die Domäne anmelden. Versuche ich es mit anderen Benutzern (Unix und Samba Account existiert) schlägt die Integration fehl.
Außerdem kann ich das Benutzerprofil von "Client" nicht in dem Verzeichnis finden,das ich dafür angegeben habe (siehe Auszug aus meiner smb.conf) Besser gesagt finde ich es überhaupt nicht auf dem Server obwohl es ja da sein muss, da Änderungen, z.B am Desktop übernommen werden. Ich benutze als Clients OS WinXP (Profil serverseitig speichern ist aktiviert). Hier nun ein Auszug aus der smb.conf:

[global]
workgroup = REINNET
server string = Samba %v
logon path = /srv/samba/profiles/%U
domain logons = yes
os level = 65
preferred master = yes
domain master = yes
wins support = yes
invalid users = amd
read only = no
profile acls = Yes



[netlogon]
comment = Domäne Logon
path = /srv/samba/netlogon/
guest ok = yes

[profiles]
comment = Netzwerk Profil
path = /srv/samba/profiles/%U

Ich bin noch Neuling auf dem Gebiet und bin für jeden Tipp dankbar, da ich absolut nicht mehr weiter weiß.

Danke im Voraus für eure Hilfe

Vatras
Mitglied: DERMOLCH
25.09.2006 um 11:56 Uhr
Es gibt in der Registry einen String der die Art der Verschlüsselung zu einen Domäne regelt. Den sollte man auf 0 oder 1 setzen und dann mal probieren. Such mal in der Registry nach :

signorseal und verändere dort man den Wert bei der Workstation die sich nicht einloggen kann. Vergleiche mal den Wert in der registry des rechners der sich anmelden läßt. Würd mich mal interessieren ob das dann geht ....
Bitte warten ..
Mitglied: pfoe
25.09.2006 um 12:14 Uhr
wegen den Servergespeichterten Profilen:

Passen die Sicherheitseinstellungen deines Profilordners au fdem Client?

ggf kann man das auch, wenns muckt über die MMC anpassen

im Reiter Konsole -auf Snap-in Hinzufügen/entfernen gehen und Gruppenrichtlinie hinzufügen!

Gruppenrichtlinie öffnen, dort auf Computerkonfiguration – Administrative Vorlagen – System – Anmeldung - Eigentümer von servergespeicherten Profilen nicht prüfen *Aktivieren

Wichtig: ServicePack4 muss installiert sein auf W2k

Greez PFoE
Bitte warten ..
Mitglied: Vatras
25.09.2006 um 14:20 Uhr
Zunächst mal danke für eure Antorten!

@der MOLCH:
Es handelt sich um ein und den selben Client, nur der Benutzer ist ein anderer. Den signorseal-Wert habe ich schon geändert.

@pfoe
werde ich umgehend ausprobieren sobald ich zu hause bin.

Habe ich vielleicht irgendwelche Pfade falsch angegeben? Die Rechte auf dem Server sind zu Testzwecken so vergeben, dass jeder auf "profiles" zugreifen kann.

MFG

Vatras
Bitte warten ..
Mitglied: Guenni
25.09.2006 um 15:43 Uhr
@Vatras

Hi,

Ändere das …
logon path = /srv/samba/profiles/%u
... mal um in:
logon path = \\%L\profiles\%U

Da Windows sich dort anmeldet, muß der Pfad auch windowskonform
angegeben werden(nicht /, sondern \).

%L ist der Netbiosname des Servers.

Grüße
Günni
Bitte warten ..
Mitglied: Vatras
25.09.2006 um 19:22 Uhr
Guten Abend zusammen,

ich habe den Pfad jetzt folgendermaßen abgeändert:
"logon path = \\%L\profiles\%U"

Aber es funktioniert immer noch nicht. Jetzt kann sich kein Benutzer mehr am System
anmelden. Habt ihr noch andere Ideen oder Anregungen. Bin echt am verzweifeln.
Muss ich noch irgendwelche Unterordner erstellen oder etwas in der Richtung?

Beim anmelden mit dem WinXP Client bekomme ich folgende Fehlermeldung:
"Das System kann den angegebenen Pfad nicht finden".

"Testparm" meldet keinerlei syntaktische Fehler!


Gruß,

Vatras
Bitte warten ..
Mitglied: Guenni
26.09.2006 um 14:25 Uhr
@Vatras

Hi,

[profiles]
comment = Netzwerk Profil
path = /srv/samba/profiles/%U

Lass hier am Ende das /%U weg.
Das Verzeichnis muß für alle beschreibbar sein:

chmod 777 /srv/samba/profiles

Das Userverzeichnis %U ist ja nicht die Freigabe,
sondern profiles. Sorry, hatte ich übersehen.

Unter [global] trag noch
interfaces = IP_des_Servers/Subnetzmaske ein.

Es existiert eine Domäne "Servus" ....

Ist Servus der Computername des Servers? Aus Sicht der Windows-Clients ist
workgroup=reinnet der Domänenname.

Hast du für die Clients ein Computerkonto(Unix- und Samba-Account) erstellt?

Zuerst eine Gruppe:

groupadd gruppenname(z.B.: clients)

Dann das Konto:

useradd -g clients -d /dev/null -s /bin/false -c "NT-Computer" computername$

Und der Samba-Account

smbpasswd -a -m computername$

Das $ am Ende nicht vergessen, das deutet für das System, dass
es sich um einen Maschinen-Account handelt.

Grüsse
Günni
Bitte warten ..
Mitglied: Vatras
26.09.2006 um 17:55 Uhr
Hi

@Günni

Es hat tatsächlich nur an dem Parameter "%U" gelegen. Bei der Domäne hatte ich mich vertippt, sorry. Die Domäne heißt "reinnet" und der Server "servus".

Tausend Dank für deine Hilfe. Es funktioniert jetzt alles wunderbar.
Werde dich weiterempfehlen

Gruß,

Vatras
Bitte warten ..
Ähnliche Inhalte
Samba
AD-Profil auf Samba-Share
Frage von DeciderSamba8 Kommentare

Guten Morgen, ich besitze ein Windows AD und möchte die Profile meiner Benutzer auf einem Samba-Share speichern. Die Ordner ...

Microsoft
MS Windows Roaming Profiles mit SAMBA AD
Frage von server110Microsoft3 Kommentare

Hallo zusammen, wir haben ein ziemlich merkwürdiges Problem. Folgende Ausgangssituation: - Samba AD auf Synology NAS (neuster Stand) - ...

Microsoft

OpenOffice Problem mit servergespeicherten Profilen

Frage von LordNicon79Microsoft4 Kommentare

Hi, ich setze Open Office auf zwei Rechnern in einer Domäne ein und habe auch noch Servergespeicherte Profile aktiviert. ...

Windows Netzwerk

Temporäres Profile Problem

gelöst Frage von Hendrik2586Windows Netzwerk19 Kommentare

Guten Morgen @ all! Vielleicht kennt einer von euch dieses Problem. Ich habe in meiner Domain einen Mitarbeiter , ...

Neue Wissensbeiträge
Windows Server
DP mit Benutzerdatenträger und VDS-SAN-policy
Tipp von lcer00 vor 18 StundenWindows Server

Hallo zusammen, ich habe gerade einen halben Tag mit Recherche zu dem Thema hinter mir und endlich ein Ergebnis. ...

Internet

Europa baut Zensurinfrastruktur auf: EU-Parlament stimmt für Upload-Filter, Leistungsschutzrecht und gegen KI-Forschung

Information von Frank vor 3 TagenInternet10 Kommentare

Eine sehr schlechte Entscheidungen für die Zukunft Europas ist gefallen: Der Rechtsausschuss im EU-Parlament stimmte heute morgen in einer ...

Windows 10

Mikrofon von Headset geht nach Update auf Windows 10 1803 nicht mehr

Tipp von Deepsys vor 6 TagenWindows 102 Kommentare

Ich verwende ein Plantronics Headset das per USB mit dem Windows 10 PC verbunden ist. Damit kann ich auch ...

Video & Streaming

Ruckelfreies Fernsehen auf Smartphone oder Tablet - in SD oder gar HD - Eine Alternative zum Fritz DVB-C Receiver

Anleitung von power-user vor 6 TagenVideo & Streaming11 Kommentare

Wer kennt das nicht: Man möchte gemütlich auf dem Balkon sitzen und vielleicht grillen und dabei das WM-Spiel gucken ...

Heiß diskutierte Inhalte
Switche und Hubs
VPN Router empfehlung
Frage von mstSwitche und Hubs13 Kommentare

Moin Leute ich hab mal eine Frage an die VPN und Netzwerkprofis unter euch. Folgendes Szenario, ich habe einen ...

LAN, WAN, Wireless
Sophos UTM 110 120 in Betrieb nehmen und IP Adresse am Cisco Switch herausfinden
Frage von KabuntelLAN, WAN, Wireless13 Kommentare

Hallo, ich mache in Rahmen meiner Umschulung zum Fachinformatiker - Systemintegration ein Praktikum. Gestern hat mir mein Chef gleich ...

Hardware
Neue Hardware für meine pfSense - APU2 apu4b4?
Frage von jokru1Hardware8 Kommentare

Hallo zusammen, ich betreibe aktuell meine pfSense auf einer APU2-Hardware (3 NICs, 4GB RAM) ohne AES-NI-Unterstützung. Diese möchte ich ...

LAN, WAN, Wireless
Netzwerkverkehr bei WLAN-Repeater immer über Router?
Frage von ahussainLAN, WAN, Wireless8 Kommentare

Hallo, beim Einsatz eines WLAN-Repeaters baut dieser ja ein eigenes Funknetz auf. Mich würde interessieren, ob der Netzwerkverkehr immer ...