Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Serv-U FTP und SMC2804WBR V.2

Mitglied: IceBeer

IceBeer (Level 2) - Jetzt verbinden

18.10.2004, aktualisiert 18.07.2005, 13348 Aufrufe, 5 Kommentare

Seit dem Routereinsatz geht der FTP nicht mehr...

Hallo,

seit ich besagten Router integriert habe geht der FTP-Server nur noch teilweise...

Der Router hat eine DynDNS-Namen. Sprech ich den FTP-Server über diesen Namen an, egal ob dies aus dem Internet oder dem Intranet passiert klappt zwar der Login auf dem FTp-Server aber das directory listing schlägt fehl..... Sprech ich den FTP-Server von intern mit der direkten Server-IP an geht alles einwandfrei....
--> Daraus schliese ich der Fehler liegt am Router, aber ich hab keine Ahnung wo. Der Port (21) wird weitergeleitet sonst würde ja auch der Login nicht klappen...

Hat jemand nenn Tipp für mich ???

Gruß Ice

(P.S. Server: 192.168.0.1 - 255.255.255.0
Router: 192.168.0.11 - 255.255.255.0)
Mitglied: Maximon
18.10.2004 um 11:22 Uhr
Hallo,

Welchen FTP Client benutzt du denn?

Hast du schonmal versucht die Verbinung zum FTP Server mit abgeschalteteter Passive Mode zu machen (z.B. mit FlashFXP)?
Das ist meistens schon die Ursache wenn der Server hinter einem Router steht das das Listing nicht funktioniert.

Oder hast du einfach mal versucht außer dem Port 21 den Port 20 auf deinen Server (192.168.0.1) weiterzuleiten?

Vielleicht funktionierts ja so

Gruß

Thorsten
Bitte warten ..
Mitglied: IceBeer
18.10.2004 um 11:39 Uhr
Hallo,

das Problem trat auf egal mit welchem Client ich den Zugriff versucht habe (FlashFXP, IE, Mozilla, gFTP) auch ein anderer FTP-Server hat nichts geändert.

Dabei hat auch das ändern der aktiv/passiv einstellung nichts geändert.

Was soll das bringen Port 20 noch zu forwarden, das ist doch nur die Leitung für die organisatorische Kommunikation oder ???

Gruß Ice
Bitte warten ..
Mitglied: Maximon
18.10.2004 um 11:45 Uhr
Hallo,

FTP verwendet zwei Ports! Der eine Port ist der "command" Port und der andere der "data" Port. Dabei wird Port 21 für die Steuerung (command) und der Port 20 für die Daten (data) verwendet.

Um passive Mode zu verwenden musst du auf deinem Router eine willkürliche Range an Ports forwarden die >1024 liegt da bei Passive Mode nicht der Port 20 (data) benutzt wird.

Hoffe das leuchtet so im groben ein

Wenn Fragen / Kritiken, her damit
Bitte warten ..
Mitglied: bigfoot
20.11.2004 um 23:54 Uhr
heist das ich nur am router den port 1024 forrwarden muss damit er den passiv mod aus macht ?
Bitte warten ..
Mitglied: flugfaust
18.07.2005 um 10:57 Uhr
Habe dass selbe Problem. Mit dem alten Router gings obwohl ich nur Port 20 und 21 geforwardet hatte.
Nun habe ich den Provider gewechselt, zeitgleich ging aber der Router durch ein Gewitter kaputt und nach mehreren verschiendenen Routern funktiooniert FTP nicht mehr richtig.
Das selbe habe ich aber auch bei VNC und RDP. Habe aber auch nen Webserver drauf laufen und der läuft einwandfrei. VPN Einwahl funktioniert auch

Seltsam
Bitte warten ..
Ähnliche Inhalte
DNS
2 FTP-Server hinter einer IP
Frage von MarkusW3400DNS12 Kommentare

Hallo, nachdem ich gerne experimentiere stoße ich manchmal an meine Grenzen und bitte euch um Hilfe. :) Ich möchte ...

Windows 10
Windows 10 1709 - UE-V
Frage von Sunny89Windows 102 Kommentare

Hallo zusammen, baue gerade in meinem LAB eine Testumgebung auf wegen "UE-V". Seit Version 1607 ist dies ja im ...

Firewall
UTM 2 WAN u-turn
gelöst Frage von HecconFirewall4 Kommentare

Hallo, eine generelle Frage zu UTMs. Zum Hintergrund : schon vorhanden bzw. konfiguriert : - SBS2011 (SBS), Terminalserver (TS), ...

Hyper-V
MS Server 2012 - Hyper-V - 2 NICs
gelöst Frage von MiStHyper-V5 Kommentare

Guten Morgen, ich habe einen 2012er-Server mit dem ich Hyper-V nutzen möchte. Ich würde dann gerne eine 2te NIC ...

Neue Wissensbeiträge
Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 3 TagenAusbildung36 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 4 TagenSpeicherkarten5 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 5 TagenSicherheit1 Kommentar

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 5 TagenHardware4 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Passwortwechsel Zeitpunkt festlegen
Frage von Looser27Windows Userverwaltung27 Kommentare

Guten Morgen liebe Kolleginnen und Kollegen, da es eine Userin in meinem Urlaub geschafft hat, sich vom AD vollständig ...

Windows Server
Probleme im AD am Außenstandort
gelöst Frage von emeriksWindows Server19 Kommentare

Hi, wir haben ein Problem mit AD und GPO am Außenstandort und ich stehe momentan mächtig auf dem Schlauch. ...

Microsoft
Netzlaufwerksordner Berechtigungen Speichern unter aus Programmen
Frage von ITler7Microsoft15 Kommentare

Moin, bin in ein neues Unternehmen eingetreten und habe die Anforderung bekommen Berechtigungen auf einige Ordner anzupassen, da bisher ...

CMS
Seltsame Joomla-Meldung auf unserer WebSite
Frage von Winfried-HHCMS14 Kommentare

Hallo in die Runde! Kennt sich jemand mit Joomla aus? Im Backend unserer WebSite lesen wir seit einiger Zeit ...