Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Serv-U FTP und SMC2804WBR V.2

Mitglied: IceBeer

IceBeer (Level 2) - Jetzt verbinden

18.10.2004, aktualisiert 18.07.2005, 13353 Aufrufe, 5 Kommentare

Seit dem Routereinsatz geht der FTP nicht mehr...

Hallo,

seit ich besagten Router integriert habe geht der FTP-Server nur noch teilweise...

Der Router hat eine DynDNS-Namen. Sprech ich den FTP-Server über diesen Namen an, egal ob dies aus dem Internet oder dem Intranet passiert klappt zwar der Login auf dem FTp-Server aber das directory listing schlägt fehl..... Sprech ich den FTP-Server von intern mit der direkten Server-IP an geht alles einwandfrei....
--> Daraus schliese ich der Fehler liegt am Router, aber ich hab keine Ahnung wo. Der Port (21) wird weitergeleitet sonst würde ja auch der Login nicht klappen...

Hat jemand nenn Tipp für mich ???

Gruß Ice

(P.S. Server: 192.168.0.1 - 255.255.255.0
Router: 192.168.0.11 - 255.255.255.0)
Mitglied: Maximon
18.10.2004 um 11:22 Uhr
Hallo,

Welchen FTP Client benutzt du denn?

Hast du schonmal versucht die Verbinung zum FTP Server mit abgeschalteteter Passive Mode zu machen (z.B. mit FlashFXP)?
Das ist meistens schon die Ursache wenn der Server hinter einem Router steht das das Listing nicht funktioniert.

Oder hast du einfach mal versucht außer dem Port 21 den Port 20 auf deinen Server (192.168.0.1) weiterzuleiten?

Vielleicht funktionierts ja so

Gruß

Thorsten
Bitte warten ..
Mitglied: IceBeer
18.10.2004 um 11:39 Uhr
Hallo,

das Problem trat auf egal mit welchem Client ich den Zugriff versucht habe (FlashFXP, IE, Mozilla, gFTP) auch ein anderer FTP-Server hat nichts geändert.

Dabei hat auch das ändern der aktiv/passiv einstellung nichts geändert.

Was soll das bringen Port 20 noch zu forwarden, das ist doch nur die Leitung für die organisatorische Kommunikation oder ???

Gruß Ice
Bitte warten ..
Mitglied: Maximon
18.10.2004 um 11:45 Uhr
Hallo,

FTP verwendet zwei Ports! Der eine Port ist der "command" Port und der andere der "data" Port. Dabei wird Port 21 für die Steuerung (command) und der Port 20 für die Daten (data) verwendet.

Um passive Mode zu verwenden musst du auf deinem Router eine willkürliche Range an Ports forwarden die >1024 liegt da bei Passive Mode nicht der Port 20 (data) benutzt wird.

Hoffe das leuchtet so im groben ein

Wenn Fragen / Kritiken, her damit
Bitte warten ..
Mitglied: bigfoot
20.11.2004 um 23:54 Uhr
heist das ich nur am router den port 1024 forrwarden muss damit er den passiv mod aus macht ?
Bitte warten ..
Mitglied: flugfaust
18.07.2005 um 10:57 Uhr
Habe dass selbe Problem. Mit dem alten Router gings obwohl ich nur Port 20 und 21 geforwardet hatte.
Nun habe ich den Provider gewechselt, zeitgleich ging aber der Router durch ein Gewitter kaputt und nach mehreren verschiendenen Routern funktiooniert FTP nicht mehr richtig.
Das selbe habe ich aber auch bei VNC und RDP. Habe aber auch nen Webserver drauf laufen und der läuft einwandfrei. VPN Einwahl funktioniert auch

Seltsam
Bitte warten ..
Ähnliche Inhalte
DNS
2 FTP-Server hinter einer IP
Frage von MarkusW3400DNS12 Kommentare

Hallo, nachdem ich gerne experimentiere stoße ich manchmal an meine Grenzen und bitte euch um Hilfe. :) Ich möchte ...

Windows 10
Windows 10 1709 - UE-V
Frage von Sunny89Windows 102 Kommentare

Hallo zusammen, baue gerade in meinem LAB eine Testumgebung auf wegen "UE-V". Seit Version 1607 ist dies ja im ...

Firewall
UTM 2 WAN u-turn
gelöst Frage von HecconFirewall4 Kommentare

Hallo, eine generelle Frage zu UTMs. Zum Hintergrund : schon vorhanden bzw. konfiguriert : - SBS2011 (SBS), Terminalserver (TS), ...

Hyper-V
MS Server 2012 - Hyper-V - 2 NICs
gelöst Frage von MiStHyper-V5 Kommentare

Guten Morgen, ich habe einen 2012er-Server mit dem ich Hyper-V nutzen möchte. Ich würde dann gerne eine 2te NIC ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 20 StundenSonstige Systeme4 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 23 StundenDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 1 TagHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Werksreset HP 1920S-24G
gelöst Frage von HenereNetzwerkgrundlagen14 Kommentare

Servus zusammen, ich habe mir 2 neue Switche zugelegt, doch ich komme damit nicht ganz klar. Waren Vorführgeräte zum ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL14 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Firewall
Sophos UTM 9.5 Firewall Log-File durchsuchen
gelöst Frage von Leo-leFirewall13 Kommentare

Hallo zusammen, weiß jemand von Euch, ob man bei der Sophos die Firewall logs noch etwas besser filtern kann? ...

LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless12 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...