Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server 2003: Startscripte werden nicht immer ausgeführt

Mitglied: Popeye

Popeye (Level 1) - Jetzt verbinden

15.08.2006, aktualisiert 16.08.2006, 3622 Aufrufe, 3 Kommentare

Hallo Experten,

ich habe gestern einen Server 2003 nach einem Hardwaredefekt neu installieren müssen. Backup war zwar da, aber die Installation war eh etwas vermurkst, also habe ich in den sauren Apfel gebissen...

Funktioniert mittlerweile auch ganz gut, nur mit den Startscripten der User habe ich ein Problem. Ich konnte mich bei der Installation nicht recht erinnern, wo die eigentlich hingehören (sysvol irgendwo), also habe ich sie in ein Verzeichnis "Scripte" direkt unter c: gelegt und dies Verzeichnis freigegeben. Das ist insofern nicht sicher, weil nun jeder darauf greifen kann und auch Scripte ausführen, die nicht für ihn sind, also werde ich das noch ändern müssen... Ist aber nicht so dringend, weil da nichts schlimmes passieren kann.

Allerdings habe ich jetzt den Effekt, daß die Scripte nach der Anmeldung der User gelegentlich nicht ausgeführt werden, ich könnte mir denken daß die Anmeldung "zu schnell" geht und das Scriptverzeichnis in dem Moment noch nicht zu sehen ist. Ist das so? Sind die Scripte, wenn sie am richtigen Ort liegen, besser im Zugriff? Falls ja, muß ich das wohl doch etwas früher ändern als geplant. Oder kan es einen anderen Grund geben, warum das nicht so klappt wie es soll?
Mitglied: gemini
15.08.2006 um 18:56 Uhr
Hallo Popeye,

wo die Loginscripten liegen hängt davon ab wie du sie zugewiesen hast.
Erfolgt die Zuweisung:
a) in den Eigenschaften des Users, dann müssen die Scripten in der Freigabe NETLOGON (lokaler Pfad: SYSVOL\sysvol\Domänenname\Scripts) auf dem Server liegen. In den Usereigenschaften darf dann NUR der Name des Scripts ohne Pfad stehen
b) über Gruppenrichtlinien, dann liegen die Scripten in SYSVOL\sysvol\Domänenname\Policies\GUID der Policy\User\Scripts\Logon.

Wenn die Speicherorte der Scripten nicht stimmen kann ich mir schwerlich vorstellen, dass sie _gelegentlich_ nicht ausgeführt werden, dann werden sie _gar nicht_ ausgeführt.

BTW die Benutzer müssen auf die Scripten mind. das Recht Lesen und Ausführen haben, da die Anmeldescripte ja mit den Rechten des Benutzers ausgeführt werden.
Ob die verhindern kannst, dass manche mit den Scripten spielen weiß ich nicht, hab ich ehrlich gesagt auch noch nie gebraucht.
Du könntest versuchen der entspr. Benutzergruppe das Recht Ordnerinhalt auflisten NUR FÜR DIESEN ORDNER zu entziehen. Ist aber nur ein Gedanke und ungetestet!

Gruß
gemini
Bitte warten ..
Mitglied: Popeye
15.08.2006 um 23:28 Uhr
Danke für die Antwort, und du hast natürlich Recht! Die Scripte wurden in Wirklichkeit gar nicht ausgeführt. Da bin ich nur bei der Probiererei durcheinandergekommen, weil einige Freigaben auf den User-PCs zwar verbunden waren, aber eben nicht wegen der Scripte...

Tja, man sollte wenn etwas nicht geht erstmal überlegen statt hektisch irgendwas zu versuchen.

Ich verspreche, mich zu bessern!
Bitte warten ..
Mitglied: Biber
16.08.2006 um 00:24 Uhr
Ich verspreche, mich zu bessern!
Auch wenn ich nur stiller Mitleser war - für dieses Versprechen gebe ich 5 Punkte!

Gruss
Biber
P.S. *winkzzzzz @gemini
Schön, Dich zu lesen!
Bitte warten ..
Ähnliche Inhalte
Windows Server

Startscript wird nicht überall ausgeführt

Frage von Thor01Windows Server5 Kommentare

Hallo, habe einer bestehenden Domäne einige neue PCs hinzugefügt und diese in die passenden OUs gesteckt. Verwunderlich ist jetzt, ...

Ubuntu

Startscripts in -etc-profile.d werden vor der Anmeldung ausgeführt

gelöst Frage von adm2015Ubuntu6 Kommentare

Hallo zusammen. Ich verwende derzeit die Ubuntu Version 17.10 bzw. im Test 18.04. Ich habe meine Anmeldescripte in dem ...

Linux

Startscript PID statt PPID

gelöst Frage von schneerunzelLinux5 Kommentare

Hallo zusammen, ich habe auf Grundlage des Beispiels ein Startscript für Java Applikation geschrieben nun habe ich folgendes Problem ...

Windows Server

Gruppenrichtlinie wird nur bei Anmeldung am Server, aber nicht am Client ausgeführt

gelöst Frage von klanaxWindows Server3 Kommentare

Hallo an alle! Wir haben einen Windows Server 2011 SBS (also eigentlich Windows Server 2008 R2) als Domain-Controller und ...

Neue Wissensbeiträge
Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 21 StundenAusbildung8 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 2 TagenSpeicherkarten3 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 2 TagenSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 3 TagenHardware3 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Off Topic
SysAdmin im öffentlichen Dienst - jemand Erfahrungen?
Frage von JohnDorianOff Topic22 Kommentare

Hallo zusammen, hat jemand Erfahrung wie es so ist als SysAdmin im öffentlichen Dienst (Landkreis) im Südwesten der Republik ...

Vmware
Offene LDAP-Server in AS
gelöst Frage von obi-wan-kenobiVmware16 Kommentare

Hallo alle Miteinander, ich habe ein Problem, unsere VM-Ware Appliance (Version. 6.5.0.10000) ist scheinbar angreifbar. Wir haben eben die ...

SAN, NAS, DAS
Nas mit USB und LAN gleichzeitig zugreifen
gelöst Frage von MarkBeakerSAN, NAS, DAS16 Kommentare

Hallo zusammen, ich suche eine Art NAS, womit ich via LAN und USB zugreifen kann. Folgender Aufbau ist gedacht: ...

Google Android
Samsung S7 Kontakte gelöscht. Kann man die wieder herstellen
Frage von merkelGoogle Android10 Kommentare

Hallo, auf einem S7 wurden Kontakte gelöscht. kann man die wieder herstellen ? gruss Jonas