Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server 2008 klonen

Mitglied: LarsJakubowski

LarsJakubowski (Level 2) - Jetzt verbinden

27.07.2009, aktualisiert 10:53 Uhr, 7474 Aufrufe, 19 Kommentare

Hallo,

folgendes Problem haben wir bei unseren Servern:

Wir haben insgesamt 4 Server, wobei immer 2 identischsein (Absolut identisch mit gleichen Firmwares).
2 Server sind installiert im Rahmen einer Migration. Ein Server, ein Dell 2850 ist ein Small Business Server 2008 und ein anderer, Dell 1800 ist ein normaler WIndows Server 2008.
Alle System haben RAID1 eingerichtet

Beide Server laufen problemlos und fehlerfrei. Da es sich aber um Tower Geräte handelt, möchten wir diese nun in unsere identischen rackserver bringen.

Wir nehmen also eine Festplatte aus dem SBS raus und stecken diese in einen identischen Server. Der Server startet und bleibt dann bei "Computer Einstellungen werden geladen" hängen. Im Abgesicherten Modus mit Netzwerk startet das System voll durch.
Nur im normalen Modus nicht. Das ist Problem Nummer eins.

Problem Nummer 2 betrifft den Server 2008 (DELL 2850, auch mit RAID 1).
Das System soll nach dem selben Verfahren geklont werden. Das System startet kurz und bricht danach und startet aufs neu.

Das ist das Problem Nummer 2!

Hat jemand schon ähnliche Erfahrungen gemacht oder hat jemand vielleicht ne Lösung oder einen Ansatz?
Wie gesagt, die Systeme sind identisch!

Grüße
Lars
Mitglied: M3rlin
27.07.2009 um 11:09 Uhr
Hallo Lars,

ich bin mir nicht sicher, ob ich es richtig verstanden habe:

2 Systeme sind immer identisch in Hardware und Firmware.
Das heist, der SBS und der Server 2008 im Towergehäuse sind gleich und die beiden Rack Server sind gleich.
Dann hättest Du, wenn ich richtig liege, unterschiedliche Hardware, auf die Du migrieren willst.
Denn die Rackhardware ist zwar identisch aber dennoch unterschiedlich zu den towergehäusen.
(klingt ein wenig wirr, ich weiss)

Das könnte dann zu den Problemen führen

steht denn irgendwas im Eventlog ?
Wenn ihr die Platten zurücktauscht, laufen die Server dan wieder normal ?

Vielleicht wäre eine der folgenden Möglichkeiten die bessere lösung:

Entweder Du migrierst z.B. mit Acronis Bare Metal restore (das heist, Sicherung (Imaging) und dann Restore auf der neuen Hardware oder andere Software)
oder
Du installierst die beiden Server neu, und migrierst dann die daten.


Gruß

M3rlin
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 11:17 Uhr
Hallo M3rlin,

danke für die schnelle Antwort.

Also die Server sind identisch, gleiche Mainboards, Controller CPU`s usw.
Es unterscheidet sich lediglich das Gehäuse der Systeme (RACK und Tower).

Das Eventlog beider Server ist sauber und die Kisten machen im laufenden betrieb auch keine Problem.

Wenn wir die Platten zurück tauschen, läuft alles super, da die durch die verbleibende Platte restort werden (ist ja ein Raid1).

Haben es schon mal mit Acronis universal Restore probiert. Gleicher erfolg.

Komisch ist beim SBS, das dieser ja startet und dann beim Hochfahren bei "Computereinstellungen werden geladen" stehen bleibt. Die DNS Settings sind okay. Das war meine erste Vermutung.

Grüße
Lars
Bitte warten ..
Mitglied: n.o.b.o.d.y
27.07.2009 um 11:30 Uhr
Hallo,

schaffste Du es die Treiber auf den Rackserver noch dem Hochfahren noch mal drüber zu installieren? Hört sich für mich nach einem Treiberproblem an. Vielleicht hat eine der HW-Komponenten eine zu weit abweichende HW-Revision.
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 11:34 Uhr
Hallo,

nein, so weit komme ich nicht.
Der SBS Server 2008 kommt ja brav hoch und hängt dann (Computer Einstellungen werden geladen). Im abgesicherten Modus stehen die Treiber sauber da und Eventlog ist sauber!

Der normale Server 2008 kommt erst nicht so weit. Auch abgesicherter Modus klappt hier nicht.

Wie schon gesagt, mit Acronis Universal Restore ist das Ergebnis gleich
Bitte warten ..
Mitglied: Supaman
27.07.2009 um 11:53 Uhr
ich vermute ein problem mit dem raid-controller. teilweise "merken" sich die controller anhand der seriennummern, welche platten angeschlossen waren - das wären einstellungen, die du auch mit acronis nicht kopieren kannst.
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 11:56 Uhr
Aber was mir dann nicht ganz einleuchtet ist, warum startet Windows?
Es startet ja und bricht nur irgendwann ab bzw. der SBS hängt dann!

Es ist ja nicht so, als wenn das System nicht startet. Der SBS lässt sich ja auch im abgesicherten Modus mit Netzwerk hochfahren. Der Server 2008 bricht ja irgendwann wenn Windows gestartet wird ab?!

Ich habe so was auch noch nicht gehabt!
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 12:43 Uhr
Hallo,

es hat im letzten Jahr auf diese Weise auch schon mal funktioniert. Allerdings unter Windows Server 2003.
Hier gab es keinerlei Probleme oder Fehler!

Jemand noch ne Idee?

Lars
Bitte warten ..
Mitglied: Pjordorf
27.07.2009 um 14:07 Uhr
Hallo,

wie "lange" oder kurz hast du denn mal beim SBS 2008 gewartet? Nicht das der SBS gleichzeitig mit dem originalen SBS am gleichen Netz hängt. DNS, DHCP usw. das kann dann schon mal länger dauern. Hast du Hardware RAID's mit externe Controller oder Software RAID's. Nicht das dein SBS dort auf die andere HDD wartet.

Peter
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 14:10 Uhr
Hallo,

also der SBS hängt an einem Switch und sieht dort nur sich selbst. Es besteht also keine Verbindung zum produktiven LAN.
Sonst wären die sich ja in die Quere gekommen.

Es handelt sich ebi beiden Servern um Hardware RAIDS mit PERC4 Controlern. Alle Controler sind identisch (gleicher Firmwarestand und Konfiguration). Der SBS hat es nun geschafft hochzufahren!

Aber der normale Server 2008 macht noch nach wie vor die Probleme, das er nicht hoch fährt.

Lars
Bitte warten ..
Mitglied: Pjordorf
27.07.2009 um 14:31 Uhr
Hallo,

und was war es beim SBS?

Wann fährt denn der Server 2008 wieder runter und startet neu? Unterbinde doch erstmal das neustarten damit du evtl fehler (Bluescreen????) erkennen kannst. Was steht denn im ereignissprotokoll nach so einem crash wenn du wieder im abgesicherten Modus hochfährst?

Peter
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 14:36 Uhr
Hallo Peter,

was es beim SBS war, kann ich nicht sagen. Nach dem Wochenende stand der da, wie er es sollte.
Aber dem gehe ich nun mal nach!

Der Server 2008 startet ja noch nichtmal im abgesicherten Modus!
Leider steht der Server nicht hier bei uns im haus. Kann somit erst Morgen mal nachsehen. Ich habe das letzte Woche schon mal gemacht und den Bluescreen gesehen. Glaube es war CRCDisk als Fehler
Bitte warten ..
Mitglied: n.o.b.o.d.y
27.07.2009 um 15:51 Uhr
Hallo,

kann das was mit den Windows-Lizenzen zu tun haben? Wegen der geänderten HW, oder so?
Bitte warten ..
Mitglied: LarsJakubowski
27.07.2009 um 15:54 Uhr
Hallo,

denke eher nicht.
Dann würde er ja zum aktivieren auffordern und nicht den bootvorgang des Windows unterbrechen.


Ist echt ein super toller Fehler!
Eigentlich vom Gedanken her dürfte das alles kein Thema sein
Bitte warten ..
Mitglied: hajowe
28.07.2009 um 10:02 Uhr
Grundsätzliches zu den Dell Servern und deren Raids

Wie hast du die Raids auf den Rackgehäusen eingerichtet?

Normalerweise wird der Server so installiert (Kurzfassung):
1. Serveriunstallations-CD rein
2. Raid einrichten (Hier müssen natürlich Platten da sein, Hierbei werden auf den Raidcontroller und Platten einträge gemacht.)
2. Alle Angaben machen
3. OS System einlegen

Wie wurde mit den Rackserververn verfahren?
Hatten diese am Anfang welche?

Wenn du nun die Platten aus einem System komplett herrausnimmst und durch neue Platten ersetzt, die ein anderes Raid haben,
wird es beim erneuten einschalten des Servers vom Controller bemerkt.
Er meldet eine Unstimmigkeit zwischen den Informationen aufd dem Perc4 und den auf den Platten gespreicherten Raidinformationen.
Daraufhin fragt er welches Raid er denn nehmen soll.

Hier sollte man jedoch sehr genau wissen was man tut, da ansonsten die Daten dabei zerstört werden können.
Bitte warten ..
Mitglied: LarsJakubowski
28.07.2009 um 10:13 Uhr
Hallo,

grundsätzlich ist das klar und auch so gemacht.

Es handelt sich bei beiden Servern um ein RAID1 System, also Spiegelung der Festplatten.
Der Towerserver läuft problemlos und auch im Dell management Programm auf dem Tower keine Probleme.

Klar, wenn ich die Festplatten aus dem Tower in den Rack Server stecke, meldet der Perc das hier Unstimmigkeiten sind. Da fragt er welche Konfiguration genommen wird. Gewählt wurde hier, das die Festplatten den Controller überschreiben sollen. Anschließend Neustart und Windows wird angefangen zu laden. Dabei bricht das System dann ab.


Es wurde schon darauf geachtet, dass die Konfiguration des RAID identisch ist und das klappt wohl auch.
Bitte warten ..
Mitglied: hajowe
28.07.2009 um 10:53 Uhr
Wenn du es soi gemacht hast, denke ich nicht das es ein HW-Problem ist.
Ich denke das es eher am Windows liegt.

Hast du den schonmal den Dell Support in Anspruch genommen.
Ich denke die sollten doch sowas wissen.

Ich vermute mal das du die Server dort mit dem OS erworben hast und dann steht dir kostenfreier Support zu.
Bitte warten ..
Mitglied: LarsJakubowski
28.07.2009 um 11:08 Uhr
Ausgeliefert und supportet werden die Systeme leider nur mit WIndows Server 2003!
Der Support schiebt es auf Microsoft und Microsoft schiebt es auf den Dell Support.

Ofiziell werden die Systeme mit WIndows Server 2008 nicht supportet. Allerdings bietet Dell Treiber für das OS an.
Bitte warten ..
Mitglied: hajowe
28.07.2009 um 13:52 Uhr
Was mir noch einfallen würde, wäre das du mal auf den Servern mit dem OMSA
die entsprechenden Bios, Firmwareund Driverversionen
der Hardwarekomponenten anschauen könntest.

Vielleicht kannst du da was feststellen.
Bitte warten ..
Mitglied: Pjordorf
28.07.2009 um 13:57 Uhr
Hallo,

schalte doch erstmal den automatischen neustart nach fehlern ab. Dann kannst du ja vielleicht eine fehlermeldung / Bluescreen erkennen.

Peter
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
SSD mit Server 2012 klonen
gelöst Frage von wbecker53Festplatten, SSD, Raid9 Kommentare

Ich habe eine Samsung EVO840 auf eine 850er zu klonen. Auf der SSD befindet sich der MS Server 2012. ...

Windows Installation
Windows Server 2012R2 Klon aktivieren
gelöst Frage von fishrainWindows Installation9 Kommentare

Hallo, hab den Post jetzt unter "Windows Installation" reingesetzthoffe das stimmt soauch wenn es sich eigentlich um eine "Windows ...

Sicherheitsgrundlagen
Klonen von Festplatten
Frage von Manu1987Sicherheitsgrundlagen4 Kommentare

Hallo. Ich möchte verschiedene Festplatten klonen. Meine Frage ist, wenn ich auf Festplatte 1. Daten lösche, diese dann klone, ...

Windows Server
RODC Klonen
Frage von Jannis92Windows Server3 Kommentare

Moin Moin, ich mal wieder :) Frage: Hat hier jemand Erfahrungswerte in Sachen "RODC Klonen"? Hintergrund: Bei uns in ...

Neue Wissensbeiträge
Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 3 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 12 StundenInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 TagWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server36 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Webbrowser
Welcher Browser ist der Beste?
Frage von justtinWebbrowser15 Kommentare

Hallo Leute Ich habe eine interessante Frage. Mich wurde mal interessieren welcher Browser ist eure meinung nach der beste? ...