Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server Client kann Internetseiten mit Javascript nicht aufrufen

Mitglied: 68463

68463 (Level 1)

11.08.2008, aktualisiert 18.10.2012, 4171 Aufrufe, 8 Kommentare

Ich habe folgendes Problem, zu dem ich im Netz (Google etc.) leider keine passende Antwort gefunden habe:

Situation ist folgende:

1 Windows Server 2003 SBS, der verschiedenen WLAN-Clients (Windows XP Prof., SP II) eine Internetverbindung zur Verfügung stellt. Diese kommen damit auch wunderbar ins Netz. Das klappt soweit.

Nun habe ich aber folgendes Problem: Manche Internetseiten bzw. Teilbereiche von Seiten, in denen JavaScript bzw. AJAX Komponenten ausgeführt werden, lassen sich einfach nicht laden. Das Komische dabei ist, dass der Server diese Seiten sehr wohl anzeigen kann. Es liegt scheinbar an den Clients bzw. den Rechte- bzw. Sicherheitseinstellungen für diese. Aber wo setzt man da an? Ich habe schon so einiges durchprobiert, leider ohne Erfolg.

Ich wäre sehr dankbar für Anregungen bzw. Hilfestellungen!

MfG

atillwe
Mitglied: 45246
12.08.2008 um 11:50 Uhr
Probier es doch mal über die Gruppenrichtlinien. Vielleicht sind dort derartige Linien deaktiviert oder noch nicht gesetzt.
Bitte warten ..
Mitglied: gijoe
12.08.2008, aktualisiert 18.10.2012
Hi,
hatte das selbe Problem:
https://www.administrator.de/forum/java-script-erlauben-im-internet-expl ...

Somit importierst du für die "normalen" Benutzer die Richtlinien des Administrators (bei dem klappts ja vermutlich prima?) Danach gings tadellos.


Gruss
Bitte warten ..
Mitglied: 68463
12.08.2008 um 15:18 Uhr
Vielen Dank erstmal!
Das hört sich ja schon sehr gut an!

Wo finde ich aber den "Gruppenrichtlinieneditor" bei der Small Business Server Version von Windows Server 2003. Mir scheint, als ob der SBS ein wenig anders strukturiert ist als seine Vorgängerversionen.

Oder kann ich das ganze auch über "Ausführen..." aufrufen?
Bitte warten ..
Mitglied: gijoe
12.08.2008 um 16:15 Uhr
also eigentlich sollte es so gehen:
Start => Ausführen => gpedit.msc

und dann nach der Anleitung handeln
Bitte warten ..
Mitglied: 68463
14.08.2008 um 12:19 Uhr
Tut mir leid, dass ich mich erst jetzt wieder zu diesem Thread melde...
Habe in der Zwischenzeit einiges ausprobiert.

Desweiteren habe ich mir auch den oben erwähnten Thread durchgelesen, leider ohne Erfolg.

Mein Problem ist, dass ich unter den Einstellungen im Gruppenrichtlinien-Editor keine Optionsmöglichkeit habe, Java ein bzw. auszuschalten.

Ich habe dann in der Übersicht gesehen, das unter dem Eintrag "Small Business Server -Internetverbindungsfirewall" unter dem Unterpunkt "Microsoft VM" steht, dass Java deaktiviert ist. Ich vermute, dass der Fehler hier liegt.

Aber wie kann ich nun Java aktivieren? Ich finde leider nirgends einen Eintrag, wo ich das umstellen kann.

Vielleicht könnte mir da noch mal jemand einen Tipp geben!

Vielen Dank im voraus!
Bitte warten ..
Mitglied: 68463
14.08.2008 um 12:22 Uhr
Ach so, dann noch was:

Muss ich, wenn ich die Einstellungen geändert habe, irgendwas auf dem Client aktualisieren, so a la "gpupdate /force"?

Oder übernimmt der Client die Einstellungen dann automatisch?
Bitte warten ..
Mitglied: gijoe
14.08.2008 um 13:50 Uhr
Hm, also ich arbeite mit Samba, und die Richtlinie war bei mir nur auf dem Server-also lokal und wurde sofort angewendet. Am besten du loggst dich einfach schnell ein mit einem User.
Bitte warten ..
Mitglied: 68463
21.08.2008 um 10:04 Uhr
Hallo zusammen!

Leider konnte ich mich in den letzten Tagen aufgrund anderer Verpflichtungen nicht intensiver mit diesem eigentlich doch so dringenden Problem beschäftigen.

Ich habe gestern nochmal einige Einstellungen auf dem Server vorgenommen und unter anderem auch die Gruppenrichtlinienobjekte überprüft. Ich bin mir nun nicht mehr wirklich sicher, ob es wirklich an diesen Richtlinieneinstellungen liegt. Gestern habe ich einmal alle Gruppenrichtlinienobjekte deaktiviert und die Einstellungen dann mittels "gpupdate /force" auf dem Client neu laden lassen.

Leider ohne den gewünschten Erfolg, die JavaScript-Funktionalitäten auf dem Client-Browser waren immer noch eingeschränkt.

Gibt es vielleicht noch andere Dinge / Einstellungen, die ich übersehen habe, oder muss ich wirklich eine eigenen Richtlinie anlegen, in der explizit festgelegt sein muss, dass Java aktiviert ist?

Vielleicht noch ein paar Infos zu meinem Netzwerk / Rechnerumfeld:
Die Clients verbinden sich über einenen WLAN-Access Point (RADIUS) mit dem Windows Server 2003 SBS, von dem sie dann per DHCP die IPs zugewiesen bekommen und der auch die Internetverbindung zur Verfügung stellt.

Im Moment funktioniert das JavaScript nur, wenn ich mich auf dem Server als Administrator anmelde. Auf den Clients geht es nicht, auch wenn ich mich dort mit Administratorrechten anmelde.

Habt ihr noch Ideen / Anregungen für mich? Woran kann es noch liegen?
Für Antworten wäre ich sehr dankbar!

Gruß,
atillweb
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen

Nach wechsel des ISPs aufruf von Internetseiten langsam

gelöst Frage von TheRaiderNetzwerkgrundlagen10 Kommentare

Hallo zusammen, wir haben in unserer Firma vor kurzem den ISP gewechselt. Jetzt haben wir jedoch das Problem, dass ...

Debian

LibCEC - CEC-Client über Webseite aufrufen

gelöst Frage von mabue88Debian5 Kommentare

Hallo, ich habe einen Raspberry Pi an einem Flachbildschirm angeschlossen. Auf dem Raspbian läuft ein LAMP-Server. Der Bildschirm soll ...

Webbrowser

Wie bei Firefox Portable nach ein paar Minuten Inaktivität bestimmte Internetseite aufrufen

gelöst Frage von Server-NutzerWebbrowser3 Kommentare

Hallo Leute und guten Morgen. Wir benutzen den Firefox Portable ganz gern, um auf Veranstaltungen auf uns nicht gehörenden ...

Firewall

Fritzbox 6.80 Filter für Internetseiten berücksichtigt gesperrte Domains jetzt auch bei https-Aufrufen

Frage von thomasreischerFirewall12 Kommentare

Hallo zusammen, Seit Fritz Version 6.80 ist es nun auch möglich https Seiten zu Sperren. Ich Frage noch wie ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing19 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

Grafikkarten & Monitore
4k EIZO Monitor, Fernseher und Splitter
Frage von LerxxeyGrafikkarten & Monitore9 Kommentare

Hallo Zusammen, vielleicht könnt ihr mir bei einem Problem helfen wo ich einfach nicht mehr weiterkomme Und zwar haben ...