Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst SLES 10 - Anmeldung als root nicht mehr möglich

Mitglied: heparus

heparus (Level 1) - Jetzt verbinden

23.07.2009, aktualisiert 15:38 Uhr, 6050 Aufrufe, 1 Kommentar, 1 Danke

Hallo ich hab ein SLES 10 mit Samba auf einer IBM I6 am laufen, dessen Authentifizierung bis eben über Xerberos an unserem Windows Server 2003 lief. Auf wunsch der GL sollte kein Xerberos mehr verwendet werden und Samba mit LDAP laufen.

Mein Problem ist nun, dass ich mich an der Maschine weder über SSH noch über VNC anmelden kann. Ich erhalte immer die Fehlermeldung, es steht kein gültiges Anmeldeverfahren zur Verfügung.

Was war geschen: Da ich in Eile war habe über Yast den LDAP-Client konfiguriert und bestätigt. yast hat dann nachgefragt, welche Informationen er in zukunft nutzen soll, da ja der Xerberos-Client auch noch am laufen war. Ich hab dann LDAP gewählt und die Konfiguration wurde geschrieben, aber beim Starten der Dienste ist Yast bei 50% hängen geblieben. Ich wollte mir nun per SSH eine zweite Session öffnen und musste feststellen, dass ich mich als root nicht mehr Anmelden konte. Geschweige den einer der anderen User. Da die Maschine in einem externen Rechenzentrum steht, habe ich leider auch keinen physikalischen Zugriff auf das Gerät bzw. die HMC steht auch dort.

Ich hab eine Sicherung der Maschine mit Bacula von letzter Nacht, müsste mir aber dafür erstmal ne Boot-CD bauen, um die Sicherung zurückzuspielen. Außerdem müsste ich das Tape erst anfordern und hätte es erst frühstens morgennachmittag vorort.

Ich hoffe mir kann jemand weiterhelfen.
Mitglied: heparus
28.07.2009 um 17:19 Uhr
OK, ich hab es jetzt wie folgt gelöst.

Neugestartet und im Bootmanager mit init=/bin/bash gestartet. Und die Root-Partition zum lesen/schreiben gemountet.
Hab dann PAM (/etc/pam.d/common-auth, -account, -password und -session) kontrolliert und mehrere falsche Einträge entfernt. In common-password war ein Eintrag, welcher auf pam_unix2.so mit dem Parameter MD5 verwiess.
Anschliessend /etc/shaddow und /etc/passwd kontrolliert und aus shadow das root pw gelöscht.

Neugestartet, aber root liess sich immer noch nicht anmelden.

Wieder mit init=/bin/bash gestartet.
Dannach in /etc/nsswitch die Schalter wieder alles auf files gesetzt.
Und zum Schluss dem Root ein neues Password verpasst und neugestartet.

Siehe da seit dem kann man sich wieder lokal anmelden. Anschliessend LDAP wieder eingerichtet.

Warum die lokale Anmeldung nicht mehr funktioniert hat, ist mir bis jetzt schleierhaft.
Bitte warten ..
Ähnliche Inhalte
Windows 10

Windows 10: Keine Anmeldung mehr möglich nach verlassen der Domäne

gelöst Frage von klanaxWindows 105 Kommentare

Hallo an alle! Ich stehe hier vor einem seltsamen Problem. Kurz die Vorgeschichte: Unser Windows-10-Surface-Book, das in die Firmendomäne ...

Virtualisierung

SLES 10 SP2 Virtualisierung Hyper-V

Frage von hubi82Virtualisierung1 Kommentar

Hallo, ich möchte einen physischen SLES 10 SP2 Server auf Hyper-V virtualisieren, am besten Remote im laufenden Betrieb. Ist ...

Windows 10

Windows 10 anmeldung mit Email

Frage von uniqmasterWindows 102 Kommentare

Hallo Zusammen, habe ein Problemfall mit einem Windows 10 Rechner. Auf den Rechner erfolgt die Anmeldung über eine Email ...

Windows 7

Windows Administrator Anmeldung nicht möglich

Frage von bud5890Windows 74 Kommentare

Moin zusammen, ich habe an einem unseren PCs folgendes Problem: Auf dem Client arbeitet ein User mit eingeschränkten Rechten. ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)8 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...