Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SLES 10 - masquerading funktioniert nicht

Mitglied: daveChristopher

daveChristopher (Level 1) - Jetzt verbinden

22.07.2008, aktualisiert 23.07.2008, 5368 Aufrufe, 3 Kommentare

Hallo,

folgende Ausgangssituation:

Ich habe einen Exchange Server der von extern (Internet -> Mobile User) über imap (Port 143) angesprochen werden soll.

Imap Dienst auf Exchange Server läuft!

Die Internetanbindung macht bei uns ein SLES Version 10 Rechner.

Sprich: INTERNET <----> EXTERNES NETZ <---> SLES 10 <---> INTERNES NETZ

Problem:

telnet 10.1.2.3 143 -----> FUNKTIONIERT

telnet feste-ip-zum-internet 143 -----> FUNKTIONIERT NICHT

Konfiguration am SLES 10 Rechner:

YAST2 -> Sicherheit und Benutzer -> Firewall -> Masquerading

Masquerading für Netzwerke = Aktiviert

Anfragen an Masquerading IP umleiten:

QuellNetzwerk: 0/0
Protokoll: TCP
Benötigte IP: -
Benötigter Port: imap(143)
Umleiten an IP: 10.1.2.3
Umleiten an Port: imap(143)

Weiter -> Einstellungen Speichern und Firewall Neustarten

sollte doch eigentlich alles passen?!

Ich weiß nicht was ich falsch mache...

Vielleicht kann mir ja ein Linux/Computer-Guru hier im Forum helfen.

Ich freue mich auf sämtliche antworten

Viele Grüße

David
Mitglied: theton
22.07.2008 um 16:52 Uhr
Gibt '/proc/sys/net/ipv4/ip_forward' eine '1' aus? Wie sehen die iptables-Regeln aus (iptables -L)? Ist evtl. noch ein Portforwarding notwendig? Was heisst "funktioniert nicht"... kommt ein 'destination host unreachable' oder bleibt die Verbindung einfach hängen? Ist der Mailserver mittels Ping erreichbar? An welcher Stelle bleibt ein 'traceroute' hängen?
Bitte warten ..
Mitglied: daveChristopher
23.07.2008 um 08:08 Uhr
Gibt '/proc/sys/net/ipv4/ip_forward' eine '1' aus?

Die Ausgabe ist folgende: /proc/sys/net/ipv4/ip_forward: Permission denied

schaue ich aber direkt in die Datei, steht darin eine "1".

Wie sehen die iptables-Regeln aus (iptables -L)?

Folgendes könnte da relevant sein (Die andeen Ausgaben beziehensich auf andere Protokolle):

01.
LOG        tcp  --  anywhere             exchange.domäne.local limit: avg 3/m                                         in burst 5 tcp dpt:imap state NEW LOG level warning tcp-options ip-options prefi                                         x `SFW2-FWDint-ACC-REVMASQ ' 
02.
ACCEPT     tcp  --  anywhere             exchange.domäne.local tcp dpt:imap 
03.
ACCEPT     tcp  --  exchange.domäne.local  anywhere            state RELATED,                                         ESTABLISHED 
04.
LOG        tcp  --  anywhere             exchange.domäne.local limit: avg 3/m                                         in burst 5 tcp dpt:smtps state NEW LOG level warning tcp-options ip-options pref                                         ix `SFW2-FWDint-ACC-REVMASQ ' 
05.
ACCEPT     tcp  --  anywhere             exchange.domäne.local tcp dpt:smtps 
06.
ACCEPT     tcp  --  exchange.domäne.local  anywhere            state RELATED,                                         ESTABLISHED 
07.
LOG        tcp  --  anywhere             exchange.domäne.local limit: avg 3/m                                         in burst 5 tcp dpt:imaps state NEW LOG level warning tcp-options ip-options pref                                         ix `SFW2-FWDint-ACC-REVMASQ ' 
08.
ACCEPT     tcp  --  anywhere             exchange.domäne.local tcp dpt:imaps 
09.
ACCEPT     tcp  --  exchange.domäne.local  anywhere            state RELATED, 
Ist evtl. noch ein Portforwarding notwendig?

In wie fern? Ich will ja nur: Alles aus dem Internet (von Port 143) zu exchange Server (10.1.2.3) auf Port 143.

Was heisst "funktioniert nicht"... kommt ein 'destination host unreachable' oder bleibt die Verbindung einfach hängen?

telnet: connect to address externe-feste-ip-adresse: Connection refused (von Linux aus)

Verbindungsaufbau zu externe-feste-ip-adresse:...Es konnte keine Verbindung mit dem Host h
ergestellt werden, auf Port 143: Verbinden fehlgeschlagen (von Windows aus)

ist der Mailserver mittels Ping erreichbar?

Ja, ist erreichbar! OWA über Apache Reverse-Proxy funktioniert auch.

An welcher Stelle bleibt ein 'traceroute' hängen?

Ich komme bis zu unseren SLES-10 Server, woberi ich bei tracert/treaceroute keinen Port mit angeben kann.

Viele Grüße

David
Bitte warten ..
Mitglied: daveChristopher
23.07.2008 um 08:44 Uhr
ich glaube fast die Weiterleitung von der Linux Seite funktioniert, aber der Excahnge Server lässt es nicht durch...

Ich habe jetzt nämlich testweise auf einen client mal wireshark installiert und den port auf diesen umgeleitet. Wireshark zeigt bei jeden Verbindungsversuch aktivität -> Sprich Weiterleitung funktioniert.

IP-Adresse (Testclient): 10.1.1.16 (funktioniert von extern)

IP-Adresse (Proxy, Gateway): 10.1.1.8

IP-Adresse (exchange): 10.1.3.2

Subnetz: 255.255.0.0

Netzwerkseitig dürfte es doch da auch keine Probleme geben oder?

Nachtrag:

Noch zu erwähnen ist, dass diese Konfiguration vorher schon einmal lief, nur jetzt nicht mehr.

einzige Änderungen:

1. Auf Exchange Server 2003 läuft OWAadmin

2. Der Exchange Server läuft nicht mehr auf 10.1.1.6 sonder auf 10.1.3.2
Bitte warten ..
Ähnliche Inhalte
Virtualisierung
SLES 10 SP2 Virtualisierung Hyper-V
Frage von hubi82Virtualisierung1 Kommentar

Hallo, ich möchte einen physischen SLES 10 SP2 Server auf Hyper-V virtualisieren, am besten Remote im laufenden Betrieb. Ist ...

Suse
SLES SDA in HDA ändern
Frage von HakketasSuse12 Kommentare

Hallo, habe durch eine Konvertierung von VMWare zu HyperV nur die Möglichkeit die Festplatten per IDE anzubinden. Es handelt ...

Windows 10
Windows 10 Suche funktioniert nicht
gelöst Frage von CorvoAttanoWindows 109 Kommentare

Hallo, nachdem mir zahlreiche Websites nicht weiterhelfen konnten, stelle ich nun hier meine Frage. Die Windows 10 Suche funktioniert ...

Windows 10
Windows 10 Update funktioniert nicht
Frage von master3477Windows 1010 Kommentare

Hallo, ich habe auf einem PC ein Win10 bei dem die Updates nicht mehr funktionieren. Wenn ich das Update ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
WRT keine Verbindung zum Web Interface
Frage von ILeonardRouter & Routing15 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

Grafikkarten & Monitore
4k EIZO Monitor, Fernseher und Splitter
Frage von LerxxeyGrafikkarten & Monitore9 Kommentare

Hallo Zusammen, vielleicht könnt ihr mir bei einem Problem helfen wo ich einfach nicht mehr weiterkomme Und zwar haben ...

Humor (lol)
Nerd Zeitschrift gesucht
Frage von 2SeitenHumor (lol)6 Kommentare

Hey Zusammen, Ich suche eine Zeitschrift bei der es ums technische Basteln geht. Pc zusammenschrauben, Arduino Projekte, Server Tipps ...