Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Smartermail- Problem mit Relay Server

Mitglied: tobhehe

tobhehe (Level 1) - Jetzt verbinden

21.10.2011 um 19:49 Uhr, 6099 Aufrufe, 3 Kommentare

Hallo Gemeinde,

ich habe vor einiger Zeit Smartermail erfolgreich installiert.
Die Installation hat soweit ohne Probleme geklappt!

Der Mailserver läuft stabiel und zuverlässig.

--Some Background--

Das folgende Problem bezieht sich nur auf ausgehende Mails.

Smartermail läuft als Relay Server, d.h. Mails die an meine Mailadresse gesendet werden, werden bei meinen Provider im Postfrach gesammelt (POP3).
Smartermail ruft diese dann über POP3 ab. (funktioniert wunderbar)

Wenn ich nun eine Mail senden will (SMTP) sollte dieser Vorgang in umgekehrter Reihe erfolgen. (Smartermail-> Mein Postfach vom Provider -> Empfänger).

Der Mailserver Smartermail besitzt die schöne Funktion eines (outgoing) Gateways, wo die Daten eingegeben werden und dadurch die Mails über das Postfach meines Providers umgeleitet werden.

--The Problem--

Wenn ich das entsprechende Gateway mit Daten füttere (Server Adresse; Port; Benutzername; Passwort; Verschlüsselung), sendet der Provider mir die Nachricht, dass die Authentifizierung fehlgeschlagen ist. (Daten sind selbstverständlich mehrmals überprüft worden etc.)

Das Postfach beim Provider benötigt die Authentifizierung.
Bei Outlook kann ich die Mails ohne Probleme Senden wenn der Hacken unter SMTP bei "Gleiche Einstellungen wie beim Posteingangserver verwenden" gesetzt ist.

--Server Log--

Folgendes spuckt Smartermail als Log aus:

16:57:41 [88007] Delivery started for @mydomain.de at 16:57:41
16:57:44 [88007] Skipping spam checks: No local recipients
16:57:47 [88007] Sending remote mail for @mydomain.de
16:57:47 [88007] Initiating connection to 212.172.221.23
16:57:47 [88007] Connecting to 212.172.221.23:25 (Id: 1)
16:57:47 [88007] Binding to local IP 154.250.15.78:0 (Id: 1)
16:57:47 [88007] Connection to 154.250.15.78:0 from 154.250.15.70:0:3824 succeeded (Id: 1)
16:57:47 [88007] RSP: 220 freesurf.webhoster.ag ESMTP freesurf.webhoster.ag
16:57:47 [88007] CMD: EHLO server.mydomain.de
16:57:47 [88007] RSP: 250-freesurf.webhoster.ag
16:57:47 [88007] RSP: 250-PIPELINING
16:57:47 [88007] RSP: 250-SIZE 629145600
16:57:47 [88007] RSP: 250-VRFY
16:57:47 [88007] RSP: 250-ETRN
16:57:47 [88007] RSP: 250-STARTTLS
16:57:47 [88007] RSP: 250-AUTH PLAIN CRAM-MD5 LOGIN GSSAPI DIGEST-MD5
16:57:47 [88007] RSP: 250-AUTH=PLAIN CRAM-MD5 LOGIN GSSAPI DIGEST-MD5
16:57:47 [88007] RSP: 250-ENHANCEDSTATUSCODES
16:57:47 [88007] RSP: 250-8BITMIME
16:57:47 [88007] RSP: 250 DSN
16:57:47 [88007] CMD: STARTTLS
16:57:47 [88007] RSP: 220 2.0.0 Ready to start TLS
16:57:47 [88007] CMD: EHLO server.mydomain.de
16:57:47 [88007] RSP: 250-freesurf.webhoster.ag
16:57:47 [88007] RSP: 250-PIPELINING
16:57:47 [88007] RSP: 250-SIZE 629145600
16:57:47 [88007] RSP: 250-VRFY
16:57:47 [88007] RSP: 250-ETRN
16:57:47 [88007] RSP: 250-AUTH PLAIN CRAM-MD5 LOGIN GSSAPI DIGEST-MD5
16:57:47 [88007] RSP: 250-AUTH=PLAIN CRAM-MD5 LOGIN GSSAPI DIGEST-MD5
16:57:47 [88007] RSP: 250-ENHANCEDSTATUSCODES
16:57:47 [88007] RSP: 250-8BITMIME
16:57:47 [88007] RSP: 250 DSN
16:57:47 [88007] CMD: AUTH CRAM-MD5
16:57:47 [88007] RSP: 334 PDE4NjMxNTM2NzAuOTg5NTA5OUBmcmVlc3VyZi53ZWJob3N0ZXIuYWc+
16:57:47 [88007] RSP: 535 5.7.0 Error: authentication failed: authentication failure
16:57:47 [88007] CMD: QUIT
16:57:47 [88007] RSP: 221 2.0.0 Bye
16:57:47 [88007] Bounce email written to 250688008.eml
16:57:47 [88007] Delivery for@mydomain.de to @mydomain.de has completed (Bounced)
16:57:50 [88008] Delivery started for at 16:57:50
16:57:50 [88007] Delivery finished for @mydomain.de at 16:57:50 [id:250688007]
16:57:53 [88008] Error checking SPF Record: Spf check failed due to null sender's ip
16:57:53 [88008] Spam check results: [_REVERSEDNSLOOKUP: passed], [_INTERNALSPAMASSASSIN: 0:0], [_DK: None], [_DKIM: None], [FIVE-TEN: passed], [HOSTKARMA - BLACKLIST: passed], [HOSTKARMA - BROWNLIST: passed], [HOSTKARMA - WHITELIST: passed], [NJABL - PROXY: passed], [NJABL - RELAY: passed], [NJABL - SPAM: passed], [RHSBL: passed], [SORBS - ABUSE: passed], [SORBS - DYNAMIC IP: passed], [SORBS - PROXY: passed], [SORBS - SOCKS: passed], [SPAMCOP: passed], [SPAMHAUS - PBL: passed], [SPAMHAUS - PBL2: passed], [SPAMHAUS - SBL: passed], [SPAMHAUS - XBL: passed], [SPAMHAUS - XBL2: passed], [UCEPROTECT LEVEL 1: passed], [UCEPROTECT LEVEL 2: passed], [UCEPROTECT LEVEL 3: passed]
16:57:56 [88008] Starting local delivery to @mydomain.de
16:57:56 [88008] Delivery for to@mydomain.de has completed (Delivered) Filter: None
16:57:56 [88008] End delivery to @mydomain.de
16:57:56 [88008] Delivery finished for @mydomain.de at 16:57:56 [id:250688008]

--Question--

Hat jemand einen Lösungsvorschlag? oder einen Gedankenanreiz... bin um jede Hilfe sehr dankbar!

LG
Mitglied: transocean
21.10.2011 um 20:06 Uhr
Moin,

ich hatte vor zwei Jahren mal Smartermail auf meinem WHS am Laufen und hatte ein ähnliches Problem. Ich meine mich zu erinnern, dass damals die Verschlüsselung das Problem war und es ohne selbige mit dem Versand über den Provider funktionierte.

Gruß

Uwe
Bitte warten ..
Mitglied: tobhehe
21.10.2011 um 22:58 Uhr
Servus,

schonmal danke für die Antwort.

Ich denke nicht, dass es an der Veschlüsselung an sich liegt (TSL bzw. SSL--> habe ich auch schon beides via test 'n' try ausprobiert), es geht zwar in die Richtung, aber es hat denke ich was mit der Übermittlung der Daten zu tun.

Da gibt es das sogenannte AUTH CRAM-MD5, dass da etwas mit zu tun hat, aber ganz erlich, da hört zurzeit mein Wissen auf.
Bitte warten ..
Mitglied: AndiEoh
14.11.2011 um 16:02 Uhr
Die Spur könnte richtig sein. Der Server bietet zwar diverse Authentifizierungs-Verfahren an, aber oft funktioniert nur PLAIN bzw. LOGIN. Falls Smartermail dazu in der Lage ist, einfach mal die Authentifizierung auf PLAIN/LOGIN fest pinnen und am besten auch gleich TLS mandatory.

Gruß

Andreas
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Problem mit Zyxel USG60 als DHCP Relay
Frage von MikeC91Router & Routing8 Kommentare

Hallo Leute Nach langem versuchen das ganze selbst zu konfigurieren muss ich mich doch geschlagen geben. /-: Ich versuche ...

E-Mail
Lokaler Relay-Server
Frage von eccos01E-Mail10 Kommentare

Hallo zusammen, ich will aus diversen Batch- / PowerShell-Skripten und einigen Tools Emails verschicken. Dabei habe ich aber folgende ...

Exchange Server
DNS und Relay-Server(SmartHost)
Frage von oceExchange Server4 Kommentare

Hallo zusammen, ich habe einen Exchange 2010 aufgesetzt der auch Intern ohne Probleme funktioniert. Ich möchte ihn jetzt von ...

LAN, WAN, Wireless

DHCP Relay Problem ZyWALL USG 300 und Monowall

Frage von letstryandfindoutLAN, WAN, Wireless5 Kommentare

Hallo zusammen, ich bin leider etwas am verzweifeln. Ich habe folgendes Problem und kriege irgendwie keine Lösung hin. Ich ...

Neue Wissensbeiträge
Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 9 StundenHumor (lol)

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Exchange Server

Exchange 2010-2019 Sicherheitslücke durch Regkey löschen schließen

Information von sabines vor 20 StundenExchange Server1 Kommentar

Unter ist eine Lücke im Exchange 2010-2019 beschrieben, die durch das Löschen eines reg keys geschlossen werden kann. In ...

Windows Server
Erneutes Release von WS2019 und Win10 v1809
Tipp von IT-Pro vor 1 TagWindows Server3 Kommentare

Hi, nachdem der Windows Server 2019 und Windows 10 in der Version 1809 aufgrund von verschwinden von Dateien nach ...

CPU, RAM, Mainboards
Spectre Update Tool für ältere PCs
Information von sabines vor 1 TagCPU, RAM, Mainboards6 Kommentare

Mit Hilfe eines Tools wird der betreffende PC permanent von einem USB Stick gestartet, der ein passendes Microcode Update ...

Heiß diskutierte Inhalte
Java
Testautomatisierung
gelöst Frage von WPFORGEJava15 Kommentare

Hallo, nehmen wir an, es gibt eine Webseite mit einer Karte und einem Suchfeld. Nun wird in das Suchfeld ...

Viren und Trojaner
Office365 Trojaner Analyse
Frage von ZeppelinViren und Trojaner12 Kommentare

Liebe Community, ich wende mich an euch, um mehr über den Office365 Trojaner zu erfahren, welcher grade seine Runden ...

Exchange Server
PST Datei enthält weder Betreff noch Absender
gelöst Frage von SSamuelExchange Server10 Kommentare

Hallo zusammen, ich versuche aus einer wiederhergestellten Exchange (SBS2011) .EDB mit dem Programm "Kernel for Exchange von Nucleus" eine ...

Netzwerke
Anfänger in SSL Zertifikat
Frage von Florian961988Netzwerke10 Kommentare

Guten Morgen liebes Forum, ich habe mal Fragen zum Thema SSL zertifikat verlängern/bzw ändern! Aber von vorne wir haben ...