Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Software via GPO zuweisen funktioniert nicht...

Mitglied: ahstax

ahstax (Level 2) - Jetzt verbinden

08.02.2012 um 14:14 Uhr, 7889 Aufrufe, 4 Kommentare

Ich möchte Software via GPO installieren (lassen), was aber nicht funktioniert, obwohl die Richtlinie am Client (mittels gpresult) als angewendet angezeigt wird.

Hallo,

ein Clientrechner (WinXP SP3) soll mit einer Software versehen werden, die auf diesem (noch) nicht installiert ist.

Der Rechner ist im AD (Win Server 2003 R2) in einer Organisationseinheit (laut ldp.exe (verfremdet...):
OU=OU4,OU=OU3,OU=OU2,OU=OU1,DC=domain,DC=local
darin
CN=Client,OU=OU4,OU=OU3,OU=OU2,OU=OU1,DC=domain,DC=local
in der gpmc.msc habe ich ein Gruppenrichtlinienobjekt (ich hoffe, ich verwende die richtige Vokabel...) erstellt und dann mit der OU4 verknüpft.

Sicherheitsfilter: Authentifizierte Benutzer
(ich hatte da mal ne Gruppe mit dem Client drin, das funktionierte aber nicht, weswegen ich dann wieder die Originaleinstellung verwendet habe...)

In dem GPO ist in
Computerkonfiguration, Softwareeinstellungen, Softwareinstallation
ein (funktionierendes) MSI-Paket zugewiesen (!)...

Da ich entsprechendes als Fehlerquelle schon mal gelesen habe, habe ich "Sprache beim Bereitstellen... ignorieren" aktiviert.


Das mal für den Anfang...

Das Problem ist nun, dass die Software nicht installiert wird, obwohl am Client bei der Abfrage mit "gpresult" die GPO als angewendet angezeigt wird...

Kann mir jemand helfen? Kennt jemand das Problem?

Danke für Antworten schon jetzt!!!

Grüße aus Stuttgart,
Andreas


PS.: Ich "verwalte" zwar das Netzwerk, das heißt aber nicht, dass ich weiß, wovon ich rede...
Mitglied: SlainteMhath
08.02.2012 um 14:22 Uhr
Moin,

sieht soweit alles richtoig aus.

Fragen dazu:
- Was steht denn im Eventlogs des Clients? Falls bei der Installation Fehler auftreten sollten die da vermerkt sein.
- Wird per UNC auf das MSI verwiesen?
- Stimmen die Rechte auf das Share und den NTFS Ordern (Jeder=lesen)?

lg,
Slainte
Bitte warten ..
Mitglied: ahstax
08.02.2012 um 15:42 Uhr
Hallo Slaint,

  1. Da sind einige Fehler drin... s.u.
  2. Ja, via UNC. Allerdings sieht der recht lang aus... ( \\Server\Freigabe\01\02\03\04\05\Software.msi ) kann das daran liegen?Leerzeichen sind keine drin, allerdings Unterstriche.
  3. Auf die Freigabe hat die Gruppe "Jeder" Leseberechtigung. Ebenfalls auf die untergeordneten Ordner und das MSI-File. Allerdings... NTFS-Ordner? Mein Gesicht verzieht sich zu einem großen Fragezeichen... Hab ich das in jedem Fall, wenn diese Freigaben vorhanden sind (sein können)? Wie bekomme ich das heraus?


Hier ist "unten"...:
Alle EInträge des Eventlogs "Anwendungen" seit dem letzten Systemstart, zu dem die Installation hätte erfolgen sollen.
Mir scheint, da ist irgendwas krumm...?!?

-------------<SNIP>-----------------
Ereignistyp: Fehler
Ereignisquelle: AutoEnrollment
Ereigniskategorie: Keine
Ereigniskennung: 15
Datum: 08.02.2012
Zeit: 14:39:33
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die automatische Zertifikatregistrierung für "lokaler Computer" konnte keine Verbindung zum Active Directory (0x8007054b) herstellen. Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.
Die Registrierung wird nicht durchgeführt.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: Userenv
Ereigniskategorie: Keine
Ereigniskennung: 1054
Datum: 08.02.2012
Zeit: 14:39:32
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: PC062-210211
Beschreibung:
Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden. ). Die Verarbeitung der Gruppenrichtlinie wurde abgebrochen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SecurityCenter
Ereigniskategorie: Keine
Ereigniskennung: 1807
Datum: 08.02.2012
Zeit: 14:39:20
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: AutoEnrollment
Ereigniskategorie: Keine
Ereigniskennung: 15
Datum: 08.02.2012
Zeit: 12:49:30
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die automatische Zertifikatregistrierung für "lokaler Computer" konnte keine Verbindung zum Active Directory (0x8007054b) herstellen. Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.
Die Registrierung wird nicht durchgeführt.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: Userenv
Ereigniskategorie: Keine
Ereigniskennung: 1054
Datum: 08.02.2012
Zeit: 12:49:30
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: PC062-210211
Beschreibung:
Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden. ). Die Verarbeitung der Gruppenrichtlinie wurde abgebrochen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SecurityCenter
Ereigniskategorie: Keine
Ereigniskennung: 1807
Datum: 08.02.2012
Zeit: 12:49:17
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SceCli
Ereigniskategorie: Keine
Ereigniskennung: 1704
Datum: 07.02.2012
Zeit: 17:18:10
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die Sicherheitsrichtlinie in den Gruppenrichtlinienobjekten wurde erfolgreich angewendet.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: LoadPerf
Ereigniskategorie: Keine
Ereigniskennung: 1000
Datum: 07.02.2012
Zeit: 15:42:15
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die Leistungsindikatoren für den Dienst WmiApRpl (WmiApRpl) wurden geladen. Die Daten enthalten die dem Dienst zugeordneten neuen Indexwerte.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: 0c 14 00 00 ....


Ereignistyp: Informationen
Ereignisquelle: LoadPerf
Ereigniskategorie: Keine
Ereigniskennung: 1001
Datum: 07.02.2012
Zeit: 15:42:15
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die Leistungsindikatoren für den Dienst WmiApRpl (WmiApRpl) wurden entfernt. Die Daten enthalten die neuen Werte der Registrierungseinträge Last Counter und Last Help.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: f2 3c 00 00 f3 3c 00 00 ò<..ó<..
0008: 17 07 00 00 ....


Ereignistyp: Fehler
Ereignisquelle: AutoEnrollment
Ereigniskategorie: Keine
Ereigniskennung: 15
Datum: 07.02.2012
Zeit: 15:38:07
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die automatische Zertifikatregistrierung für "lokaler Computer" konnte keine Verbindung zum Active Directory (0x8007054b) herstellen. Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.
Die Registrierung wird nicht durchgeführt.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: Userenv
Ereigniskategorie: Keine
Ereigniskennung: 1054
Datum: 07.02.2012
Zeit: 15:38:06
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: PC062-210211
Beschreibung:
Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden. ). Die Verarbeitung der Gruppenrichtlinie wurde abgebrochen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SecurityCenter
Ereigniskategorie: Keine
Ereigniskennung: 1807
Datum: 07.02.2012
Zeit: 15:37:54
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
-------------<SNIP>-----------------



Was könnte da denn falsch sein und wie könnte ich das beheben?

Grüße aus Stuttgart,
Andreas
Bitte warten ..
Mitglied: SirAnimus
08.02.2012 um 16:30 Uhr
Hallo

Würde mal folgende Richtlinie setzen. Computerkonfiguration -> Administrative Vorlagen -> System -> Anmelden-> Beim Neustart des Computers und bei der Anmeldung immer auf das Netzwerk warten, aktiviert.

Damit zuerst das Netzwerk richtig funktioniert bevor die Software installiert wird.


Als zweites könntes du mal versuchen die MSI lokal auf dem PC zu starten. am besten mit dem Parameter /qr. Damit die Installtion wie auch mit GPO ohne Benutzer Eingabe installiert wird.


Berechtigungen muss auch der Computer haben:

Zum testen mal auf dem Software-Ordner den Computer direkt zu den NTFS Berechtigungen legen.

Beispiel: Client002 - Lesen

Das gleiche auch auf dem Share



MFG
Bitte warten ..
Mitglied: ahstax
08.02.2012 um 16:51 Uhr
Interessante Neuigkeit...

Ob es da einen Zusammenhang gibt oder nicht, kann ich icht so genau sagen, dennoch:
Als ich gerade an dem Client ein wenig "rumgespielt habe, ist mir aufgefallen, dass unter
"Status von LAN-Verbindung" - "Eigenschaften von LAN-Verbindung" - "Eigenschaften von Internetprotokoll (TCP/IP)" - "Erweitert"
im Reiter "WINS" kein EIntrag vorhanden war. Darin habe ich die IPs der beiden Domänencontroler ergänzt, und die Software wurde installiert.
Wenn ich das nun reproduzieren kann, wäre ich der Lösung vermutlich sehr nah...!

Den Hinweis mit der Richtline "Warten bis Netzwerk" werde ich gleich umsetzen!!!
Bitte warten ..
Ähnliche Inhalte
Windows Server

Laufwerke mit GPO zuweisen funktioniert bei zwei Laufwerken nicht

Frage von M.MarzWindows Server10 Kommentare

Hallo zusammen, ich möchte im Betrieb 6 Laufwerke für eine Abteilung mittels der GPO mappen. Vorher waren es noch ...

Windows 7

Netzlaufwerk per GPO zuweisen

gelöst Frage von JimPietWindows 711 Kommentare

Moin, ich versuche derzeit krampfhaft eine Laufwerkszuordnung per GPO zu einem Server, der nicht in der Domäne ist, zu ...

Windows Server

GPO einem Benutzer zuweisen

gelöst Frage von RaucherbeinWindows Server6 Kommentare

Hallo. Ich benötige mal bitte eure Hilfe bei folgendem Verständnisproblem. Ich habe eine virtuelle Testumgebung aufgebaut (siehe Bild). Nun ...

Windows Server

Zuweisen von Gruppenrichtlinien über Sicherheitsgruppen funktioniert nicht

gelöst Frage von YaimaelWindows Server10 Kommentare

Hallo Zusammen, ich habe ein Problem mit der Zuweisung von GPOs über Sicherheitsgruppen. Auch nach längeren Googlen und testen ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 1 TagSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 1 TagMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 1 TagHardware12 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++27 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux27 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless22 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...