Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareinstallation via GPO

Mitglied: Screeper

Screeper (Level 1) - Jetzt verbinden

07.11.2011, aktualisiert 18.10.2012, 6031 Aufrufe, 6 Kommentare

Hallo nochmal alle zusammen. Ich habe mal wieder ein Problem bezüglich einer Installation. Wir haben nur Windows XP Rechner im Netz und ich muss eine Installation unserer Warenwirtschaft durchführen. Eine MSI Installation fällt flach, die funktioniert nicht.

Nun möchte ich die Installation per Runas Script durchführen und dieses Script beim Starten oder Herunterfahren des Rechners ausführen lassen.

Ich habe im Netlogon Verzeichnis unseres DCs die benötigten Dateien hinterlegt. Wenn ich das Script manuell ausführe, funktioniert es.
Nun lege ich eine Policy an (Test), Computerkonfig, Richtlinien, Windowseinstellungen, Scripts und hinterlege dort beim Starten/Herunterfahren (je nach dem) die install.bat, die den Prozess auslösen soll. Nichts passiert.
Die OU passt, Rechner und Benutzer sind der OU zugeordnet.

Wenn ich ein Richtlinienergebnis modelliere, erhalte ich einen Fehler "Unbekannter Fehler bei der Zusammenstellung von Informationen für Ordner für diese Erweiterung. Details: Nicht gefunden".

Komischerweise erhalten ich diesen Fehler auch bei unserem "normalen" Benutzeranmeldeskript. Dieses funktioniert allerdings trotz dieser Fehlermeldung.

Hätte ich dochmal die Finger von den GPOs gelassen
Mitglied: DerWoWusste
07.11.2011, aktualisiert 18.10.2012
Hi.

Knüpf doch mal ordentlich an https://www.administrator.de/forum/msi-installationen-per-gpo-175758.htm ... an: warum fällt das flach? Dein Problem hätten wir in den Griff bekommen, wenn Du mitgemacht hättest.
Zu diesem würde ich erst kommen, wenn das alte beendet ist aus gutem Grund.

Zu diesem Problem fehlen einige Infos:
-warum runas und nicht mit Systemrechten?
-ist die install.bat silent?
-stell sicher, ob das Startskript die Batch anfässt, oder nicht (Überwachungsrichtlinie am Server anschalten usw.) - mit Sicherheit wird sie angefasst. Du könntest Startskripte auch sichtbar ausführen lassen (konfigurierbar per GPO).
Bitte warten ..
Mitglied: Screeper
07.11.2011, aktualisiert 18.10.2012
Zitat von DerWoWusste:
Hi.

Knüpf doch mal ordentlich an https://www.administrator.de/forum/msi-installationen-per-gpo-175758.htm ... an: warum fällt das flach? Dein
Problem hätten wir in den Griff bekommen, wenn Du mitgemacht hättest.
Zu diesem würde ich erst kommen, wenn das alte beendet ist aus gutem Grund.

Sorry aber das hat gar nichts mit dem Problem in diesem Thread zu tun. Bei o. g. Problem läuft die MSI, das Programm läuft nach der Installation und alles ist toll. Was nach wie vor bei diesem Thema offen ist, ist die Tatsache, warum denn diese Installation erst startet, nachdem jeder Client mindestens zweimal gestartet wird. Nicht mehr, nicht weniger.

Bei diesem Thema hier läuft die MSI Installation, das Programm funktioniert aber nicht so, wie es sein soll und bringt eine programmspezifische Fehlermeldung. Wird die Installation mittels der Setup.exe aber auf herkömmlichen Wege durchgeführt, funktioniert es einwandfrei. Somit fällt der Weg über eine MSI flach und ich muss nun einen Weg finden, um über die manuelle Installation von 84 Clients herum zu kommen


Zu diesem Problem fehlen einige Infos:
-warum runas und nicht mit Systemrechten?

Ich habe mit Runas schon bei der Vorgängerversion dieser Applikation gearbeitet und diese über unser Login Skript mittels Runas verteilt. Das war aber etwas lästig, da die Installation natürlich nach jedem Login eines Users angestossen wurde und durchlief - egal, ob das Programm auf diesem Client schon installiert war oder nicht.

Kann ich denn die Setup.exe direkt über die Computerkonfiguration aufrufen und wird die dann automatisch mit System Berechtigung installiert?? Dann kann ich mir natürlich die Runas-Sache sparen.

BTW - die Setup.exe hat leider keinerlei Möglichkeiten Attribute wie Silent Installation zu setzen.


-ist die install.bat silent?

Die Runas Datei wird Silent aufgerufen.

-stell sicher, ob das Startskript die Batch anfässt, oder nicht (Überwachungsrichtlinie am Server anschalten usw.) - mit
Sicherheit wird sie angefasst. Du könntest Startskripte auch sichtbar ausführen lassen (konfigurierbar per GPO).


Wenn Sie angefasst werden würde, bekäme ich doch zumindest die Installationsdialoge angezeigt, in denen ich die Installation dann manuell weiter führen müsste. Die Batchdatei macht eigentlich nichts anderes (oder sie soll es zumindest), als die Setup.exe aufrufen.

Wie erwähnt, bei dem Richtlinienergebnis kommt folgender Fehler raus

"Unbekannter Fehler bei der Zusammenstellung von Informationen für Ordner für diese Erweiterung. Details: Nicht gefunden"

Sorry, aber ich fange erst mit den GPOs an und besitze noch keinen großen Erfahrungsschatz diesbezgl.

VG
Screeper


PS: Ich habe festgestellt, dass in der Ereignisanzeige des Clients die Meldung erscheint:

"Folgendes Skript konnte nicht ausgeführt werden: \\53.xxx.xxx.xxx\msi\GamisV16\install.bat. Zugriff verweigert".

Das verwirrt mich etwas, da das Verzeichnis definitiv für jedes Domänenmitglied voll zugriffsfähig ist. Wenn ich im selben Moment die Batchdatei manuell an genau diesem Ort aufrufe, funktioniert sie....?!?!
Bitte warten ..
Mitglied: DerWoWusste
07.11.2011 um 23:28 Uhr
Okeydokey, da haben wir doch Punkte um anzusetzen.

Wenn die Anwendung als MSI vorliegt, dann ist doch zu unterstellen, dass der Hersteller eine Verteilung vorsieht. Wende Dich an deren Support mit der Fehlermeldung.
MSI-Pakete werden über die GPO-Softwareverteilung mit dem Systemkonto installiert - klar, es ist ja noch kein Nutzer angemeldet. Schlägt das fehl, würde eine Installation per Startskript vermutlich ebenso fehlschlagen, mit einiger Sicherheit.
Wenn Sie angefasst werden würde, bekäme ich doch zumindest die Installationsdialoge angezeigt, in denen ich die Installation dann manuell weiter führen müsste
Nein. Das Startskript läuft im Systemkontext und gewollt per default unsichtbar ab. Die Dialoge bleiben somit nicht eingreifbar.

Wenn die setup.exe keine Silentschalter hat, solltest Du zumindest noch einmal bei appdeploy.com in der package Knowledgebase reinschauen, vielleicht ist das Paket bekannt.
Wenn nicht, versuch es mit repackaging, d.h. mach einen before-Snapshot eines Test-PCs mit wininstall LE, installiere die Software manuell und fertige einen after-snapshot an. Wininstall LE 10 macht aus der Differenz ein verteilbares MSI, vielleicht klappt es damit http://downloads.ondemandsoftware.com/Download/Installs/Wininstall10102 ... Freeware!
Bitte warten ..
Mitglied: Screeper
07.11.2011 um 23:38 Uhr
Da habe ich mich etwas missverständlich ausgedrückt. Das Package lag nicht vom Hersteller als MSI vor, das habe ich selbst mit WinInstall LE erstellt. Das funktionierte dann aber nicht - wie erwähnt. Also die Installation lief aber das Resultat war fehlerhaft.

Weiterhin wird die Setup-Datei nicht bekannt sein, da sie nahezu direkt von unserem Markenhersteller kommt. Das ist also keine öffentliche, frei zugängliche oder käuflich erwerbbare Software.

Hab meinen Beitrag von eben nochmal editiert. Da haben wir uns überschnitten:

PS: Ich habe festgestellt, dass in der Ereignisanzeige des Clients die Meldung erscheint:

"Folgendes Skript konnte nicht ausgeführt werden: \\53.xxx.xxx.xxx\msi\GamisV16\install.bat. Zugriff verweigert".

Das verwirrt mich etwas, da das Verzeichnis definitiv für jedes Domänenmitglied voll zugriffsfähig ist. Wenn ich im selben Moment die Batchdatei manuell an genau diesem Ort aufrufe, funktioniert sie....?!?!
Bitte warten ..
Mitglied: DerWoWusste
07.11.2011 um 23:47 Uhr
Das verwirrt mich etwas, da das Verzeichnis definitiv für jedes Domänenmitglied...
Gib an, was in der ACL steht. "Jede Domänenmitglied" ist ungenau. Es muss für "authentifizierte Benutzer" zugänglich sein, die umfassen auch die Gruppe der Domänencomputer (=Systemkonten). Wenn Du manuell aufrufst, handelst DU und nicht das Systemkonto wie im Startskript.
Frag Euren Hersteller, wie ein Deployment aussehen soll. Vielleicht sieht er doch etwas vor.
Bitte warten ..
Mitglied: Screeper
08.11.2011 um 06:22 Uhr
Zitat von DerWoWusste:
Es muss für "authentifizierte
Benutzer" zugänglich sein, die umfassen auch die Gruppe der Domänencomputer (=Systemkonten).

Genau das steht drin.

EDIT: Wenn ich die install.bat in die Benutzerkonfig eintrage und als Startskript ausführen lasse, startet die Installation. In der Computerkonfig passiert nichts.

Frag Euren Hersteller, wie ein Deployment aussehen soll. Vielleicht sieht er doch etwas vor.

Naja versuchen kann man es mal, obwohl ich da schwarz sehe. Ohne den Hersteller nennen zu wollen, ist er in Sachen EDV nicht immer "Vorreiter"
Immerhin können wir schon Ende nächsten Jahres damit rechnen, dass alle seine Programmmodule auf Windows 7 lauffähig sein werden :-S

Habe nachher noch ein anderes Modul "EKS" zu aktualisieren. Hoffe mal, dass dieses dann als MSI Paket läuft. Anschl. muss ich mich weiter um dieses hier kümmern :-S
Bitte warten ..
Ähnliche Inhalte
Windows Server

GPO wird nicht angewendet (softwareinstallation)

Frage von IT-BieneWindows Server4 Kommentare

Hi Community, ich habe gestern versucht eine Software über die GPO zu installieren. Wie Sie sicher ahnen, hat das ...

Windows Server

Softwareinstallation über GPO keine Statusanzeige

Frage von lordofremixesWindows Server3 Kommentare

Hallo zusammen, vor kurzem habe ich mich ja in das Thema der Softwareinstallation per GPO einarbeiten müssen. (wir sind ...

Rechtliche Fragen

Gewährleistungspflicht des Systemhauses bei Softwareinstallation von Drittanbietern

gelöst Frage von PhysixxsRechtliche Fragen14 Kommentare

Hallo zusammen, ganz neu hier und schon folgende "knifflige" Situation Wir haben von knapp 9 Monaten eine Migration von ...

Windows Server

Anzeige der Softwareinstallation auf dem Client vor der Benutzeranmeldung

Frage von DonQuichoteWindows Server12 Kommentare

Hallo zusammen, wie schaffe ich es, dass eine per Startscript gestartete Softwareinstallation beim Hochfahren des Clients angezeigt wird und ...

Neue Wissensbeiträge
Server-Hardware

Lösung für Ersatz eines defekter Raid-Controllers

Anleitung von wellknown vor 7 StundenServer-Hardware1 Kommentar

Hallo, da ich nichts gefunden habe und selbst eine Lösung brauchte, hier eine kleine Anleitung für alle die vor ...

Windows 10

Kumuative Updates für .NET Framework kommen für Windows 10 V1809

Information von kgborn vor 11 StundenWindows 10

Microsoft hat das Ganze im Beitrag Announcing Cumulative Updates for .NET Framework for Windows 10 October 2018 Update vorgestellt. ...

Sicherheit
Neue IT-Administrator Ausgabe - Endpoint Security
Information von Frank vor 12 StundenSicherheit

Die Endgeräte in Unternehmen stellen das wohl größte Einfallstor für Angreifer dar. Ein geöffneter, infizierter E-Mail-Anhang oder der Besuch ...

Windows Tools

Windows 10 BitLocker Laufwerkverschlüsselung ohne TPM-Chip

Anleitung von Frank vor 13 StundenWindows Tools4 Kommentare

Diese Anleitung zeigt, wie man die Windows BitLocker Laufwerkverschlüsselung ohne TPM-Chip Schritt für Schritt aktiviert. Zwar haben viele Laptops ...

Heiß diskutierte Inhalte
Hyper-V
Windows Serer 2016 Standard virtualisieren
gelöst Frage von fritte87Hyper-V33 Kommentare

Hallo zusammen, ich muss für eine kleine Firma ein entsprechendes neues kleines Konzept bauen. Ich habe einen Server Standard ...

Windows Server
Kann DNS-Einträge nicht finden
gelöst Frage von BPeterWindows Server19 Kommentare

Hallo, wenn ich folgenden Befehl absetze, bekomme ich eine Liste zurück mit allen Einträgen der DNS-Zone. Wenn ich aber ...

Voice over IP
Umstellung Anlagenanschluss ISDN auf IP - Welcher Router?
Frage von ToniSchmidtVoice over IP12 Kommentare

Hallo zusammen, zum Ende des Jahres werden unsere geliebten ISDN Anlagenanschlüsse zwangsweise auf IP Anschlüsse umgestellt. Wir betreiben die ...

Firewall
Externer Zugriff auf Webserver
Frage von KingLouieFirewall12 Kommentare

Hallo zusammen, ich habe folgendes Problem: Ein Kollege muss gelegentlich auf einen Webserver zugreiffen, sowohl von intern als auch ...