Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareverteilung - Repaketierung - GUI von msiexec bei jedem Programmstart

Mitglied: utopia

utopia (Level 1) - Jetzt verbinden

04.01.2008, aktualisiert 05.01.2008, 6226 Aufrufe, 5 Kommentare

Hallo,

Gegebene Situation
Ich betreue ein kleines Netzwerk mit Windows 2003 Servern und Windows XP Clients. Die Clients werden per RIS übers Netzwerk aufgesetzt. Die RIS-Images enthalten nur die Abbilder eines Rechnertyps samt vollständiger Treiberinstallation/Treiberkonfiguration je nach Bauart. Die Software wird via Active Directory GPOs verteilt (per Machine).
Da so manche installierte Software liefert keinen bzw. einen ungenügenden Installer bzw. MSI-Paket. Also habe ich ein Paket paketiert. Als beispiel soll hier ein vorkonfiguriertes Eclipse dienen. Dieses Paket wird durch einen Snapshot erstellt, die benutzerspezifischen Einträge entfernt (C:\Dokumente und Einstellung\%USERNAME%\* und HKEY_CURRENT_USER). Die Verteilung läuft perfekt.

Problem
Sofern ein Benutzer Eclipse öffnet startet erst ein msiexec-Fester, das darauf hinweißt, dass die Software konfiguriert wird. Bis dahin ist es ja verständlich, da erst die benutzerspeziefischen Daten ins Anwendungsverzeichnis geschrieben werden. Das wird aber bei JEDEM start der Software getan, sogar in der selben Session.

Frage
Wieso wird dieses Installations-Fenster überhaupt eingeblendet, wenn das Paket Eclipse ausschließlich Dateien enthält, die nach %PROGRAMFILES%\Eclipse entpackt werden. Registry-Änderungen werden auch nicht vorgenommen?
Wieso wird dieser Dialog bei jedem Start der Software angezeigt. Die Benutzerinformationen müssten doch schon bestehen?
Wieso funktioniert die Anwendung auch dann, wenn ich beim Installer-GUI auf Abbrechen drücke?
Bei manchen Paketen funktioniert es, das sind aber sehr wenige (5 - 10%)?

Ungeeignete Lösungen
- Softwareintegrierung in RIS-Images, da häufige Updates, die mittels GPO's besser verwaltet werden können.
- Kommerzielle Drittsoftware (Kosten)
- Scriptinstallation (Teils sichtbare Anwendungsfenster des msiexec trotz silent-mode, ist mir auch etwas unsympatisch)

Vielen Dank für Eure Antworten.
Mitglied: HuskyMcFly
04.01.2008 um 08:52 Uhr
Hi.
Wenn ich Pakete über Snapshots erstelle bekomme ich teilweise auch die wildesten Fehler. Ich traue diesem Verfahren auch nicht mehr über den Weg. Vielleicht versuchst du es mal Testweise mit einem Freeware Paketierprogramm. Ich selber benutze sehr gerne den Installer2Go. Bei sichtbaren Installationen gibt es nervige Werbescreens, wenn du es aber per GPO verteilst bleibt das Paket absolut Silent. Das Programm ist so easy das man kein Manual braucht. Vom Kauf des I2G kann ich allerdings abraten. Habe mir das Programm gekauft und auch einen Registrierschlüssel bekommen. Der funktioniert allerdings nicht, und vom Support habe ich trotz mehrmaliger Nachfrage nie eine Antwort erhalten, und das ist jetzt mehr als 2 Monate her. Sehr ärgerlich!

http://www.dev4pc.com/
Bitte warten ..
Mitglied: Logan000
04.01.2008 um 09:25 Uhr
Startest Du das Progamm einmal, wenn du einen Snapshot erstellst? Soltest Du tun.
Evtl. hast Du auch zuviel aus deinem Paket herausgeschmissen.

Als beispiel soll hier ein vorkonfiguriertes Eclipse dienen...
Wenn es is erster linie um die konfiguration geht, d. h. du hast ein MSI paket und möchtest nur einstellungen des Programms ändern, dann würde ich eher die bewusten RegKeys/Dateinen ermitteln und diese seperat per GPO ändern/anlegen.
Bitte warten ..
Mitglied: utopia
04.01.2008 um 23:34 Uhr
Bei Setup's, bei denen ich genau weiß, was installiert wird mag das gehen. Wie sieht es mit Software aus, die nicht auf msi-Setup basiert, sondern eigene oder andere Installer verwendet. Wie kann ich da ermitteln, was ich wo eintragen und ändern muss.
Bitte warten ..
Mitglied: utopia
04.01.2008 um 23:35 Uhr
Nein, die Programme habe ich nicht gestartet, erstelle aber gerade ein Paket um das zu prüfen. Zuviel habe ich nicht rausgeschmissen, da ich alle Reg-Einträge überprüft habe und da nur Explorer und weiß ich was für Änderungen entfernt wurden, die nichts mit der Software zu tun hatten.
Bitte warten ..
Mitglied: utopia
05.01.2008 um 19:56 Uhr
Ich habe jetzt mal ein paar paar programme nochmal neu paketiert und dabei gestartet. Selbes Verhalten.

Hat nochjemand eine Idee?
Bitte warten ..
Ähnliche Inhalte
Installation
MSIEXEC parameter
gelöst Frage von EverestInstallation7 Kommentare

Hallo zusammen, hat jemand schon mal so was gemacht, eine MSI-Datei direkt aus Internet installieren? Ich möchte diese MSI-Datei ...

Visual Studio

Tastaturabfrage während Programmstart

gelöst Frage von MartinSVisual Studio2 Kommentare

Guten Tag, ich möchte während des Programmstarts meine Tastatur abfragen, ob eine bestimmte Taste gedrückt ist. Diese soll die ...

Windows Installation

GPO: msiexec im Startup-Skript

gelöst Frage von bensonhedgesWindows Installation7 Kommentare

Hallo, ich würde gern ein MSI-Paket, welches ich mit Parameter aufrufen muss, per GPO als Startup-Skript ausführen lassen. Das ...

Windows Installation

CMD-Batch Programmstart Befehle

Frage von timsen96Windows Installation1 Kommentar

Schönen guten Tag zusammen, ich möchte gerne über eine cmd oder batch datei ein Programm oder Installation öffnen und ...

Neue Wissensbeiträge
Drucker und Scanner
HP-MF-Drucker per Fax angreifbsr
Information von Lochkartenstanzer vor 1 TagDrucker und Scanner3 Kommentare

Endlich eine sinnvolle Verwendung für Faxe: Damit kann man offensichtlich den Drucker übernehmen. lks

Router & Routing

Das pfSense Buch ist jetzt für jeden kostenlos zu beziehen

Tipp von magicteddy vor 2 TagenRouter & Routing2 Kommentare

Bisher war das Buch nur für zahlende Unterstützer verfügbar, jetzt steht für Jedermann kostenlos zur Verfügung. Siehe auch The ...

Firewall

Möglicherweise neue Sicherheitslücke in Mikrotik-Firmware

Information von LordGurke vor 4 TagenFirewall3 Kommentare

Hallo zusammen, vor ein paar Monaten gab es ja bereits eine Sicherheitslücke in der Firmware von Mikrotik-Routern, über welche ...

Erkennung und -Abwehr
Rechner hacken mit Cortana, auch Remote
Information von Lochkartenstanzer vor 5 TagenErkennung und -Abwehr3 Kommentare

heise berichtet über den Vortrag von der Blackhat Open Sesame: Picking Locks with Cortana. Einige Fehler sind schon gefixt, ...

Heiß diskutierte Inhalte
Windows 10
WIN 10 1803 - LTE Stick kein Internetzugriff
Frage von killtecWindows 1023 Kommentare

Hallo, ich habe mit einem Windows 10 1803 Probleme mit einem LTE-Stick. Das gleiche Problem ist bei mehreren Rechnern ...

CPU, RAM, Mainboards
Xeon E5620: noch schnell genug?
Frage von ahussainCPU, RAM, Mainboards19 Kommentare

Hallo allerseits, ich habe die Möglichkeit, aus Restbeständen einen Tower mit Xeon E5620 CPU und 24 GB RAM zu ...

Datenbanken
MySQL Datenbank Import Aufgabe für mehrere .csv dateien
Frage von Marcel1989Datenbanken18 Kommentare

Hi, ich komm nicht weiter. Ich hab auf einem Windows Server 2012 r2 eine MariaDB/MySQL laufen. Nun soll diese ...

Peripheriegeräte
Steckdose(nleiste) mit Schwellwert für off und mit externem Taster
Frage von ahstaxPeripheriegeräte16 Kommentare

Hallo, ich suche eine Steckdose oder Steckdosenleiste mit externem Taster und Schwellwerterkennung. Zu realisieren ist folgendes: Ein PC soll ...